Sitecore Social Connected

[image]

Sitecore Social Connected 1.3.1 API
Sitecore Social Connected
Send Feedback
You can perform the following actions using Sitecore Social Connected API:
  • Manage social networks, applications and accounts.
  • Retrieve and manage social profiles. Configure posting preferences.
  • Create and post messages, gather message statistics.
  • Log in users with social networks credentials. Attach social profiles to existing users.
  • Receive account credentials and data from a social network.

Namespaces

Namespace | Description
Sitecore.Social.Api | Provides classes that allow to manage entities defined in the domain's model.
Sitecore.Social.Api.Extensions | Provides a set of extension classes.
Sitecore.Social.BusinessLogic.Exceptions | Provides a set of custom exception classes.
Sitecore.Social.BusinessLogic.Extensions | Provides a set of extension classes.
Sitecore.Social.BusinessLogic.Model | Provides classes that extend domain's model.
Sitecore.Social.Client.Api | Provides classes that allow to manage presentation layer actions (login, requests to social networs, etc).
Sitecore.Social.Client.Domain | Provides a set of classes that extends domain's model.
Sitecore.Social.Client.Domain.Requests | Provides classes that represent requests.
Sitecore.Social.Client.Domain.Responses | Provides classes that represent responses.
Sitecore.Social.Domain | Provides classes that represent the domain.
Sitecore.Social.Domain.Model | Provides classes that represent the domain's model.
Sitecore.Social.Domain.SearchArgs | Provides classes that represent the domain's search arguments.
Sitecore.Social.Facebook.Api.Model | Provides classes that extend domain's model with Facebook specific entities.
Sitecore.Social.Twitter.Api.Model | Provides classes that extend domain's model with Twitter specific entities.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore


Sitecore.Social.Api Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Api Namespace
Send Feedback
Provides classes that allow to manage entities defined in the domain's model.

Classes

 | Class | Description
Public class | AccountManager | Defines the methods that are used to get and create social network accounts.
Public class | ApplicationManager | Defines the methods that are used to manage social network applications.
Public class | MessageManager | Defines the methods that are used to manage social network messages.
Public class | MessageStatisticsManager | Defines the methods that are used to manage social network message statistics.
Public class | NetworkManager | Defines the methods that are used to manage social networks.
Public class | PostingPreferenceManager | Defines the methods that are used to manage user’s posting preferences.
Public class | SocialProfileManager | Defines the methods that are used to manage a social profile.


AccountManager Class

[image]

Sitecore Social Connected 1.3.1 API
AccountManager Class
Members See Also Send Feedback
Defines the methods that are used to get and create social network accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class AccountManager : IAccountManager
Visual Basic
Public Class AccountManager _
    Implements IAccountManager
Visual C++
public ref class AccountManager : IAccountManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..AccountManager

See Also

AccountManager Members
Sitecore.Social.Api Namespace


AccountManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountManager Members
AccountManager Class Constructors Methods See Also Send Feedback

The AccountManager type exposes the following members.

Constructors

 | Name | Description
Public method | AccountManager()()()() | Initializes a new instance of the AccountManager class.
Public method | AccountManager(INetworkManager, IAccountBusinessManager) | Initializes a new instance of the AccountManager class.

Methods

 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.

See Also

AccountManager Class
Sitecore.Social.Api Namespace


AccountManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountManager Constructor
AccountManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AccountManager()()()() | Initializes a new instance of the AccountManager class.
Public method | AccountManager(INetworkManager, IAccountBusinessManager) | Initializes a new instance of the AccountManager class.

See Also

AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
AccountManager Constructor
AccountManager Class See Also Send Feedback
Initializes a new instance of the AccountManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountManager()
Visual Basic
Public Sub New
Visual C++
public:
AccountManager()

See Also

AccountManager Class
AccountManager Overload
Sitecore.Social.Api Namespace


AccountManager Constructor (INetworkManager, )

[image]

Sitecore Social Connected 1.3.1 API
AccountManager Constructor (INetworkManager, )
AccountManager Class See Also Send Feedback
Initializes a new instance of the AccountManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountManager(
    INetworkManager networkManager,
    IAccountBusinessManager accountBusinessManager
)
Visual Basic
Public Sub New ( _
    networkManager As INetworkManager, _
    accountBusinessManager As IAccountBusinessManager _
)
Visual C++
public:
AccountManager(
    INetworkManager^ networkManager,
    IAccountBusinessManager^ accountBusinessManager
)

Parameters

networkManager
Type: Sitecore.Social.Domain..::..INetworkManager
The network manager.
accountBusinessManager
Type: IAccountBusinessManager
The account business manager.

See Also

AccountManager Class
AccountManager Overload
Sitecore.Social.Api Namespace


AccountManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountManager Methods
AccountManager Class See Also Send Feedback

The AccountManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.

See Also

AccountManager Class
Sitecore.Social.Api Namespace


CreateAccount Method

[image]

Sitecore Social Connected 1.3.1 API
AccountManager..::..CreateAccount Method
AccountManager Class Example See Also Send Feedback
Creates an account.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void CreateAccount(
    Account account
)
Visual Basic
Public Sub CreateAccount ( _
    account As Account _
)
Visual C++
public:
virtual void CreateAccount(
    Account^ account
) sealed

Parameters

account
Type: Sitecore.Social.Domain.Model..::..Account
The account to create.

Implements

IAccountManager..::..CreateAccount(Account)

Remarks

The Id field will contain identifier of the new account.

Examples

CopyC#
var facebookAccount = new Account
{
  ApplicationId = facebookApplicationId,
  Name = "John Smith",
  AccountCredentials = new AccountCredentials
  {
    AccessToken = "sldkfgj23423-===12",
    AccessTokenSecret = "12312kkwerkqw"
  },
  AccountContainer = "/sitecore/system/social/accounts",
  LastRenewalDate = DateTime.Now
};

accountManager.CreateAccount(facebookAccount);

this.ShowAccount(facebookAccount);

Exceptions

Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions..::..AccountContainerIsNotFoundException | Account container is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..CannotReadAccountException | Account was created, but could not be read.

See Also

AccountManager Class
Sitecore.Social.Api Namespace


GetAccount Method

[image]

Sitecore Social Connected 1.3.1 API
AccountManager..::..GetAccount Method
AccountManager Class Example See Also Send Feedback
Gets an account by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Account GetAccount(
    Identifier accountId
)
Visual Basic
Public Function GetAccount ( _
    accountId As Identifier _
) As Account
Visual C++
public:
virtual Account^ GetAccount(
    Identifier^ accountId
) sealed

Parameters

accountId
Type: Sitecore.Social.Domain.Model..::..Identifier
The account id.

Return Value

The account. If the account is not found, Empty is returned.

Implements

IAccountManager..::..GetAccount(Identifier)

Examples

CopyC#
var account = accountManager.GetAccount(accountId);

if (!account.IsEmpty)
{
  this.ShowAccount(account);
}

See Also

AccountManager Class
Sitecore.Social.Api Namespace


GetAccounts Method

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountManager..::..GetAccounts Method
AccountManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.

See Also

AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


GetAccounts Method (String)

[image]

Sitecore Social Connected 1.3.1 API
AccountManager..::..GetAccounts Method (String)
AccountManager Class Example See Also Send Feedback
Gets all accounts by network name. Returns a collection of accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Account> GetAccounts(
    string networkName
)
Visual Basic
Public Function GetAccounts ( _
    networkName As String _
) As IEnumerable(Of Account)
Visual C++
public:
virtual IEnumerable<Account^>^ GetAccounts(
    String^ networkName
) sealed

Parameters

networkName
Type: System..::..String
The name of the network (case-sensitive).

Return Value

The account list. If no accounts are found an empty list is returned.

Implements

IAccountManager..::..GetAccounts(String)

Examples

CopyC#
var accounts = accountManager.GetAccounts("Facebook");

foreach (var account in accounts)
{
  this.ShowAccount(account);
}

See Also

AccountManager Class
GetAccounts Overload
Sitecore.Social.Api Namespace


GetAccounts Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
AccountManager..::..GetAccounts Method (Identifier)
AccountManager Class Example See Also Send Feedback
Gets all accounts by network id. Returns a collection of accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Account> GetAccounts(
    Identifier networkId
)
Visual Basic
Public Function GetAccounts ( _
    networkId As Identifier _
) As IEnumerable(Of Account)
Visual C++
public:
virtual IEnumerable<Account^>^ GetAccounts(
    Identifier^ networkId
) sealed

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.

Return Value

The account list. If no accounts are found an empty list is returned.

Implements

IAccountManager..::..GetAccounts(Identifier)

Examples

CopyC#
var accounts = accountManager.GetAccounts(facebookNetworkId);

foreach (var account in accounts)
{
  this.ShowAccount(account);
}

See Also

AccountManager Class
GetAccounts Overload
Sitecore.Social.Api Namespace


GetAccountsByApplication Method

[image]

Sitecore Social Connected 1.3.1 API
AccountManager..::..GetAccountsByApplication Method
AccountManager Class Example See Also Send Feedback
Gets all accounts by application id. Returns a collection of accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Account> GetAccountsByApplication(
    Identifier applicationId
)
Visual Basic
Public Function GetAccountsByApplication ( _
    applicationId As Identifier _
) As IEnumerable(Of Account)
Visual C++
public:
virtual IEnumerable<Account^>^ GetAccountsByApplication(
    Identifier^ applicationId
) sealed

Parameters

applicationId
Type: Sitecore.Social.Domain.Model..::..Identifier
The application id.

Return Value

The account list. If no accounts are found an empty list is returned.

Implements

IAccountManager..::..GetAccountsByApplication(Identifier)

Examples

CopyC#
var accounts = accountManager.GetAccountsByApplication(applicationId);

foreach (var account in accounts)
{
  this.ShowAccount(account);
}

See Also

AccountManager Class
Sitecore.Social.Api Namespace


ApplicationManager Class

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager Class
Members See Also Send Feedback
Defines the methods that are used to manage social network applications.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class ApplicationManager : IApplicationManager
Visual Basic
Public Class ApplicationManager _
    Implements IApplicationManager
Visual C++
public ref class ApplicationManager : IApplicationManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..ApplicationManager

See Also

ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationManager Members
ApplicationManager Class Constructors Methods See Also Send Feedback

The ApplicationManager type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationManager()()()() | Initializes a new instance of the ApplicationManager class.
Public method | ApplicationManager(INetworkManager, IApplicationBusinessManager) | Initializes a new instance of the ApplicationManager class.

Methods

 | Name | Description
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.

See Also

ApplicationManager Class
Sitecore.Social.Api Namespace


ApplicationManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationManager Constructor
ApplicationManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplicationManager()()()() | Initializes a new instance of the ApplicationManager class.
Public method | ApplicationManager(INetworkManager, IApplicationBusinessManager) | Initializes a new instance of the ApplicationManager class.

See Also

ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager Constructor
ApplicationManager Class See Also Send Feedback
Initializes a new instance of the ApplicationManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationManager()
Visual Basic
Public Sub New
Visual C++
public:
ApplicationManager()

See Also

ApplicationManager Class
ApplicationManager Overload
Sitecore.Social.Api Namespace


ApplicationManager Constructor (INetworkManager, )

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager Constructor (INetworkManager, )
ApplicationManager Class See Also Send Feedback
Initializes a new instance of the ApplicationManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationManager(
    INetworkManager networkManager,
    IApplicationBusinessManager applicationBusinessManager
)
Visual Basic
Public Sub New ( _
    networkManager As INetworkManager, _
    applicationBusinessManager As IApplicationBusinessManager _
)
Visual C++
public:
ApplicationManager(
    INetworkManager^ networkManager,
    IApplicationBusinessManager^ applicationBusinessManager
)

Parameters

networkManager
Type: Sitecore.Social.Domain..::..INetworkManager
The network manager.
applicationBusinessManager
Type: IApplicationBusinessManager
The application business manager.

See Also

ApplicationManager Class
ApplicationManager Overload
Sitecore.Social.Api Namespace


ApplicationManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationManager Methods
ApplicationManager Class See Also Send Feedback

The ApplicationManager type exposes the following members.

Methods

 | Name | Description
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.

See Also

ApplicationManager Class
Sitecore.Social.Api Namespace


GetApplication Method

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplication Method
ApplicationManager Class Example See Also Send Feedback
Gets an application by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Application GetApplication(
    Identifier applicationId
)
Visual Basic
Public Function GetApplication ( _
    applicationId As Identifier _
) As Application
Visual C++
public:
virtual Application^ GetApplication(
    Identifier^ applicationId
) sealed

Parameters

applicationId
Type: Sitecore.Social.Domain.Model..::..Identifier
The application id.

Return Value

The application. If the application is not found Empty is returned.

Implements

IApplicationManager..::..GetApplication(Identifier)

Examples

CopyC#
var application = applicationManager.GetApplication(applicationId);
if (!application.IsEmpty)
{
  this.ShowApplication(application);
}

See Also

ApplicationManager Class
Sitecore.Social.Api Namespace


GetApplicationContainer Method

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplicationContainer Method
ApplicationManager Class Example See Also Send Feedback
Gets the application container by account container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string GetApplicationContainer(
    string accountContainer
)
Visual Basic
Public Function GetApplicationContainer ( _
    accountContainer As String _
) As String
Visual C++
public:
virtual String^ GetApplicationContainer(
    String^ accountContainer
) sealed

Parameters

accountContainer
Type: System..::..String
The account container.

Return Value

The application container. If the application container is not found string.Empty is returned.

Implements

IApplicationManager..::..GetApplicationContainer(String)

Examples

CopyC#
var applicationContainer = applicationManager.GetApplicationContainer("/sitecore/system/Social/Accounts");

Console.WriteLine("The application container for the account container /sitecore/system/Social/Accounts is: {0}", applicationContainer);

See Also

ApplicationManager Class
Sitecore.Social.Api Namespace


GetApplications Method

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplications Method
ApplicationManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.

See Also

ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


GetApplications Method (String)

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplications Method (String)
ApplicationManager Class Example See Also Send Feedback
Gets the applications by network name.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Application> GetApplications(
    string networkName
)
Visual Basic
Public Function GetApplications ( _
    networkName As String _
) As IEnumerable(Of Application)
Visual C++
public:
virtual IEnumerable<Application^>^ GetApplications(
    String^ networkName
) sealed

Parameters

networkName
Type: System..::..String
The name of the network (case-sensitive).

Return Value

The application list. If no applications are found an empty list is returned.

Implements

IApplicationManager..::..GetApplications(String)

Examples

CopyC#
var applications = applicationManager.GetApplications("Facebook");
foreach (var application in applications)
{
  this.ShowApplication(application);
}

See Also

ApplicationManager Class
GetApplications Overload
Sitecore.Social.Api Namespace


GetApplications Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplications Method (Identifier)
ApplicationManager Class Example See Also Send Feedback
Gets the applications by network id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Application> GetApplications(
    Identifier networkId
)
Visual Basic
Public Function GetApplications ( _
    networkId As Identifier _
) As IEnumerable(Of Application)
Visual C++
public:
virtual IEnumerable<Application^>^ GetApplications(
    Identifier^ networkId
) sealed

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
Id of the network.

Return Value

The application list. If no applications are found an empty list is returned.

Implements

IApplicationManager..::..GetApplications(Identifier)

Examples

CopyC#
var facebookNetwork = networkManager.GetNetwork("Facebook");
var applications = applicationManager.GetApplications(facebookNetwork.Id);
foreach (var application in applications)
{
  this.ShowApplication(application);
}

See Also

ApplicationManager Class
GetApplications Overload
Sitecore.Social.Api Namespace


GetApplicationsByContainer Method

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplicationsByContainer Method
ApplicationManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.

See Also

ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


GetApplicationsByContainer Method (String)

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplicationsByContainer Method (String)
ApplicationManager Class Example See Also Send Feedback
Gets the applications by container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer
)
Visual Basic
Public Function GetApplicationsByContainer ( _
    applicationContainer As String _
) As IEnumerable(Of Application)
Visual C++
public:
virtual IEnumerable<Application^>^ GetApplicationsByContainer(
    String^ applicationContainer
) sealed

Parameters

applicationContainer
Type: System..::..String
The application container.

Return Value

The application list. If no applications are found an empty list is returned.

Implements

IApplicationManager..::..GetApplicationsByContainer(String)

Examples

CopyC#
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default");
foreach (var application in applications)
{
  this.ShowApplication(application);
}

See Also

ApplicationManager Class
GetApplicationsByContainer Overload
Sitecore.Social.Api Namespace


GetApplicationsByContainer Method (String, Identifier)

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplicationsByContainer Method (String, Identifier)
ApplicationManager Class Example See Also Send Feedback
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    Identifier networkId
)
Visual Basic
Public Function GetApplicationsByContainer ( _
    applicationContainer As String, _
    networkId As Identifier _
) As IEnumerable(Of Application)
Visual C++
public:
virtual IEnumerable<Application^>^ GetApplicationsByContainer(
    String^ applicationContainer,
    Identifier^ networkId
) sealed

Parameters

applicationContainer
Type: System..::..String
The application container.
networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
Id of the network.

Return Value

The application list. If no applications are found an empty list is returned.

Implements

IApplicationManager..::..GetApplicationsByContainer(String, Identifier)

Examples

CopyC#
var facebookNetwork = networkManager.GetNetwork("Facebook");
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default", facebookNetwork.Id);
foreach (var application in applications)
{
  this.ShowApplication(application);
}

See Also

ApplicationManager Class
GetApplicationsByContainer Overload
Sitecore.Social.Api Namespace


GetApplicationsByContainer Method (String, String)

[image]

Sitecore Social Connected 1.3.1 API
ApplicationManager..::..GetApplicationsByContainer Method (String, String)
ApplicationManager Class Example See Also Send Feedback
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    string networkName
)
Visual Basic
Public Function GetApplicationsByContainer ( _
    applicationContainer As String, _
    networkName As String _
) As IEnumerable(Of Application)
Visual C++
public:
virtual IEnumerable<Application^>^ GetApplicationsByContainer(
    String^ applicationContainer,
    String^ networkName
) sealed

Parameters

applicationContainer
Type: System..::..String
The application container.
networkName
Type: System..::..String
The name of the network (case-sensitive).

Return Value

The application list. If no applications are found an empty list is returned.

Implements

IApplicationManager..::..GetApplicationsByContainer(String, String)

Examples

CopyC#
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default", "Facebook");
foreach (var application in applications)
{
  this.ShowApplication(application);
}

See Also

ApplicationManager Class
GetApplicationsByContainer Overload
Sitecore.Social.Api Namespace


MessageManager Class

[image]

Sitecore Social Connected 1.3.1 API
MessageManager Class
Members See Also Send Feedback
Defines the methods that are used to manage social network messages.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class MessageManager : IMessageManager
Visual Basic
Public Class MessageManager _
    Implements IMessageManager
Visual C++
public ref class MessageManager : IMessageManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..MessageManager

See Also

MessageManager Members
Sitecore.Social.Api Namespace


MessageManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageManager Members
MessageManager Class Constructors Methods See Also Send Feedback

The MessageManager type exposes the following members.

Constructors

 | Name | Description
Public method | MessageManager()()()() | Initializes a new instance of the MessageManager class.
Public method | MessageManager(INetworkManager, IMessageBusinessManager) | Initializes a new instance of the MessageManager class.

Methods

 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | GetMessage | Gets the message by id.
Public method | GetMessages(PostingConfigurationSearchArgs) | Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessageStatus | Gets the message status.
Public method | PostMessage | Posts the message to a social network.
Public method | UpdateMessage | Updates the message.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


MessageManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageManager Constructor
MessageManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageManager()()()() | Initializes a new instance of the MessageManager class.
Public method | MessageManager(INetworkManager, IMessageBusinessManager) | Initializes a new instance of the MessageManager class.

See Also

MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
MessageManager Constructor
MessageManager Class See Also Send Feedback
Initializes a new instance of the MessageManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageManager()
Visual Basic
Public Sub New
Visual C++
public:
MessageManager()

See Also

MessageManager Class
MessageManager Overload
Sitecore.Social.Api Namespace


MessageManager Constructor (INetworkManager, )

[image]

Sitecore Social Connected 1.3.1 API
MessageManager Constructor (INetworkManager, )
MessageManager Class See Also Send Feedback
Initializes a new instance of the MessageManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageManager(
    INetworkManager networkManager,
    IMessageBusinessManager messageBusinessManager
)
Visual Basic
Public Sub New ( _
    networkManager As INetworkManager, _
    messageBusinessManager As IMessageBusinessManager _
)
Visual C++
public:
MessageManager(
    INetworkManager^ networkManager,
    IMessageBusinessManager^ messageBusinessManager
)

Parameters

networkManager
Type: Sitecore.Social.Domain..::..INetworkManager
The network manager.
messageBusinessManager
Type: IMessageBusinessManager
The message business manager.

See Also

MessageManager Class
MessageManager Overload
Sitecore.Social.Api Namespace


MessageManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageManager Methods
MessageManager Class See Also Send Feedback

The MessageManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | GetMessage | Gets the message by id.
Public method | GetMessages(PostingConfigurationSearchArgs) | Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessageStatus | Gets the message status.
Public method | PostMessage | Posts the message to a social network.
Public method | UpdateMessage | Updates the message.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


CreateMessage Method

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..CreateMessage Method
MessageManager Class Example See Also Send Feedback
Creates a message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void CreateMessage(
    Message message
)
Visual Basic
Public Sub CreateMessage ( _
    message As Message _
)
Visual C++
public:
virtual void CreateMessage(
    Message^ message
) sealed

Parameters

message
Type: Sitecore.Social.Domain.Model..::..Message
The message to create.

Implements

IMessageManager..::..CreateMessage(Message)

Remarks

  • The Id field will contain identifier of the created message.
  • To post messages automatically on a goal triggering the following rule should be configured for the goal:
    • condition - System: where true (actions always execute)
    • action - Social: post associated messages

Examples

CopyC#
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "<link linktype=\"internal\" url=\"/Home.aspx\" querystring=\"sc_lang=en\" target=\"\" id=\"{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}\" />",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "<image mediaid=\"{EBA7F6D5-8C28-4304-B976-12E9DDBCF32A}\" mediapath=\"/Images/hero3\" src=\"~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx\" />",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var contentPostingConfiguration = new ContentPostingConfiguration("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");
foreach (var accountId in accountManager.GetAccounts(facebookNetworkId).Select(account => account.Id))
{
  contentPostingConfiguration.AccountIds.Add(accountId);
}

var facebookMessage = new Message(facebookNetworkId, facebookMessageData, contentPostingConfiguration);

messageManager.CreateMessage(facebookMessage);

this.ShowMessage(facebookMessage);

Exceptions

Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
System..::..InvalidCastException | Invalid casts occured.
System..::..FormatException | Invalid values are presented.
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException | Message data builder is not found.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


DeleteMessage Method

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..DeleteMessage Method
MessageManager Class Example See Also Send Feedback
Deletes the message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void DeleteMessage(
    Identifier messageId
)
Visual Basic
Public Sub DeleteMessage ( _
    messageId As Identifier _
)
Visual C++
public:
virtual void DeleteMessage(
    Identifier^ messageId
) sealed

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Implements

IMessageManager..::..DeleteMessage(Identifier)

Examples

CopyC#
messageManager.DeleteMessage(messageId);

Console.WriteLine("Deleted!");

Exceptions

Exception | Condition
ItemNotFoundException | Item is not found.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


GetMessage Method

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..GetMessage Method
MessageManager Class Example See Also Send Feedback
Gets the message by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Message GetMessage(
    Identifier messageId
)
Visual Basic
Public Function GetMessage ( _
    messageId As Identifier _
) As Message
Visual C++
public:
virtual Message^ GetMessage(
    Identifier^ messageId
) sealed

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The message. If message is not found Empty is returned.

Implements

IMessageManager..::..GetMessage(Identifier)

Examples

CopyC#
var message = messageManager.GetMessage(messageId);

if (!message.IsEmpty)
{
  this.ShowMessage(message);
}

Exceptions

Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException | Message data builder is not found.
System..::..InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


GetMessages Method

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..GetMessages Method
MessageManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages(PostingConfigurationSearchArgs) | Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Gets all messages by network ID which contain specific search arguments.

See Also

MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


GetMessages Method (PostingConfigurationSearchArgs)

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..GetMessages Method (PostingConfigurationSearchArgs)
MessageManager Class Example See Also Send Feedback
Gets all messages containing specific search arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs
)
Visual Basic
Public Function GetMessages ( _
    searchArgs As PostingConfigurationSearchArgs _
) As IEnumerable(Of Message)
Visual C++
public:
virtual IEnumerable<Message^>^ GetMessages(
    PostingConfigurationSearchArgs^ searchArgs
) sealed

Parameters

searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search arguments.

Return Value

The messages list. If no messages are found an empty list is returned.

Implements

IMessageManager..::..GetMessages(PostingConfigurationSearchArgs)

Examples

CopyC#
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var contentMessages = messageManager.GetMessages(searchArgs);

Console.WriteLine("Content messages:");
foreach (var message in contentMessages)
{
  this.ShowMessage(message);
}

Exceptions

Exception | Condition
System..::..FormatException | Invalid search arguments values are presented.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationSearchArgsAdapterIsNotFoundException | Posting configuration search arguments adapter is not found.
System..::..InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException | Message data builder is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.

See Also

MessageManager Class
GetMessages Overload
Sitecore.Social.Api Namespace


GetMessages Method (PostingConfigurationSearchArgs, Identifier)

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..GetMessages Method (PostingConfigurationSearchArgs, Identifier)
MessageManager Class Example See Also Send Feedback
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    Identifier networkId
)
Visual Basic
Public Function GetMessages ( _
    searchArgs As PostingConfigurationSearchArgs, _
    networkId As Identifier _
) As IEnumerable(Of Message)
Visual C++
public:
virtual IEnumerable<Message^>^ GetMessages(
    PostingConfigurationSearchArgs^ searchArgs,
    Identifier^ networkId
) sealed

Parameters

searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.

Return Value

The messages list. If no messages are found an empty list is returned.

Implements

IMessageManager..::..GetMessages(PostingConfigurationSearchArgs, Identifier)

Examples

CopyC#
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var facebookMessages = messageManager.GetMessages(searchArgs, facebookId);

foreach (var message in facebookMessages)
{
  this.ShowMessage(message);
}

Exceptions

Exception | Condition
System..::..FormatException | Invalid search arguments values are presented.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationSearchArgsAdapterIsNotFoundException | Posting configuration search arguments adapter is not found.
System..::..InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException | Message data builder is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.

See Also

MessageManager Class
GetMessages Overload
Sitecore.Social.Api Namespace


GetMessages Method (PostingConfigurationSearchArgs, String)

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..GetMessages Method (PostingConfigurationSearchArgs, String)
MessageManager Class Example See Also Send Feedback
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    string networkName
)
Visual Basic
Public Function GetMessages ( _
    searchArgs As PostingConfigurationSearchArgs, _
    networkName As String _
) As IEnumerable(Of Message)
Visual C++
public:
virtual IEnumerable<Message^>^ GetMessages(
    PostingConfigurationSearchArgs^ searchArgs,
    String^ networkName
) sealed

Parameters

searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
networkName
Type: System..::..String
The name of the network (case-sensitive).

Return Value

The messages list. If no messages are found an empty list is returned.

Implements

IMessageManager..::..GetMessages(PostingConfigurationSearchArgs, String)

Examples

CopyC#
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var facebookMessages = messageManager.GetMessages(searchArgs, "Facebook");

foreach (var message in facebookMessages)
{
  this.ShowMessage(message);
}

Exceptions

Exception | Condition
System..::..FormatException | Invalid search arguments values are presented.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationSearchArgsAdapterIsNotFoundException | Posting configuration search arguments adapter is not found.
System..::..InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException | Message data builder is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.

See Also

MessageManager Class
GetMessages Overload
Sitecore.Social.Api Namespace


GetMessageStatus Method

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..GetMessageStatus Method
MessageManager Class Example See Also Send Feedback
Gets the message status.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatus GetMessageStatus(
    Identifier messageId
)
Visual Basic
Public Function GetMessageStatus ( _
    messageId As Identifier _
) As MessageStatus
Visual C++
public:
virtual MessageStatus^ GetMessageStatus(
    Identifier^ messageId
) sealed

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The MessageStatus. If the status is not defined Empty is returned.

Implements

IMessageManager..::..GetMessageStatus(Identifier)

Examples

CopyC#
var messageStatus = messageManager.GetMessageStatus(messageId);

if (!messageStatus.IsEmpty)
{
  foreach (var accountStatus in messageStatus.AccountStatuses.Where(status => status.PostingStatus is FailedPostingStatus))
  {
    Console.WriteLine("Account Id: {0}, ErrorText: {1}", accountStatus.AccountId, ((FailedPostingStatus)accountStatus.PostingStatus).ErrorText);
  }
}

Exceptions

Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions..::..MessageStatusBuilderIsNotFoundException | Message status builder is not found.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


PostMessage Method

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..PostMessage Method
MessageManager Class Example See Also Send Feedback
Posts the message to a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void PostMessage(
    Identifier messageId
)
Visual Basic
Public Sub PostMessage ( _
    messageId As Identifier _
)
Visual C++
public:
virtual void PostMessage(
    Identifier^ messageId
) sealed

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Implements

IMessageManager..::..PostMessage(Identifier)

Examples

CopyC#
messageManager.PostMessage(messageId);

var messageStatus = messageManager.GetMessageStatus(messageId);
if (!messageStatus.IsEmpty)
{
  foreach (var accountStatus in messageStatus.AccountStatuses.Where(accountStatus => accountStatus.PostingStatus is FailedPostingStatus))
  {
    Console.WriteLine("Account Id: {0}, ErrorText: {1}", accountStatus.AccountId, ((FailedPostingStatus)accountStatus.PostingStatus).ErrorText);
  }
}

Exceptions

Exception | Condition
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
System..::..InvalidCastException | Invalid casts occured.
System..::..FormatException | Invalid values are presented.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


UpdateMessage Method

[image]

Sitecore Social Connected 1.3.1 API
MessageManager..::..UpdateMessage Method
MessageManager Class Example See Also Send Feedback
Updates the message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void UpdateMessage(
    Message message
)
Visual Basic
Public Sub UpdateMessage ( _
    message As Message _
)
Visual C++
public:
virtual void UpdateMessage(
    Message^ message
) sealed

Parameters

message
Type: Sitecore.Social.Domain.Model..::..Message
The message to update.

Implements

IMessageManager..::..UpdateMessage(Message)

Examples

CopyC#
var facebookMessage = messageManager.GetMessage(facebookMessageId);

if (!facebookMessage.IsEmpty)
{
  var facebookMessageData = (FacebookMessageData)facebookMessage.MessageData;
  facebookMessageData.Text += "updated";
  facebookMessageData.LinkDescription += "updated";

  var postingConfiguration = (ContentPostingConfiguration)facebookMessage.PostingConfiguration;
  postingConfiguration.AccountIds.Add(newAccountId);

  messageManager.UpdateMessage(facebookMessage);

  this.ShowMessage(facebookMessage);
}

Exceptions

Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
System..::..InvalidCastException | Invalid casts occured.
System..::..FormatException | Invalid values are presented.
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException | Message data builder is not found.

See Also

MessageManager Class
Sitecore.Social.Api Namespace


MessageStatisticsManager Class

[image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager Class
Members See Also Send Feedback
Defines the methods that are used to manage social network message statistics.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class MessageStatisticsManager : IMessageStatisticsManager
Visual Basic
Public Class MessageStatisticsManager _
    Implements IMessageStatisticsManager
Visual C++
public ref class MessageStatisticsManager : IMessageStatisticsManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..MessageStatisticsManager

See Also

MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager Members
MessageStatisticsManager Class Constructors Methods See Also Send Feedback

The MessageStatisticsManager type exposes the following members.

Constructors

 | Name | Description
Public method | MessageStatisticsManager()()()() | Initializes a new instance of the MessageStatisticsManager class.
Public method | MessageStatisticsManager(IMessageStatisticsBusinessManager) | Initializes a new instance of the MessageStatisticsManager class.

Methods

 | Name | Description
Public method | GetMessageStatistics | Gets message statistics.
Public method | RefreshMessageStatistics | Refreshes message statistics.

See Also

MessageStatisticsManager Class
Sitecore.Social.Api Namespace


MessageStatisticsManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager Constructor
MessageStatisticsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageStatisticsManager()()()() | Initializes a new instance of the MessageStatisticsManager class.
Public method | MessageStatisticsManager(IMessageStatisticsBusinessManager) | Initializes a new instance of the MessageStatisticsManager class.

See Also

MessageStatisticsManager Class
MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager Constructor
MessageStatisticsManager Class See Also Send Feedback
Initializes a new instance of the MessageStatisticsManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatisticsManager()
Visual Basic
Public Sub New
Visual C++
public:
MessageStatisticsManager()

See Also

MessageStatisticsManager Class
MessageStatisticsManager Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager Constructor ()

[image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager Constructor ()
MessageStatisticsManager Class See Also Send Feedback
Initializes a new instance of the MessageStatisticsManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatisticsManager(
    IMessageStatisticsBusinessManager messageStatisticsBusinessManager
)
Visual Basic
Public Sub New ( _
    messageStatisticsBusinessManager As IMessageStatisticsBusinessManager _
)
Visual C++
public:
MessageStatisticsManager(
    IMessageStatisticsBusinessManager^ messageStatisticsBusinessManager
)

Parameters

messageStatisticsBusinessManager
Type: IMessageStatisticsBusinessManager
The message statistics business manager.

See Also

MessageStatisticsManager Class
MessageStatisticsManager Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager Methods
MessageStatisticsManager Class See Also Send Feedback

The MessageStatisticsManager type exposes the following members.

Methods

 | Name | Description
Public method | GetMessageStatistics | Gets message statistics.
Public method | RefreshMessageStatistics | Refreshes message statistics.

See Also

MessageStatisticsManager Class
Sitecore.Social.Api Namespace


GetMessageStatistics Method

[image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager..::..GetMessageStatistics Method
MessageStatisticsManager Class Example See Also Send Feedback
Gets message statistics.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatistics GetMessageStatistics(
    Identifier messageId
)
Visual Basic
Public Function GetMessageStatistics ( _
    messageId As Identifier _
) As MessageStatistics
Visual C++
public:
virtual MessageStatistics^ GetMessageStatistics(
    Identifier^ messageId
) sealed

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The message statistics.

Implements

IMessageStatisticsManager..::..GetMessageStatistics(Identifier)

Examples

CopyC#
var messageStatistics = messageStatisticsManager.GetMessageStatistics(facebookMessageId);

if (!messageStatistics.IsEmpty)
{
  Console.WriteLine("MessageId: {0}, StartRefreshDate: {1}, LastRefreshDate: {2}", messageStatistics.MessageId, messageStatistics.StartRefreshDate, messageStatistics.LastRefreshDate);

  foreach (var accountStatistics in messageStatistics.AccountsStatistics)
  {
    Console.WriteLine("AccountId: {0}", accountStatistics.AccountId);

    foreach (var statisticsCounter in accountStatistics.StatisticsCounters)
    {
      Console.WriteLine("Name: {0}, Number: {1}", statisticsCounter.Name, ((NumberCounter)statisticsCounter).Number);
    }
  }
}

See Also

MessageStatisticsManager Class
Sitecore.Social.Api Namespace


RefreshMessageStatistics Method

[image]

Sitecore Social Connected 1.3.1 API
MessageStatisticsManager..::..RefreshMessageStatistics Method
MessageStatisticsManager Class Example See Also Send Feedback
Refreshes message statistics.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void RefreshMessageStatistics(
    Identifier messageId
)
Visual Basic
Public Sub RefreshMessageStatistics ( _
    messageId As Identifier _
)
Visual C++
public:
virtual void RefreshMessageStatistics(
    Identifier^ messageId
) sealed

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Implements

IMessageStatisticsManager..::..RefreshMessageStatistics(Identifier)

Examples

CopyC#
messageStatisticsManager.RefreshMessageStatistics(messageId);

var messageStatistics = messageStatisticsManager.GetMessageStatistics(messageId);

if (!messageStatistics.IsEmpty)
{
  foreach (var accountStatistics in messageStatistics.AccountsStatistics.Where(accountStatistics => accountStatistics.StatisticsStatus is FailedStatisticsStatus))
  {
    Console.WriteLine("Account Id: {0}", accountStatistics.AccountId);
  }
}

See Also

MessageStatisticsManager Class
Sitecore.Social.Api Namespace


NetworkManager Class

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager Class
Members See Also Send Feedback
Defines the methods that are used to manage social networks.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class NetworkManager : INetworkManager
Visual Basic
Public Class NetworkManager _
    Implements INetworkManager
Visual C++
public ref class NetworkManager : INetworkManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..NetworkManager

See Also

NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
NetworkManager Members
NetworkManager Class Constructors Methods See Also Send Feedback

The NetworkManager type exposes the following members.

Constructors

 | Name | Description
Public method | NetworkManager()()()() | Initializes a new instance of the NetworkManager class.
Public method | NetworkManager(INetworkBusinessManager) | Initializes a new instance of the NetworkManager class.

Methods

 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.

See Also

NetworkManager Class
Sitecore.Social.Api Namespace


NetworkManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
NetworkManager Constructor
NetworkManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetworkManager()()()() | Initializes a new instance of the NetworkManager class.
Public method | NetworkManager(INetworkBusinessManager) | Initializes a new instance of the NetworkManager class.

See Also

NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager Constructor
NetworkManager Class See Also Send Feedback
Initializes a new instance of the NetworkManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public NetworkManager()
Visual Basic
Public Sub New
Visual C++
public:
NetworkManager()

See Also

NetworkManager Class
NetworkManager Overload
Sitecore.Social.Api Namespace


NetworkManager Constructor ()

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager Constructor ()
NetworkManager Class See Also Send Feedback
Initializes a new instance of the NetworkManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public NetworkManager(
    INetworkBusinessManager networkBusinessManager
)
Visual Basic
Public Sub New ( _
    networkBusinessManager As INetworkBusinessManager _
)
Visual C++
public:
NetworkManager(
    INetworkBusinessManager^ networkBusinessManager
)

Parameters

networkBusinessManager
Type: INetworkBusinessManager
The network business manager.

See Also

NetworkManager Class
NetworkManager Overload
Sitecore.Social.Api Namespace


NetworkManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
NetworkManager Methods
NetworkManager Class See Also Send Feedback

The NetworkManager type exposes the following members.

Methods

 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.

See Also

NetworkManager Class
Sitecore.Social.Api Namespace


CanPostTo Method

[image] [image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..CanPostTo Method
NetworkManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.

See Also

NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


CanPostTo Method (String)

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..CanPostTo Method (String)
NetworkManager Class Example See Also Send Feedback
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool CanPostTo(
    string networkName
)
Visual Basic
Public Function CanPostTo ( _
    networkName As String _
) As Boolean
Visual C++
public:
virtual bool CanPostTo(
    String^ networkName
) sealed

Parameters

networkName
Type: System..::..String
The network name.

Return Value

true if it is possible to post messages to the network; otherwise, false.

Remarks

false is returned, if the network is not found.

Implements

INetworkManager..::..CanPostTo(String)

Examples

CopyC#
var result = networkManager.CanPostTo("Facebook");

Console.WriteLine("Can post to network: {0}", result);

See Also

NetworkManager Class
CanPostTo Overload
Sitecore.Social.Api Namespace


CanPostTo Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..CanPostTo Method (Identifier)
NetworkManager Class Example See Also Send Feedback
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool CanPostTo(
    Identifier networkId
)
Visual Basic
Public Function CanPostTo ( _
    networkId As Identifier _
) As Boolean
Visual C++
public:
virtual bool CanPostTo(
    Identifier^ networkId
) sealed

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.

Return Value

true if it is possible to post messages to the network; otherwise, false.

Remarks

false is returned, if the network is not found.

Implements

INetworkManager..::..CanPostTo(Identifier)

Examples

CopyC#
var result = networkManager.CanPostTo(facebookId);

Console.WriteLine("Can post to network: {0}", result);

See Also

NetworkManager Class
CanPostTo Overload
Sitecore.Social.Api Namespace


GetNetwork Method

[image] [image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..GetNetwork Method
NetworkManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.

See Also

NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


GetNetwork Method (String)

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..GetNetwork Method (String)
NetworkManager Class Example See Also Send Feedback
Gets a network by name.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Network GetNetwork(
    string networkName
)
Visual Basic
Public Function GetNetwork ( _
    networkName As String _
) As Network
Visual C++
public:
virtual Network^ GetNetwork(
    String^ networkName
) sealed

Parameters

networkName
Type: System..::..String
The name of the network (case-sensitive).

Return Value

The network. If the network is not found Empty is returned.

Implements

INetworkManager..::..GetNetwork(String)

Examples

CopyC#
var facebookNetwork = networkManager.GetNetwork("Facebook");
if (!facebookNetwork.IsEmpty)
{
  this.ShowNetwork(facebookNetwork);
}

See Also

NetworkManager Class
GetNetwork Overload
Sitecore.Social.Api Namespace


GetNetwork Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..GetNetwork Method (Identifier)
NetworkManager Class Example See Also Send Feedback
Gets a network by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Network GetNetwork(
    Identifier networkId
)
Visual Basic
Public Function GetNetwork ( _
    networkId As Identifier _
) As Network
Visual C++
public:
virtual Network^ GetNetwork(
    Identifier^ networkId
) sealed

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
Id of the network.

Return Value

The network. If the network is not found Empty is returned.

Implements

INetworkManager..::..GetNetwork(Identifier)

Examples

CopyC#
var facebookNetwork = networkManager.GetNetwork(facebookNetworkId);
if (!facebookNetwork.IsEmpty)
{
  this.ShowNetwork(facebookNetwork);
}

See Also

NetworkManager Class
GetNetwork Overload
Sitecore.Social.Api Namespace


GetNetworks Method

[image]

Sitecore Social Connected 1.3.1 API
NetworkManager..::..GetNetworks Method
NetworkManager Class Example See Also Send Feedback
Gets all registered networks.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<Network> GetNetworks()
Visual Basic
Public Function GetNetworks As IEnumerable(Of Network)
Visual C++
public:
virtual IEnumerable<Network^>^ GetNetworks() sealed

Return Value

The network list. If there are no networks, an empty list is returned.

Implements

INetworkManager..::..GetNetworks()()()()

Examples

CopyC#
var networks = networkManager.GetNetworks();

foreach (var network in networks)
{
  this.ShowNetwork(network);
}

See Also

NetworkManager Class
Sitecore.Social.Api Namespace


PostingPreferenceManager Class

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager Class
Members See Also Send Feedback
Defines the methods that are used to manage user’s posting preferences.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class PostingPreferenceManager : IPostingPreferenceManager
Visual Basic
Public Class PostingPreferenceManager _
    Implements IPostingPreferenceManager
Visual C++
public ref class PostingPreferenceManager : IPostingPreferenceManager

Remarks

Use it to manage posting preferences of the website visitors (whether or not they want messages to be posted automatically on their social network walls, for example, when you have configured Sitecore to post messages to the social network when a visitor achieves a goal on the website).

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..PostingPreferenceManager

See Also

PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager Members
PostingPreferenceManager Class Constructors Methods See Also Send Feedback

The PostingPreferenceManager type exposes the following members.

Constructors

 | Name | Description
Public method | PostingPreferenceManager()()()() | Initializes a new instance of the PostingPreferenceManager class.
Public method | PostingPreferenceManager(IPostingPreferenceBusinessManager, IMessageManager) | Initializes a new instance of the PostingPreferenceManager class.

Methods

 | Name | Description
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences | Gets user's posting preferences for all messages found by arguments.
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

PostingPreferenceManager Class
Sitecore.Social.Api Namespace


PostingPreferenceManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager Constructor
PostingPreferenceManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PostingPreferenceManager()()()() | Initializes a new instance of the PostingPreferenceManager class.
Public method | PostingPreferenceManager(IPostingPreferenceBusinessManager, IMessageManager) | Initializes a new instance of the PostingPreferenceManager class.

See Also

PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager Constructor
PostingPreferenceManager Class See Also Send Feedback
Initializes a new instance of the PostingPreferenceManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingPreferenceManager()
Visual Basic
Public Sub New
Visual C++
public:
PostingPreferenceManager()

See Also

PostingPreferenceManager Class
PostingPreferenceManager Overload
Sitecore.Social.Api Namespace


PostingPreferenceManager Constructor (, IMessageManager)

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager Constructor (, IMessageManager)
PostingPreferenceManager Class See Also Send Feedback
Initializes a new instance of the PostingPreferenceManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingPreferenceManager(
    IPostingPreferenceBusinessManager postingPreferenceBusinessManager,
    IMessageManager messageManager
)
Visual Basic
Public Sub New ( _
    postingPreferenceBusinessManager As IPostingPreferenceBusinessManager, _
    messageManager As IMessageManager _
)
Visual C++
public:
PostingPreferenceManager(
    IPostingPreferenceBusinessManager^ postingPreferenceBusinessManager,
    IMessageManager^ messageManager
)

Parameters

postingPreferenceBusinessManager
Type: IPostingPreferenceBusinessManager
The posting preference business manager.
messageManager
Type: Sitecore.Social.Domain..::..IMessageManager
The message manager.

See Also

PostingPreferenceManager Class
PostingPreferenceManager Overload
Sitecore.Social.Api Namespace


PostingPreferenceManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager Methods
PostingPreferenceManager Class See Also Send Feedback

The PostingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences | Gets user's posting preferences for all messages found by arguments.
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

PostingPreferenceManager Class
Sitecore.Social.Api Namespace


AllowAutomaticPostingByDefault Method

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager..::..AllowAutomaticPostingByDefault Method
PostingPreferenceManager Class Example See Also Send Feedback
Determines if automatic posting is allowed by default.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool AllowAutomaticPostingByDefault()
Visual Basic
Public Function AllowAutomaticPostingByDefault As Boolean
Visual C++
public:
virtual bool AllowAutomaticPostingByDefault() sealed

Return Value

true if automatic posting is allowed by default, otherwise false.

Implements

IPostingPreferenceManager..::..AllowAutomaticPostingByDefault()()()()

Remarks

The value is set in the [website_root]\app_config\include\sitecore.social.config file, in the "Social.AllowPublishByDefault" setting

Examples

CopyC#
var allowAutomaticPostingByDefault = postingPreferenceManager.AllowAutomaticPostingByDefault();

Console.WriteLine("Allow automatic posting by default: {0}", allowAutomaticPostingByDefault);

See Also

PostingPreferenceManager Class
Sitecore.Social.Api Namespace


GetPostingPreference Method

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager..::..GetPostingPreference Method
PostingPreferenceManager Class Example See Also Send Feedback
Gets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingPreference GetPostingPreference(
    IPrincipal user,
    Identifier messageId
)
Visual Basic
Public Function GetPostingPreference ( _
    user As IPrincipal, _
    messageId As Identifier _
) As PostingPreference
Visual C++
public:
virtual PostingPreference^ GetPostingPreference(
    IPrincipal^ user,
    Identifier^ messageId
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The posting preference. If the posting preference is not found the Default value is used.

Implements

IPostingPreferenceManager..::..GetPostingPreference(IPrincipal, Identifier)

Examples

CopyC#
var postingPreference = postingPreferenceManager.GetPostingPreference(user, messageId);

Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);

Exceptions

Exception | Condition
System..::..NotSupportedException | The automatic posting preference is not supported.

See Also

PostingPreferenceManager Class
Sitecore.Social.Api Namespace
PostingPreference..::..AutomaticPostingPreference
UserExtensions..::..GetPostingPreference(IPrincipal, Identifier)


GetPostingPreferences Method

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager..::..GetPostingPreferences Method
PostingPreferenceManager Class Example See Also Send Feedback
Gets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
Visual Basic
Public Function GetPostingPreferences ( _
    user As IPrincipal, _
    searchArgs As PostingConfigurationSearchArgs _
) As IEnumerable(Of PostingPreference)
Visual C++
public:
virtual IEnumerable<PostingPreference^>^ GetPostingPreferences(
    IPrincipal^ user,
    PostingConfigurationSearchArgs^ searchArgs
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search arguments.

Return Value

The posting preference list. If no preferences are found an empty list is returned.

Implements

IPostingPreferenceManager..::..GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs)

Examples

CopyC#
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

var postingPreferences = postingPreferenceManager.GetPostingPreferences(user, searchArgs);

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}

Exceptions

Exception | Condition
System..::..NotSupportedException | The automatic posting preference is not supported.

See Also

PostingPreferenceManager Class
Sitecore.Social.Api Namespace
UserExtensions..::..GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs)


SetPostingPreference Method

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager..::..SetPostingPreference Method
PostingPreferenceManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager..::..SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)
PostingPreferenceManager Class Example See Also Send Feedback
Sets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void SetPostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
Public Sub SetPostingPreference ( _
    user As IPrincipal, _
    messageId As Identifier, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
public:
virtual void SetPostingPreference(
    IPrincipal^ user,
    Identifier^ messageId,
    AutomaticPostingPreference automaticPostingPreference
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

Implements

IPostingPreferenceManager..::..SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference)

Examples

CopyC#
postingPreferenceManager.SetPostingPreference(user, messageId, AutomaticPostingPreference.Denied);

Exceptions

Exception | Condition
System..::..Exception | Message is not found.
System..::..Exception | Message has invalid template.
System..::..Exception | Impossible to set preference to anonymous user.
System..::..NotSupportedException | The automatic posting preference is not supported.

See Also

PostingPreferenceManager Class
SetPostingPreference Overload
Sitecore.Social.Api Namespace
UserExtensions..::..SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference)


SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

[image]

Sitecore Social Connected 1.3.1 API
PostingPreferenceManager..::..SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)
PostingPreferenceManager Class Example See Also Send Feedback
Sets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void SetPostingPreference(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
Public Sub SetPostingPreference ( _
    user As IPrincipal, _
    searchArgs As PostingConfigurationSearchArgs, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
public:
virtual void SetPostingPreference(
    IPrincipal^ user,
    PostingConfigurationSearchArgs^ searchArgs,
    AutomaticPostingPreference automaticPostingPreference
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

Implements

IPostingPreferenceManager..::..SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

Examples

CopyC#
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

postingPreferenceManager.SetPostingPreference(user, searchArgs, AutomaticPostingPreference.Denied);

Exceptions

Exception | Condition
System..::..Exception | Impossible to set preference to anonymous user.
System..::..NotSupportedException | The automatic posting preference is not supported.

See Also

PostingPreferenceManager Class
SetPostingPreference Overload
Sitecore.Social.Api Namespace
UserExtensions..::..SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)


SocialProfileManager Class

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager Class
Members See Also Send Feedback
Defines the methods that are used to manage a social profile.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class SocialProfileManager : ISocialProfileManager
Visual Basic
Public Class SocialProfileManager _
    Implements ISocialProfileManager
Visual C++
public ref class SocialProfileManager : ISocialProfileManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api..::..SocialProfileManager

See Also

SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager Members
SocialProfileManager Class Constructors Methods See Also Send Feedback

The SocialProfileManager type exposes the following members.

Constructors

 | Name | Description
Public method | SocialProfileManager()()()() | Initializes a new instance of the SocialProfileManager class.
Public method | SocialProfileManager(ISocialProfileBusinessManager) | Initializes a new instance of the SocialProfileManager class.

Methods

 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | GetSocialProfile | Gets a social profile.
Public method | GetSocialProfiles | Gets social profiles.
Public method | IsSocialProfileExists | Checks if a social profile exists.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | UpdateSocialProfile | Updates a social profile of the specified user.

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


SocialProfileManager Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager Constructor
SocialProfileManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialProfileManager()()()() | Initializes a new instance of the SocialProfileManager class.
Public method | SocialProfileManager(ISocialProfileBusinessManager) | Initializes a new instance of the SocialProfileManager class.

See Also

SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager Constructor
SocialProfileManager Class See Also Send Feedback
Initializes a new instance of the SocialProfileManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public SocialProfileManager()
Visual Basic
Public Sub New
Visual C++
public:
SocialProfileManager()

See Also

SocialProfileManager Class
SocialProfileManager Overload
Sitecore.Social.Api Namespace


SocialProfileManager Constructor ()

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager Constructor ()
SocialProfileManager Class See Also Send Feedback
Initializes a new instance of the SocialProfileManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public SocialProfileManager(
    ISocialProfileBusinessManager socialProfileBusinessManager
)
Visual Basic
Public Sub New ( _
    socialProfileBusinessManager As ISocialProfileBusinessManager _
)
Visual C++
public:
SocialProfileManager(
    ISocialProfileBusinessManager^ socialProfileBusinessManager
)

Parameters

socialProfileBusinessManager
Type: ISocialProfileBusinessManager
The social profile business manager.

See Also

SocialProfileManager Class
SocialProfileManager Overload
Sitecore.Social.Api Namespace


SocialProfileManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager Methods
SocialProfileManager Class See Also Send Feedback

The SocialProfileManager type exposes the following members.

Methods

 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | GetSocialProfile | Gets a social profile.
Public method | GetSocialProfiles | Gets social profiles.
Public method | IsSocialProfileExists | Checks if a social profile exists.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | UpdateSocialProfile | Updates a social profile of the specified user.

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


AttachSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..AttachSocialProfile Method
SocialProfileManager Class Example See Also Send Feedback
Attaches a social profile to the specified user.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void AttachSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Visual Basic
Public Sub AttachSocialProfile ( _
    user As IPrincipal, _
    socialProfile As SocialProfile _
)
Visual C++
public:
virtual void AttachSocialProfile(
    IPrincipal^ user,
    SocialProfile^ socialProfile
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
socialProfile
Type: Sitecore.Social.Domain.Model..::..SocialProfile
The social profile.

Implements

ISocialProfileManager..::..AttachSocialProfile(IPrincipal, SocialProfile)

Examples

CopyC#
try
{
  var facebookProfile = new SocialProfile
  {
    AccountCredentials = new AccountCredentials
    {
      AccessToken = "239842+-02399==",
      AccessTokenSecret = "8282271371232=-29382855"
    },
    Email = "john.smith@fakedomain.com",
    FullName = "John Smith",
    NetworkAccountId = "888127718888463",
    ApplicationCredentials = new ApplicationCredentials
    {
      ApplicationKey = "jkdsf90392===399",
      ApplicationSecret = "128281--==39939"
    },
    NetworkName = "Facebook",
    Fields = new Dictionary<string, string>
    {
      {
        "timezone", "UTC+8"
      },
      {
        "gender", "male"
      }
    }
  };

  socialProfileManager.AttachSocialProfile(user, facebookProfile);
  this.ShowSocialProfile(facebookProfile);
}
catch (AccountInUserDuplicatedException)
{
  // Following user already has another attached account of the same network.
}
catch (AccountInDomainDuplicatedException)
{
  // There is another user with the same account in domain.
}

Exceptions

Exception | Condition
AccountInUserDuplicatedException | Following user already has another attached account of the same network.
AccountInDomainDuplicatedException | There is another user with the same account in domain.

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


DetachSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..DetachSocialProfile Method
SocialProfileManager Class Example See Also Send Feedback
Removes a social profile from the specified user.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void DetachSocialProfile(
    IPrincipal user,
    string networkName
)
Visual Basic
Public Sub DetachSocialProfile ( _
    user As IPrincipal, _
    networkName As String _
)
Visual C++
public:
virtual void DetachSocialProfile(
    IPrincipal^ user,
    String^ networkName
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Implements

ISocialProfileManager..::..DetachSocialProfile(IPrincipal, String)

Examples

CopyC#
try
{
  socialProfileManager.DetachSocialProfile(user, "Facebook");
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}

Exceptions

Exception | Condition
AccountIsNotExistException | Following user has not account in this network.

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


GetSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..GetSocialProfile Method
SocialProfileManager Class Example See Also Send Feedback
Gets a social profile.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public SocialProfile GetSocialProfile(
    IPrincipal user,
    string networkName
)
Visual Basic
Public Function GetSocialProfile ( _
    user As IPrincipal, _
    networkName As String _
) As SocialProfile
Visual C++
public:
virtual SocialProfile^ GetSocialProfile(
    IPrincipal^ user,
    String^ networkName
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Return Value

The social profile. If there are no profiles, an empty profile is returned.

Implements

ISocialProfileManager..::..GetSocialProfile(IPrincipal, String)

Examples

CopyC#
var facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");

if (!facebookSocialProfile.IsEmpty)
{
  this.ShowSocialProfile(facebookSocialProfile);
}

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


GetSocialProfiles Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..GetSocialProfiles Method
SocialProfileManager Class Example See Also Send Feedback
Gets social profiles.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<SocialProfile> GetSocialProfiles(
    IPrincipal user
)
Visual Basic
Public Function GetSocialProfiles ( _
    user As IPrincipal _
) As IEnumerable(Of SocialProfile)
Visual C++
public:
virtual IEnumerable<SocialProfile^>^ GetSocialProfiles(
    IPrincipal^ user
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.

Return Value

The list of social profiles.

Implements

ISocialProfileManager..::..GetSocialProfiles(IPrincipal)

Examples

CopyC#
var socialProfiles = socialProfileManager.GetSocialProfiles(user);

foreach (var socialProfile in socialProfiles)
{
  this.ShowSocialProfile(socialProfile);
}

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


IsSocialProfileExists Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..IsSocialProfileExists Method
SocialProfileManager Class Example See Also Send Feedback
Checks if a social profile exists.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsSocialProfileExists(
    IPrincipal user,
    string networkName
)
Visual Basic
Public Function IsSocialProfileExists ( _
    user As IPrincipal, _
    networkName As String _
) As Boolean
Visual C++
public:
virtual bool IsSocialProfileExists(
    IPrincipal^ user,
    String^ networkName
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Return Value

The Boolean.

Implements

ISocialProfileManager..::..IsSocialProfileExists(IPrincipal, String)

Examples

CopyC#
var result = socialProfileManager.IsSocialProfileExists(user, "Facebook");

Console.WriteLine("The social profile exists: {0}", result);

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


RetrieveSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..RetrieveSocialProfile Method
SocialProfileManager Class Example See Also Send Feedback
Retrieves a social profile from the social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public SocialProfile RetrieveSocialProfile(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials
)
Visual Basic
Public Function RetrieveSocialProfile ( _
    networkName As String, _
    applicationCredentials As ApplicationCredentials, _
    accountCredentials As AccountCredentials _
) As SocialProfile
Visual C++
public:
virtual SocialProfile^ RetrieveSocialProfile(
    String^ networkName,
    ApplicationCredentials^ applicationCredentials,
    AccountCredentials^ accountCredentials
) sealed

Parameters

networkName
Type: System..::..String
The name of the network (case-sensitive).
applicationCredentials
Type: Sitecore.Social.Domain.Model..::..ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model..::..AccountCredentials
The account credentials.

Return Value

The social profile. If the request couldn't be executed, an Empty is returned.

Implements

ISocialProfileManager..::..RetrieveSocialProfile(String, ApplicationCredentials, AccountCredentials)

Examples

CopyC#
if (!socialProfileManager.IsSocialProfileExists(user, "Facebook"))
{
  var applicationCredentials = new ApplicationCredentials
  {
    ApplicationKey = "sdhjkfvskdwe0001-23-=3",
    ApplicationSecret = "212dujjdasnkjdna38383"
  };

  var accountCredentials = new AccountCredentials
  {
    AccessToken = "nnvxmncvmzxcv,sdd002-304",
    AccessTokenSecret = "213980f90fsdfjhwqjwqeru093--1=2039="
  };

  var socialProfile = socialProfileManager.RetrieveSocialProfile("Facebook", applicationCredentials, accountCredentials);

  if (!socialProfile.IsEmpty)
  {
    socialProfileManager.AttachSocialProfile(user, socialProfile);

    this.ShowSocialProfile(socialProfile);
  }
}

Exceptions

Exception | Condition
System..::..InvalidCastException | The network provider is not implemented IGetAccountInfo interface.

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


UpdateSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
SocialProfileManager..::..UpdateSocialProfile Method
SocialProfileManager Class Example See Also Send Feedback
Updates a social profile of the specified user.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void UpdateSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Visual Basic
Public Sub UpdateSocialProfile ( _
    user As IPrincipal, _
    socialProfile As SocialProfile _
)
Visual C++
public:
virtual void UpdateSocialProfile(
    IPrincipal^ user,
    SocialProfile^ socialProfile
) sealed

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
socialProfile
Type: Sitecore.Social.Domain.Model..::..SocialProfile
The social profile.

Implements

ISocialProfileManager..::..UpdateSocialProfile(IPrincipal, SocialProfile)

Examples

CopyC#
try
{
  var facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");

  if (!facebookSocialProfile.IsEmpty)
  {
    facebookSocialProfile.Email = facebookSocialProfile.Email + "updated";
    socialProfileManager.UpdateSocialProfile(user, facebookSocialProfile);
  }

  facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");
  this.ShowSocialProfile(facebookSocialProfile);
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}

Exceptions

Exception | Condition
AccountIsNotExistException | Following user has not account in this network.

See Also

SocialProfileManager Class
Sitecore.Social.Api Namespace


Sitecore.Social.Api.Extensions Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Api.Extensions Namespace
Send Feedback
Provides a set of extension classes.

Classes

 | Class | Description
Public class | UserExtensions | Provides a set of static methods that are used to get extended user information.


UserExtensions Class

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions Class
Members See Also Send Feedback
Provides a set of static methods that are used to get extended user information.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static class UserExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class UserExtensions
Visual C++
[ExtensionAttribute]
public ref class UserExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Api.Extensions..::..UserExtensions

See Also

UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions Members

[image] [image]

Sitecore Social Connected 1.3.1 API
UserExtensions Members
UserExtensions Class Methods See Also Send Feedback

The UserExtensions type exposes the following members.

Methods

Name | Description
AttachSocialProfile | Attaches a social profile to the specified user.
DetachSocialProfile | Removes a social profile from the specified user.
GetPostingPreference | Gets user's posting preferences for the specific message.
GetPostingPreferences | Gets user's posting preferences for all messages found by arguments.
GetSocialProfile | Gets a social profile of the user in the specified network.
GetSocialProfiles | Gets all social profiles of the user.
IsSocialProfileExists | Defines if a social profile exists in the specified network.
SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.
UpdateSocialProfile | Updates a social profile of the specified user.

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


UserExtensions Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
UserExtensions Methods
UserExtensions Class See Also Send Feedback

The UserExtensions type exposes the following members.

Methods

Name | Description
AttachSocialProfile | Attaches a social profile to the specified user.
DetachSocialProfile | Removes a social profile from the specified user.
GetPostingPreference | Gets user's posting preferences for the specific message.
GetPostingPreferences | Gets user's posting preferences for all messages found by arguments.
GetSocialProfile | Gets a social profile of the user in the specified network.
GetSocialProfiles | Gets all social profiles of the user.
IsSocialProfileExists | Defines if a social profile exists in the specified network.
SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.
UpdateSocialProfile | Updates a social profile of the specified user.

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


AttachSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..AttachSocialProfile Method
UserExtensions Class Example See Also Send Feedback
Attaches a social profile to the specified user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static void AttachSocialProfile(
    this IPrincipal user,
    SocialProfile socialProfile
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub AttachSocialProfile ( _
    user As IPrincipal, _
    socialProfile As SocialProfile _
)
Visual C++
[ExtensionAttribute]
public:
static void AttachSocialProfile(
    IPrincipal^ user,
    SocialProfile^ socialProfile
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
socialProfile
Type: Sitecore.Social.Domain.Model..::..SocialProfile
The social profile.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
try
{
  var facebookProfile = new SocialProfile
  {
    AccountCredentials = new AccountCredentials
    {
      AccessToken = "239842+-02399==",
      AccessTokenSecret = "8282271371232=-29382855"
    },
    Email = "john.smith@fakedomain.com",
    FullName = "John Smith",
    NetworkAccountId = "888127718888463",
    ApplicationCredentials = new ApplicationCredentials
    {
      ApplicationKey = "jkdsf90392===399",
      ApplicationSecret = "128281--==39939"
    },
    NetworkName = "Facebook",
    Fields = new Dictionary<string, string>
    {
      {
        "timezone", "UTC+8"
      },
      {
        "gender", "male"
      }
    }
  };

  Sitecore.Context.User.AttachSocialProfile(facebookProfile);
  this.ShowSocialProfile(facebookProfile);
}
catch (AccountInUserDuplicatedException)
{
  // Following user already has another attached account of the same network.
}
catch (AccountInDomainDuplicatedException)
{
  // There is another user with the same account in domain.
}

Exceptions

Exception | Condition
AccountInUserDuplicatedException | Following user already has another attached account of the same network.
AccountInDomainDuplicatedException | There is another user with the same account in domain.

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


DetachSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..DetachSocialProfile Method
UserExtensions Class Example See Also Send Feedback
Removes a social profile from the specified user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static void DetachSocialProfile(
    this IPrincipal user,
    string networkName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub DetachSocialProfile ( _
    user As IPrincipal, _
    networkName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void DetachSocialProfile(
    IPrincipal^ user,
    String^ networkName
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
try
{
  Sitecore.Context.User.DetachSocialProfile("Facebook");
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}

Exceptions

Exception | Condition
AccountIsNotExistException | Following user has not account in this network.

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


GetPostingPreference Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..GetPostingPreference Method
UserExtensions Class Example See Also Send Feedback
Gets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static PostingPreference GetPostingPreference(
    this IPrincipal user,
    Identifier messageId
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetPostingPreference ( _
    user As IPrincipal, _
    messageId As Identifier _
) As PostingPreference
Visual C++
[ExtensionAttribute]
public:
static PostingPreference^ GetPostingPreference(
    IPrincipal^ user,
    Identifier^ messageId
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The posting preference. If the posting preference is not found the Default value is used.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var postingPreference = Sitecore.Context.User.GetPostingPreference(messageId);

Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace
PostingPreference..::..AutomaticPostingPreference


GetPostingPreferences Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..GetPostingPreferences Method
UserExtensions Class Example See Also Send Feedback
Gets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static IEnumerable<PostingPreference> GetPostingPreferences(
    this IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetPostingPreferences ( _
    user As IPrincipal, _
    searchArgs As PostingConfigurationSearchArgs _
) As IEnumerable(Of PostingPreference)
Visual C++
[ExtensionAttribute]
public:
static IEnumerable<PostingPreference^>^ GetPostingPreferences(
    IPrincipal^ user,
    PostingConfigurationSearchArgs^ searchArgs
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search arguments.

Return Value

The posting preference list. If no preferences are found an empty list is returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

var postingPreferences = Sitecore.Context.User.GetPostingPreferences(searchArgs);

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


GetSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..GetSocialProfile Method
UserExtensions Class Example See Also Send Feedback
Gets a social profile of the user in the specified network.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static SocialProfile GetSocialProfile(
    this IPrincipal user,
    string networkName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetSocialProfile ( _
    user As IPrincipal, _
    networkName As String _
) As SocialProfile
Visual C++
[ExtensionAttribute]
public:
static SocialProfile^ GetSocialProfile(
    IPrincipal^ user,
    String^ networkName
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Return Value

The social profile. If there are no profiles, an empty profile is returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");

if (!facebookSocialProfile.IsEmpty)
{
  this.ShowSocialProfile(facebookSocialProfile);
}

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


GetSocialProfiles Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..GetSocialProfiles Method
UserExtensions Class Example See Also Send Feedback
Gets all social profiles of the user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static IEnumerable<SocialProfile> GetSocialProfiles(
    this IPrincipal user
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetSocialProfiles ( _
    user As IPrincipal _
) As IEnumerable(Of SocialProfile)
Visual C++
[ExtensionAttribute]
public:
static IEnumerable<SocialProfile^>^ GetSocialProfiles(
    IPrincipal^ user
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.

Return Value

The social profiles list. If there are no profiles, an empty list is returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var socialProfiles = Sitecore.Context.User.GetSocialProfiles();

foreach (var socialProfile in socialProfiles)
{
  this.ShowSocialProfile(socialProfile);
}

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


IsSocialProfileExists Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..IsSocialProfileExists Method
UserExtensions Class Example See Also Send Feedback
Defines if a social profile exists in the specified network.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static bool IsSocialProfileExists(
    this IPrincipal user,
    string networkName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsSocialProfileExists ( _
    user As IPrincipal, _
    networkName As String _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool IsSocialProfileExists(
    IPrincipal^ user,
    String^ networkName
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Return Value

The Boolean.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var result = Sitecore.Context.User.IsSocialProfileExists("Facebook");

Console.WriteLine("The social profile exists: {0}", result);

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


SetPostingPreference Method

[image] [image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..SetPostingPreference Method
UserExtensions Class See Also Send Feedback

Overload List

Name | Description
SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)
UserExtensions Class Example See Also Send Feedback
Sets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static void SetPostingPreference(
    this IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetPostingPreference ( _
    user As IPrincipal, _
    messageId As Identifier, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
[ExtensionAttribute]
public:
static void SetPostingPreference(
    IPrincipal^ user,
    Identifier^ messageId,
    AutomaticPostingPreference automaticPostingPreference
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
Sitecore.Context.User.SetPostingPreference(messageId, AutomaticPostingPreference.Denied);

Exceptions

Exception | Condition
System..::..Exception | Message is not found.
System..::..Exception | Message has invalid template.
System..::..Exception | Impossible to set preference to anonymous user.

See Also

UserExtensions Class
SetPostingPreference Overload
Sitecore.Social.Api.Extensions Namespace


SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)
UserExtensions Class Example See Also Send Feedback
Sets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static void SetPostingPreference(
    this IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetPostingPreference ( _
    user As IPrincipal, _
    searchArgs As PostingConfigurationSearchArgs, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
[ExtensionAttribute]
public:
static void SetPostingPreference(
    IPrincipal^ user,
    PostingConfigurationSearchArgs^ searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

Sitecore.Context.User.SetPostingPreference(searchArgs, AutomaticPostingPreference.Denied);

Exceptions

Exception | Condition
System..::..Exception | Impossible to set preference to anonymous user.

See Also

UserExtensions Class
SetPostingPreference Overload
Sitecore.Social.Api.Extensions Namespace


UpdateSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
UserExtensions..::..UpdateSocialProfile Method
UserExtensions Class Example See Also Send Feedback
Updates a social profile of the specified user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static void UpdateSocialProfile(
    this IPrincipal user,
    SocialProfile socialProfile
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub UpdateSocialProfile ( _
    user As IPrincipal, _
    socialProfile As SocialProfile _
)
Visual C++
[ExtensionAttribute]
public:
static void UpdateSocialProfile(
    IPrincipal^ user,
    SocialProfile^ socialProfile
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
socialProfile
Type: Sitecore.Social.Domain.Model..::..SocialProfile
The social profile.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
try
{
  var facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");

  if (!facebookSocialProfile.IsEmpty)
  {
    facebookSocialProfile.Email = facebookSocialProfile.Email + "updated";
    Sitecore.Context.User.UpdateSocialProfile(facebookSocialProfile);
  }

  facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");
  this.ShowSocialProfile(facebookSocialProfile);
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}

Exceptions

Exception | Condition
AccountIsNotExistException | Following user has not account in this network.

See Also

UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


Sitecore.Social.BusinessLogic.Exceptions Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.BusinessLogic.Exceptions Namespace
Send Feedback
Provides a set of custom exception classes.

Classes

 | Class | Description
Public class | AccountContainerIsNotFoundException | The exception that is thrown when the account container is not found.
Public class | CannotReadAccountException | The exception that is thrown when the account item was found, but could not be read.
Public class | MessageDataBuilderIsNotFoundException | The exception that is thrown when the message data builder is not found.
Public class | MessageStatusBuilderIsNotFoundException | The exception that is thrown when the message status builder is not found.
Public class | PostingConfigurationBuilderIsNotFoundException | The exception that is thrown when the posting configuration builder is not found.
Public class | PostingConfigurationSearchArgsAdapterIsNotFoundException | The exception that is thrown when the posting configuration search arguments adapter is not found.


AccountContainerIsNotFoundException Class

[image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the account container is not found.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class AccountContainerIsNotFoundException : Exception
Visual Basic
<SerializableAttribute> _
Public Class AccountContainerIsNotFoundException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class AccountContainerIsNotFoundException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Social.BusinessLogic.Exceptions..::..AccountContainerIsNotFoundException

See Also

AccountContainerIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace
Account..::..AccountContainer


AccountContainerIsNotFoundException Members

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Members
AccountContainerIsNotFoundException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | AccountContainerIsNotFoundException()()()() | Initializes a new instance of the AccountContainerIsNotFoundException class.
Public method | AccountContainerIsNotFoundException(String) | Initializes a new instance of the AccountContainerIsNotFoundException class with the account container value.
Protected method | AccountContainerIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the AccountContainerIsNotFoundException class with serialized data.
Public method | AccountContainerIsNotFoundException(String, Exception) | Initializes a new instance of the AccountContainerIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

AccountContainerIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Constructor
AccountContainerIsNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AccountContainerIsNotFoundException()()()() | Initializes a new instance of the AccountContainerIsNotFoundException class.
Public method | AccountContainerIsNotFoundException(String) | Initializes a new instance of the AccountContainerIsNotFoundException class with the account container value.
Protected method | AccountContainerIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the AccountContainerIsNotFoundException class with serialized data.
Public method | AccountContainerIsNotFoundException(String, Exception) | Initializes a new instance of the AccountContainerIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor

[image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Constructor
AccountContainerIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the AccountContainerIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountContainerIsNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
AccountContainerIsNotFoundException()

Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The account container is not found."

See Also

AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Constructor (String)
AccountContainerIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the AccountContainerIsNotFoundException class with the account container value.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountContainerIsNotFoundException(
    string accountContainer
)
Visual Basic
Public Sub New ( _
    accountContainer As String _
)
Visual C++
public:
AccountContainerIsNotFoundException(
    String^ accountContainer
)

Parameters

accountContainer
Type: System..::..String
The account container value.

See Also

AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Constructor (SerializationInfo, StreamingContext)
AccountContainerIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the AccountContainerIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected AccountContainerIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
AccountContainerIsNotFoundException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
An object that describes the source or destination of the serialized data.

See Also

AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor (String, Exception)

[image]

Sitecore Social Connected 1.3.1 API
AccountContainerIsNotFoundException Constructor (String, Exception)
AccountContainerIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the AccountContainerIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountContainerIsNotFoundException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
AccountContainerIsNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The error message that explains the reason for this exception.
inner
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Class

[image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Class
Members See Also Send Feedback
The exception that is thrown when the account item was found, but could not be read.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class CannotReadAccountException : Exception
Visual Basic
<SerializableAttribute> _
Public Class CannotReadAccountException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class CannotReadAccountException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Social.BusinessLogic.Exceptions..::..CannotReadAccountException

See Also

CannotReadAccountException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace
AccountBusinessManagerCreateAccount(Account)


CannotReadAccountException Members

[image] [image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Members
CannotReadAccountException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | CannotReadAccountException()()()() | Initializes a new instance of the CannotReadAccountException class.
Public method | CannotReadAccountException(String) | Initializes a new instance of the CannotReadAccountException class with a specified error message.
Protected method | CannotReadAccountException(SerializationInfo, StreamingContext) | Initializes a new instance of the CannotReadAccountException class with serialized data.
Public method | CannotReadAccountException(String, Exception) | Initializes a new instance of the CannotReadAccountException class with a specified error message and the exception that is the cause of this exception.

See Also

CannotReadAccountException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Constructor
CannotReadAccountException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CannotReadAccountException()()()() | Initializes a new instance of the CannotReadAccountException class.
Public method | CannotReadAccountException(String) | Initializes a new instance of the CannotReadAccountException class with a specified error message.
Protected method | CannotReadAccountException(SerializationInfo, StreamingContext) | Initializes a new instance of the CannotReadAccountException class with serialized data.
Public method | CannotReadAccountException(String, Exception) | Initializes a new instance of the CannotReadAccountException class with a specified error message and the exception that is the cause of this exception.

See Also

CannotReadAccountException Class
CannotReadAccountException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor

[image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Constructor
CannotReadAccountException Class See Also Send Feedback
Initializes a new instance of the CannotReadAccountException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public CannotReadAccountException()
Visual Basic
Public Sub New
Visual C++
public:
CannotReadAccountException()

Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "Could not read account."

See Also

CannotReadAccountException Class
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Constructor (String)
CannotReadAccountException Class See Also Send Feedback
Initializes a new instance of the CannotReadAccountException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public CannotReadAccountException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
CannotReadAccountException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

CannotReadAccountException Class
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Constructor (SerializationInfo, StreamingContext)
CannotReadAccountException Class See Also Send Feedback
Initializes a new instance of the CannotReadAccountException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected CannotReadAccountException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
CannotReadAccountException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
An object that describes the source or destination of the serialized data.

See Also

CannotReadAccountException Class
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor (String, Exception)

[image]

Sitecore Social Connected 1.3.1 API
CannotReadAccountException Constructor (String, Exception)
CannotReadAccountException Class See Also Send Feedback
Initializes a new instance of the CannotReadAccountException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public CannotReadAccountException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
CannotReadAccountException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The error message that explains the reason for this exception.
inner
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

CannotReadAccountException Class
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Class

[image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the message data builder is not found.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class MessageDataBuilderIsNotFoundException : Exception
Visual Basic
<SerializableAttribute> _
Public Class MessageDataBuilderIsNotFoundException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class MessageDataBuilderIsNotFoundException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Social.BusinessLogic.Exceptions..::..MessageDataBuilderIsNotFoundException

See Also

MessageDataBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Members
MessageDataBuilderIsNotFoundException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | MessageDataBuilderIsNotFoundException()()()() | Initializes a new instance of the MessageDataBuilderIsNotFoundException class.
Public method | MessageDataBuilderIsNotFoundException(String) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message.
Public method | MessageDataBuilderIsNotFoundException(Type) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class the message type.
Protected method | MessageDataBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with serialized data.
Public method | MessageDataBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

MessageDataBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Constructor
MessageDataBuilderIsNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageDataBuilderIsNotFoundException()()()() | Initializes a new instance of the MessageDataBuilderIsNotFoundException class.
Public method | MessageDataBuilderIsNotFoundException(String) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message.
Public method | MessageDataBuilderIsNotFoundException(Type) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class the message type.
Protected method | MessageDataBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with serialized data.
Public method | MessageDataBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor

[image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Constructor
MessageDataBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageDataBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageDataBuilderIsNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
MessageDataBuilderIsNotFoundException()

Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The message data builder is not found."

See Also

MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Constructor (String)
MessageDataBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageDataBuilderIsNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MessageDataBuilderIsNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (Type)

[image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Constructor (Type)
MessageDataBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageDataBuilderIsNotFoundException class the message type.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageDataBuilderIsNotFoundException(
    Type messageType
)
Visual Basic
Public Sub New ( _
    messageType As Type _
)
Visual C++
public:
MessageDataBuilderIsNotFoundException(
    Type^ messageType
)

Parameters

messageType
Type: System..::..Type
Type of the message.

See Also

MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)
MessageDataBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageDataBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected MessageDataBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MessageDataBuilderIsNotFoundException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
An object that describes the source or destination of the serialized data.

See Also

MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (String, Exception)

[image]

Sitecore Social Connected 1.3.1 API
MessageDataBuilderIsNotFoundException Constructor (String, Exception)
MessageDataBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageDataBuilderIsNotFoundException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
MessageDataBuilderIsNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The error message that explains the reason for this exception.
inner
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Class

[image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the message status builder is not found.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class MessageStatusBuilderIsNotFoundException : Exception
Visual Basic
<SerializableAttribute> _
Public Class MessageStatusBuilderIsNotFoundException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class MessageStatusBuilderIsNotFoundException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Social.BusinessLogic.Exceptions..::..MessageStatusBuilderIsNotFoundException

See Also

MessageStatusBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Members
MessageStatusBuilderIsNotFoundException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | MessageStatusBuilderIsNotFoundException()()()() | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class.
Public method | MessageStatusBuilderIsNotFoundException(String) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message.
Protected method | MessageStatusBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with serialized data.
Public method | MessageStatusBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this error.

See Also

MessageStatusBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Constructor
MessageStatusBuilderIsNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageStatusBuilderIsNotFoundException()()()() | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class.
Public method | MessageStatusBuilderIsNotFoundException(String) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message.
Protected method | MessageStatusBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with serialized data.
Public method | MessageStatusBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this error.

See Also

MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor

[image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Constructor
MessageStatusBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatusBuilderIsNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
MessageStatusBuilderIsNotFoundException()

Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The message status builder is not found."

See Also

MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Constructor (String)
MessageStatusBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatusBuilderIsNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MessageStatusBuilderIsNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)
MessageStatusBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected MessageStatusBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MessageStatusBuilderIsNotFoundException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
An object that describes the source or destination of the serialized data.

See Also

MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor (String, Exception)

[image]

Sitecore Social Connected 1.3.1 API
MessageStatusBuilderIsNotFoundException Constructor (String, Exception)
MessageStatusBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this error.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatusBuilderIsNotFoundException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
MessageStatusBuilderIsNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The error message that explains the reason for this exception.
inner
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Class

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the posting configuration builder is not found.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class PostingConfigurationBuilderIsNotFoundException : Exception
Visual Basic
<SerializableAttribute> _
Public Class PostingConfigurationBuilderIsNotFoundException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class PostingConfigurationBuilderIsNotFoundException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationBuilderIsNotFoundException

See Also

PostingConfigurationBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Members
PostingConfigurationBuilderIsNotFoundException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | PostingConfigurationBuilderIsNotFoundException()()()() | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class.
Public method | PostingConfigurationBuilderIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message.
Public method | PostingConfigurationBuilderIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with the posting configuration type.
Protected method | PostingConfigurationBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with serialized data.
Public method | PostingConfigurationBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

PostingConfigurationBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Constructor
PostingConfigurationBuilderIsNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PostingConfigurationBuilderIsNotFoundException()()()() | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class.
Public method | PostingConfigurationBuilderIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message.
Public method | PostingConfigurationBuilderIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with the posting configuration type.
Protected method | PostingConfigurationBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with serialized data.
Public method | PostingConfigurationBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Constructor
PostingConfigurationBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationBuilderIsNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
PostingConfigurationBuilderIsNotFoundException()

Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The posting configuration builder is not found."

See Also

PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Constructor (String)
PostingConfigurationBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationBuilderIsNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
PostingConfigurationBuilderIsNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (Type)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Constructor (Type)
PostingConfigurationBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with the posting configuration type.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationBuilderIsNotFoundException(
    Type postingConfigurationType
)
Visual Basic
Public Sub New ( _
    postingConfigurationType As Type _
)
Visual C++
public:
PostingConfigurationBuilderIsNotFoundException(
    Type^ postingConfigurationType
)

Parameters

postingConfigurationType
Type: System..::..Type
Type of the posting configuration.

See Also

PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)
PostingConfigurationBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected PostingConfigurationBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
PostingConfigurationBuilderIsNotFoundException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
An object that describes the source or destination of the serialized data.

See Also

PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (String, Exception)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationBuilderIsNotFoundException Constructor (String, Exception)
PostingConfigurationBuilderIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationBuilderIsNotFoundException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
PostingConfigurationBuilderIsNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The error message that explains the reason for this exception.
inner
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Class

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the posting configuration search arguments adapter is not found.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class PostingConfigurationSearchArgsAdapterIsNotFoundException : Exception
Visual Basic
<SerializableAttribute> _
Public Class PostingConfigurationSearchArgsAdapterIsNotFoundException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class PostingConfigurationSearchArgsAdapterIsNotFoundException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Social.BusinessLogic.Exceptions..::..PostingConfigurationSearchArgsAdapterIsNotFoundException

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
PostingConfigurationSearchArgsAdapterIsNotFoundException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException()()()() | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with the type of posting configuration search args.
Protected method | PostingConfigurationSearchArgsAdapterIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with serialized data.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor
PostingConfigurationSearchArgsAdapterIsNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException()()()() | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with the type of posting configuration search args.
Protected method | PostingConfigurationSearchArgsAdapterIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with serialized data.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor
PostingConfigurationSearchArgsAdapterIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationSearchArgsAdapterIsNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
PostingConfigurationSearchArgsAdapterIsNotFoundException()

Remarks

This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The posting configuration search arguments adapter is not found."

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String)
PostingConfigurationSearchArgsAdapterIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
PostingConfigurationSearchArgsAdapterIsNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (Type)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (Type)
PostingConfigurationSearchArgsAdapterIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with the type of posting configuration search args.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    Type postingConfigurationSearchArgsType
)
Visual Basic
Public Sub New ( _
    postingConfigurationSearchArgsType As Type _
)
Visual C++
public:
PostingConfigurationSearchArgsAdapterIsNotFoundException(
    Type^ postingConfigurationSearchArgsType
)

Parameters

postingConfigurationSearchArgsType
Type: System..::..Type
Type of the posting configuration search args.

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (SerializationInfo, StreamingContext)
PostingConfigurationSearchArgsAdapterIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected PostingConfigurationSearchArgsAdapterIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
PostingConfigurationSearchArgsAdapterIsNotFoundException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
An object that describes the source or destination of the serialized data.

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String, Exception)

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String, Exception)
PostingConfigurationSearchArgsAdapterIsNotFoundException Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
PostingConfigurationSearchArgsAdapterIsNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The error message that explains the reason for this exception.
inner
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


Sitecore.Social.BusinessLogic.Extensions Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.BusinessLogic.Extensions Namespace
Send Feedback
Provides a set of extension classes.

Classes

 | Class | Description
Public class | IdentifierExtensions | Provides a set of static methods to get ID for Identifier objects.
Public class | IDExtensions | Provides a set of static methods to get Identifier for ID objects.


IdentifierExtensions Class

[image]

Sitecore Social Connected 1.3.1 API
IdentifierExtensions Class
Members See Also Send Feedback
Provides a set of static methods to get ID for Identifier objects.

Namespace: Sitecore.Social.BusinessLogic.Extensions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static class IdentifierExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class IdentifierExtensions
Visual C++
[ExtensionAttribute]
public ref class IdentifierExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Social.BusinessLogic.Extensions..::..IdentifierExtensions

See Also

IdentifierExtensions Members
Sitecore.Social.BusinessLogic.Extensions Namespace


IdentifierExtensions Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IdentifierExtensions Members
IdentifierExtensions Class Methods See Also Send Feedback

The IdentifierExtensions type exposes the following members.

Methods

Name | Description
GetID | Gets the ID from identifier.

See Also

IdentifierExtensions Class
Sitecore.Social.BusinessLogic.Extensions Namespace


IdentifierExtensions Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IdentifierExtensions Methods
IdentifierExtensions Class See Also Send Feedback

The IdentifierExtensions type exposes the following members.

Methods

Name | Description
GetID | Gets the ID from identifier.

See Also

IdentifierExtensions Class
Sitecore.Social.BusinessLogic.Extensions Namespace


GetID Method

[image]

Sitecore Social Connected 1.3.1 API
IdentifierExtensions..::..GetID Method
IdentifierExtensions Class Example See Also Send Feedback
Gets the ID from identifier.

Namespace: Sitecore.Social.BusinessLogic.Extensions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static ID GetID(
    this Identifier id
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetID ( _
    id As Identifier _
) As ID
Visual C++
[ExtensionAttribute]
public:
static ID^ GetID(
    Identifier^ id
)

Parameters

id
Type: Sitecore.Social.Domain.Model..::..Identifier
The id.

Return Value

The ID.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Identifier. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var messageItemID = messageId.GetID();

Exceptions

Exception | Condition
System..::..InvalidCastException | The 'id' argument is not an IDIdentifier object.

See Also

IdentifierExtensions Class
Sitecore.Social.BusinessLogic.Extensions Namespace
Sitecore.Social.BusinessLogic.Model..::..IDIdentifier


IDExtensions Class

[image]

Sitecore Social Connected 1.3.1 API
IDExtensions Class
Members See Also Send Feedback
Provides a set of static methods to get Identifier for ID objects.

Namespace: Sitecore.Social.BusinessLogic.Extensions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static class IDExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class IDExtensions
Visual C++
[ExtensionAttribute]
public ref class IDExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Social.BusinessLogic.Extensions..::..IDExtensions

See Also

IDExtensions Members
Sitecore.Social.BusinessLogic.Extensions Namespace


IDExtensions Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IDExtensions Members
IDExtensions Class Methods See Also Send Feedback

The IDExtensions type exposes the following members.

Methods

Name | Description
GetIdentifier | Gets the identifier from ID.

See Also

IDExtensions Class
Sitecore.Social.BusinessLogic.Extensions Namespace


IDExtensions Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IDExtensions Methods
IDExtensions Class See Also Send Feedback

The IDExtensions type exposes the following members.

Methods

Name | Description
GetIdentifier | Gets the identifier from ID.

See Also

IDExtensions Class
Sitecore.Social.BusinessLogic.Extensions Namespace


GetIdentifier Method

[image]

Sitecore Social Connected 1.3.1 API
IDExtensions..::..GetIdentifier Method
IDExtensions Class Example See Also Send Feedback
Gets the identifier from ID.

Namespace: Sitecore.Social.BusinessLogic.Extensions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static Identifier GetIdentifier(
    this ID id
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetIdentifier ( _
    id As ID _
) As Identifier
Visual C++
[ExtensionAttribute]
public:
static Identifier^ GetIdentifier(
    ID^ id
)

Parameters

id
Type: ID
The id.

Return Value

The Identifier.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ID. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Examples

CopyC#
var messageId = messageItemID.GetIdentifier();

See Also

IDExtensions Class
Sitecore.Social.BusinessLogic.Extensions Namespace
Sitecore.Social.BusinessLogic.Model..::..IDIdentifier


Sitecore.Social.BusinessLogic.Model Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.BusinessLogic.Model Namespace
Send Feedback
Provides classes that extend domain's model.

Classes

 | Class | Description
Public class | IDIdentifier | Represents the identifier for ID object.


IDIdentifier Class

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier Class
Members See Also Send Feedback
Represents the identifier for ID object.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class IDIdentifier : Identifier
Visual Basic
<SerializableAttribute> _
Public Class IDIdentifier _
    Inherits Identifier
Visual C++
[SerializableAttribute]
public ref class IDIdentifier : public Identifier

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..Identifier
Sitecore.Social.BusinessLogic.Model..::..IDIdentifier

See Also

IDIdentifier Members
Sitecore.Social.BusinessLogic.Model Namespace


IDIdentifier Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IDIdentifier Members
IDIdentifier Class Constructors Methods Fields Properties See Also Send Feedback

The IDIdentifier type exposes the following members.

Constructors

 | Name | Description
Public method | IDIdentifier | Initializes a new instance of the IDIdentifier class from the id.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if current identifier is equal to other one. (Overrides Identifier..::..Equals(Identifier).)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | ToString | Returns a String that represents this instance. (Inherited from Identifier.)

Extension Methods

 | Name | Description
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)

Fields

Name | Description
Empty | A read-only instance of the IDIdentifier class whose value represents not found identifier.

Properties

 | Name | Description
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty. (Overrides Identifier..::..IsEmpty.)
Public property | OriginalId | Gets the original id.
Public property | OriginalType | Gets the original type. (Overrides Identifier..::..OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


IDIdentifier Constructor

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier Constructor
IDIdentifier Class See Also Send Feedback
Initializes a new instance of the IDIdentifier class from the id.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IDIdentifier(
    ID id
)
Visual Basic
Public Sub New ( _
    id As ID _
)
Visual C++
public:
IDIdentifier(
    ID^ id
)

Parameters

id
Type: ID
The id.

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


IDIdentifier Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
IDIdentifier Fields
IDIdentifier Class See Also Send Feedback

The IDIdentifier type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the IDIdentifier class whose value represents not found identifier.

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier..::..Empty Field
IDIdentifier Class See Also Send Feedback
A read-only instance of the IDIdentifier class whose value represents not found identifier.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly IDIdentifier Empty
Visual Basic
Public Shared ReadOnly Empty As IDIdentifier
Visual C++
public:
static initonly IDIdentifier^ Empty

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


IDIdentifier Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IDIdentifier Methods
IDIdentifier Class See Also Send Feedback

The IDIdentifier type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if current identifier is equal to other one. (Overrides Identifier..::..Equals(Identifier).)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | ToString | Returns a String that represents this instance. (Inherited from Identifier.)

Extension Methods

 | Name | Description
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


Equals Method

[image] [image]

Sitecore Social Connected 1.3.1 API
IDIdentifier..::..Equals Method
IDIdentifier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if current identifier is equal to other one. (Overrides Identifier..::..Equals(Identifier).)

See Also

IDIdentifier Class
IDIdentifier Members
Sitecore.Social.BusinessLogic.Model Namespace


Equals Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier..::..Equals Method (Identifier)
IDIdentifier Class See Also Send Feedback
Checks if current identifier is equal to other one.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public override bool Equals(
    Identifier other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Identifier _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Identifier^ other
) override

Parameters

other
Type: Sitecore.Social.Domain.Model..::..Identifier
The other.

Return Value

true if current identifier is equal to other one, otherwise false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

IDIdentifier Class
Equals Overload
Sitecore.Social.BusinessLogic.Model Namespace


IDIdentifier Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
IDIdentifier Properties
IDIdentifier Class See Also Send Feedback

The IDIdentifier type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty. (Overrides Identifier..::..IsEmpty.)
Public property | OriginalId | Gets the original id.
Public property | OriginalType | Gets the original type. (Overrides Identifier..::..OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier..::..IsEmpty Property
IDIdentifier Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public override bool IsEmpty { get; }
Visual Basic
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () override;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


OriginalId Property

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier..::..OriginalId Property
IDIdentifier Class See Also Send Feedback
Gets the original id.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ID OriginalId { get; private set; }
Visual Basic
Public Property OriginalId As ID
    Get
    Private Set
Visual C++
public:
property ID^ OriginalId {
    ID^ get ();
    private: void set (ID^ value);
}

Field Value

The original id.

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


OriginalType Property

[image]

Sitecore Social Connected 1.3.1 API
IDIdentifier..::..OriginalType Property
IDIdentifier Class See Also Send Feedback
Gets the original type.

Namespace: Sitecore.Social.BusinessLogic.Model
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public override Type OriginalType { get; }
Visual Basic
Public Overrides ReadOnly Property OriginalType As Type
    Get
Visual C++
public:
virtual property Type^ OriginalType {
    Type^ get () override;
}

Field Value

The original type.

See Also

IDIdentifier Class
Sitecore.Social.BusinessLogic.Model Namespace


Sitecore.Social.Client.Api Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Client.Api Namespace
Send Feedback
Provides classes that allow to manage presentation layer actions (login, requests to social networs, etc).

Classes

 | Class | Description
Public class | AccountClientManager | Defines the methods that are used to work with a social network account.
Public class | ConnectorClientManager | Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.
Public class | ExceptionClientManager | Represents receiving of exception information.
Public class | ExceptionInfo | Represents the information about exception.

Interfaces

 | Interface | Description
Public interface | IExceptionClientManager | Represents receiving of exception information.


AccountClientManager Class

[image]

Sitecore Social Connected 1.3.1 API
AccountClientManager Class
Members See Also Send Feedback
Defines the methods that are used to work with a social network account.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class AccountClientManager : IAccountClientManager
Visual Basic
Public Class AccountClientManager _
    Implements IAccountClientManager
Visual C++
public ref class AccountClientManager : IAccountClientManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Client.Api..::..AccountClientManager

See Also

AccountClientManager Members
Sitecore.Social.Client.Api Namespace


AccountClientManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountClientManager Members
AccountClientManager Class Constructors Methods See Also Send Feedback

The AccountClientManager type exposes the following members.

Constructors

 | Name | Description
Public method | AccountClientManager | Initializes a new instance of the AccountClientManager class

Methods

 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.

See Also

AccountClientManager Class
Sitecore.Social.Client.Api Namespace


AccountClientManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
AccountClientManager Constructor
AccountClientManager Class See Also Send Feedback
Initializes a new instance of the AccountClientManager class

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountClientManager()
Visual Basic
Public Sub New
Visual C++
public:
AccountClientManager()

See Also

AccountClientManager Class
Sitecore.Social.Client.Api Namespace


AccountClientManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountClientManager Methods
AccountClientManager Class See Also Send Feedback

The AccountClientManager type exposes the following members.

Methods

 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.

See Also

AccountClientManager Class
Sitecore.Social.Client.Api Namespace


BeginGetAccountCredentials Method

[image]

Sitecore Social Connected 1.3.1 API
AccountClientManager..::..BeginGetAccountCredentials Method
AccountClientManager Class Example See Also Send Feedback
Initializes the process of receiving the social network account credentials.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void BeginGetAccountCredentials(
    GetAccountCredentialsRequest request
)
Visual Basic
Public Sub BeginGetAccountCredentials ( _
    request As GetAccountCredentialsRequest _
)
Visual C++
public:
virtual void BeginGetAccountCredentials(
    GetAccountCredentialsRequest^ request
) sealed

Parameters

request
Type: Sitecore.Social.Client.Domain.Requests..::..GetAccountCredentialsRequest
The account credentials request.

Implements

IAccountClientManager..::..BeginGetAccountCredentials(GetAccountCredentialsRequest)

Remarks

  • Use EndGetAccountCredentials(String) to receive the account credentials response by this request id.
  • Use GetExceptionInfo(HttpRequest) to receive the exception information in a case of error.

Examples

CopyC#
var newAccountName = accountNameTextBox.Text;

var facebookApplication = applicationManager.GetApplication(facebookApplicationId);

if (!facebookApplication.IsEmpty)
{
  var accountDataRequest = new GetAccountCredentialsRequest(
    "Facebook",
    facebookApplication.ApplicationCredentials,
    HttpContext.Current.Request.Url,
    new Dictionary<string, object>
      {
        { "ApplicationId", facebookApplicationId },
        { "AccountName", newAccountName }
      });

  // to get AccessToken without expiration
  accountDataRequest.Permissions.Add("offline_access", string.Empty);

  // to grant publish on the wall
  accountDataRequest.Permissions.Add("publish_stream", string.Empty);

  // to retreive user pages accessTokens
  accountDataRequest.Permissions.Add("manage_pages", string.Empty);

  // to get message statistics
  accountDataRequest.Permissions.Add("read_stream", string.Empty);

  accountClientManager.BeginGetAccountCredentials(accountDataRequest);
}

See Also

AccountClientManager Class
Sitecore.Social.Client.Api Namespace


EndGetAccountCredentials Method

[image]

Sitecore Social Connected 1.3.1 API
AccountClientManager..::..EndGetAccountCredentials Method
AccountClientManager Class Example See Also Send Feedback
Returns the account credentials by request id.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GetAccountCredentialsResponse EndGetAccountCredentials(
    string requestId
)
Visual Basic
Public Function EndGetAccountCredentials ( _
    requestId As String _
) As GetAccountCredentialsResponse
Visual C++
public:
virtual GetAccountCredentialsResponse^ EndGetAccountCredentials(
    String^ requestId
) sealed

Parameters

requestId
Type: System..::..String
The request id returned in the query string at the end of the flow.

Return Value

The account credentials response.

Implements

IAccountClientManager..::..EndGetAccountCredentials(String)

Remarks

This method helps you to complete the process of receiving account credentials. At the end of the flow you'll be redirected to the CallbackPageUrl with the RequestIdParameterName parameter in a query string. Use this request id to receive the account credentials response.

Examples

CopyC#
var requestId = HttpContext.Current.Request.QueryString[GetAccountCredentialsRequest.RequestIdParameterName];
var response = accountClientManager.EndGetAccountCredentials(requestId);

switch (response.Status)
{
  case GetAccountCredentialsResponseStatus.Done:
    var contextData = (Dictionary<string, object>)response.ContextData;

    var newAccount = new Account
      {
        AccountContainer = "/sitecore/system/Social/Accounts",
        AccountCredentials = response.AccountCredentials,
        ApplicationId = (Identifier)contextData["ApplicationId"],
        LastRenewalDate = DateTime.Now,
        Name = (string)contextData["AccountName"]
      };

    accountManager.CreateAccount(newAccount);
    this.ShowAccount(newAccount);
    break;
  case GetAccountCredentialsResponseStatus.Failed:
    var exceptionClientManager = new ExceptionClientManager();
    var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);
    this.ShowExceptionInfo(exceptionInfo);
    break;
  case GetAccountCredentialsResponseStatus.ResponseIsNotFound:
    Console.WriteLine("Session is expired or response is not found.");
    break;
}

See Also

AccountClientManager Class
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Class

[image]

Sitecore Social Connected 1.3.1 API
ConnectorClientManager Class
Members See Also Send Feedback
Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class ConnectorClientManager : IConnectorClientManager
Visual Basic
Public Class ConnectorClientManager _
    Implements IConnectorClientManager
Visual C++
public ref class ConnectorClientManager : IConnectorClientManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Client.Api..::..ConnectorClientManager

See Also

ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ConnectorClientManager Members
ConnectorClientManager Class Constructors Methods See Also Send Feedback

The ConnectorClientManager type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectorClientManager | Initializes a new instance of the ConnectorClientManager class

Methods

 | Name | Description
Public method | AttachToUser | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | LogOnUser | Logs the user in the specified network. If the user account doesn’t exist, it will be created.

See Also

ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
ConnectorClientManager Constructor
ConnectorClientManager Class See Also Send Feedback
Initializes a new instance of the ConnectorClientManager class

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ConnectorClientManager()
Visual Basic
Public Sub New
Visual C++
public:
ConnectorClientManager()

See Also

ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
ConnectorClientManager Methods
ConnectorClientManager Class See Also Send Feedback

The ConnectorClientManager type exposes the following members.

Methods

 | Name | Description
Public method | AttachToUser | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | LogOnUser | Logs the user in the specified network. If the user account doesn’t exist, it will be created.

See Also

ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


AttachToUser Method

[image]

Sitecore Social Connected 1.3.1 API
ConnectorClientManager..::..AttachToUser Method
ConnectorClientManager Class Example See Also Send Feedback
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void AttachToUser(
    string networkName
)
Visual Basic
Public Sub AttachToUser ( _
    networkName As String _
)
Visual C++
public:
virtual void AttachToUser(
    String^ networkName
) sealed

Parameters

networkName
Type: System..::..String
The name of the network (case-sensitive).

Implements

IConnectorClientManager..::..AttachToUser(String)

Remarks

At the end of the flow you'll be redirected on the same page again. Use GetExceptionInfo(HttpRequest) to get exception information in a case of error.

Examples

Remarks

Example of how to start the process of attaching a social profile.
CopyC#
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook");
}

Remarks

Example of how to finish the process of attaching a social profile.
CopyC#
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}

See Also

ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


LogOnUser Method

[image]

Sitecore Social Connected 1.3.1 API
ConnectorClientManager..::..LogOnUser Method
ConnectorClientManager Class Example See Also Send Feedback
Logs the user in the specified network. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public void LogOnUser(
    string networkName
)
Visual Basic
Public Sub LogOnUser ( _
    networkName As String _
)
Visual C++
public:
virtual void LogOnUser(
    String^ networkName
) sealed

Parameters

networkName
Type: System..::..String
The name of the network (case-sensitive).

Implements

IConnectorClientManager..::..LogOnUser(String)

Remarks

At the end of the flow you'll be redirected to the same page again. Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples

Remarks

Example of how to start the login process.
CopyC#
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook");
}

Remarks

Example of how to finish the login process.
CopyC#
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}

See Also

ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Class

[image]

Sitecore Social Connected 1.3.1 API
ExceptionClientManager Class
Members See Also Send Feedback
Represents receiving of exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class ExceptionClientManager : IExceptionClientManager
Visual Basic
Public Class ExceptionClientManager _
    Implements IExceptionClientManager
Visual C++
public ref class ExceptionClientManager : IExceptionClientManager

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Client.Api..::..ExceptionClientManager

See Also

ExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionClientManager Members
ExceptionClientManager Class Constructors Methods See Also Send Feedback

The ExceptionClientManager type exposes the following members.

Constructors

 | Name | Description
Public method | ExceptionClientManager | Initializes a new instance of the ExceptionClientManager class

Methods

 | Name | Description
Public method | GetExceptionInfo | Receives the exception information.

See Also

ExceptionClientManager Class
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Constructor

[image]

Sitecore Social Connected 1.3.1 API
ExceptionClientManager Constructor
ExceptionClientManager Class See Also Send Feedback
Initializes a new instance of the ExceptionClientManager class

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ExceptionClientManager()
Visual Basic
Public Sub New
Visual C++
public:
ExceptionClientManager()

See Also

ExceptionClientManager Class
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionClientManager Methods
ExceptionClientManager Class See Also Send Feedback

The ExceptionClientManager type exposes the following members.

Methods

 | Name | Description
Public method | GetExceptionInfo | Receives the exception information.

See Also

ExceptionClientManager Class
Sitecore.Social.Client.Api Namespace


GetExceptionInfo Method

[image]

Sitecore Social Connected 1.3.1 API
ExceptionClientManager..::..GetExceptionInfo Method
ExceptionClientManager Class Example See Also Send Feedback
Receives the exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ExceptionInfo GetExceptionInfo(
    HttpRequest request
)
Visual Basic
Public Function GetExceptionInfo ( _
    request As HttpRequest _
) As ExceptionInfo
Visual C++
public:
virtual ExceptionInfo^ GetExceptionInfo(
    HttpRequest^ request
) sealed

Parameters

request
Type: System.Web..::..HttpRequest
The http request.

Return Value

The exception information.

Implements

IExceptionClientManager..::..GetExceptionInfo(HttpRequest)

Examples

CopyC#
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);
if (!exceptionInfo.IsEmpty)
{
  this.ShowExceptionInfo(exceptionInfo);
}

See Also

ExceptionClientManager Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo Class

[image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Class
Members See Also Send Feedback
Represents the information about exception.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class ExceptionInfo : SocialExceptionInfo,
    IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class ExceptionInfo _
    Inherits SocialExceptionInfo _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class ExceptionInfo : public SocialExceptionInfo,
    IEmptyable

Inheritance Hierarchy

System..::..Object
SocialExceptionInfo
Sitecore.Social.Client.Api..::..ExceptionInfo

See Also

ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Members
ExceptionInfo Class Constructors Methods Fields Properties See Also Send Feedback

The ExceptionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExceptionInfo()()()() | Initializes a new instance of the ExceptionInfo class.
Public method | ExceptionInfo(ISocialException) | Initializes a new instance of the ExceptionInfo class and fills the class with information from the provided ISocialException parameter.

Methods

 | Name | Description
Public method | Equals(SocialExceptionInfo) | (Inherited from SocialExceptionInfo.)
Public method | Equals(Object) | (Inherited from SocialExceptionInfo.)
Public method | GetHashCode | (Inherited from SocialExceptionInfo.)

Fields

Name | Description
Empty | A read-only instance of the ExceptionInfo class whose value represents not found exception info.

Properties

 | Name | Description
Public property | DetailedMessage | (Inherited from SocialExceptionInfo.)
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | SimpleMessage | (Inherited from SocialExceptionInfo.)

See Also

ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Constructor
ExceptionInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExceptionInfo()()()() | Initializes a new instance of the ExceptionInfo class.
Public method | ExceptionInfo(ISocialException) | Initializes a new instance of the ExceptionInfo class and fills the class with information from the provided ISocialException parameter.

See Also

ExceptionInfo Class
ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Constructor

[image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Constructor
ExceptionInfo Class See Also Send Feedback
Initializes a new instance of the ExceptionInfo class.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ExceptionInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExceptionInfo()

See Also

ExceptionInfo Class
ExceptionInfo Overload
Sitecore.Social.Client.Api Namespace


ExceptionInfo Constructor ()

[image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Constructor ()
ExceptionInfo Class See Also Send Feedback
Initializes a new instance of the ExceptionInfo class and fills the class with information from the provided ISocialException parameter.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ExceptionInfo(
    ISocialException exception
)
Visual Basic
Public Sub New ( _
    exception As ISocialException _
)
Visual C++
public:
ExceptionInfo(
    ISocialException^ exception
)

Parameters

exception
Type: ISocialException
The exception.

See Also

ExceptionInfo Class
ExceptionInfo Overload
Sitecore.Social.Client.Api Namespace


ExceptionInfo Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Fields
ExceptionInfo Class See Also Send Feedback

The ExceptionInfo type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the ExceptionInfo class whose value represents not found exception info.

See Also

ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo..::..Empty Field
ExceptionInfo Class See Also Send Feedback
A read-only instance of the ExceptionInfo class whose value represents not found exception info.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly ExceptionInfo Empty
Visual Basic
Public Shared ReadOnly Empty As ExceptionInfo
Visual C++
public:
static initonly ExceptionInfo^ Empty

See Also

ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Methods
ExceptionInfo Class See Also Send Feedback

The ExceptionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(SocialExceptionInfo) | (Inherited from SocialExceptionInfo.)
Public method | Equals(Object) | (Inherited from SocialExceptionInfo.)
Public method | GetHashCode | (Inherited from SocialExceptionInfo.)

See Also

ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


Equals Method

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo..::..Equals Method
ExceptionInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(SocialExceptionInfo) | (Inherited from SocialExceptionInfo.)
Public method | Equals(Object) | (Inherited from SocialExceptionInfo.)

See Also

ExceptionInfo Class
ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo Properties
ExceptionInfo Class See Also Send Feedback

The ExceptionInfo type exposes the following members.

Properties

 | Name | Description
Public property | DetailedMessage | (Inherited from SocialExceptionInfo.)
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | SimpleMessage | (Inherited from SocialExceptionInfo.)

See Also

ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
ExceptionInfo..::..IsEmpty Property
ExceptionInfo Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


IExceptionClientManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IExceptionClientManager Interface
Members See Also Send Feedback
Represents receiving of exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IExceptionClientManager
Visual Basic
Public Interface IExceptionClientManager
Visual C++
public interface class IExceptionClientManager

See Also

IExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


IExceptionClientManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IExceptionClientManager Members
IExceptionClientManager Interface Methods See Also Send Feedback

The IExceptionClientManager type exposes the following members.

Methods

 | Name | Description
Public method | GetExceptionInfo | Receives the exception information.

See Also

IExceptionClientManager Interface
Sitecore.Social.Client.Api Namespace


IExceptionClientManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IExceptionClientManager Methods
IExceptionClientManager Interface See Also Send Feedback

The IExceptionClientManager type exposes the following members.

Methods

 | Name | Description
Public method | GetExceptionInfo | Receives the exception information.

See Also

IExceptionClientManager Interface
Sitecore.Social.Client.Api Namespace


GetExceptionInfo Method

[image]

Sitecore Social Connected 1.3.1 API
IExceptionClientManager..::..GetExceptionInfo Method
IExceptionClientManager Interface See Also Send Feedback
Receives the exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
ExceptionInfo GetExceptionInfo(
    HttpRequest request
)
Visual Basic
Function GetExceptionInfo ( _
    request As HttpRequest _
) As ExceptionInfo
Visual C++
ExceptionInfo^ GetExceptionInfo(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::..HttpRequest
The http request.

Return Value

The exception information.

See Also

IExceptionClientManager Interface
Sitecore.Social.Client.Api Namespace


Sitecore.Social.Client.Domain Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Client.Domain Namespace
Send Feedback
Provides a set of classes that extends domain's model.

Interfaces

 | Interface | Description
Public interface | IAccountClientManager | Defines the methods that are used to work with a social network account.
Public interface | IConnectorClientManager | Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.


IAccountClientManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IAccountClientManager Interface
Members See Also Send Feedback
Defines the methods that are used to work with a social network account.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IAccountClientManager
Visual Basic
Public Interface IAccountClientManager
Visual C++
public interface class IAccountClientManager

See Also

IAccountClientManager Members
Sitecore.Social.Client.Domain Namespace


IAccountClientManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IAccountClientManager Members
IAccountClientManager Interface Methods See Also Send Feedback

The IAccountClientManager type exposes the following members.

Methods

 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.

See Also

IAccountClientManager Interface
Sitecore.Social.Client.Domain Namespace


IAccountClientManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IAccountClientManager Methods
IAccountClientManager Interface See Also Send Feedback

The IAccountClientManager type exposes the following members.

Methods

 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.

See Also

IAccountClientManager Interface
Sitecore.Social.Client.Domain Namespace


BeginGetAccountCredentials Method

[image]

Sitecore Social Connected 1.3.1 API
IAccountClientManager..::..BeginGetAccountCredentials Method
IAccountClientManager Interface See Also Send Feedback
Initializes the process of receiving the social network account credentials.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void BeginGetAccountCredentials(
    GetAccountCredentialsRequest request
)
Visual Basic
Sub BeginGetAccountCredentials ( _
    request As GetAccountCredentialsRequest _
)
Visual C++
void BeginGetAccountCredentials(
    GetAccountCredentialsRequest^ request
)

Parameters

request
Type: Sitecore.Social.Client.Domain.Requests..::..GetAccountCredentialsRequest
The account credentials request.

See Also

IAccountClientManager Interface
Sitecore.Social.Client.Domain Namespace


EndGetAccountCredentials Method

[image]

Sitecore Social Connected 1.3.1 API
IAccountClientManager..::..EndGetAccountCredentials Method
IAccountClientManager Interface See Also Send Feedback
Returns the account credentials by request id.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
GetAccountCredentialsResponse EndGetAccountCredentials(
    string requestId
)
Visual Basic
Function EndGetAccountCredentials ( _
    requestId As String _
) As GetAccountCredentialsResponse
Visual C++
GetAccountCredentialsResponse^ EndGetAccountCredentials(
    String^ requestId
)

Parameters

requestId
Type: System..::..String
The request id returned in the query string at the end of the flow.

Return Value

The account credentials response.

See Also

IAccountClientManager Interface
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IConnectorClientManager Interface
Members See Also Send Feedback
Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IConnectorClientManager
Visual Basic
Public Interface IConnectorClientManager
Visual C++
public interface class IConnectorClientManager

See Also

IConnectorClientManager Members
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IConnectorClientManager Members
IConnectorClientManager Interface Methods See Also Send Feedback

The IConnectorClientManager type exposes the following members.

Methods

 | Name | Description
Public method | AttachToUser | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | LogOnUser | Logs the user in the specified network. If the user account doesn’t exist, it will be created.

See Also

IConnectorClientManager Interface
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IConnectorClientManager Methods
IConnectorClientManager Interface See Also Send Feedback

The IConnectorClientManager type exposes the following members.

Methods

 | Name | Description
Public method | AttachToUser | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | LogOnUser | Logs the user in the specified network. If the user account doesn’t exist, it will be created.

See Also

IConnectorClientManager Interface
Sitecore.Social.Client.Domain Namespace


AttachToUser Method

[image]

Sitecore Social Connected 1.3.1 API
IConnectorClientManager..::..AttachToUser Method
IConnectorClientManager Interface See Also Send Feedback
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void AttachToUser(
    string networkName
)
Visual Basic
Sub AttachToUser ( _
    networkName As String _
)
Visual C++
void AttachToUser(
    String^ networkName
)

Parameters

networkName
Type: System..::..String
The name of the network.

See Also

IConnectorClientManager Interface
Sitecore.Social.Client.Domain Namespace


LogOnUser Method

[image]

Sitecore Social Connected 1.3.1 API
IConnectorClientManager..::..LogOnUser Method
IConnectorClientManager Interface See Also Send Feedback
Logs the user in the specified network. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void LogOnUser(
    string networkName
)
Visual Basic
Sub LogOnUser ( _
    networkName As String _
)
Visual C++
void LogOnUser(
    String^ networkName
)

Parameters

networkName
Type: System..::..String
The name of the network.

See Also

IConnectorClientManager Interface
Sitecore.Social.Client.Domain Namespace


Sitecore.Social.Client.Domain.Requests Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Client.Domain.Requests Namespace
Send Feedback
Provides classes that represent requests.

Classes

 | Class | Description
Public class | GetAccountCredentialsRequest | Represents the account credentials request.


GetAccountCredentialsRequest Class

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Class
Members See Also Send Feedback
Represents the account credentials request.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class GetAccountCredentialsRequest
Visual Basic
<SerializableAttribute> _
Public Class GetAccountCredentialsRequest
Visual C++
[SerializableAttribute]
public ref class GetAccountCredentialsRequest

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Client.Domain.Requests..::..GetAccountCredentialsRequest

See Also

GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Members

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Members
GetAccountCredentialsRequest Class Constructors Fields Properties See Also Send Feedback

The GetAccountCredentialsRequest type exposes the following members.

Constructors

 | Name | Description
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri) | Initializes a new instance of the GetAccountCredentialsRequest class.
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri, Object) | Initializes a new instance of the GetAccountCredentialsRequest class.

Fields

Name | Description
RequestIdParameterName | The request id parameter name

Properties

 | Name | Description
Public property | ApplicationCredentials | Gets the application credentials.
Public property | CallbackPageUrl | Gets the URL of the page to be redirected at the end of the flow.
Public property | ContextData | Gets the context data.
Public property | NetworkName | Gets the name of the network.
Public property | Permissions | Gets the permissions.
Public property | RequestId | Gets the request id.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Constructor
GetAccountCredentialsRequest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri) | Initializes a new instance of the GetAccountCredentialsRequest class.
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri, Object) | Initializes a new instance of the GetAccountCredentialsRequest class.

See Also

GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri)

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri)
GetAccountCredentialsRequest Class See Also Send Feedback
Initializes a new instance of the GetAccountCredentialsRequest class.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GetAccountCredentialsRequest(
    string networkName,
    ApplicationCredentials applicationCredentials,
    Uri callbackPageUrl
)
Visual Basic
Public Sub New ( _
    networkName As String, _
    applicationCredentials As ApplicationCredentials, _
    callbackPageUrl As Uri _
)
Visual C++
public:
GetAccountCredentialsRequest(
    String^ networkName,
    ApplicationCredentials^ applicationCredentials,
    Uri^ callbackPageUrl
)

Parameters

networkName
Type: System..::..String
The network name.
applicationCredentials
Type: Sitecore.Social.Domain.Model..::..ApplicationCredentials
The application credentials.
callbackPageUrl
Type: System..::..Uri
The callback page url.

See Also

GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Overload
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri, Object)

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri, Object)
GetAccountCredentialsRequest Class See Also Send Feedback
Initializes a new instance of the GetAccountCredentialsRequest class.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GetAccountCredentialsRequest(
    string networkName,
    ApplicationCredentials applicationCredentials,
    Uri callbackPageUrl,
    Object contextData
)
Visual Basic
Public Sub New ( _
    networkName As String, _
    applicationCredentials As ApplicationCredentials, _
    callbackPageUrl As Uri, _
    contextData As Object _
)
Visual C++
public:
GetAccountCredentialsRequest(
    String^ networkName,
    ApplicationCredentials^ applicationCredentials,
    Uri^ callbackPageUrl,
    Object^ contextData
)

Parameters

networkName
Type: System..::..String
The network name.
applicationCredentials
Type: Sitecore.Social.Domain.Model..::..ApplicationCredentials
The application credentials.
callbackPageUrl
Type: System..::..Uri
The callback page url.
contextData
Type: System..::..Object
The context data. It's recommended to be serializable.

See Also

GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Overload
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Fields
GetAccountCredentialsRequest Class See Also Send Feedback

The GetAccountCredentialsRequest type exposes the following members.

Fields

Name | Description
RequestIdParameterName | The request id parameter name

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


RequestIdParameterName Field

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..RequestIdParameterName Field
GetAccountCredentialsRequest Class See Also Send Feedback
The request id parameter name

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly string RequestIdParameterName
Visual Basic
Public Shared ReadOnly RequestIdParameterName As String
Visual C++
public:
static initonly String^ RequestIdParameterName

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest Properties
GetAccountCredentialsRequest Class See Also Send Feedback

The GetAccountCredentialsRequest type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationCredentials | Gets the application credentials.
Public property | CallbackPageUrl | Gets the URL of the page to be redirected at the end of the flow.
Public property | ContextData | Gets the context data.
Public property | NetworkName | Gets the name of the network.
Public property | Permissions | Gets the permissions.
Public property | RequestId | Gets the request id.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


ApplicationCredentials Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..ApplicationCredentials Property
GetAccountCredentialsRequest Class See Also Send Feedback
Gets the application credentials.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationCredentials ApplicationCredentials { get; private set; }
Visual Basic
Public Property ApplicationCredentials As ApplicationCredentials
    Get
    Private Set
Visual C++
public:
property ApplicationCredentials^ ApplicationCredentials {
    ApplicationCredentials^ get ();
    private: void set (ApplicationCredentials^ value);
}

Field Value

The application credentials.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


CallbackPageUrl Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..CallbackPageUrl Property
GetAccountCredentialsRequest Class See Also Send Feedback
Gets the URL of the page to be redirected at the end of the flow.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Uri CallbackPageUrl { get; private set; }
Visual Basic
Public Property CallbackPageUrl As Uri
    Get
    Private Set
Visual C++
public:
property Uri^ CallbackPageUrl {
    Uri^ get ();
    private: void set (Uri^ value);
}

Field Value

The callback page URL.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


ContextData Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..ContextData Property
GetAccountCredentialsRequest Class See Also Send Feedback
Gets the context data.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Object ContextData { get; private set; }
Visual Basic
Public Property ContextData As Object
    Get
    Private Set
Visual C++
public:
property Object^ ContextData {
    Object^ get ();
    private: void set (Object^ value);
}

Field Value

The context data.

Remarks

During the receiving account credentials process you'll be redirected on a domain of social network and then redirected back. Use this storage if you want to keep any data during this process.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


NetworkName Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..NetworkName Property
GetAccountCredentialsRequest Class See Also Send Feedback
Gets the name of the network.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string NetworkName { get; private set; }
Visual Basic
Public Property NetworkName As String
    Get
    Private Set
Visual C++
public:
property String^ NetworkName {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The name of the network.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


Permissions Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..Permissions Property
GetAccountCredentialsRequest Class See Also Send Feedback
Gets the permissions.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IDictionary<string, string> Permissions { get; private set; }
Visual Basic
Public Property Permissions As IDictionary(Of String, String)
    Get
    Private Set
Visual C++
public:
property IDictionary<String^, String^>^ Permissions {
    IDictionary<String^, String^>^ get ();
    private: void set (IDictionary<String^, String^>^ value);
}

Field Value

The permissions.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


RequestId Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsRequest..::..RequestId Property
GetAccountCredentialsRequest Class See Also Send Feedback
Gets the request id.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string RequestId { get; private set; }
Visual Basic
Public Property RequestId As String
    Get
    Private Set
Visual C++
public:
property String^ RequestId {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The request id.

See Also

GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


Sitecore.Social.Client.Domain.Responses Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Client.Domain.Responses Namespace
Send Feedback
Provides classes that represent responses.

Classes

 | Class | Description
Public class | GetAccountCredentialsResponse | Represents the account credentials response.
Public class | ResponseStatus<(Of <(<'T>)>)> | Represents the base class for API responses.

Enumerations

 | Enumeration | Description
Public enumeration | GetAccountCredentialsResponseStatus | Defines constants for account credentials response status.


GetAccountCredentialsResponse Class

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Class
Members See Also Send Feedback
Represents the account credentials response.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class GetAccountCredentialsResponse : ResponseStatus<GetAccountCredentialsResponseStatus>
Visual Basic
<SerializableAttribute> _
Public Class GetAccountCredentialsResponse _
    Inherits ResponseStatus(Of GetAccountCredentialsResponseStatus)
Visual C++
[SerializableAttribute]
public ref class GetAccountCredentialsResponse : public ResponseStatus<GetAccountCredentialsResponseStatus>

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Client.Domain.Responses..::..ResponseStatus <(Of <(<' GetAccountCredentialsResponseStatus >)>)>
Sitecore.Social.Client.Domain.Responses..::..GetAccountCredentialsResponse

See Also

GetAccountCredentialsResponse Members
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Members

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Members
GetAccountCredentialsResponse Class Constructors Properties See Also Send Feedback

The GetAccountCredentialsResponse type exposes the following members.

Constructors

 | Name | Description
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials, Object) | Initializes a new instance of the GetAccountCredentialsResponse class.

Properties

 | Name | Description
Public property | AccountCredentials | Gets the account credentials.
Public property | ContextData | Gets the context data.
Public property | Status | Gets the status. (Inherited from ResponseStatus<(Of <(<'T>)>)>.)

See Also

GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Constructor
GetAccountCredentialsResponse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials, Object) | Initializes a new instance of the GetAccountCredentialsResponse class.

See Also

GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus)

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus)
GetAccountCredentialsResponse Class See Also Send Feedback
Initializes a new instance of the GetAccountCredentialsResponse class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status
)
Visual Basic
Public Sub New ( _
    status As GetAccountCredentialsResponseStatus _
)
Visual C++
public:
GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status
)

Parameters

status
Type: Sitecore.Social.Client.Domain.Responses..::..GetAccountCredentialsResponseStatus
The status.

See Also

GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Overload
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials)

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials)
GetAccountCredentialsResponse Class See Also Send Feedback
Initializes a new instance of the GetAccountCredentialsResponse class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials accountCredentials
)
Visual Basic
Public Sub New ( _
    status As GetAccountCredentialsResponseStatus, _
    accountCredentials As AccountCredentials _
)
Visual C++
public:
GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials^ accountCredentials
)

Parameters

status
Type: Sitecore.Social.Client.Domain.Responses..::..GetAccountCredentialsResponseStatus
The status.
accountCredentials
Type: Sitecore.Social.Domain.Model..::..AccountCredentials
The account credentials.

See Also

GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Overload
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials, Object)

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials, Object)
GetAccountCredentialsResponse Class See Also Send Feedback
Initializes a new instance of the GetAccountCredentialsResponse class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials accountCredentials,
    Object contextData
)
Visual Basic
Public Sub New ( _
    status As GetAccountCredentialsResponseStatus, _
    accountCredentials As AccountCredentials, _
    contextData As Object _
)
Visual C++
public:
GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials^ accountCredentials,
    Object^ contextData
)

Parameters

status
Type: Sitecore.Social.Client.Domain.Responses..::..GetAccountCredentialsResponseStatus
The status.
accountCredentials
Type: Sitecore.Social.Domain.Model..::..AccountCredentials
The account credentials.
contextData
Type: System..::..Object
The context data.

See Also

GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Overload
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse Properties
GetAccountCredentialsResponse Class See Also Send Feedback

The GetAccountCredentialsResponse type exposes the following members.

Properties

 | Name | Description
Public property | AccountCredentials | Gets the account credentials.
Public property | ContextData | Gets the context data.
Public property | Status | Gets the status. (Inherited from ResponseStatus<(Of <(<'T>)>)>.)

See Also

GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


AccountCredentials Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse..::..AccountCredentials Property
GetAccountCredentialsResponse Class See Also Send Feedback
Gets the account credentials.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountCredentials AccountCredentials { get; private set; }
Visual Basic
Public Property AccountCredentials As AccountCredentials
    Get
    Private Set
Visual C++
public:
property AccountCredentials^ AccountCredentials {
    AccountCredentials^ get ();
    private: void set (AccountCredentials^ value);
}

Field Value

The account credentials.

See Also

GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


ContextData Property

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponse..::..ContextData Property
GetAccountCredentialsResponse Class See Also Send Feedback
Gets the context data.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Object ContextData { get; private set; }
Visual Basic
Public Property ContextData As Object
    Get
    Private Set
Visual C++
public:
property Object^ ContextData {
    Object^ get ();
    private: void set (Object^ value);
}

Field Value

The context data.

Remarks

During the receiving account credentials process you'll be redirected on a domain of social network and then redirected back. Use this storage if you want to keep any data during this process.

See Also

GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponseStatus Enumeration

[image]

Sitecore Social Connected 1.3.1 API
GetAccountCredentialsResponseStatus Enumeration
See Also Send Feedback
Defines constants for account credentials response status.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public enum GetAccountCredentialsResponseStatus
Visual Basic
<SerializableAttribute> _
Public Enumeration GetAccountCredentialsResponseStatus
Visual C++
[SerializableAttribute]
public enum class GetAccountCredentialsResponseStatus

Members

Member name | Value | Description
Done | 0 | Account credentials received successfully.
Failed | 1 | Receiving failed.
ResponseIsNotFound | 2 | The response is not found

See Also

Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Class

[image]

Sitecore Social Connected 1.3.1 API
ResponseStatus<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents the base class for API responses.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public class ResponseStatus<T>
where T : struct, new()
Visual Basic
Public Class ResponseStatus(Of T As {Structure, New})
Visual C++
generic<typename T>
where T : value class, gcnew()
public ref class ResponseStatus

Type Parameters

T
The response status type.

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Client.Domain.Responses..::..ResponseStatus<(Of <(<'T>)>)>
Sitecore.Social.Client.Domain.Responses..::..GetAccountCredentialsResponse

See Also

ResponseStatus<(Of <(<'T>)>)> Members
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ResponseStatus<(Of <(<'T>)>)> Members
ResponseStatus<(Of <(<'T>)>)> Class Constructors Properties See Also Send Feedback

The ResponseStatus<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseStatus<(Of <(<'T>)>)> | Initializes a new instance of the ResponseStatus<(Of <(<'T>)>)> class.

Properties

 | Name | Description
Public property | Status | Gets the status.

See Also

ResponseStatus<(Of <(<'T>)>)> Class
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Constructor

[image]

Sitecore Social Connected 1.3.1 API
ResponseStatus<(Of <(<'T>)>)> Constructor
ResponseStatus<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the ResponseStatus<(Of <(<'T>)>)> class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ResponseStatus(
    T status
)
Visual Basic
Public Sub New ( _
    status As T _
)
Visual C++
public:
ResponseStatus(
    T status
)

Parameters

status
Type: T
The status.

See Also

ResponseStatus<(Of <(<'T>)>)> Class
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ResponseStatus<(Of <(<'T>)>)> Properties
ResponseStatus<(Of <(<'T>)>)> Class See Also Send Feedback

The ResponseStatus<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Status | Gets the status.

See Also

ResponseStatus<(Of <(<'T>)>)> Class
Sitecore.Social.Client.Domain.Responses Namespace


Status Property

[image]

Sitecore Social Connected 1.3.1 API
ResponseStatus<(Of <(<'T>)>)>..::..Status Property
ResponseStatus<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the status.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public T Status { get; private set; }
Visual Basic
Public Property Status As T
    Get
    Private Set
Visual C++
public:
property T Status {
    T get ();
    private: void set (T value);
}

Field Value

The status.

See Also

ResponseStatus<(Of <(<'T>)>)> Class
Sitecore.Social.Client.Domain.Responses Namespace


Sitecore.Social.Domain Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Domain Namespace
Send Feedback
Provides classes that represent the domain.

Interfaces

 | Interface | Description
Public interface | IAccountManager | Defines the methods that are used to get and create social network accounts.
Public interface | IApplicationManager | Defines the methods that are used to manage social network applications.
Public interface | IEmptyable | Defines the property that is used to check if an entity is empty.
Public interface | IMessageManager | Defines the methods that are used to manage social network messages.
Public interface | IMessageStatisticsManager | Defines the methods that are used to manage social network message statistics.
Public interface | INetworkManager | Defines the methods that are used to manage social networks.
Public interface | IPostingPreferenceManager | Defines the methods that are used to manage user’s posting preferences.
Public interface | ISocialProfileManager | Defines the methods that are used to manage a social profile.


IAccountManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IAccountManager Interface
Members See Also Send Feedback
Defines the methods that are used to get and create social network accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IAccountManager
Visual Basic
Public Interface IAccountManager
Visual C++
public interface class IAccountManager

See Also

IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IAccountManager Members
IAccountManager Interface Methods See Also Send Feedback

The IAccountManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.

See Also

IAccountManager Interface
Sitecore.Social.Domain Namespace


IAccountManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IAccountManager Methods
IAccountManager Interface See Also Send Feedback

The IAccountManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.

See Also

IAccountManager Interface
Sitecore.Social.Domain Namespace


CreateAccount Method

[image]

Sitecore Social Connected 1.3.1 API
IAccountManager..::..CreateAccount Method
IAccountManager Interface See Also Send Feedback
Creates an account.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void CreateAccount(
    Account account
)
Visual Basic
Sub CreateAccount ( _
    account As Account _
)
Visual C++
void CreateAccount(
    Account^ account
)

Parameters

account
Type: Sitecore.Social.Domain.Model..::..Account
The account to create.

Remarks

The Id field will contain identifier of the new account after creation.

See Also

IAccountManager Interface
Sitecore.Social.Domain Namespace


GetAccount Method

[image]

Sitecore Social Connected 1.3.1 API
IAccountManager..::..GetAccount Method
IAccountManager Interface See Also Send Feedback
Gets an account by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
Account GetAccount(
    Identifier accountId
)
Visual Basic
Function GetAccount ( _
    accountId As Identifier _
) As Account
Visual C++
Account^ GetAccount(
    Identifier^ accountId
)

Parameters

accountId
Type: Sitecore.Social.Domain.Model..::..Identifier
The account id.

Return Value

The account. If the account is not found, Empty is returned.

See Also

IAccountManager Interface
Sitecore.Social.Domain Namespace


GetAccounts Method

[image] [image]

Sitecore Social Connected 1.3.1 API
IAccountManager..::..GetAccounts Method
IAccountManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.

See Also

IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


GetAccounts Method (String)

[image]

Sitecore Social Connected 1.3.1 API
IAccountManager..::..GetAccounts Method (String)
IAccountManager Interface See Also Send Feedback
Gets all accounts by network name. Returns a collection of accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Account> GetAccounts(
    string networkName
)
Visual Basic
Function GetAccounts ( _
    networkName As String _
) As IEnumerable(Of Account)
Visual C++
IEnumerable<Account^>^ GetAccounts(
    String^ networkName
)

Parameters

networkName
Type: System..::..String
The name of the network.

Return Value

The account list. If no accounts are found an empty list is returned.

See Also

IAccountManager Interface
GetAccounts Overload
Sitecore.Social.Domain Namespace


GetAccounts Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
IAccountManager..::..GetAccounts Method (Identifier)
IAccountManager Interface See Also Send Feedback
Gets all accounts by network id. Returns a collection of accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Account> GetAccounts(
    Identifier networkId
)
Visual Basic
Function GetAccounts ( _
    networkId As Identifier _
) As IEnumerable(Of Account)
Visual C++
IEnumerable<Account^>^ GetAccounts(
    Identifier^ networkId
)

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.

Return Value

The account list. If no accounts are found an empty list is returned.

See Also

IAccountManager Interface
GetAccounts Overload
Sitecore.Social.Domain Namespace


GetAccountsByApplication Method

[image]

Sitecore Social Connected 1.3.1 API
IAccountManager..::..GetAccountsByApplication Method
IAccountManager Interface See Also Send Feedback
Gets all accounts by application id. Returns a collection of accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Account> GetAccountsByApplication(
    Identifier applicationId
)
Visual Basic
Function GetAccountsByApplication ( _
    applicationId As Identifier _
) As IEnumerable(Of Account)
Visual C++
IEnumerable<Account^>^ GetAccountsByApplication(
    Identifier^ applicationId
)

Parameters

applicationId
Type: Sitecore.Social.Domain.Model..::..Identifier
The application id.

Return Value

The account list. If no accounts are found an empty list is returned.

See Also

IAccountManager Interface
Sitecore.Social.Domain Namespace


IApplicationManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager Interface
Members See Also Send Feedback
Defines the methods that are used to manage social network applications.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IApplicationManager
Visual Basic
Public Interface IApplicationManager
Visual C++
public interface class IApplicationManager

See Also

IApplicationManager Members
Sitecore.Social.Domain Namespace


IApplicationManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IApplicationManager Members
IApplicationManager Interface Methods See Also Send Feedback

The IApplicationManager type exposes the following members.

Methods

 | Name | Description
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.

See Also

IApplicationManager Interface
Sitecore.Social.Domain Namespace


IApplicationManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IApplicationManager Methods
IApplicationManager Interface See Also Send Feedback

The IApplicationManager type exposes the following members.

Methods

 | Name | Description
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.

See Also

IApplicationManager Interface
Sitecore.Social.Domain Namespace


GetApplication Method

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplication Method
IApplicationManager Interface See Also Send Feedback
Gets an application by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
Application GetApplication(
    Identifier applicationId
)
Visual Basic
Function GetApplication ( _
    applicationId As Identifier _
) As Application
Visual C++
Application^ GetApplication(
    Identifier^ applicationId
)

Parameters

applicationId
Type: Sitecore.Social.Domain.Model..::..Identifier
The application id.

Return Value

The application. If the application is not found Empty is returned.

See Also

IApplicationManager Interface
Sitecore.Social.Domain Namespace


GetApplicationContainer Method

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplicationContainer Method
IApplicationManager Interface See Also Send Feedback
Gets the application container by account container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
string GetApplicationContainer(
    string accountContainer
)
Visual Basic
Function GetApplicationContainer ( _
    accountContainer As String _
) As String
Visual C++
String^ GetApplicationContainer(
    String^ accountContainer
)

Parameters

accountContainer
Type: System..::..String
The account container.

Return Value

The application container. If the application container is not found string.Empty is returned.

See Also

IApplicationManager Interface
Sitecore.Social.Domain Namespace


GetApplications Method

[image] [image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplications Method
IApplicationManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.

See Also

IApplicationManager Interface
IApplicationManager Members
Sitecore.Social.Domain Namespace


GetApplications Method (String)

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplications Method (String)
IApplicationManager Interface See Also Send Feedback
Gets the applications by network name.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Application> GetApplications(
    string networkName
)
Visual Basic
Function GetApplications ( _
    networkName As String _
) As IEnumerable(Of Application)
Visual C++
IEnumerable<Application^>^ GetApplications(
    String^ networkName
)

Parameters

networkName
Type: System..::..String
The name of the network.

Return Value

The application list. If no applications are found an empty list is returned.

See Also

IApplicationManager Interface
GetApplications Overload
Sitecore.Social.Domain Namespace


GetApplications Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplications Method (Identifier)
IApplicationManager Interface See Also Send Feedback
Gets the applications by network id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Application> GetApplications(
    Identifier networkId
)
Visual Basic
Function GetApplications ( _
    networkId As Identifier _
) As IEnumerable(Of Application)
Visual C++
IEnumerable<Application^>^ GetApplications(
    Identifier^ networkId
)

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
Id of the network.

Return Value

The application list. If no applications are found an empty list is returned.

See Also

IApplicationManager Interface
GetApplications Overload
Sitecore.Social.Domain Namespace


GetApplicationsByContainer Method

[image] [image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplicationsByContainer Method
IApplicationManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.

See Also

IApplicationManager Interface
IApplicationManager Members
Sitecore.Social.Domain Namespace


GetApplicationsByContainer Method (String)

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplicationsByContainer Method (String)
IApplicationManager Interface See Also Send Feedback
Gets the applications by container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer
)
Visual Basic
Function GetApplicationsByContainer ( _
    applicationContainer As String _
) As IEnumerable(Of Application)
Visual C++
IEnumerable<Application^>^ GetApplicationsByContainer(
    String^ applicationContainer
)

Parameters

applicationContainer
Type: System..::..String
The application container.

Return Value

The application list. If no applications are found an empty list is returned.

See Also

IApplicationManager Interface
GetApplicationsByContainer Overload
Sitecore.Social.Domain Namespace


GetApplicationsByContainer Method (String, Identifier)

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplicationsByContainer Method (String, Identifier)
IApplicationManager Interface See Also Send Feedback
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    Identifier networkId
)
Visual Basic
Function GetApplicationsByContainer ( _
    applicationContainer As String, _
    networkId As Identifier _
) As IEnumerable(Of Application)
Visual C++
IEnumerable<Application^>^ GetApplicationsByContainer(
    String^ applicationContainer,
    Identifier^ networkId
)

Parameters

applicationContainer
Type: System..::..String
The application container.
networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
Id of the network.

Return Value

The application list. If no applications are found an empty list is returned.

See Also

IApplicationManager Interface
GetApplicationsByContainer Overload
Sitecore.Social.Domain Namespace


GetApplicationsByContainer Method (String, String)

[image]

Sitecore Social Connected 1.3.1 API
IApplicationManager..::..GetApplicationsByContainer Method (String, String)
IApplicationManager Interface See Also Send Feedback
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    string networkName
)
Visual Basic
Function GetApplicationsByContainer ( _
    applicationContainer As String, _
    networkName As String _
) As IEnumerable(Of Application)
Visual C++
IEnumerable<Application^>^ GetApplicationsByContainer(
    String^ applicationContainer,
    String^ networkName
)

Parameters

applicationContainer
Type: System..::..String
The application container.
networkName
Type: System..::..String
The name of the network.

Return Value

The application list. If no applications are found an empty list is returned.

See Also

IApplicationManager Interface
GetApplicationsByContainer Overload
Sitecore.Social.Domain Namespace


IEmptyable Interface

[image]

Sitecore Social Connected 1.3.1 API
IEmptyable Interface
Members See Also Send Feedback
Defines the property that is used to check if an entity is empty.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IEmptyable
Visual Basic
Public Interface IEmptyable
Visual C++
public interface class IEmptyable

See Also

IEmptyable Members
Sitecore.Social.Domain Namespace


IEmptyable Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IEmptyable Members
IEmptyable Interface Properties See Also Send Feedback

The IEmptyable type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.

See Also

IEmptyable Interface
Sitecore.Social.Domain Namespace


IEmptyable Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
IEmptyable Properties
IEmptyable Interface See Also Send Feedback

The IEmptyable type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.

See Also

IEmptyable Interface
Sitecore.Social.Domain Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
IEmptyable..::..IsEmpty Property
IEmptyable Interface See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
bool IsEmpty { get; }
Visual Basic
ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

IEmptyable Interface
Sitecore.Social.Domain Namespace


IMessageManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager Interface
Members See Also Send Feedback
Defines the methods that are used to manage social network messages.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IMessageManager
Visual Basic
Public Interface IMessageManager
Visual C++
public interface class IMessageManager

See Also

IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IMessageManager Members
IMessageManager Interface Methods See Also Send Feedback

The IMessageManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | GetMessage | Gets the message by id.
Public method | GetMessages(PostingConfigurationSearchArgs) | Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessageStatus | Gets the message status.
Public method | PostMessage | Posts the message to a social network.
Public method | UpdateMessage | Updates the message.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


IMessageManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IMessageManager Methods
IMessageManager Interface See Also Send Feedback

The IMessageManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | GetMessage | Gets the message by id.
Public method | GetMessages(PostingConfigurationSearchArgs) | Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessageStatus | Gets the message status.
Public method | PostMessage | Posts the message to a social network.
Public method | UpdateMessage | Updates the message.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


CreateMessage Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..CreateMessage Method
IMessageManager Interface See Also Send Feedback
Creates a message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void CreateMessage(
    Message message
)
Visual Basic
Sub CreateMessage ( _
    message As Message _
)
Visual C++
void CreateMessage(
    Message^ message
)

Parameters

message
Type: Sitecore.Social.Domain.Model..::..Message
The message to create.

Remarks

The Id field will contain identifier of the created message.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


DeleteMessage Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..DeleteMessage Method
IMessageManager Interface See Also Send Feedback
Deletes the message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void DeleteMessage(
    Identifier messageId
)
Visual Basic
Sub DeleteMessage ( _
    messageId As Identifier _
)
Visual C++
void DeleteMessage(
    Identifier^ messageId
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


GetMessage Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..GetMessage Method
IMessageManager Interface See Also Send Feedback
Gets the message by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
Message GetMessage(
    Identifier messageId
)
Visual Basic
Function GetMessage ( _
    messageId As Identifier _
) As Message
Visual C++
Message^ GetMessage(
    Identifier^ messageId
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The message. If message is not found Empty is returned.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


GetMessages Method

[image] [image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..GetMessages Method
IMessageManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages(PostingConfigurationSearchArgs) | Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Gets all messages by network ID which contain specific search arguments.

See Also

IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


GetMessages Method (PostingConfigurationSearchArgs)

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..GetMessages Method (PostingConfigurationSearchArgs)
IMessageManager Interface See Also Send Feedback
Gets all messages containing specific search arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs
)
Visual Basic
Function GetMessages ( _
    searchArgs As PostingConfigurationSearchArgs _
) As IEnumerable(Of Message)
Visual C++
IEnumerable<Message^>^ GetMessages(
    PostingConfigurationSearchArgs^ searchArgs
)

Parameters

searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search arguments.

Return Value

The messages list. If no messages are found an empty list is returned.

See Also

IMessageManager Interface
GetMessages Overload
Sitecore.Social.Domain Namespace


GetMessages Method (PostingConfigurationSearchArgs, Identifier)

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..GetMessages Method (PostingConfigurationSearchArgs, Identifier)
IMessageManager Interface See Also Send Feedback
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    Identifier networkId
)
Visual Basic
Function GetMessages ( _
    searchArgs As PostingConfigurationSearchArgs, _
    networkId As Identifier _
) As IEnumerable(Of Message)
Visual C++
IEnumerable<Message^>^ GetMessages(
    PostingConfigurationSearchArgs^ searchArgs,
    Identifier^ networkId
)

Parameters

searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.

Return Value

The messages list. If no messages are found an empty list is returned.

See Also

IMessageManager Interface
GetMessages Overload
Sitecore.Social.Domain Namespace


GetMessages Method (PostingConfigurationSearchArgs, String)

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..GetMessages Method (PostingConfigurationSearchArgs, String)
IMessageManager Interface See Also Send Feedback
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    string networkName
)
Visual Basic
Function GetMessages ( _
    searchArgs As PostingConfigurationSearchArgs, _
    networkName As String _
) As IEnumerable(Of Message)
Visual C++
IEnumerable<Message^>^ GetMessages(
    PostingConfigurationSearchArgs^ searchArgs,
    String^ networkName
)

Parameters

searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
networkName
Type: System..::..String
The name of the network.

Return Value

The messages list. If no messages are found an empty list is returned.

See Also

IMessageManager Interface
GetMessages Overload
Sitecore.Social.Domain Namespace


GetMessageStatus Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..GetMessageStatus Method
IMessageManager Interface See Also Send Feedback
Gets the message status.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
MessageStatus GetMessageStatus(
    Identifier messageId
)
Visual Basic
Function GetMessageStatus ( _
    messageId As Identifier _
) As MessageStatus
Visual C++
MessageStatus^ GetMessageStatus(
    Identifier^ messageId
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The MessageStatus. If the status is not defined Empty is returned.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


PostMessage Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..PostMessage Method
IMessageManager Interface See Also Send Feedback
Posts the message to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void PostMessage(
    Identifier messageId
)
Visual Basic
Sub PostMessage ( _
    messageId As Identifier _
)
Visual C++
void PostMessage(
    Identifier^ messageId
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


UpdateMessage Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageManager..::..UpdateMessage Method
IMessageManager Interface See Also Send Feedback
Updates the message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void UpdateMessage(
    Message message
)
Visual Basic
Sub UpdateMessage ( _
    message As Message _
)
Visual C++
void UpdateMessage(
    Message^ message
)

Parameters

message
Type: Sitecore.Social.Domain.Model..::..Message
The message to update.

See Also

IMessageManager Interface
Sitecore.Social.Domain Namespace


IMessageStatisticsManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IMessageStatisticsManager Interface
Members See Also Send Feedback
Defines the methods that are used to manage social network message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IMessageStatisticsManager
Visual Basic
Public Interface IMessageStatisticsManager
Visual C++
public interface class IMessageStatisticsManager

See Also

IMessageStatisticsManager Members
Sitecore.Social.Domain Namespace


IMessageStatisticsManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IMessageStatisticsManager Members
IMessageStatisticsManager Interface Methods See Also Send Feedback

The IMessageStatisticsManager type exposes the following members.

Methods

 | Name | Description
Public method | GetMessageStatistics | Gets message statistics.
Public method | RefreshMessageStatistics | Refreshes message statistics.

See Also

IMessageStatisticsManager Interface
Sitecore.Social.Domain Namespace


IMessageStatisticsManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IMessageStatisticsManager Methods
IMessageStatisticsManager Interface See Also Send Feedback

The IMessageStatisticsManager type exposes the following members.

Methods

 | Name | Description
Public method | GetMessageStatistics | Gets message statistics.
Public method | RefreshMessageStatistics | Refreshes message statistics.

See Also

IMessageStatisticsManager Interface
Sitecore.Social.Domain Namespace


GetMessageStatistics Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageStatisticsManager..::..GetMessageStatistics Method
IMessageStatisticsManager Interface See Also Send Feedback
Gets message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
MessageStatistics GetMessageStatistics(
    Identifier messageId
)
Visual Basic
Function GetMessageStatistics ( _
    messageId As Identifier _
) As MessageStatistics
Visual C++
MessageStatistics^ GetMessageStatistics(
    Identifier^ messageId
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The message statistics.

See Also

IMessageStatisticsManager Interface
Sitecore.Social.Domain Namespace


RefreshMessageStatistics Method

[image]

Sitecore Social Connected 1.3.1 API
IMessageStatisticsManager..::..RefreshMessageStatistics Method
IMessageStatisticsManager Interface See Also Send Feedback
Refreshes message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void RefreshMessageStatistics(
    Identifier messageId
)
Visual Basic
Sub RefreshMessageStatistics ( _
    messageId As Identifier _
)
Visual C++
void RefreshMessageStatistics(
    Identifier^ messageId
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

See Also

IMessageStatisticsManager Interface
Sitecore.Social.Domain Namespace


INetworkManager Interface

[image]

Sitecore Social Connected 1.3.1 API
INetworkManager Interface
Members See Also Send Feedback
Defines the methods that are used to manage social networks.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface INetworkManager
Visual Basic
Public Interface INetworkManager
Visual C++
public interface class INetworkManager

See Also

INetworkManager Members
Sitecore.Social.Domain Namespace


INetworkManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
INetworkManager Members
INetworkManager Interface Methods See Also Send Feedback

The INetworkManager type exposes the following members.

Methods

 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.

See Also

INetworkManager Interface
Sitecore.Social.Domain Namespace


INetworkManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
INetworkManager Methods
INetworkManager Interface See Also Send Feedback

The INetworkManager type exposes the following members.

Methods

 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.

See Also

INetworkManager Interface
Sitecore.Social.Domain Namespace


CanPostTo Method

[image] [image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..CanPostTo Method
INetworkManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.

See Also

INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


CanPostTo Method (String)

[image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..CanPostTo Method (String)
INetworkManager Interface See Also Send Feedback
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
bool CanPostTo(
    string networkName
)
Visual Basic
Function CanPostTo ( _
    networkName As String _
) As Boolean
Visual C++
bool CanPostTo(
    String^ networkName
)

Parameters

networkName
Type: System..::..String
The network name.

Return Value

true if it is possible to post messages to the network; otherwise, false.

Remarks

false is returned, if the network is not found.

See Also

INetworkManager Interface
CanPostTo Overload
Sitecore.Social.Domain Namespace


CanPostTo Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..CanPostTo Method (Identifier)
INetworkManager Interface See Also Send Feedback
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
bool CanPostTo(
    Identifier networkId
)
Visual Basic
Function CanPostTo ( _
    networkId As Identifier _
) As Boolean
Visual C++
bool CanPostTo(
    Identifier^ networkId
)

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.

Return Value

true if it is possible to post messages to the network; otherwise, false.

Remarks

false is returned, if the network is not found.

See Also

INetworkManager Interface
CanPostTo Overload
Sitecore.Social.Domain Namespace


GetNetwork Method

[image] [image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..GetNetwork Method
INetworkManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.

See Also

INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


GetNetwork Method (String)

[image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..GetNetwork Method (String)
INetworkManager Interface See Also Send Feedback
Gets a network by name.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
Network GetNetwork(
    string networkName
)
Visual Basic
Function GetNetwork ( _
    networkName As String _
) As Network
Visual C++
Network^ GetNetwork(
    String^ networkName
)

Parameters

networkName
Type: System..::..String
The name of the network.

Return Value

The network. If the network is not found Empty is returned.

See Also

INetworkManager Interface
GetNetwork Overload
Sitecore.Social.Domain Namespace


GetNetwork Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..GetNetwork Method (Identifier)
INetworkManager Interface See Also Send Feedback
Gets a network by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
Network GetNetwork(
    Identifier networkId
)
Visual Basic
Function GetNetwork ( _
    networkId As Identifier _
) As Network
Visual C++
Network^ GetNetwork(
    Identifier^ networkId
)

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
Id of the network.

Return Value

The network. If the network is not found Empty is returned.

See Also

INetworkManager Interface
GetNetwork Overload
Sitecore.Social.Domain Namespace


GetNetworks Method

[image]

Sitecore Social Connected 1.3.1 API
INetworkManager..::..GetNetworks Method
INetworkManager Interface See Also Send Feedback
Gets all registered networks.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<Network> GetNetworks()
Visual Basic
Function GetNetworks As IEnumerable(Of Network)
Visual C++
IEnumerable<Network^>^ GetNetworks()

Return Value

The network list. If there are no networks, an empty list is returned.

See Also

INetworkManager Interface
Sitecore.Social.Domain Namespace


IPostingPreferenceManager Interface

[image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager Interface
Members See Also Send Feedback
Defines the methods that are used to manage user’s posting preferences.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface IPostingPreferenceManager
Visual Basic
Public Interface IPostingPreferenceManager
Visual C++
public interface class IPostingPreferenceManager

See Also

IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager Members
IPostingPreferenceManager Interface Methods See Also Send Feedback

The IPostingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences | Gets user's posting preferences for all messages found by arguments.
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace


IPostingPreferenceManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager Methods
IPostingPreferenceManager Interface See Also Send Feedback

The IPostingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences | Gets user's posting preferences for all messages found by arguments.
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace


AllowAutomaticPostingByDefault Method

[image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager..::..AllowAutomaticPostingByDefault Method
IPostingPreferenceManager Interface See Also Send Feedback
Determines if automatic posting is allowed by default.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
bool AllowAutomaticPostingByDefault()
Visual Basic
Function AllowAutomaticPostingByDefault As Boolean
Visual C++
bool AllowAutomaticPostingByDefault()

Return Value

true if automatic posting is allowed by default, otherwise false.

See Also

IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace


GetPostingPreference Method

[image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager..::..GetPostingPreference Method
IPostingPreferenceManager Interface See Also Send Feedback
Gets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
PostingPreference GetPostingPreference(
    IPrincipal user,
    Identifier messageId
)
Visual Basic
Function GetPostingPreference ( _
    user As IPrincipal, _
    messageId As Identifier _
) As PostingPreference
Visual C++
PostingPreference^ GetPostingPreference(
    IPrincipal^ user,
    Identifier^ messageId
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.

Return Value

The posting preference. If the posting preference is not found the Default value is used.

See Also

IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace
PostingPreference..::..AutomaticPostingPreference


GetPostingPreferences Method

[image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager..::..GetPostingPreferences Method
IPostingPreferenceManager Interface See Also Send Feedback
Gets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
Visual Basic
Function GetPostingPreferences ( _
    user As IPrincipal, _
    searchArgs As PostingConfigurationSearchArgs _
) As IEnumerable(Of PostingPreference)
Visual C++
IEnumerable<PostingPreference^>^ GetPostingPreferences(
    IPrincipal^ user,
    PostingConfigurationSearchArgs^ searchArgs
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search arguments.

Return Value

The posting preference list. If no preferences are found an empty list is returned.

See Also

IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace


SetPostingPreference Method

[image] [image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager..::..SetPostingPreference Method
IPostingPreferenceManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences for the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Sets user's posting preferences for all messages found by arguments.

See Also

IPostingPreferenceManager Interface
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)

[image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager..::..SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)
IPostingPreferenceManager Interface See Also Send Feedback
Sets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void SetPostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
Sub SetPostingPreference ( _
    user As IPrincipal, _
    messageId As Identifier, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
void SetPostingPreference(
    IPrincipal^ user,
    Identifier^ messageId,
    AutomaticPostingPreference automaticPostingPreference
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

See Also

IPostingPreferenceManager Interface
SetPostingPreference Overload
Sitecore.Social.Domain Namespace


SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

[image]

Sitecore Social Connected 1.3.1 API
IPostingPreferenceManager..::..SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)
IPostingPreferenceManager Interface See Also Send Feedback
Sets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void SetPostingPreference(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
Sub SetPostingPreference ( _
    user As IPrincipal, _
    searchArgs As PostingConfigurationSearchArgs, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
void SetPostingPreference(
    IPrincipal^ user,
    PostingConfigurationSearchArgs^ searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
The search args.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

See Also

IPostingPreferenceManager Interface
SetPostingPreference Overload
Sitecore.Social.Domain Namespace


ISocialProfileManager Interface

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager Interface
Members See Also Send Feedback
Defines the methods that are used to manage a social profile.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public interface ISocialProfileManager
Visual Basic
Public Interface ISocialProfileManager
Visual C++
public interface class ISocialProfileManager

See Also

ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager Members
ISocialProfileManager Interface Methods See Also Send Feedback

The ISocialProfileManager type exposes the following members.

Methods

 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | GetSocialProfile | Gets a social profile of the user in the specified network.
Public method | GetSocialProfiles | Gets all social profiles of the user.
Public method | IsSocialProfileExists | Defines if a social profile exists in the specified network.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | UpdateSocialProfile | Updates a social profile of the specified user.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


ISocialProfileManager Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager Methods
ISocialProfileManager Interface See Also Send Feedback

The ISocialProfileManager type exposes the following members.

Methods

 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | GetSocialProfile | Gets a social profile of the user in the specified network.
Public method | GetSocialProfiles | Gets all social profiles of the user.
Public method | IsSocialProfileExists | Defines if a social profile exists in the specified network.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | UpdateSocialProfile | Updates a social profile of the specified user.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


AttachSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..AttachSocialProfile Method
ISocialProfileManager Interface See Also Send Feedback
Attaches a social profile to the specified user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void AttachSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Visual Basic
Sub AttachSocialProfile ( _
    user As IPrincipal, _
    socialProfile As SocialProfile _
)
Visual C++
void AttachSocialProfile(
    IPrincipal^ user,
    SocialProfile^ socialProfile
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
socialProfile
Type: Sitecore.Social.Domain.Model..::..SocialProfile
The social profile.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


DetachSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..DetachSocialProfile Method
ISocialProfileManager Interface See Also Send Feedback
Removes a social profile from the specified user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void DetachSocialProfile(
    IPrincipal user,
    string networkName
)
Visual Basic
Sub DetachSocialProfile ( _
    user As IPrincipal, _
    networkName As String _
)
Visual C++
void DetachSocialProfile(
    IPrincipal^ user,
    String^ networkName
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


GetSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..GetSocialProfile Method
ISocialProfileManager Interface See Also Send Feedback
Gets a social profile of the user in the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
SocialProfile GetSocialProfile(
    IPrincipal user,
    string networkName
)
Visual Basic
Function GetSocialProfile ( _
    user As IPrincipal, _
    networkName As String _
) As SocialProfile
Visual C++
SocialProfile^ GetSocialProfile(
    IPrincipal^ user,
    String^ networkName
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Return Value

The social profile. If there are no profiles, an empty profile is returned.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


GetSocialProfiles Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..GetSocialProfiles Method
ISocialProfileManager Interface See Also Send Feedback
Gets all social profiles of the user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
IEnumerable<SocialProfile> GetSocialProfiles(
    IPrincipal user
)
Visual Basic
Function GetSocialProfiles ( _
    user As IPrincipal _
) As IEnumerable(Of SocialProfile)
Visual C++
IEnumerable<SocialProfile^>^ GetSocialProfiles(
    IPrincipal^ user
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.

Return Value

The social profiles list. If there are no profiles, an empty list is returned.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


IsSocialProfileExists Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..IsSocialProfileExists Method
ISocialProfileManager Interface See Also Send Feedback
Defines if a social profile exists in the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
bool IsSocialProfileExists(
    IPrincipal user,
    string networkName
)
Visual Basic
Function IsSocialProfileExists ( _
    user As IPrincipal, _
    networkName As String _
) As Boolean
Visual C++
bool IsSocialProfileExists(
    IPrincipal^ user,
    String^ networkName
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
networkName
Type: System..::..String
The network name.

Return Value

The Boolean.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


RetrieveSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..RetrieveSocialProfile Method
ISocialProfileManager Interface See Also Send Feedback
Retrieves a social profile from the social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
SocialProfile RetrieveSocialProfile(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials
)
Visual Basic
Function RetrieveSocialProfile ( _
    networkName As String, _
    applicationCredentials As ApplicationCredentials, _
    accountCredentials As AccountCredentials _
) As SocialProfile
Visual C++
SocialProfile^ RetrieveSocialProfile(
    String^ networkName,
    ApplicationCredentials^ applicationCredentials,
    AccountCredentials^ accountCredentials
)

Parameters

networkName
Type: System..::..String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model..::..ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model..::..AccountCredentials
The account credentials.

Return Value

The social profile. If the request couldn't be executed, an Empty is returned.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


UpdateSocialProfile Method

[image]

Sitecore Social Connected 1.3.1 API
ISocialProfileManager..::..UpdateSocialProfile Method
ISocialProfileManager Interface See Also Send Feedback
Updates a social profile of the specified user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
void UpdateSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Visual Basic
Sub UpdateSocialProfile ( _
    user As IPrincipal, _
    socialProfile As SocialProfile _
)
Visual C++
void UpdateSocialProfile(
    IPrincipal^ user,
    SocialProfile^ socialProfile
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
socialProfile
Type: Sitecore.Social.Domain.Model..::..SocialProfile
The social profile.

See Also

ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


Sitecore.Social.Domain.Model Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Domain.Model Namespace
Send Feedback
Provides classes that represent the domain's model.

Classes

 | Class | Description
Public class | Account | Represents the social network account entity.
Public class | AccountCredentials | Represents the social network account credentials.
Public class | AccountStatistics | Represents the social network statistics by account entity.
Public class | AccountStatus | Represents the message posting status to the account.
Public class | Application | Represents the social network application entity.
Public class | ApplicationCredentials | Represents the social network application credentials.
Public class | ContainerPostingConfiguration | Represents an abstract class for posting configurations with a container.
Public class | ContentPostingConfiguration | Represents content posting configuration.
Public class | DonePostingStatus | Represents the successfully posted message's account status.
Public class | FailedPostingStatus | Represents the failed posting message's account status.
Public class | FailedStatisticsStatus | Represents a failed statistics status.
Public class | GoalPostingConfiguration | Represents a goal posting configuration.
Public class | Identifier | Represents an abstract class of identifiers.
Public class | Message | Represents a social network message.
Public class | MessageData | Represents a social network message data.
Public class | MessageStatistics | Represents a social network message statistics.
Public class | MessageStatus | Represents social message status.
Public class | Network | Represents the social network entity.
Public class | NumberCounter | Represents the statistics number counter.
Public class | PostingConfiguration | Represents an abstract class of posting configurations.
Public class | PostingPreference | Represents user's posting preference for the specific message.
Public class | PostingStatus | Represents an abstract class of message's account posting statuses.
Public class | SocialProfile | Represents a social profile.
Public class | StatisticsCounter | Represents the statistics counter.
Public class | StatisticsStatus | Represents a statistics status.
Public class | UpdatedStatisticsStatus | Represents an updated statistics status.

Enumerations

 | Enumeration | Description
Public enumeration | AutomaticPostingPreference | Defines constants for automatic posting preference.


Account Class

[image]

Sitecore Social Connected 1.3.1 API
Account Class
Members See Also Send Feedback
Represents the social network account entity.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class Account : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class Account _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class Account : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..Account

See Also

Account Members
Sitecore.Social.Domain.Model Namespace
Account..::..AccountCredentials


Account Members

[image] [image]

Sitecore Social Connected 1.3.1 API
Account Members
Account Class Constructors Fields Properties See Also Send Feedback

The Account type exposes the following members.

Constructors

 | Name | Description
Public method | Account | Initializes a new instance of the Account class

Fields

Name | Description
Empty | A read-only instance of the Account class whose value represents not found account.

Properties

 | Name | Description
Public property | AccountContainer | Gets or sets the account container.
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationId | Gets or sets the application id.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | LastRenewalDate | Gets or sets the last renewal date.
Public property | Name | Gets or sets the name.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


Account Constructor

[image]

Sitecore Social Connected 1.3.1 API
Account Constructor
Account Class See Also Send Feedback
Initializes a new instance of the Account class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Account()
Visual Basic
Public Sub New
Visual C++
public:
Account()

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


Account Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
Account Fields
Account Class See Also Send Feedback

The Account type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the Account class whose value represents not found account.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
Account..::..Empty Field
Account Class See Also Send Feedback
A read-only instance of the Account class whose value represents not found account.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly Account Empty
Visual Basic
Public Shared ReadOnly Empty As Account
Visual C++
public:
static initonly Account^ Empty

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


Account Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
Account Properties
Account Class See Also Send Feedback

The Account type exposes the following members.

Properties

 | Name | Description
Public property | AccountContainer | Gets or sets the account container.
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationId | Gets or sets the application id.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | LastRenewalDate | Gets or sets the last renewal date.
Public property | Name | Gets or sets the name.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


AccountContainer Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..AccountContainer Property
Account Class See Also Send Feedback
Gets or sets the account container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string AccountContainer { get; set; }
Visual Basic
Public Property AccountContainer As String
    Get
    Set
Visual C++
public:
property String^ AccountContainer {
    String^ get ();
    void set (String^ value);
}

Field Value

The account container.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..AccountCredentials Property
Account Class See Also Send Feedback
Gets or sets account credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountCredentials AccountCredentials { get; set; }
Visual Basic
Public Property AccountCredentials As AccountCredentials
    Get
    Set
Visual C++
public:
property AccountCredentials^ AccountCredentials {
    AccountCredentials^ get ();
    void set (AccountCredentials^ value);
}

Field Value

The account credentials.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


ApplicationId Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..ApplicationId Property
Account Class See Also Send Feedback
Gets or sets the application id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As Identifier
    Get
    Set
Visual C++
public:
property Identifier^ ApplicationId {
    Identifier^ get ();
    void set (Identifier^ value);
}

Field Value

The application id.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


Id Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..Id Property
Account Class See Also Send Feedback
Gets or sets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier Id { get; set; }
Visual Basic
Public Property Id As Identifier
    Get
    Set
Visual C++
public:
property Identifier^ Id {
    Identifier^ get ();
    void set (Identifier^ value);
}

Field Value

The id.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..IsEmpty Property
Account Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


LastRenewalDate Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..LastRenewalDate Property
Account Class See Also Send Feedback
Gets or sets the last renewal date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Nullable<DateTime> LastRenewalDate { get; set; }
Visual Basic
Public Property LastRenewalDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> LastRenewalDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Field Value

The last renewal date.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


Name Property

[image]

Sitecore Social Connected 1.3.1 API
Account..::..Name Property
Account Class See Also Send Feedback
Gets or sets the name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

Account Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials Class

[image]

Sitecore Social Connected 1.3.1 API
AccountCredentials Class
Members See Also Send Feedback
Represents the social network account credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class AccountCredentials
Visual Basic
<SerializableAttribute> _
Public Class AccountCredentials
Visual C++
[SerializableAttribute]
public ref class AccountCredentials

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..AccountCredentials

See Also

AccountCredentials Members
Sitecore.Social.Domain.Model Namespace
Account..::..AccountCredentials
SocialProfile..::..AccountCredentials


AccountCredentials Members

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountCredentials Members
AccountCredentials Class Constructors Properties See Also Send Feedback

The AccountCredentials type exposes the following members.

Constructors

 | Name | Description
Public method | AccountCredentials()()()() | Initializes a new instance of the AccountCredentials class.
Public method | AccountCredentials(String, String) | Initializes a new instance of the AccountCredentials class with the specific parameters.

Properties

 | Name | Description
Public property | AccessToken | Gets or sets the access token.
Public property | AccessTokenSecret | Gets or sets the access token secret.

See Also

AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountCredentials Constructor
AccountCredentials Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AccountCredentials()()()() | Initializes a new instance of the AccountCredentials class.
Public method | AccountCredentials(String, String) | Initializes a new instance of the AccountCredentials class with the specific parameters.

See Also

AccountCredentials Class
AccountCredentials Members
Sitecore.Social.Domain.Model Namespace


AccountCredentials Constructor

[image]

Sitecore Social Connected 1.3.1 API
AccountCredentials Constructor
AccountCredentials Class See Also Send Feedback
Initializes a new instance of the AccountCredentials class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountCredentials()
Visual Basic
Public Sub New
Visual C++
public:
AccountCredentials()

See Also

AccountCredentials Class
AccountCredentials Overload
Sitecore.Social.Domain.Model Namespace


AccountCredentials Constructor (String, String)

[image]

Sitecore Social Connected 1.3.1 API
AccountCredentials Constructor (String, String)
AccountCredentials Class See Also Send Feedback
Initializes a new instance of the AccountCredentials class with the specific parameters.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountCredentials(
    string accessToken,
    string accessTokenSecret
)
Visual Basic
Public Sub New ( _
    accessToken As String, _
    accessTokenSecret As String _
)
Visual C++
public:
AccountCredentials(
    String^ accessToken,
    String^ accessTokenSecret
)

Parameters

accessToken
Type: System..::..String
The access token.
accessTokenSecret
Type: System..::..String
The access token secret.

See Also

AccountCredentials Class
AccountCredentials Overload
Sitecore.Social.Domain.Model Namespace


AccountCredentials Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountCredentials Properties
AccountCredentials Class See Also Send Feedback

The AccountCredentials type exposes the following members.

Properties

 | Name | Description
Public property | AccessToken | Gets or sets the access token.
Public property | AccessTokenSecret | Gets or sets the access token secret.

See Also

AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccessToken Property

[image]

Sitecore Social Connected 1.3.1 API
AccountCredentials..::..AccessToken Property
AccountCredentials Class See Also Send Feedback
Gets or sets the access token.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string AccessToken { get; set; }
Visual Basic
Public Property AccessToken As String
    Get
    Set
Visual C++
public:
property String^ AccessToken {
    String^ get ();
    void set (String^ value);
}

Field Value

The access token.

See Also

AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccessTokenSecret Property

[image]

Sitecore Social Connected 1.3.1 API
AccountCredentials..::..AccessTokenSecret Property
AccountCredentials Class See Also Send Feedback
Gets or sets the access token secret.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string AccessTokenSecret { get; set; }
Visual Basic
Public Property AccessTokenSecret As String
    Get
    Set
Visual C++
public:
property String^ AccessTokenSecret {
    String^ get ();
    void set (String^ value);
}

Field Value

The access token secret.

See Also

AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics Class

[image]

Sitecore Social Connected 1.3.1 API
AccountStatistics Class
Members See Also Send Feedback
Represents the social network statistics by account entity.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class AccountStatistics
Visual Basic
<SerializableAttribute> _
Public Class AccountStatistics
Visual C++
[SerializableAttribute]
public ref class AccountStatistics

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..AccountStatistics

See Also

AccountStatistics Members
Sitecore.Social.Domain.Model Namespace
MessageStatistics..::..AccountsStatistics


AccountStatistics Members

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountStatistics Members
AccountStatistics Class Constructors Properties See Also Send Feedback

The AccountStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | AccountStatistics | Initializes a new instance of the AccountStatistics class.

Properties

 | Name | Description
Public property | AccountId | Gets the account id.
Public property | StatisticsCounters | Gets the statistics counters.
Public property | StatisticsStatus | Gets the statistics status.

See Also

AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics Constructor

[image]

Sitecore Social Connected 1.3.1 API
AccountStatistics Constructor
AccountStatistics Class See Also Send Feedback
Initializes a new instance of the AccountStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountStatistics(
    Identifier accountId,
    StatisticsStatus statisticsStatus,
    IEnumerable<StatisticsCounter> statisticsCounters
)
Visual Basic
Public Sub New ( _
    accountId As Identifier, _
    statisticsStatus As StatisticsStatus, _
    statisticsCounters As IEnumerable(Of StatisticsCounter) _
)
Visual C++
public:
AccountStatistics(
    Identifier^ accountId,
    StatisticsStatus^ statisticsStatus,
    IEnumerable<StatisticsCounter^>^ statisticsCounters
)

Parameters

accountId
Type: Sitecore.Social.Domain.Model..::..Identifier
The account id.
statisticsStatus
Type: Sitecore.Social.Domain.Model..::..StatisticsStatus
The statistics status.
statisticsCounters
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StatisticsCounter >)>)>
The statistics counters.

See Also

AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountStatistics Properties
AccountStatistics Class See Also Send Feedback

The AccountStatistics type exposes the following members.

Properties

 | Name | Description
Public property | AccountId | Gets the account id.
Public property | StatisticsCounters | Gets the statistics counters.
Public property | StatisticsStatus | Gets the statistics status.

See Also

AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountId Property

[image]

Sitecore Social Connected 1.3.1 API
AccountStatistics..::..AccountId Property
AccountStatistics Class See Also Send Feedback
Gets the account id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier AccountId { get; private set; }
Visual Basic
Public Property AccountId As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ AccountId {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The account id.

See Also

AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounters Property

[image]

Sitecore Social Connected 1.3.1 API
AccountStatistics..::..StatisticsCounters Property
AccountStatistics Class See Also Send Feedback
Gets the statistics counters.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<StatisticsCounter> StatisticsCounters { get; private set; }
Visual Basic
Public Property StatisticsCounters As IEnumerable(Of StatisticsCounter)
    Get
    Private Set
Visual C++
public:
property IEnumerable<StatisticsCounter^>^ StatisticsCounters {
    IEnumerable<StatisticsCounter^>^ get ();
    private: void set (IEnumerable<StatisticsCounter^>^ value);
}

Field Value

The statistics counters.

See Also

AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


StatisticsStatus Property

[image]

Sitecore Social Connected 1.3.1 API
AccountStatistics..::..StatisticsStatus Property
AccountStatistics Class See Also Send Feedback
Gets the statistics status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public StatisticsStatus StatisticsStatus { get; private set; }
Visual Basic
Public Property StatisticsStatus As StatisticsStatus
    Get
    Private Set
Visual C++
public:
property StatisticsStatus^ StatisticsStatus {
    StatisticsStatus^ get ();
    private: void set (StatisticsStatus^ value);
}

Field Value

The statistics status.

See Also

AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatus Class

[image]

Sitecore Social Connected 1.3.1 API
AccountStatus Class
Members See Also Send Feedback
Represents the message posting status to the account.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class AccountStatus
Visual Basic
<SerializableAttribute> _
Public Class AccountStatus
Visual C++
[SerializableAttribute]
public ref class AccountStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..AccountStatus

See Also

AccountStatus Members
Sitecore.Social.Domain.Model Namespace
MessageStatus..::..AccountStatuses


AccountStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountStatus Members
AccountStatus Class Constructors Properties See Also Send Feedback

The AccountStatus type exposes the following members.

Constructors

 | Name | Description
Public method | AccountStatus | Initializes a new instance of the AccountStatus class.

Properties

 | Name | Description
Public property | AccountId | Gets the account id.
Public property | PostingStatus | Gets the posting status.

See Also

AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
AccountStatus Constructor
AccountStatus Class See Also Send Feedback
Initializes a new instance of the AccountStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountStatus(
    Identifier accountId,
    PostingStatus postingStatus
)
Visual Basic
Public Sub New ( _
    accountId As Identifier, _
    postingStatus As PostingStatus _
)
Visual C++
public:
AccountStatus(
    Identifier^ accountId,
    PostingStatus^ postingStatus
)

Parameters

accountId
Type: Sitecore.Social.Domain.Model..::..Identifier
The account id.
postingStatus
Type: Sitecore.Social.Domain.Model..::..PostingStatus
The posting status.

See Also

AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatus Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
AccountStatus Properties
AccountStatus Class See Also Send Feedback

The AccountStatus type exposes the following members.

Properties

 | Name | Description
Public property | AccountId | Gets the account id.
Public property | PostingStatus | Gets the posting status.

See Also

AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountId Property

[image]

Sitecore Social Connected 1.3.1 API
AccountStatus..::..AccountId Property
AccountStatus Class See Also Send Feedback
Gets the account id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier AccountId { get; private set; }
Visual Basic
Public Property AccountId As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ AccountId {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The account id.

See Also

AccountStatus Class
Sitecore.Social.Domain.Model Namespace


PostingStatus Property

[image]

Sitecore Social Connected 1.3.1 API
AccountStatus..::..PostingStatus Property
AccountStatus Class See Also Send Feedback
Gets the posting status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingStatus PostingStatus { get; private set; }
Visual Basic
Public Property PostingStatus As PostingStatus
    Get
    Private Set
Visual C++
public:
property PostingStatus^ PostingStatus {
    PostingStatus^ get ();
    private: void set (PostingStatus^ value);
}

Field Value

The posting status.

See Also

AccountStatus Class
Sitecore.Social.Domain.Model Namespace


Application Class

[image]

Sitecore Social Connected 1.3.1 API
Application Class
Members See Also Send Feedback
Represents the social network application entity.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class Application : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class Application _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class Application : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..Application

See Also

Application Members
Sitecore.Social.Domain.Model Namespace
Application..::..ApplicationCredentials


Application Members

[image] [image]

Sitecore Social Connected 1.3.1 API
Application Members
Application Class Constructors Fields Properties See Also Send Feedback

The Application type exposes the following members.

Constructors

 | Name | Description
Public method | Application | Initializes a new instance of the Application class

Fields

Name | Description
Empty | A read-only instance of the Application class whose value represents not found application.

Properties

 | Name | Description
Public property | ApplicationContainer | Gets or sets the application container.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Public property | NetworkId | Gets or sets the network id.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


Application Constructor

[image]

Sitecore Social Connected 1.3.1 API
Application Constructor
Application Class See Also Send Feedback
Initializes a new instance of the Application class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Application()
Visual Basic
Public Sub New
Visual C++
public:
Application()

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


Application Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
Application Fields
Application Class See Also Send Feedback

The Application type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the Application class whose value represents not found application.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
Application..::..Empty Field
Application Class See Also Send Feedback
A read-only instance of the Application class whose value represents not found application.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly Application Empty
Visual Basic
Public Shared ReadOnly Empty As Application
Visual C++
public:
static initonly Application^ Empty

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


Application Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationContainer | Gets or sets the application container.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Public property | NetworkId | Gets or sets the network id.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


ApplicationContainer Property

[image]

Sitecore Social Connected 1.3.1 API
Application..::..ApplicationContainer Property
Application Class See Also Send Feedback
Gets or sets the application container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string ApplicationContainer { get; set; }
Visual Basic
Public Property ApplicationContainer As String
    Get
    Set
Visual C++
public:
property String^ ApplicationContainer {
    String^ get ();
    void set (String^ value);
}

Field Value

The application container.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Property

[image]

Sitecore Social Connected 1.3.1 API
Application..::..ApplicationCredentials Property
Application Class See Also Send Feedback
Gets or sets application credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationCredentials ApplicationCredentials { get; set; }
Visual Basic
Public Property ApplicationCredentials As ApplicationCredentials
    Get
    Set
Visual C++
public:
property ApplicationCredentials^ ApplicationCredentials {
    ApplicationCredentials^ get ();
    void set (ApplicationCredentials^ value);
}

Field Value

The application credentials.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


Id Property

[image]

Sitecore Social Connected 1.3.1 API
Application..::..Id Property
Application Class See Also Send Feedback
Gets or sets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier Id { get; set; }
Visual Basic
Public Property Id As Identifier
    Get
    Set
Visual C++
public:
property Identifier^ Id {
    Identifier^ get ();
    void set (Identifier^ value);
}

Field Value

The id.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
Application..::..IsEmpty Property
Application Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


Name Property

[image]

Sitecore Social Connected 1.3.1 API
Application..::..Name Property
Application Class See Also Send Feedback
Gets or sets the name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


NetworkId Property

[image]

Sitecore Social Connected 1.3.1 API
Application..::..NetworkId Property
Application Class See Also Send Feedback
Gets or sets the network id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier NetworkId { get; set; }
Visual Basic
Public Property NetworkId As Identifier
    Get
    Set
Visual C++
public:
property Identifier^ NetworkId {
    Identifier^ get ();
    void set (Identifier^ value);
}

Field Value

The network id.

See Also

Application Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Class

[image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials Class
Members See Also Send Feedback
Represents the social network application credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class ApplicationCredentials
Visual Basic
<SerializableAttribute> _
Public Class ApplicationCredentials
Visual C++
[SerializableAttribute]
public ref class ApplicationCredentials

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..ApplicationCredentials

See Also

ApplicationCredentials Members
Sitecore.Social.Domain.Model Namespace
Application..::..ApplicationCredentials
SocialProfile..::..ApplicationCredentials


ApplicationCredentials Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials Members
ApplicationCredentials Class Constructors Properties See Also Send Feedback

The ApplicationCredentials type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationCredentials()()()() | Initializes a new instance of the ApplicationCredentials class.
Public method | ApplicationCredentials(String, String) | Initializes a new instance of the ApplicationCredentials class with the specific parameters.

Properties

 | Name | Description
Public property | ApplicationKey | Gets or sets the application key.
Public property | ApplicationSecret | Gets or sets the application secret.

See Also

ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials Constructor
ApplicationCredentials Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplicationCredentials()()()() | Initializes a new instance of the ApplicationCredentials class.
Public method | ApplicationCredentials(String, String) | Initializes a new instance of the ApplicationCredentials class with the specific parameters.

See Also

ApplicationCredentials Class
ApplicationCredentials Members
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Constructor

[image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials Constructor
ApplicationCredentials Class See Also Send Feedback
Initializes a new instance of the ApplicationCredentials class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationCredentials()
Visual Basic
Public Sub New
Visual C++
public:
ApplicationCredentials()

See Also

ApplicationCredentials Class
ApplicationCredentials Overload
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Constructor (String, String)

[image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials Constructor (String, String)
ApplicationCredentials Class See Also Send Feedback
Initializes a new instance of the ApplicationCredentials class with the specific parameters.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationCredentials(
    string applicationKey,
    string applicationSecret
)
Visual Basic
Public Sub New ( _
    applicationKey As String, _
    applicationSecret As String _
)
Visual C++
public:
ApplicationCredentials(
    String^ applicationKey,
    String^ applicationSecret
)

Parameters

applicationKey
Type: System..::..String
The application key.
applicationSecret
Type: System..::..String
The application secret.

See Also

ApplicationCredentials Class
ApplicationCredentials Overload
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials Properties
ApplicationCredentials Class See Also Send Feedback

The ApplicationCredentials type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationKey | Gets or sets the application key.
Public property | ApplicationSecret | Gets or sets the application secret.

See Also

ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


ApplicationKey Property

[image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials..::..ApplicationKey Property
ApplicationCredentials Class See Also Send Feedback
Gets or sets the application key.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string ApplicationKey { get; set; }
Visual Basic
Public Property ApplicationKey As String
    Get
    Set
Visual C++
public:
property String^ ApplicationKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The application key.

See Also

ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


ApplicationSecret Property

[image]

Sitecore Social Connected 1.3.1 API
ApplicationCredentials..::..ApplicationSecret Property
ApplicationCredentials Class See Also Send Feedback
Gets or sets the application secret.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string ApplicationSecret { get; set; }
Visual Basic
Public Property ApplicationSecret As String
    Get
    Set
Visual C++
public:
property String^ ApplicationSecret {
    String^ get ();
    void set (String^ value);
}

Field Value

The application secret.

See Also

ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


AutomaticPostingPreference Enumeration

[image]

Sitecore Social Connected 1.3.1 API
AutomaticPostingPreference Enumeration
See Also Send Feedback
Defines constants for automatic posting preference.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public enum AutomaticPostingPreference
Visual Basic
<SerializableAttribute> _
Public Enumeration AutomaticPostingPreference
Visual C++
[SerializableAttribute]
public enum class AutomaticPostingPreference

Members

Member name | Value | Description
Default | 0 | Use default automatic posting preference.
Allowed | 1 | The automatic posting is allowed.
Denied | 2 | The automatic posting is denied.

See Also

Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Class

[image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfiguration Class
Members See Also Send Feedback
Represents an abstract class for posting configurations with a container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class ContainerPostingConfiguration : PostingConfiguration
Visual Basic
<SerializableAttribute> _
Public MustInherit Class ContainerPostingConfiguration _
    Inherits PostingConfiguration
Visual C++
[SerializableAttribute]
public ref class ContainerPostingConfiguration abstract : public PostingConfiguration

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingConfiguration
Sitecore.Social.Domain.Model..::..ContainerPostingConfiguration
Sitecore.Social.Domain.Model..::..ContentPostingConfiguration
Sitecore.Social.Domain.Model..::..GoalPostingConfiguration

See Also

ContainerPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Sitecore.Social.Domain.Model..::..ContentPostingConfiguration
Sitecore.Social.Domain.Model..::..GoalPostingConfiguration


ContainerPostingConfiguration Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfiguration Members
ContainerPostingConfiguration Class Constructors Properties See Also Send Feedback

The ContainerPostingConfiguration type exposes the following members.

Constructors

 | Name | Description
Protected method | ContainerPostingConfiguration | Initializes a new instance of the ContainerPostingConfiguration class.

Properties

 | Name | Description
Public property | Container | Gets the container.

See Also

ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Constructor

[image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfiguration Constructor
ContainerPostingConfiguration Class See Also Send Feedback
Initializes a new instance of the ContainerPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected ContainerPostingConfiguration(
    string container
)
Visual Basic
Protected Sub New ( _
    container As String _
)
Visual C++
protected:
ContainerPostingConfiguration(
    String^ container
)

Parameters

container
Type: System..::..String
The container.

See Also

ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfiguration Properties
ContainerPostingConfiguration Class See Also Send Feedback

The ContainerPostingConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container.

See Also

ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


Container Property

[image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfiguration..::..Container Property
ContainerPostingConfiguration Class See Also Send Feedback
Gets the container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Container { get; private set; }
Visual Basic
Public Property Container As String
    Get
    Private Set
Visual C++
public:
property String^ Container {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The container.

See Also

ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Class

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration Class
Members See Also Send Feedback
Represents content posting configuration.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class ContentPostingConfiguration : ContainerPostingConfiguration
Visual Basic
<SerializableAttribute> _
Public Class ContentPostingConfiguration _
    Inherits ContainerPostingConfiguration
Visual C++
[SerializableAttribute]
public ref class ContentPostingConfiguration : public ContainerPostingConfiguration

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingConfiguration
Sitecore.Social.Domain.Model..::..ContainerPostingConfiguration
Sitecore.Social.Domain.Model..::..ContentPostingConfiguration

See Also

ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Message..::..PostingConfiguration


ContentPostingConfiguration Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration Members
ContentPostingConfiguration Class Constructors Properties See Also Send Feedback

The ContentPostingConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ContentPostingConfiguration(String) | Initializes a new instance of the ContentPostingConfiguration class.
Public method | ContentPostingConfiguration(String, Boolean) | Initializes a new instance of the ContentPostingConfiguration class.

Properties

 | Name | Description
Public property | AccountIds | Gets the identifiers of the accounts assigned to the message.
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)
Public property | PostOnContentPublishing | Gets a value indicating whether the related message should be posted to the social network when the content is published to the website.

See Also

ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration Constructor
ContentPostingConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ContentPostingConfiguration(String) | Initializes a new instance of the ContentPostingConfiguration class.
Public method | ContentPostingConfiguration(String, Boolean) | Initializes a new instance of the ContentPostingConfiguration class.

See Also

ContentPostingConfiguration Class
ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor (String)

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration Constructor (String)
ContentPostingConfiguration Class See Also Send Feedback
Initializes a new instance of the ContentPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ContentPostingConfiguration(
    string contentContainer
)
Visual Basic
Public Sub New ( _
    contentContainer As String _
)
Visual C++
public:
ContentPostingConfiguration(
    String^ contentContainer
)

Parameters

contentContainer
Type: System..::..String
The content container.

See Also

ContentPostingConfiguration Class
ContentPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor (String, Boolean)

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration Constructor (String, Boolean)
ContentPostingConfiguration Class See Also Send Feedback
Initializes a new instance of the ContentPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ContentPostingConfiguration(
    string contentContainer,
    bool postOnContentPublishing
)
Visual Basic
Public Sub New ( _
    contentContainer As String, _
    postOnContentPublishing As Boolean _
)
Visual C++
public:
ContentPostingConfiguration(
    String^ contentContainer,
    bool postOnContentPublishing
)

Parameters

contentContainer
Type: System..::..String
The content container.
postOnContentPublishing
Type: System..::..Boolean
If checked, the related message will be posted to the social network when the content is published to the website.

See Also

ContentPostingConfiguration Class
ContentPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration Properties
ContentPostingConfiguration Class See Also Send Feedback

The ContentPostingConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccountIds | Gets the identifiers of the accounts assigned to the message.
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)
Public property | PostOnContentPublishing | Gets a value indicating whether the related message should be posted to the social network when the content is published to the website.

See Also

ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


AccountIds Property

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration..::..AccountIds Property
ContentPostingConfiguration Class See Also Send Feedback
Gets the identifiers of the accounts assigned to the message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ICollection<Identifier> AccountIds { get; private set; }
Visual Basic
Public Property AccountIds As ICollection(Of Identifier)
    Get
    Private Set
Visual C++
public:
property ICollection<Identifier^>^ AccountIds {
    ICollection<Identifier^>^ get ();
    private: void set (ICollection<Identifier^>^ value);
}

Field Value

The account identifiers.

See Also

ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


PostOnContentPublishing Property

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfiguration..::..PostOnContentPublishing Property
ContentPostingConfiguration Class See Also Send Feedback
Gets a value indicating whether the related message should be posted to the social network when the content is published to the website.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool PostOnContentPublishing { get; private set; }
Visual Basic
Public Property PostOnContentPublishing As Boolean
    Get
    Private Set
Visual C++
public:
property bool PostOnContentPublishing {
    bool get ();
    private: void set (bool value);
}

Field Value

If true, the related message will be posted to the social network when the content is published to the website. Otherwise, false.

See Also

ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Class

[image]

Sitecore Social Connected 1.3.1 API
DonePostingStatus Class
Members See Also Send Feedback
Represents the successfully posted message's account status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class DonePostingStatus : PostingStatus
Visual Basic
<SerializableAttribute> _
Public Class DonePostingStatus _
    Inherits PostingStatus
Visual C++
[SerializableAttribute]
public ref class DonePostingStatus : public PostingStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingStatus
Sitecore.Social.Domain.Model..::..DonePostingStatus

See Also

DonePostingStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatus..::..PostingStatus


DonePostingStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
DonePostingStatus Members
DonePostingStatus Class Constructors Properties See Also Send Feedback

The DonePostingStatus type exposes the following members.

Constructors

 | Name | Description
Public method | DonePostingStatus | Initializes a new instance of the DonePostingStatus class.

Properties

 | Name | Description
Public property | NetworkMessageId | Gets the id of the message in the social network.

See Also

DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
DonePostingStatus Constructor
DonePostingStatus Class See Also Send Feedback
Initializes a new instance of the DonePostingStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public DonePostingStatus(
    string networkMessageId
)
Visual Basic
Public Sub New ( _
    networkMessageId As String _
)
Visual C++
public:
DonePostingStatus(
    String^ networkMessageId
)

Parameters

networkMessageId
Type: System..::..String
The id of the message in the social network.

See Also

DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
DonePostingStatus Properties
DonePostingStatus Class See Also Send Feedback

The DonePostingStatus type exposes the following members.

Properties

 | Name | Description
Public property | NetworkMessageId | Gets the id of the message in the social network.

See Also

DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


NetworkMessageId Property

[image]

Sitecore Social Connected 1.3.1 API
DonePostingStatus..::..NetworkMessageId Property
DonePostingStatus Class See Also Send Feedback
Gets the id of the message in the social network.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string NetworkMessageId { get; private set; }
Visual Basic
Public Property NetworkMessageId As String
    Get
    Private Set
Visual C++
public:
property String^ NetworkMessageId {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The network message id.

See Also

DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Class

[image]

Sitecore Social Connected 1.3.1 API
FailedPostingStatus Class
Members See Also Send Feedback
Represents the failed posting message's account status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class FailedPostingStatus : PostingStatus
Visual Basic
<SerializableAttribute> _
Public Class FailedPostingStatus _
    Inherits PostingStatus
Visual C++
[SerializableAttribute]
public ref class FailedPostingStatus : public PostingStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingStatus
Sitecore.Social.Domain.Model..::..FailedPostingStatus

See Also

FailedPostingStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatus..::..PostingStatus


FailedPostingStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
FailedPostingStatus Members
FailedPostingStatus Class Constructors Properties See Also Send Feedback

The FailedPostingStatus type exposes the following members.

Constructors

 | Name | Description
Public method | FailedPostingStatus | Initializes a new instance of the FailedPostingStatus class.

Properties

 | Name | Description
Public property | ErrorText | Gets the error text.

See Also

FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
FailedPostingStatus Constructor
FailedPostingStatus Class See Also Send Feedback
Initializes a new instance of the FailedPostingStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public FailedPostingStatus(
    string errorText
)
Visual Basic
Public Sub New ( _
    errorText As String _
)
Visual C++
public:
FailedPostingStatus(
    String^ errorText
)

Parameters

errorText
Type: System..::..String
The error text.

See Also

FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
FailedPostingStatus Properties
FailedPostingStatus Class See Also Send Feedback

The FailedPostingStatus type exposes the following members.

Properties

 | Name | Description
Public property | ErrorText | Gets the error text.

See Also

FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


ErrorText Property

[image]

Sitecore Social Connected 1.3.1 API
FailedPostingStatus..::..ErrorText Property
FailedPostingStatus Class See Also Send Feedback
Gets the error text.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string ErrorText { get; private set; }
Visual Basic
Public Property ErrorText As String
    Get
    Private Set
Visual C++
public:
property String^ ErrorText {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The error text.

See Also

FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedStatisticsStatus Class

[image]

Sitecore Social Connected 1.3.1 API
FailedStatisticsStatus Class
Members See Also Send Feedback
Represents a failed statistics status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class FailedStatisticsStatus : StatisticsStatus
Visual Basic
<SerializableAttribute> _
Public Class FailedStatisticsStatus _
    Inherits StatisticsStatus
Visual C++
[SerializableAttribute]
public ref class FailedStatisticsStatus : public StatisticsStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsStatus
Sitecore.Social.Domain.Model..::..FailedStatisticsStatus

See Also

FailedStatisticsStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics..::..StatisticsStatus


FailedStatisticsStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
FailedStatisticsStatus Members
FailedStatisticsStatus Class Constructors See Also Send Feedback

The FailedStatisticsStatus type exposes the following members.

Constructors

 | Name | Description
Public method | FailedStatisticsStatus | Initializes a new instance of the FailedStatisticsStatus class

See Also

FailedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


FailedStatisticsStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
FailedStatisticsStatus Constructor
FailedStatisticsStatus Class See Also Send Feedback
Initializes a new instance of the FailedStatisticsStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public FailedStatisticsStatus()
Visual Basic
Public Sub New
Visual C++
public:
FailedStatisticsStatus()

See Also

FailedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Class

[image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfiguration Class
Members See Also Send Feedback
Represents a goal posting configuration.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class GoalPostingConfiguration : ContainerPostingConfiguration
Visual Basic
<SerializableAttribute> _
Public Class GoalPostingConfiguration _
    Inherits ContainerPostingConfiguration
Visual C++
[SerializableAttribute]
public ref class GoalPostingConfiguration : public ContainerPostingConfiguration

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingConfiguration
Sitecore.Social.Domain.Model..::..ContainerPostingConfiguration
Sitecore.Social.Domain.Model..::..GoalPostingConfiguration

See Also

GoalPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Message..::..PostingConfiguration


GoalPostingConfiguration Members

[image] [image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfiguration Members
GoalPostingConfiguration Class Constructors Properties See Also Send Feedback

The GoalPostingConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | GoalPostingConfiguration | Initializes a new instance of the GoalPostingConfiguration class.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)

See Also

GoalPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Constructor

[image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfiguration Constructor
GoalPostingConfiguration Class See Also Send Feedback
Initializes a new instance of the GoalPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GoalPostingConfiguration(
    string goalContainer
)
Visual Basic
Public Sub New ( _
    goalContainer As String _
)
Visual C++
public:
GoalPostingConfiguration(
    String^ goalContainer
)

Parameters

goalContainer
Type: System..::..String
The goal container.

See Also

GoalPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfiguration Properties
GoalPostingConfiguration Class See Also Send Feedback

The GoalPostingConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)

See Also

GoalPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


Identifier Class

[image]

Sitecore Social Connected 1.3.1 API
Identifier Class
Members See Also Send Feedback
Represents an abstract class of identifiers.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class Identifier : IEquatable<Identifier>,
    IEmptyable
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Identifier _
    Implements IEquatable(Of Identifier), IEmptyable
Visual C++
[SerializableAttribute]
public ref class Identifier abstract : IEquatable<Identifier^>,
    IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..Identifier
Sitecore.Social.BusinessLogic.Model..::..IDIdentifier

See Also

Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier Members

[image] [image]

Sitecore Social Connected 1.3.1 API
Identifier Members
Identifier Class Constructors Methods Operators Properties See Also Send Feedback

The Identifier type exposes the following members.

Constructors

 | Name | Description
Protected method | Identifier | Initializes a new instance of the Identifier class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Public method | Equals(Identifier) | Checks if current identifier is equal to other one.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Compares two identifiers.
Inequality | Compares two identifiers.

Extension Methods

 | Name | Description
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)

Properties

 | Name | Description
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | OriginalType | Gets the original type.
Public property | StringValue | Gets the string value.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier Constructor

[image]

Sitecore Social Connected 1.3.1 API
Identifier Constructor
Identifier Class See Also Send Feedback
Initializes a new instance of the Identifier class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected Identifier(
    string value
)
Visual Basic
Protected Sub New ( _
    value As String _
)
Visual C++
protected:
Identifier(
    String^ value
)

Parameters

value
Type: System..::..String
The string value.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier Methods

[image] [image]

Sitecore Social Connected 1.3.1 API
Identifier Methods
Identifier Class See Also Send Feedback

The Identifier type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Public method | Equals(Identifier) | Checks if current identifier is equal to other one.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Extension Methods

 | Name | Description
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Equals Method

[image] [image]

Sitecore Social Connected 1.3.1 API
Identifier..::..Equals Method
Identifier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Public method | Equals(Identifier) | Checks if current identifier is equal to other one.

See Also

Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Equals Method (Object)

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..Equals Method (Object)
Identifier Class See Also Send Feedback
Determines whether the specified Object is equal to this instance.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

Exceptions

Exception | Condition
System..::..InvalidCastException | The 'obj' argument is not an Identifier object.

See Also

Identifier Class
Equals Overload
Sitecore.Social.Domain.Model Namespace


Equals Method (Identifier)

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..Equals Method (Identifier)
Identifier Class See Also Send Feedback
Checks if current identifier is equal to other one.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public virtual bool Equals(
    Identifier other
)
Visual Basic
Public Overridable Function Equals ( _
    other As Identifier _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Identifier^ other
)

Parameters

other
Type: Sitecore.Social.Domain.Model..::..Identifier
The other.

Return Value

true if current identifier is equal to other one, otherwise false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

Identifier Class
Equals Overload
Sitecore.Social.Domain.Model Namespace


GetHashCode Method

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..GetHashCode Method
Identifier Class See Also Send Feedback
Returns a hash code for this instance.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


ToString Method

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..ToString Method
Identifier Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents this instance.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier Operators

[image] [image]

Sitecore Social Connected 1.3.1 API
Identifier Operators
Identifier Class See Also Send Feedback

The Identifier type exposes the following members.

Operators

Name | Description
Equality | Compares two identifiers.
Inequality | Compares two identifiers.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Equality Operator

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..Equality Operator
Identifier Class See Also Send Feedback
Compares two identifiers.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static bool operator ==(
    Identifier id1,
    Identifier id2
)
Visual Basic
Public Shared Operator = ( _
    id1 As Identifier, _
    id2 As Identifier _
) As Boolean
Visual C++
public:
static bool operator ==(
    Identifier^ id1,
    Identifier^ id2
)

Parameters

id1
Type: Sitecore.Social.Domain.Model..::..Identifier
The id1.
id2
Type: Sitecore.Social.Domain.Model..::..Identifier
The id2.

Return Value

true if id1 is equal to id2, otherwise false.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Inequality Operator

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..Inequality Operator
Identifier Class See Also Send Feedback
Compares two identifiers.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static bool operator !=(
    Identifier id1,
    Identifier id2
)
Visual Basic
Public Shared Operator <> ( _
    id1 As Identifier, _
    id2 As Identifier _
) As Boolean
Visual C++
public:
static bool operator !=(
    Identifier^ id1,
    Identifier^ id2
)

Parameters

id1
Type: Sitecore.Social.Domain.Model..::..Identifier
The id1.
id2
Type: Sitecore.Social.Domain.Model..::..Identifier
The id2.

Return Value

true if id1 is not equal to id2, otherwise false.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
Identifier Properties
Identifier Class See Also Send Feedback

The Identifier type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | OriginalType | Gets the original type.
Public property | StringValue | Gets the string value.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..IsEmpty Property
Identifier Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public abstract bool IsEmpty { get; }
Visual Basic
Public MustOverride ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () abstract;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


OriginalType Property

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..OriginalType Property
Identifier Class See Also Send Feedback
Gets the original type.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public abstract Type OriginalType { get; }
Visual Basic
Public MustOverride ReadOnly Property OriginalType As Type
    Get
Visual C++
public:
virtual property Type^ OriginalType {
    Type^ get () abstract;
}

Field Value

The original type.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


StringValue Property

[image]

Sitecore Social Connected 1.3.1 API
Identifier..::..StringValue Property
Identifier Class See Also Send Feedback
Gets the string value.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string StringValue { get; private set; }
Visual Basic
Public Property StringValue As String
    Get
    Private Set
Visual C++
public:
property String^ StringValue {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The string value.

See Also

Identifier Class
Sitecore.Social.Domain.Model Namespace


Message Class

[image]

Sitecore Social Connected 1.3.1 API
Message Class
Members See Also Send Feedback
Represents a social network message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class Message : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class Message _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class Message : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..Message

See Also

Message Members
Sitecore.Social.Domain.Model Namespace


Message Members

[image] [image]

Sitecore Social Connected 1.3.1 API
Message Members
Message Class Constructors Fields Properties See Also Send Feedback

The Message type exposes the following members.

Constructors

 | Name | Description
Public method | Message | Initializes a new instance of the Message class.

Fields

Name | Description
Empty | A read-only instance of the Message class whose value represents not found message.

Properties

 | Name | Description
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | MessageData | Gets the message data.
Public property | NetworkId | Gets the network id.
Public property | PostingConfiguration | Gets the posting configuration.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


Message Constructor

[image]

Sitecore Social Connected 1.3.1 API
Message Constructor
Message Class See Also Send Feedback
Initializes a new instance of the Message class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Message(
    Identifier networkId,
    MessageData messageData,
    PostingConfiguration postingConfiguration
)
Visual Basic
Public Sub New ( _
    networkId As Identifier, _
    messageData As MessageData, _
    postingConfiguration As PostingConfiguration _
)
Visual C++
public:
Message(
    Identifier^ networkId,
    MessageData^ messageData,
    PostingConfiguration^ postingConfiguration
)

Parameters

networkId
Type: Sitecore.Social.Domain.Model..::..Identifier
The network id.
messageData
Type: Sitecore.Social.Domain.Model..::..MessageData
The message data.
postingConfiguration
Type: Sitecore.Social.Domain.Model..::..PostingConfiguration
The posting configuration.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


Message Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
Message Fields
Message Class See Also Send Feedback

The Message type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the Message class whose value represents not found message.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
Message..::..Empty Field
Message Class See Also Send Feedback
A read-only instance of the Message class whose value represents not found message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly Message Empty
Visual Basic
Public Shared ReadOnly Empty As Message
Visual C++
public:
static initonly Message^ Empty

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


Message Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
Message Properties
Message Class See Also Send Feedback

The Message type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | MessageData | Gets the message data.
Public property | NetworkId | Gets the network id.
Public property | PostingConfiguration | Gets the posting configuration.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


Id Property

[image]

Sitecore Social Connected 1.3.1 API
Message..::..Id Property
Message Class See Also Send Feedback
Gets or sets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier Id { get; set; }
Visual Basic
Public Property Id As Identifier
    Get
    Set
Visual C++
public:
property Identifier^ Id {
    Identifier^ get ();
    void set (Identifier^ value);
}

Field Value

The id.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
Message..::..IsEmpty Property
Message Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


MessageData Property

[image]

Sitecore Social Connected 1.3.1 API
Message..::..MessageData Property
Message Class See Also Send Feedback
Gets the message data.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageData MessageData { get; private set; }
Visual Basic
Public Property MessageData As MessageData
    Get
    Private Set
Visual C++
public:
property MessageData^ MessageData {
    MessageData^ get ();
    private: void set (MessageData^ value);
}

Field Value

The message data.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


NetworkId Property

[image]

Sitecore Social Connected 1.3.1 API
Message..::..NetworkId Property
Message Class See Also Send Feedback
Gets the network id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier NetworkId { get; private set; }
Visual Basic
Public Property NetworkId As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ NetworkId {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The network id.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


PostingConfiguration Property

[image]

Sitecore Social Connected 1.3.1 API
Message..::..PostingConfiguration Property
Message Class See Also Send Feedback
Gets the posting configuration.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingConfiguration PostingConfiguration { get; private set; }
Visual Basic
Public Property PostingConfiguration As PostingConfiguration
    Get
    Private Set
Visual C++
public:
property PostingConfiguration^ PostingConfiguration {
    PostingConfiguration^ get ();
    private: void set (PostingConfiguration^ value);
}

Field Value

The posting configuration.

See Also

Message Class
Sitecore.Social.Domain.Model Namespace


MessageData Class

[image]

Sitecore Social Connected 1.3.1 API
MessageData Class
Members See Also Send Feedback
Represents a social network message data.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class MessageData
Visual Basic
<SerializableAttribute> _
Public Class MessageData
Visual C++
[SerializableAttribute]
public ref class MessageData

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..MessageData
Sitecore.Social.Facebook.Api.Model..::..FacebookMessageData
Sitecore.Social.Twitter.Api.Model..::..TwitterMessageData

See Also

MessageData Members
Sitecore.Social.Domain.Model Namespace
Message..::..MessageData


MessageData Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageData Members
MessageData Class Constructors Properties See Also Send Feedback

The MessageData type exposes the following members.

Constructors

 | Name | Description
Public method | MessageData | Initializes a new instance of the MessageData class

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id.
Public property | Link | Gets or sets the link.
Public property | Text | Gets or sets the text.

See Also

MessageData Class
Sitecore.Social.Domain.Model Namespace


MessageData Constructor

[image]

Sitecore Social Connected 1.3.1 API
MessageData Constructor
MessageData Class See Also Send Feedback
Initializes a new instance of the MessageData class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageData()
Visual Basic
Public Sub New
Visual C++
public:
MessageData()

See Also

MessageData Class
Sitecore.Social.Domain.Model Namespace


MessageData Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageData Properties
MessageData Class See Also Send Feedback

The MessageData type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id.
Public property | Link | Gets or sets the link.
Public property | Text | Gets or sets the text.

See Also

MessageData Class
Sitecore.Social.Domain.Model Namespace


CampaignId Property

[image]

Sitecore Social Connected 1.3.1 API
MessageData..::..CampaignId Property
MessageData Class See Also Send Feedback
Gets or sets the campaign id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier CampaignId { get; set; }
Visual Basic
Public Property CampaignId As Identifier
    Get
    Set
Visual C++
public:
property Identifier^ CampaignId {
    Identifier^ get ();
    void set (Identifier^ value);
}

Field Value

The campaign id.

See Also

MessageData Class
Sitecore.Social.Domain.Model Namespace


Link Property

[image]

Sitecore Social Connected 1.3.1 API
MessageData..::..Link Property
MessageData Class See Also Send Feedback
Gets or sets the link.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Link { get; set; }
Visual Basic
Public Property Link As String
    Get
    Set
Visual C++
public:
property String^ Link {
    String^ get ();
    void set (String^ value);
}

Field Value

The link.

See Also

MessageData Class
Sitecore.Social.Domain.Model Namespace


Text Property

[image]

Sitecore Social Connected 1.3.1 API
MessageData..::..Text Property
MessageData Class See Also Send Feedback
Gets or sets the text.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

MessageData Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics Class

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Class
Members See Also Send Feedback
Represents a social network message statistics.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class MessageStatistics : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class MessageStatistics _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class MessageStatistics : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..MessageStatistics

See Also

MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Members
MessageStatistics Class Constructors Fields Properties See Also Send Feedback

The MessageStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | MessageStatistics(Identifier, IEnumerable<(Of <<'(AccountStatistics>)>>)) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, IEnumerable<(Of <<'(AccountStatistics>)>>), Nullable<(Of <<'(DateTime>)>>)) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, IEnumerable<(Of <<'(AccountStatistics>)>>), Nullable<(Of <<'(DateTime>)>>), Nullable<(Of <<'(DateTime>)>>)) | Initializes a new instance of the MessageStatistics class.

Fields

Name | Description
Empty | A read-only instance of the MessageStatistics class whose value represents not found message statistics.

Properties

 | Name | Description
Public property | AccountsStatistics | Gets the accounts statistics.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | LastRefreshDate | Gets the statistics last refresh date.
Public property | MessageId | Gets the message id.
Public property | StartRefreshDate | Gets the start refresh date.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Constructor
MessageStatistics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageStatistics(Identifier, IEnumerable<(Of <<'(AccountStatistics>)>>)) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, IEnumerable<(Of <<'(AccountStatistics>)>>), Nullable<(Of <<'(DateTime>)>>)) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, IEnumerable<(Of <<'(AccountStatistics>)>>), Nullable<(Of <<'(DateTime>)>>), Nullable<(Of <<'(DateTime>)>>)) | Initializes a new instance of the MessageStatistics class.

See Also

MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor (Identifier, IEnumerable(AccountStatistics))

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Constructor (Identifier, IEnumerable<(Of <(<'AccountStatistics>)>)>)
MessageStatistics Class See Also Send Feedback
Initializes a new instance of the MessageStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatistics(
    Identifier messageId,
    IEnumerable<AccountStatistics> accountStatistics
)
Visual Basic
Public Sub New ( _
    messageId As Identifier, _
    accountStatistics As IEnumerable(Of AccountStatistics) _
)
Visual C++
public:
MessageStatistics(
    Identifier^ messageId,
    IEnumerable<AccountStatistics^>^ accountStatistics
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
accountStatistics
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' AccountStatistics >)>)>
The account statistics.

See Also

MessageStatistics Class
MessageStatistics Overload
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor (Identifier, IEnumerable(AccountStatistics), Nullable(DateTime))

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Constructor (Identifier, IEnumerable<(Of <(<'AccountStatistics>)>)>, Nullable<(Of <(<'DateTime>)>)>)
MessageStatistics Class See Also Send Feedback
Initializes a new instance of the MessageStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatistics(
    Identifier messageId,
    IEnumerable<AccountStatistics> accountStatistics,
    Nullable<DateTime> startRefreshDate
)
Visual Basic
Public Sub New ( _
    messageId As Identifier, _
    accountStatistics As IEnumerable(Of AccountStatistics), _
    startRefreshDate As Nullable(Of DateTime) _
)
Visual C++
public:
MessageStatistics(
    Identifier^ messageId,
    IEnumerable<AccountStatistics^>^ accountStatistics,
    Nullable<DateTime> startRefreshDate
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
accountStatistics
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' AccountStatistics >)>)>
The account statistics.
startRefreshDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The start refresh date.

See Also

MessageStatistics Class
MessageStatistics Overload
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor (Identifier, IEnumerable(AccountStatistics), Nullable(DateTime), Nullable(DateTime))

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Constructor (Identifier, IEnumerable<(Of <(<'AccountStatistics>)>)>, Nullable<(Of <(<'DateTime>)>)>, Nullable<(Of <(<'DateTime>)>)>)
MessageStatistics Class See Also Send Feedback
Initializes a new instance of the MessageStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatistics(
    Identifier messageId,
    IEnumerable<AccountStatistics> accountStatistics,
    Nullable<DateTime> startRefreshDate,
    Nullable<DateTime> lastRefreshDate
)
Visual Basic
Public Sub New ( _
    messageId As Identifier, _
    accountStatistics As IEnumerable(Of AccountStatistics), _
    startRefreshDate As Nullable(Of DateTime), _
    lastRefreshDate As Nullable(Of DateTime) _
)
Visual C++
public:
MessageStatistics(
    Identifier^ messageId,
    IEnumerable<AccountStatistics^>^ accountStatistics,
    Nullable<DateTime> startRefreshDate,
    Nullable<DateTime> lastRefreshDate
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
accountStatistics
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' AccountStatistics >)>)>
The account statistics.
startRefreshDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The start refresh date.
lastRefreshDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The last refresh date.

See Also

MessageStatistics Class
MessageStatistics Overload
Sitecore.Social.Domain.Model Namespace


MessageStatistics Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Fields
MessageStatistics Class See Also Send Feedback

The MessageStatistics type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the MessageStatistics class whose value represents not found message statistics.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics..::..Empty Field
MessageStatistics Class See Also Send Feedback
A read-only instance of the MessageStatistics class whose value represents not found message statistics.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly MessageStatistics Empty
Visual Basic
Public Shared ReadOnly Empty As MessageStatistics
Visual C++
public:
static initonly MessageStatistics^ Empty

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatistics Properties
MessageStatistics Class See Also Send Feedback

The MessageStatistics type exposes the following members.

Properties

 | Name | Description
Public property | AccountsStatistics | Gets the accounts statistics.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | LastRefreshDate | Gets the statistics last refresh date.
Public property | MessageId | Gets the message id.
Public property | StartRefreshDate | Gets the start refresh date.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountsStatistics Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics..::..AccountsStatistics Property
MessageStatistics Class See Also Send Feedback
Gets the accounts statistics.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<AccountStatistics> AccountsStatistics { get; private set; }
Visual Basic
Public Property AccountsStatistics As IEnumerable(Of AccountStatistics)
    Get
    Private Set
Visual C++
public:
property IEnumerable<AccountStatistics^>^ AccountsStatistics {
    IEnumerable<AccountStatistics^>^ get ();
    private: void set (IEnumerable<AccountStatistics^>^ value);
}

Field Value

The accounts statistics.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics..::..IsEmpty Property
MessageStatistics Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


LastRefreshDate Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics..::..LastRefreshDate Property
MessageStatistics Class See Also Send Feedback
Gets the statistics last refresh date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Nullable<DateTime> LastRefreshDate { get; private set; }
Visual Basic
Public Property LastRefreshDate As Nullable(Of DateTime)
    Get
    Private Set
Visual C++
public:
property Nullable<DateTime> LastRefreshDate {
    Nullable<DateTime> get ();
    private: void set (Nullable<DateTime> value);
}

Field Value

The last refresh date.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageId Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics..::..MessageId Property
MessageStatistics Class See Also Send Feedback
Gets the message id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier MessageId { get; private set; }
Visual Basic
Public Property MessageId As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ MessageId {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The message id.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


StartRefreshDate Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatistics..::..StartRefreshDate Property
MessageStatistics Class See Also Send Feedback
Gets the start refresh date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Nullable<DateTime> StartRefreshDate { get; private set; }
Visual Basic
Public Property StartRefreshDate As Nullable(Of DateTime)
    Get
    Private Set
Visual C++
public:
property Nullable<DateTime> StartRefreshDate {
    Nullable<DateTime> get ();
    private: void set (Nullable<DateTime> value);
}

Field Value

The start refresh date.

See Also

MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatus Class

[image]

Sitecore Social Connected 1.3.1 API
MessageStatus Class
Members See Also Send Feedback
Represents social message status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class MessageStatus : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class MessageStatus _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class MessageStatus : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..MessageStatus

See Also

MessageStatus Members
Sitecore.Social.Domain.Model Namespace


MessageStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatus Members
MessageStatus Class Constructors Fields Properties See Also Send Feedback

The MessageStatus type exposes the following members.

Constructors

 | Name | Description
Public method | MessageStatus | Initializes a new instance of the MessageStatus class.

Fields

Name | Description
Empty | A read-only instance of the MessageStatus class whose value represents not found message status.

Properties

 | Name | Description
Public property | AccountStatuses | Gets the account statuses.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | MessageId | Gets the message id.

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
MessageStatus Constructor
MessageStatus Class See Also Send Feedback
Initializes a new instance of the MessageStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public MessageStatus(
    Identifier messageId,
    IEnumerable<AccountStatus> accountStatuses
)
Visual Basic
Public Sub New ( _
    messageId As Identifier, _
    accountStatuses As IEnumerable(Of AccountStatus) _
)
Visual C++
public:
MessageStatus(
    Identifier^ messageId,
    IEnumerable<AccountStatus^>^ accountStatuses
)

Parameters

messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
accountStatuses
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' AccountStatus >)>)>
The account statuses.

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatus Fields
MessageStatus Class See Also Send Feedback

The MessageStatus type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the MessageStatus class whose value represents not found message status.

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
MessageStatus..::..Empty Field
MessageStatus Class See Also Send Feedback
A read-only instance of the MessageStatus class whose value represents not found message status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly MessageStatus Empty
Visual Basic
Public Shared ReadOnly Empty As MessageStatus
Visual C++
public:
static initonly MessageStatus^ Empty

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
MessageStatus Properties
MessageStatus Class See Also Send Feedback

The MessageStatus type exposes the following members.

Properties

 | Name | Description
Public property | AccountStatuses | Gets the account statuses.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | MessageId | Gets the message id.

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatuses Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatus..::..AccountStatuses Property
MessageStatus Class See Also Send Feedback
Gets the account statuses.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IEnumerable<AccountStatus> AccountStatuses { get; private set; }
Visual Basic
Public Property AccountStatuses As IEnumerable(Of AccountStatus)
    Get
    Private Set
Visual C++
public:
property IEnumerable<AccountStatus^>^ AccountStatuses {
    IEnumerable<AccountStatus^>^ get ();
    private: void set (IEnumerable<AccountStatus^>^ value);
}

Field Value

The account statuses.

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatus..::..IsEmpty Property
MessageStatus Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageId Property

[image]

Sitecore Social Connected 1.3.1 API
MessageStatus..::..MessageId Property
MessageStatus Class See Also Send Feedback
Gets the message id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier MessageId { get; private set; }
Visual Basic
Public Property MessageId As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ MessageId {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The message id.

See Also

MessageStatus Class
Sitecore.Social.Domain.Model Namespace


Network Class

[image]

Sitecore Social Connected 1.3.1 API
Network Class
Members See Also Send Feedback
Represents the social network entity.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class Network : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class Network _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class Network : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..Network

See Also

Network Members
Sitecore.Social.Domain.Model Namespace


Network Members

[image] [image]

Sitecore Social Connected 1.3.1 API
Network Members
Network Class Constructors Fields Properties See Also Send Feedback

The Network type exposes the following members.

Constructors

 | Name | Description
Public method | Network(Identifier, String, String) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String) | Initializes a new instance of the Network class.

Fields

Name | Description
Empty | A read-only instance of the Network class whose value represents not found network.

Properties

 | Name | Description
Public property | Icon | Gets the icon.
Public property | Id | Gets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | Name | Gets the name.
Public property | Prefix | Gets the prefix.
Public property | Url | Gets the URL.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Network Constructor

[image] [image]

Sitecore Social Connected 1.3.1 API
Network Constructor
Network Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Network(Identifier, String, String) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String) | Initializes a new instance of the Network class.

See Also

Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String)

[image]

Sitecore Social Connected 1.3.1 API
Network Constructor (Identifier, String, String)
Network Class See Also Send Feedback
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Network(
    Identifier id,
    string name,
    string prefix
)
Visual Basic
Public Sub New ( _
    id As Identifier, _
    name As String, _
    prefix As String _
)
Visual C++
public:
Network(
    Identifier^ id,
    String^ name,
    String^ prefix
)

Parameters

id
Type: Sitecore.Social.Domain.Model..::..Identifier
The id.
name
Type: System..::..String
The name.
prefix
Type: System..::..String
The prefix.

See Also

Network Class
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String, Uri)

[image]

Sitecore Social Connected 1.3.1 API
Network Constructor (Identifier, String, String, Uri)
Network Class See Also Send Feedback
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url
)
Visual Basic
Public Sub New ( _
    id As Identifier, _
    name As String, _
    prefix As String, _
    url As Uri _
)
Visual C++
public:
Network(
    Identifier^ id,
    String^ name,
    String^ prefix,
    Uri^ url
)

Parameters

id
Type: Sitecore.Social.Domain.Model..::..Identifier
The id.
name
Type: System..::..String
The name.
prefix
Type: System..::..String
The prefix.
url
Type: System..::..Uri
The URL.

See Also

Network Class
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String, Uri, String)

[image]

Sitecore Social Connected 1.3.1 API
Network Constructor (Identifier, String, String, Uri, String)
Network Class See Also Send Feedback
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon
)
Visual Basic
Public Sub New ( _
    id As Identifier, _
    name As String, _
    prefix As String, _
    url As Uri, _
    icon As String _
)
Visual C++
public:
Network(
    Identifier^ id,
    String^ name,
    String^ prefix,
    Uri^ url,
    String^ icon
)

Parameters

id
Type: Sitecore.Social.Domain.Model..::..Identifier
The id.
name
Type: System..::..String
The name.
prefix
Type: System..::..String
The prefix.
url
Type: System..::..Uri
The URL.
icon
Type: System..::..String
The icon.

See Also

Network Class
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
Network Fields
Network Class See Also Send Feedback

The Network type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the Network class whose value represents not found network.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
Network..::..Empty Field
Network Class See Also Send Feedback
A read-only instance of the Network class whose value represents not found network.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly Network Empty
Visual Basic
Public Shared ReadOnly Empty As Network
Visual C++
public:
static initonly Network^ Empty

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Network Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
Network Properties
Network Class See Also Send Feedback

The Network type exposes the following members.

Properties

 | Name | Description
Public property | Icon | Gets the icon.
Public property | Id | Gets the id.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | Name | Gets the name.
Public property | Prefix | Gets the prefix.
Public property | Url | Gets the URL.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Icon Property

[image]

Sitecore Social Connected 1.3.1 API
Network..::..Icon Property
Network Class See Also Send Feedback
Gets the icon.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Icon { get; private set; }
Visual Basic
Public Property Icon As String
    Get
    Private Set
Visual C++
public:
property String^ Icon {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The icon.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Id Property

[image]

Sitecore Social Connected 1.3.1 API
Network..::..Id Property
Network Class See Also Send Feedback
Gets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier Id { get; private set; }
Visual Basic
Public Property Id As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ Id {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The id.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
Network..::..IsEmpty Property
Network Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IEmptyable..::..IsEmpty

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Name Property

[image]

Sitecore Social Connected 1.3.1 API
Network..::..Name Property
Network Class See Also Send Feedback
Gets the name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The name.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Prefix Property

[image]

Sitecore Social Connected 1.3.1 API
Network..::..Prefix Property
Network Class See Also Send Feedback
Gets the prefix.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Prefix { get; private set; }
Visual Basic
Public Property Prefix As String
    Get
    Private Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The prefix.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


Url Property

[image]

Sitecore Social Connected 1.3.1 API
Network..::..Url Property
Network Class See Also Send Feedback
Gets the URL.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Uri Url { get; private set; }
Visual Basic
Public Property Url As Uri
    Get
    Private Set
Visual C++
public:
property Uri^ Url {
    Uri^ get ();
    private: void set (Uri^ value);
}

Field Value

The URL.

See Also

Network Class
Sitecore.Social.Domain.Model Namespace


NumberCounter Class

[image]

Sitecore Social Connected 1.3.1 API
NumberCounter Class
Members See Also Send Feedback
Represents the statistics number counter.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class NumberCounter : StatisticsCounter
Visual Basic
<SerializableAttribute> _
Public Class NumberCounter _
    Inherits StatisticsCounter
Visual C++
[SerializableAttribute]
public ref class NumberCounter : public StatisticsCounter

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsCounter
Sitecore.Social.Domain.Model..::..NumberCounter
Sitecore.Social.Facebook.Api.Model..::..CommentsCounter
Sitecore.Social.Facebook.Api.Model..::..LikesCounter
Sitecore.Social.Twitter.Api.Model..::..TweetsCounter

See Also

NumberCounter Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics..::..StatisticsCounters


NumberCounter Members

[image] [image]

Sitecore Social Connected 1.3.1 API
NumberCounter Members
NumberCounter Class Constructors Properties See Also Send Feedback

The NumberCounter type exposes the following members.

Constructors

 | Name | Description
Public method | NumberCounter | Initializes a new instance of the NumberCounter class.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value.

See Also

NumberCounter Class
Sitecore.Social.Domain.Model Namespace


NumberCounter Constructor

[image]

Sitecore Social Connected 1.3.1 API
NumberCounter Constructor
NumberCounter Class See Also Send Feedback
Initializes a new instance of the NumberCounter class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public NumberCounter(
    string name,
    int number
)
Visual Basic
Public Sub New ( _
    name As String, _
    number As Integer _
)
Visual C++
public:
NumberCounter(
    String^ name,
    int number
)

Parameters

name
Type: System..::..String
The statistics name.
number
Type: System..::..Int32
The number.

See Also

NumberCounter Class
Sitecore.Social.Domain.Model Namespace


NumberCounter Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
NumberCounter Properties
NumberCounter Class See Also Send Feedback

The NumberCounter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value.

See Also

NumberCounter Class
Sitecore.Social.Domain.Model Namespace


Number Property

[image]

Sitecore Social Connected 1.3.1 API
NumberCounter..::..Number Property
NumberCounter Class See Also Send Feedback
Gets the statistics numerical value.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public int Number { get; private set; }
Visual Basic
Public Property Number As Integer
    Get
    Private Set
Visual C++
public:
property int Number {
    int get ();
    private: void set (int value);
}

Field Value

The number.

See Also

NumberCounter Class
Sitecore.Social.Domain.Model Namespace


PostingConfiguration Class

[image]

Sitecore Social Connected 1.3.1 API
PostingConfiguration Class
Members See Also Send Feedback
Represents an abstract class of posting configurations.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class PostingConfiguration
Visual Basic
<SerializableAttribute> _
Public MustInherit Class PostingConfiguration
Visual C++
[SerializableAttribute]
public ref class PostingConfiguration abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingConfiguration
Sitecore.Social.Domain.Model..::..ContainerPostingConfiguration

See Also

PostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Message..::..PostingConfiguration


PostingConfiguration Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingConfiguration Members
PostingConfiguration Class Constructors See Also Send Feedback

The PostingConfiguration type exposes the following members.

Constructors

 | Name | Description
Protected method | PostingConfiguration | Initializes a new instance of the PostingConfiguration class

See Also

PostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


PostingConfiguration Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingConfiguration Constructor
PostingConfiguration Class See Also Send Feedback
Initializes a new instance of the PostingConfiguration class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected PostingConfiguration()
Visual Basic
Protected Sub New
Visual C++
protected:
PostingConfiguration()

See Also

PostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


PostingPreference Class

[image]

Sitecore Social Connected 1.3.1 API
PostingPreference Class
Members See Also Send Feedback
Represents user's posting preference for the specific message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class PostingPreference
Visual Basic
<SerializableAttribute> _
Public Class PostingPreference
Visual C++
[SerializableAttribute]
public ref class PostingPreference

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingPreference

See Also

PostingPreference Members
Sitecore.Social.Domain.Model Namespace
PostingPreference..::..AutomaticPostingPreference


PostingPreference Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingPreference Members
PostingPreference Class Constructors Properties See Also Send Feedback

The PostingPreference type exposes the following members.

Constructors

 | Name | Description
Public method | PostingPreference | Initializes a new instance of the PostingPreference class.

Properties

 | Name | Description
Public property | AutomaticPostingPreference | Gets the automatic posting preference.
Public property | MessageId | Gets the message id.
Public property | User | Gets the user.

See Also

PostingPreference Class
Sitecore.Social.Domain.Model Namespace


PostingPreference Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingPreference Constructor
PostingPreference Class See Also Send Feedback
Initializes a new instance of the PostingPreference class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public PostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Visual Basic
Public Sub New ( _
    user As IPrincipal, _
    messageId As Identifier, _
    automaticPostingPreference As AutomaticPostingPreference _
)
Visual C++
public:
PostingPreference(
    IPrincipal^ user,
    Identifier^ messageId,
    AutomaticPostingPreference automaticPostingPreference
)

Parameters

user
Type: System.Security.Principal..::..IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model..::..Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model..::..AutomaticPostingPreference
The automatic posting preference.

See Also

PostingPreference Class
Sitecore.Social.Domain.Model Namespace


PostingPreference Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingPreference Properties
PostingPreference Class See Also Send Feedback

The PostingPreference type exposes the following members.

Properties

 | Name | Description
Public property | AutomaticPostingPreference | Gets the automatic posting preference.
Public property | MessageId | Gets the message id.
Public property | User | Gets the user.

See Also

PostingPreference Class
Sitecore.Social.Domain.Model Namespace


AutomaticPostingPreference Property

[image]

Sitecore Social Connected 1.3.1 API
PostingPreference..::..AutomaticPostingPreference Property
PostingPreference Class See Also Send Feedback
Gets the automatic posting preference.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AutomaticPostingPreference AutomaticPostingPreference { get; private set; }
Visual Basic
Public Property AutomaticPostingPreference As AutomaticPostingPreference
    Get
    Private Set
Visual C++
public:
property AutomaticPostingPreference AutomaticPostingPreference {
    AutomaticPostingPreference get ();
    private: void set (AutomaticPostingPreference value);
}

Field Value

The automatic posting preference.

See Also

PostingPreference Class
Sitecore.Social.Domain.Model Namespace


MessageId Property

[image]

Sitecore Social Connected 1.3.1 API
PostingPreference..::..MessageId Property
PostingPreference Class See Also Send Feedback
Gets the message id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public Identifier MessageId { get; private set; }
Visual Basic
Public Property MessageId As Identifier
    Get
    Private Set
Visual C++
public:
property Identifier^ MessageId {
    Identifier^ get ();
    private: void set (Identifier^ value);
}

Field Value

The message id.

See Also

PostingPreference Class
Sitecore.Social.Domain.Model Namespace


User Property

[image]

Sitecore Social Connected 1.3.1 API
PostingPreference..::..User Property
PostingPreference Class See Also Send Feedback
Gets the user.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IPrincipal User { get; private set; }
Visual Basic
Public Property User As IPrincipal
    Get
    Private Set
Visual C++
public:
property IPrincipal^ User {
    IPrincipal^ get ();
    private: void set (IPrincipal^ value);
}

Field Value

The user.

See Also

PostingPreference Class
Sitecore.Social.Domain.Model Namespace


PostingStatus Class

[image]

Sitecore Social Connected 1.3.1 API
PostingStatus Class
Members See Also Send Feedback
Represents an abstract class of message's account posting statuses.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class PostingStatus
Visual Basic
<SerializableAttribute> _
Public MustInherit Class PostingStatus
Visual C++
[SerializableAttribute]
public ref class PostingStatus abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..PostingStatus
Sitecore.Social.Domain.Model..::..DonePostingStatus
Sitecore.Social.Domain.Model..::..FailedPostingStatus

See Also

PostingStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatus..::..PostingStatus


PostingStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingStatus Members
PostingStatus Class Constructors See Also Send Feedback

The PostingStatus type exposes the following members.

Constructors

 | Name | Description
Protected method | PostingStatus | Initializes a new instance of the PostingStatus class

See Also

PostingStatus Class
Sitecore.Social.Domain.Model Namespace


PostingStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingStatus Constructor
PostingStatus Class See Also Send Feedback
Initializes a new instance of the PostingStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected PostingStatus()
Visual Basic
Protected Sub New
Visual C++
protected:
PostingStatus()

See Also

PostingStatus Class
Sitecore.Social.Domain.Model Namespace


SocialProfile Class

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile Class
Members See Also Send Feedback
Represents a social profile.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class SocialProfile : IEmptyable
Visual Basic
<SerializableAttribute> _
Public Class SocialProfile _
    Implements IEmptyable
Visual C++
[SerializableAttribute]
public ref class SocialProfile : IEmptyable

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..SocialProfile

See Also

SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile Members

[image] [image]

Sitecore Social Connected 1.3.1 API
SocialProfile Members
SocialProfile Class Constructors Fields Properties See Also Send Feedback

The SocialProfile type exposes the following members.

Constructors

 | Name | Description
Public method | SocialProfile | Initializes a new instance of the SocialProfile class

Fields

Name | Description
Empty | A read-only instance of the SocialProfile class whose value represents not found social profile.

Properties

 | Name | Description
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Email | Gets or sets an email address.
Public property | Fields | Gets or sets profile fields.
Public property | FullName | Gets or sets a full name.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | NetworkAccountId | Gets or sets a network account id.
Public property | NetworkName | Gets or sets a network name.
Public property | User | Gets or sets the user.

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile Constructor

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile Constructor
SocialProfile Class See Also Send Feedback
Initializes a new instance of the SocialProfile class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public SocialProfile()
Visual Basic
Public Sub New
Visual C++
public:
SocialProfile()

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile Fields

[image] [image]

Sitecore Social Connected 1.3.1 API
SocialProfile Fields
SocialProfile Class See Also Send Feedback

The SocialProfile type exposes the following members.

Fields

Name | Description
Empty | A read-only instance of the SocialProfile class whose value represents not found social profile.

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


Empty Field

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..Empty Field
SocialProfile Class See Also Send Feedback
A read-only instance of the SocialProfile class whose value represents not found social profile.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public static readonly SocialProfile Empty
Visual Basic
Public Shared ReadOnly Empty As SocialProfile
Visual C++
public:
static initonly SocialProfile^ Empty

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
SocialProfile Properties
SocialProfile Class See Also Send Feedback

The SocialProfile type exposes the following members.

Properties

 | Name | Description
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Email | Gets or sets an email address.
Public property | Fields | Gets or sets profile fields.
Public property | FullName | Gets or sets a full name.
Public property | IsEmpty | Returns Boolean value indicating if the specified instance is empty.
Public property | NetworkAccountId | Gets or sets a network account id.
Public property | NetworkName | Gets or sets a network name.
Public property | User | Gets or sets the user.

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..AccountCredentials Property
SocialProfile Class See Also Send Feedback
Gets or sets account credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public AccountCredentials AccountCredentials { get; set; }
Visual Basic
Public Property AccountCredentials As AccountCredentials
    Get
    Set
Visual C++
public:
property AccountCredentials^ AccountCredentials {
    AccountCredentials^ get ();
    void set (AccountCredentials^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..ApplicationCredentials Property
SocialProfile Class See Also Send Feedback
Gets or sets application credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ApplicationCredentials ApplicationCredentials { get; set; }
Visual Basic
Public Property ApplicationCredentials As ApplicationCredentials
    Get
    Set
Visual C++
public:
property ApplicationCredentials^ ApplicationCredentials {
    ApplicationCredentials^ get ();
    void set (ApplicationCredentials^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


Email Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..Email Property
SocialProfile Class See Also Send Feedback
Gets or sets an email address.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


Fields Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..Fields Property
SocialProfile Class See Also Send Feedback
Gets or sets profile fields.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IDictionary<string, string> Fields { get; set; }
Visual Basic
Public Property Fields As IDictionary(Of String, String)
    Get
    Set
Visual C++
public:
property IDictionary<String^, String^>^ Fields {
    IDictionary<String^, String^>^ get ();
    void set (IDictionary<String^, String^>^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


FullName Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..FullName Property
SocialProfile Class See Also Send Feedback
Gets or sets a full name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string FullName { get; set; }
Visual Basic
Public Property FullName As String
    Get
    Set
Visual C++
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


IsEmpty Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..IsEmpty Property
SocialProfile Class See Also Send Feedback
Returns Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Implements

IEmptyable..::..IsEmpty

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


NetworkAccountId Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..NetworkAccountId Property
SocialProfile Class See Also Send Feedback
Gets or sets a network account id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string NetworkAccountId { get; set; }
Visual Basic
Public Property NetworkAccountId As String
    Get
    Set
Visual C++
public:
property String^ NetworkAccountId {
    String^ get ();
    void set (String^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


NetworkName Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..NetworkName Property
SocialProfile Class See Also Send Feedback
Gets or sets a network name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string NetworkName { get; set; }
Visual Basic
Public Property NetworkName As String
    Get
    Set
Visual C++
public:
property String^ NetworkName {
    String^ get ();
    void set (String^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


User Property

[image]

Sitecore Social Connected 1.3.1 API
SocialProfile..::..User Property
SocialProfile Class See Also Send Feedback
Gets or sets the user.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public IPrincipal User { get; set; }
Visual Basic
Public Property User As IPrincipal
    Get
    Set
Visual C++
public:
property IPrincipal^ User {
    IPrincipal^ get ();
    void set (IPrincipal^ value);
}

See Also

SocialProfile Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Class

[image]

Sitecore Social Connected 1.3.1 API
StatisticsCounter Class
Members See Also Send Feedback
Represents the statistics counter.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class StatisticsCounter
Visual Basic
<SerializableAttribute> _
Public MustInherit Class StatisticsCounter
Visual C++
[SerializableAttribute]
public ref class StatisticsCounter abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsCounter
Sitecore.Social.Domain.Model..::..NumberCounter

See Also

StatisticsCounter Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics..::..StatisticsCounters


StatisticsCounter Members

[image] [image]

Sitecore Social Connected 1.3.1 API
StatisticsCounter Members
StatisticsCounter Class Constructors Properties See Also Send Feedback

The StatisticsCounter type exposes the following members.

Constructors

 | Name | Description
Protected method | StatisticsCounter | Initializes a new instance of the StatisticsCounter class.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name.

See Also

StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Constructor

[image]

Sitecore Social Connected 1.3.1 API
StatisticsCounter Constructor
StatisticsCounter Class See Also Send Feedback
Initializes a new instance of the StatisticsCounter class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected StatisticsCounter(
    string name
)
Visual Basic
Protected Sub New ( _
    name As String _
)
Visual C++
protected:
StatisticsCounter(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
StatisticsCounter Properties
StatisticsCounter Class See Also Send Feedback

The StatisticsCounter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name.

See Also

StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


Name Property

[image]

Sitecore Social Connected 1.3.1 API
StatisticsCounter..::..Name Property
StatisticsCounter Class See Also Send Feedback
Gets the statistics counter name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The statistics counter name.

See Also

StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


StatisticsStatus Class

[image]

Sitecore Social Connected 1.3.1 API
StatisticsStatus Class
Members See Also Send Feedback
Represents a statistics status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class StatisticsStatus
Visual Basic
<SerializableAttribute> _
Public MustInherit Class StatisticsStatus
Visual C++
[SerializableAttribute]
public ref class StatisticsStatus abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsStatus
Sitecore.Social.Domain.Model..::..FailedStatisticsStatus
Sitecore.Social.Domain.Model..::..UpdatedStatisticsStatus

See Also

StatisticsStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics..::..StatisticsStatus


StatisticsStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
StatisticsStatus Members
StatisticsStatus Class Constructors See Also Send Feedback

The StatisticsStatus type exposes the following members.

Constructors

 | Name | Description
Protected method | StatisticsStatus | Initializes a new instance of the StatisticsStatus class

See Also

StatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


StatisticsStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
StatisticsStatus Constructor
StatisticsStatus Class See Also Send Feedback
Initializes a new instance of the StatisticsStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected StatisticsStatus()
Visual Basic
Protected Sub New
Visual C++
protected:
StatisticsStatus()

See Also

StatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


UpdatedStatisticsStatus Class

[image]

Sitecore Social Connected 1.3.1 API
UpdatedStatisticsStatus Class
Members See Also Send Feedback
Represents an updated statistics status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class UpdatedStatisticsStatus : StatisticsStatus
Visual Basic
<SerializableAttribute> _
Public Class UpdatedStatisticsStatus _
    Inherits StatisticsStatus
Visual C++
[SerializableAttribute]
public ref class UpdatedStatisticsStatus : public StatisticsStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsStatus
Sitecore.Social.Domain.Model..::..UpdatedStatisticsStatus

See Also

UpdatedStatisticsStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics..::..StatisticsStatus


UpdatedStatisticsStatus Members

[image] [image]

Sitecore Social Connected 1.3.1 API
UpdatedStatisticsStatus Members
UpdatedStatisticsStatus Class Constructors See Also Send Feedback

The UpdatedStatisticsStatus type exposes the following members.

Constructors

 | Name | Description
Public method | UpdatedStatisticsStatus | Initializes a new instance of the UpdatedStatisticsStatus class

See Also

UpdatedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


UpdatedStatisticsStatus Constructor

[image]

Sitecore Social Connected 1.3.1 API
UpdatedStatisticsStatus Constructor
UpdatedStatisticsStatus Class See Also Send Feedback
Initializes a new instance of the UpdatedStatisticsStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public UpdatedStatisticsStatus()
Visual Basic
Public Sub New
Visual C++
public:
UpdatedStatisticsStatus()

See Also

UpdatedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


Sitecore.Social.Domain.SearchArgs Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Domain.SearchArgs Namespace
Send Feedback
Provides classes that represent the domain's search arguments.

Classes

 | Class | Description
Public class | ContainerPostingConfigurationSearchArgs | Represents an abstract class of search by container posting configuration arguments.
Public class | ContentPostingConfigurationSearchArgs | Represents search by content posting configuration arguments.
Public class | GoalPostingConfigurationSearchArgs | Represents search by goal posting configuration arguments.
Public class | PostingConfigurationSearchArgs | Represents an abstract class of search by posting configuration arguments.


ContainerPostingConfigurationSearchArgs Class

[image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfigurationSearchArgs Class
Members See Also Send Feedback
Represents an abstract class of search by container posting configuration arguments.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class ContainerPostingConfigurationSearchArgs : PostingConfigurationSearchArgs
Visual Basic
<SerializableAttribute> _
Public MustInherit Class ContainerPostingConfigurationSearchArgs _
    Inherits PostingConfigurationSearchArgs
Visual C++
[SerializableAttribute]
public ref class ContainerPostingConfigurationSearchArgs abstract : public PostingConfigurationSearchArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..ContainerPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..ContentPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..GoalPostingConfigurationSearchArgs

See Also

ContainerPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager..::..GetMessages(PostingConfigurationSearchArgs)


ContainerPostingConfigurationSearchArgs Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfigurationSearchArgs Members
ContainerPostingConfigurationSearchArgs Class Constructors Properties See Also Send Feedback

The ContainerPostingConfigurationSearchArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | ContainerPostingConfigurationSearchArgs | Initializes a new instance of the ContainerPostingConfigurationSearchArgs class.

Properties

 | Name | Description
Public property | Container | Gets the container.

See Also

ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContainerPostingConfigurationSearchArgs Constructor

[image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfigurationSearchArgs Constructor
ContainerPostingConfigurationSearchArgs Class See Also Send Feedback
Initializes a new instance of the ContainerPostingConfigurationSearchArgs class.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected ContainerPostingConfigurationSearchArgs(
    string container
)
Visual Basic
Protected Sub New ( _
    container As String _
)
Visual C++
protected:
ContainerPostingConfigurationSearchArgs(
    String^ container
)

Parameters

container
Type: System..::..String
The container.

See Also

ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContainerPostingConfigurationSearchArgs Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfigurationSearchArgs Properties
ContainerPostingConfigurationSearchArgs Class See Also Send Feedback

The ContainerPostingConfigurationSearchArgs type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container.

See Also

ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


Container Property

[image]

Sitecore Social Connected 1.3.1 API
ContainerPostingConfigurationSearchArgs..::..Container Property
ContainerPostingConfigurationSearchArgs Class See Also Send Feedback
Gets the container.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string Container { get; private set; }
Visual Basic
Public Property Container As String
    Get
    Private Set
Visual C++
public:
property String^ Container {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The container.

See Also

ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Class

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfigurationSearchArgs Class
Members See Also Send Feedback
Represents search by content posting configuration arguments.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class ContentPostingConfigurationSearchArgs : ContainerPostingConfigurationSearchArgs
Visual Basic
<SerializableAttribute> _
Public Class ContentPostingConfigurationSearchArgs _
    Inherits ContainerPostingConfigurationSearchArgs
Visual C++
[SerializableAttribute]
public ref class ContentPostingConfigurationSearchArgs : public ContainerPostingConfigurationSearchArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..ContainerPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..ContentPostingConfigurationSearchArgs

See Also

ContentPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager..::..GetMessages(PostingConfigurationSearchArgs)


ContentPostingConfigurationSearchArgs Members

[image] [image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfigurationSearchArgs Members
ContentPostingConfigurationSearchArgs Class Constructors Properties See Also Send Feedback

The ContentPostingConfigurationSearchArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ContentPostingConfigurationSearchArgs | Initializes a new instance of the ContentPostingConfigurationSearchArgs class.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)

See Also

ContentPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Constructor

[image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfigurationSearchArgs Constructor
ContentPostingConfigurationSearchArgs Class See Also Send Feedback
Initializes a new instance of the ContentPostingConfigurationSearchArgs class.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public ContentPostingConfigurationSearchArgs(
    string contentContainer
)
Visual Basic
Public Sub New ( _
    contentContainer As String _
)
Visual C++
public:
ContentPostingConfigurationSearchArgs(
    String^ contentContainer
)

Parameters

contentContainer
Type: System..::..String
The content container.

See Also

ContentPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
ContentPostingConfigurationSearchArgs Properties
ContentPostingConfigurationSearchArgs Class See Also Send Feedback

The ContentPostingConfigurationSearchArgs type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)

See Also

ContentPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Class

[image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfigurationSearchArgs Class
Members See Also Send Feedback
Represents search by goal posting configuration arguments.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class GoalPostingConfigurationSearchArgs : ContainerPostingConfigurationSearchArgs
Visual Basic
<SerializableAttribute> _
Public Class GoalPostingConfigurationSearchArgs _
    Inherits ContainerPostingConfigurationSearchArgs
Visual C++
[SerializableAttribute]
public ref class GoalPostingConfigurationSearchArgs : public ContainerPostingConfigurationSearchArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..ContainerPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..GoalPostingConfigurationSearchArgs

See Also

GoalPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager..::..GetMessages(PostingConfigurationSearchArgs)


GoalPostingConfigurationSearchArgs Members

[image] [image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfigurationSearchArgs Members
GoalPostingConfigurationSearchArgs Class Constructors Properties See Also Send Feedback

The GoalPostingConfigurationSearchArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GoalPostingConfigurationSearchArgs | Initializes a new instance of the GoalPostingConfigurationSearchArgs class.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)

See Also

GoalPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Constructor

[image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfigurationSearchArgs Constructor
GoalPostingConfigurationSearchArgs Class See Also Send Feedback
Initializes a new instance of the GoalPostingConfigurationSearchArgs class.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public GoalPostingConfigurationSearchArgs(
    string goalContainer
)
Visual Basic
Public Sub New ( _
    goalContainer As String _
)
Visual C++
public:
GoalPostingConfigurationSearchArgs(
    String^ goalContainer
)

Parameters

goalContainer
Type: System..::..String
The goal container.

See Also

GoalPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
GoalPostingConfigurationSearchArgs Properties
GoalPostingConfigurationSearchArgs Class See Also Send Feedback

The GoalPostingConfigurationSearchArgs type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)

See Also

GoalPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


PostingConfigurationSearchArgs Class

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgs Class
Members See Also Send Feedback
Represents an abstract class of search by posting configuration arguments.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public abstract class PostingConfigurationSearchArgs
Visual Basic
<SerializableAttribute> _
Public MustInherit Class PostingConfigurationSearchArgs
Visual C++
[SerializableAttribute]
public ref class PostingConfigurationSearchArgs abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.SearchArgs..::..PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs..::..ContainerPostingConfigurationSearchArgs

See Also

PostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager..::..GetMessages(PostingConfigurationSearchArgs)


PostingConfigurationSearchArgs Members

[image] [image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgs Members
PostingConfigurationSearchArgs Class Constructors See Also Send Feedback

The PostingConfigurationSearchArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | PostingConfigurationSearchArgs | Initializes a new instance of the PostingConfigurationSearchArgs class

See Also

PostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


PostingConfigurationSearchArgs Constructor

[image]

Sitecore Social Connected 1.3.1 API
PostingConfigurationSearchArgs Constructor
PostingConfigurationSearchArgs Class See Also Send Feedback
Initializes a new instance of the PostingConfigurationSearchArgs class

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
protected PostingConfigurationSearchArgs()
Visual Basic
Protected Sub New
Visual C++
protected:
PostingConfigurationSearchArgs()

See Also

PostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


Sitecore.Social.Facebook.Api.Model Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Facebook.Api.Model Namespace
Send Feedback
Provides classes that extend domain's model with Facebook specific entities.

Classes

 | Class | Description
Public class | CommentsCounter | Represents the comments counter.
Public class | FacebookMessageData | Represents Facebook message data.
Public class | LikesCounter | Represents the likes counter


CommentsCounter Class

[image]

Sitecore Social Connected 1.3.1 API
CommentsCounter Class
Members See Also Send Feedback
Represents the comments counter.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class CommentsCounter : NumberCounter
Visual Basic
<SerializableAttribute> _
Public Class CommentsCounter _
    Inherits NumberCounter
Visual C++
[SerializableAttribute]
public ref class CommentsCounter : public NumberCounter

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsCounter
Sitecore.Social.Domain.Model..::..NumberCounter
Sitecore.Social.Facebook.Api.Model..::..CommentsCounter

See Also

CommentsCounter Members
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Members

[image] [image]

Sitecore Social Connected 1.3.1 API
CommentsCounter Members
CommentsCounter Class Constructors Properties See Also Send Feedback

The CommentsCounter type exposes the following members.

Constructors

 | Name | Description
Public method | CommentsCounter | Initializes a new instance of the CommentsCounter class.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)

See Also

CommentsCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Constructor

[image]

Sitecore Social Connected 1.3.1 API
CommentsCounter Constructor
CommentsCounter Class See Also Send Feedback
Initializes a new instance of the CommentsCounter class.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public CommentsCounter(
    int number
)
Visual Basic
Public Sub New ( _
    number As Integer _
)
Visual C++
public:
CommentsCounter(
    int number
)

Parameters

number
Type: System..::..Int32
The number.

See Also

CommentsCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
CommentsCounter Properties
CommentsCounter Class See Also Send Feedback

The CommentsCounter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)

See Also

CommentsCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Class

[image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData Class
Members See Also Send Feedback
Represents Facebook message data.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class FacebookMessageData : MessageData
Visual Basic
<SerializableAttribute> _
Public Class FacebookMessageData _
    Inherits MessageData
Visual C++
[SerializableAttribute]
public ref class FacebookMessageData : public MessageData

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..MessageData
Sitecore.Social.Facebook.Api.Model..::..FacebookMessageData

See Also

FacebookMessageData Members
Sitecore.Social.Facebook.Api.Model Namespace
Message..::..MessageData


FacebookMessageData Members

[image] [image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData Members
FacebookMessageData Class Constructors Properties See Also Send Feedback

The FacebookMessageData type exposes the following members.

Constructors

 | Name | Description
Public method | FacebookMessageData | Initializes a new instance of the FacebookMessageData class

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | LinkDescription | Gets or sets the link description.
Public property | LinkImage | Gets or sets the link image.
Public property | LinkTitle | Gets or sets the link title.
Public property | Text | Gets or sets the text. (Inherited from MessageData.)

See Also

FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Constructor

[image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData Constructor
FacebookMessageData Class See Also Send Feedback
Initializes a new instance of the FacebookMessageData class

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public FacebookMessageData()
Visual Basic
Public Sub New
Visual C++
public:
FacebookMessageData()

See Also

FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData Properties
FacebookMessageData Class See Also Send Feedback

The FacebookMessageData type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | LinkDescription | Gets or sets the link description.
Public property | LinkImage | Gets or sets the link image.
Public property | LinkTitle | Gets or sets the link title.
Public property | Text | Gets or sets the text. (Inherited from MessageData.)

See Also

FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


LinkDescription Property

[image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData..::..LinkDescription Property
FacebookMessageData Class See Also Send Feedback
Gets or sets the link description.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string LinkDescription { get; set; }
Visual Basic
Public Property LinkDescription As String
    Get
    Set
Visual C++
public:
property String^ LinkDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

The link description.

See Also

FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


LinkImage Property

[image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData..::..LinkImage Property
FacebookMessageData Class See Also Send Feedback
Gets or sets the link image.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string LinkImage { get; set; }
Visual Basic
Public Property LinkImage As String
    Get
    Set
Visual C++
public:
property String^ LinkImage {
    String^ get ();
    void set (String^ value);
}

Field Value

The link image.

See Also

FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


LinkTitle Property

[image]

Sitecore Social Connected 1.3.1 API
FacebookMessageData..::..LinkTitle Property
FacebookMessageData Class See Also Send Feedback
Gets or sets the link title.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public string LinkTitle { get; set; }
Visual Basic
Public Property LinkTitle As String
    Get
    Set
Visual C++
public:
property String^ LinkTitle {
    String^ get ();
    void set (String^ value);
}

Field Value

The link title.

See Also

FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Class

[image]

Sitecore Social Connected 1.3.1 API
LikesCounter Class
Members See Also Send Feedback
Represents the likes counter

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class LikesCounter : NumberCounter
Visual Basic
<SerializableAttribute> _
Public Class LikesCounter _
    Inherits NumberCounter
Visual C++
[SerializableAttribute]
public ref class LikesCounter : public NumberCounter

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsCounter
Sitecore.Social.Domain.Model..::..NumberCounter
Sitecore.Social.Facebook.Api.Model..::..LikesCounter

See Also

LikesCounter Members
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Members

[image] [image]

Sitecore Social Connected 1.3.1 API
LikesCounter Members
LikesCounter Class Constructors Properties See Also Send Feedback

The LikesCounter type exposes the following members.

Constructors

 | Name | Description
Public method | LikesCounter | Initializes a new instance of the LikesCounter class.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)

See Also

LikesCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Constructor

[image]

Sitecore Social Connected 1.3.1 API
LikesCounter Constructor
LikesCounter Class See Also Send Feedback
Initializes a new instance of the LikesCounter class.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public LikesCounter(
    int number
)
Visual Basic
Public Sub New ( _
    number As Integer _
)
Visual C++
public:
LikesCounter(
    int number
)

Parameters

number
Type: System..::..Int32
The number.

See Also

LikesCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
LikesCounter Properties
LikesCounter Class See Also Send Feedback

The LikesCounter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)

See Also

LikesCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


Sitecore.Social.Twitter.Api.Model Namespace

[image]

Sitecore Social Connected 1.3.1 API
Sitecore.Social.Twitter.Api.Model Namespace
Send Feedback
Provides classes that extend domain's model with Twitter specific entities.

Classes

 | Class | Description
Public class | TweetsCounter | Represents the tweets counter
Public class | TwitterMessageData | Represents Twitter message data.


TweetsCounter Class

[image]

Sitecore Social Connected 1.3.1 API
TweetsCounter Class
Members See Also Send Feedback
Represents the tweets counter

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class TweetsCounter : NumberCounter
Visual Basic
<SerializableAttribute> _
Public Class TweetsCounter _
    Inherits NumberCounter
Visual C++
[SerializableAttribute]
public ref class TweetsCounter : public NumberCounter

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..StatisticsCounter
Sitecore.Social.Domain.Model..::..NumberCounter
Sitecore.Social.Twitter.Api.Model..::..TweetsCounter

See Also

TweetsCounter Members
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Members

[image] [image]

Sitecore Social Connected 1.3.1 API
TweetsCounter Members
TweetsCounter Class Constructors Properties See Also Send Feedback

The TweetsCounter type exposes the following members.

Constructors

 | Name | Description
Public method | TweetsCounter | Initializes a new instance of the TweetsCounter class.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)

See Also

TweetsCounter Class
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Constructor

[image]

Sitecore Social Connected 1.3.1 API
TweetsCounter Constructor
TweetsCounter Class See Also Send Feedback
Initializes a new instance of the TweetsCounter class.

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public TweetsCounter(
    int number
)
Visual Basic
Public Sub New ( _
    number As Integer _
)
Visual C++
public:
TweetsCounter(
    int number
)

Parameters

number
Type: System..::..Int32
The number.

See Also

TweetsCounter Class
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
TweetsCounter Properties
TweetsCounter Class See Also Send Feedback

The TweetsCounter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)

See Also

TweetsCounter Class
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Class

[image]

Sitecore Social Connected 1.3.1 API
TwitterMessageData Class
Members See Also Send Feedback
Represents Twitter message data.

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
[SerializableAttribute]
public class TwitterMessageData : MessageData
Visual Basic
<SerializableAttribute> _
Public Class TwitterMessageData _
    Inherits MessageData
Visual C++
[SerializableAttribute]
public ref class TwitterMessageData : public MessageData

Inheritance Hierarchy

System..::..Object
Sitecore.Social.Domain.Model..::..MessageData
Sitecore.Social.Twitter.Api.Model..::..TwitterMessageData

See Also

TwitterMessageData Members
Sitecore.Social.Twitter.Api.Model Namespace
Message..::..MessageData


TwitterMessageData Members

[image] [image]

Sitecore Social Connected 1.3.1 API
TwitterMessageData Members
TwitterMessageData Class Constructors Properties See Also Send Feedback

The TwitterMessageData type exposes the following members.

Constructors

 | Name | Description
Public method | TwitterMessageData | Initializes a new instance of the TwitterMessageData class

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)

See Also

TwitterMessageData Class
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Constructor

[image]

Sitecore Social Connected 1.3.1 API
TwitterMessageData Constructor
TwitterMessageData Class See Also Send Feedback
Initializes a new instance of the TwitterMessageData class

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 1.3.1.0 (1.3.1.0)

Syntax

C#
public TwitterMessageData()
Visual Basic
Public Sub New
Visual C++
public:
TwitterMessageData()

See Also

TwitterMessageData Class
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Properties

[image] [image]

Sitecore Social Connected 1.3.1 API
TwitterMessageData Properties
TwitterMessageData Class See Also Send Feedback

The TwitterMessageData type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)

See Also

TwitterMessageData Class
Sitecore.Social.Twitter.Api.Model Namespace