Sitecore Social Connected

Sitecore Social Connected Sitecore Social Connected 2.0 API
You can perform the following actions using Sitecore Social Connected API:
  • Manage social networks, applications and accounts.
  • Retrieve and manage social profiles. Configure posting preferences.
  • Create and post messages, gather message statistics.
  • Retrieve comments for posted messages.
  • Post messages directly to a social network.
  • Log in users with social networks credentials. Attach social profiles to existing users.
  • Receive account credentials and data from a social network.
Namespaces
Namespace | Description
Sitecore.Social.Api | Provides classes that allow managing entities defined in the domain's model.
Sitecore.Social.Api.Extensions | Provides a set of extension classes.
Sitecore.Social.BusinessLogic.Exceptions | Provides a set of custom exception classes.
Sitecore.Social.Client.Api | Provides classes that allow managing presentation layer actions (log in, requests to social networks, etc).
Sitecore.Social.Client.Domain | Provides a set of classes that extends domain's model.
Sitecore.Social.Client.Domain.Requests | Provides classes that contain requests.
Sitecore.Social.Client.Domain.Responses | Provides classes that contain responses.
Sitecore.Social.Configuration | Provides classes that allow reading the configuration.
Sitecore.Social.Configuration.Model | Provides classes that represent root configuration settings.
Sitecore.Social.Configuration.Model.Api | Provides classes that represent "socialApi" configuration settings
Sitecore.Social.Configuration.Model.GenderRule | Provides classes that represent "socialGenderRule" settings.
Sitecore.Social.Configuration.Model.InterestedInRule | Provides classes that represent "interestedInRule" settings.
Sitecore.Social.Configuration.Model.Networks | Provides classes that represent "network" settings.
Sitecore.Social.Configuration.Model.PostingConfigurations | Provides classes that represent the "postingConfigurations" settings.
Sitecore.Social.Configuration.Model.ProfileKeyMappings | Provides classes that represent the "socialProfileKeyMappings" settings.
Sitecore.Social.Domain | Provides classes that represent the domain.
Sitecore.Social.Domain.Exceptions | Provides classes that represent the domain exceptions.
Sitecore.Social.Domain.Model | Provides classes that represent the domain's model.
Sitecore.Social.Domain.SearchArgs | Provides classes that contain the domain's search arguments.
Sitecore.Social.Facebook.Api.Model | Provides classes that extend domain's model with Facebook specific entities.
Sitecore.Social.Facebook.Configuration | Provides classes that allow reading the Facebook specific configuration.
Sitecore.Social.GooglePlus.Configuration | Provides classes that allow reading the Google+ specific configuration
Sitecore.Social.Infrastructure | Provides the infrastructure classes.
Sitecore.Social.Infrastructure.Exceptions | Provides classes that represent the infrastructure exceptions.
Sitecore.Social.Infrastructure.Extensions | Provides a set of extension classes.
Sitecore.Social.Infrastructure.Identifiers | Provides a set of identifier classes.
Sitecore.Social.Infrastructure.Utils | Provides classes that represent the infrastructure utilities.
Sitecore.Social.SocialMarketer.Api.Model | Provides the classes that extend domain model with the specific entities of Social Marketer network.
Sitecore.Social.Twitter.Api.Model | Provides classes that extend domain's model with Twitter specific entities.
Sitecore.Social.Twitter.Configuration | Provides classes that allow read the Twitter specific configuration.

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore

Send Feedback on this topic to dv@sitecore.net.


Sitecore.Social.Api Namespace

Sitecore.Social.Api Namespace Sitecore Social Connected 2.0 API
Provides classes that allow managing entities defined in the domain's model.
Classes
 | Class | Description
Public class | AccountManager | Defines the methods that are used to get and create social accounts.
Public class | ApplicationManager | Defines the methods that are used to manage social network applications.
Public class | MessageManager | Defines the methods that are used to manage social network messages.
Public class | MessageStatisticsManager | Defines the methods that are used to manage social network message statistics.
Public class | NetworkManager | Defines the methods that are used to manage social networks.
Public class | PostingPreferenceManager | Defines the methods that are used to manage user’s posting preferences.
Public class | SocialProfileManager | Defines the methods that are used to manage a social profile.


AccountManager Class

AccountManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to get and create social accounts.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api AccountManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AccountManager : IAccountManager
public class AccountManager : IAccountManager
See Also
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager Members

AccountManager Members Sitecore Social Connected 2.0 API

The AccountManager type exposes the following members.
Constructors
 | Name | Description
Public method | AccountManager | Initializes a new instance of the AccountManager class.
Public method | AccountManager(INetworkManager, IAccountBusinessManager) | Initializes a new instance of the AccountManager class.
Back to Top
Methods
 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.
Public method | GetAccountsByContainer | Gets the accounts by container.
Public method | GetDaysUntilRenewalRequired | Gets the number of days before the required renewal of an account.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier) | Gets an account display name in a social network.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String) | Gets an account display name in a social network.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountManager Class
Sitecore.Social.Api Namespace


AccountManager Constructor

AccountManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | AccountManager | Initializes a new instance of the AccountManager class.
Public method | AccountManager(INetworkManager, IAccountBusinessManager) | Initializes a new instance of the AccountManager class.
Back to Top
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager Constructor

AccountManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountManager()
public AccountManager()
See Also
AccountManager Class
AccountManager Members
AccountManager Overload
Sitecore.Social.Api Namespace


AccountManager Constructor (INetworkManager, )

AccountManager Constructor (INetworkManager, ) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountManager(
    INetworkManager networkManager,
    IAccountBusinessManager accountBusinessManager
)
public AccountManager(
    INetworkManager networkManager,
    IAccountBusinessManager accountBusinessManager
)
Parameters
networkManager
Type: Sitecore.Social.Domain INetworkManager
The network manager.
accountBusinessManager
Type: IAccountBusinessManager
The account business manager.
See Also
AccountManager Class
AccountManager Members
AccountManager Overload
Sitecore.Social.Api Namespace


AccountManager Methods

AccountManager Methods Sitecore Social Connected 2.0 API
The AccountManager type exposes the following members.
Methods
 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.
Public method | GetAccountsByContainer | Gets the accounts by container.
Public method | GetDaysUntilRenewalRequired | Gets the number of days before the required renewal of an account.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier) | Gets an account display name in a social network.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String) | Gets an account display name in a social network.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountManager Class
Sitecore.Social.Api Namespace


AccountManager.CreateAccount Method

AccountManager CreateAccount Method Sitecore Social Connected 2.0 API
Creates an account.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CreateAccount(
    Account account
)
public void CreateAccount(
    Account account
)
Parameters
account
Type: Sitecore.Social.Domain.Model Account
The account to create.
Implements
IAccountManager CreateAccount(Account)
Exceptions
Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions AccountContainerIsNotFoundException | Account container is not found.
Sitecore.Social.BusinessLogic.Exceptions CannotReadAccountException | Account was created, but could not be read.
Remarks
The Id field will contain identifier of the new account.
Examples
View Colorized Copy to Clipboard Print
var facebookAccount = new NetworkAccount
{
  ApplicationId = facebookApplicationId,
  Name = "John Smith",
  AccountCredentials = new AccountCredentials
  {
    AccessToken = "sldkfgj23423-===12",
    AccessTokenSecret = "12312kkwerkqw"
  },
  AccountContainer = "/sitecore/system/social/accounts",
  LastRenewalDate = DateTime.Now,
  Description = "Facebook wall of John Smith",
  MessageLanguage = "English",
  ReviewingWorkflowId = socialMessageWorkflowId
};

facebookAccount.ReviewingRoles.Add(@"sitecore\Facebook Message Reviewer");

accountManager.CreateAccount(facebookAccount);

this.ShowAccount(facebookAccount);
var facebookAccount = new NetworkAccount
{
  ApplicationId = facebookApplicationId,
  Name = "John Smith",
  AccountCredentials = new AccountCredentials
  {
    AccessToken = "sldkfgj23423-===12",
    AccessTokenSecret = "12312kkwerkqw"
  },
  AccountContainer = "/sitecore/system/social/accounts",
  LastRenewalDate = DateTime.Now,
  Description = "Facebook wall of John Smith",
  MessageLanguage = "English",
  ReviewingWorkflowId = socialMessageWorkflowId
};

facebookAccount.ReviewingRoles.Add(@"sitecore\Facebook Message Reviewer");

accountManager.CreateAccount(facebookAccount);

this.ShowAccount(facebookAccount);
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetAccount Method

AccountManager GetAccount Method Sitecore Social Connected 2.0 API
Gets an account by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Account GetAccount(
    Identifier accountId
)
public Account GetAccount(
    Identifier accountId
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
Return Value
Type: Account

             The account. If the account is not found, an empty account is returned.

Implements
IAccountManager GetAccount(Identifier)
Examples
View Colorized Copy to Clipboard Print
var account = accountManager.GetAccount(accountId);

if (!account.IsEmpty)
{
  this.ShowAccount(account);
}
var account = accountManager.GetAccount(accountId);

if (!account.IsEmpty)
{
  this.ShowAccount(account);
}
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetAccounts Method

AccountManager GetAccounts Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Back to Top
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetAccounts Method (String)

AccountManager GetAccounts Method (String) Sitecore Social Connected 2.0 API
Gets all accounts by network name. Returns a collection of accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Account> GetAccounts(
    string networkName
)
public IEnumerable<Account> GetAccounts(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network (case-sensitive).
Return Value
Type:   Online IEnumerable  Account

             The account list. If no accounts are found an empty list is returned.

Implements
IAccountManager GetAccounts(String)
Examples
View Colorized Copy to Clipboard Print
var accounts = accountManager.GetAccounts("Facebook");

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
var accounts = accountManager.GetAccounts("Facebook");

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
See Also
AccountManager Class
AccountManager Members
GetAccounts Overload
Sitecore.Social.Api Namespace


AccountManager.GetAccounts Method (Identifier)

AccountManager GetAccounts Method (Identifier) Sitecore Social Connected 2.0 API
Gets all accounts by network id. Returns a collection of accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Account> GetAccounts(
    Identifier networkId
)
public IEnumerable<Account> GetAccounts(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online IEnumerable  Account

             The account list. If no accounts are found an empty list is returned.

Implements
IAccountManager GetAccounts(Identifier)
Examples
View Colorized Copy to Clipboard Print
var accounts = accountManager.GetAccounts(facebookNetworkId);

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
var accounts = accountManager.GetAccounts(facebookNetworkId);

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
See Also
AccountManager Class
AccountManager Members
GetAccounts Overload
Sitecore.Social.Api Namespace


AccountManager.GetAccountsByApplication Method

AccountManager GetAccountsByApplication Method Sitecore Social Connected 2.0 API
Gets all accounts by application id. Returns a collection of accounts.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Account> GetAccountsByApplication(
    Identifier applicationId
)
public IEnumerable<Account> GetAccountsByApplication(
    Identifier applicationId
)
Parameters
applicationId
Type: Sitecore.Social.Domain.Model Identifier
The application id.
Return Value
Type:   Online IEnumerable  Account

             The account list. If no accounts are found an empty list is returned.

Implements
IAccountManager GetAccountsByApplication(Identifier)
Examples
View Colorized Copy to Clipboard Print
var accounts = accountManager.GetAccountsByApplication(applicationId);

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
var accounts = accountManager.GetAccountsByApplication(applicationId);

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetAccountsByContainer Method

AccountManager GetAccountsByContainer Method Sitecore Social Connected 2.0 API
Gets the accounts by container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Account> GetAccountsByContainer(
    string accountContainer
)
public IEnumerable<Account> GetAccountsByContainer(
    string accountContainer
)
Parameters
accountContainer
Type:   Online System String
The account container.
Return Value
Type:   Online IEnumerable  Account

            The account list. If no accounts are found an empty list is returned.

Implements
IAccountManager GetAccountsByContainer(String)
Examples
View Colorized Copy to Clipboard Print
var accounts = accountManager.GetAccountsByContainer("/sitecore/system/Social/Accounts");

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
var accounts = accountManager.GetAccountsByContainer("/sitecore/system/Social/Accounts");

foreach (var account in accounts)
{
  this.ShowAccount(account);
}
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetDaysUntilRenewalRequired Method

AccountManager GetDaysUntilRenewalRequired Method Sitecore Social Connected 2.0 API
Gets the number of days before the required renewal of an account.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> GetDaysUntilRenewalRequired(
    Identifier accountId
)
public Nullable<int> GetDaysUntilRenewalRequired(
    Identifier accountId
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
Return Value
Type:   Online Nullable    Online Int32
The number of days. If negative then account expired, if null then account renewal disabled or not needed.
Implements
IAccountManager GetDaysUntilRenewalRequired(Identifier)
Examples
View Colorized Copy to Clipboard Print
var numberOfDays = accountManager.DaysBeforeRenewalRequired(accountId);

if (numberOfDays != null)
{
  Console.WriteLine("Number of days before the required renewal of account: {0}", numberOfDays);
}
var numberOfDays = accountManager.DaysBeforeRenewalRequired(accountId);

if (numberOfDays != null)
{
  Console.WriteLine("Number of days before the required renewal of account: {0}", numberOfDays);
}
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetNetworkAccountDisplayName Method

AccountManager GetNetworkAccountDisplayName Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier) | Gets an account display name in a social network.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String) | Gets an account display name in a social network.
Back to Top
See Also
AccountManager Class
AccountManager Members
Sitecore.Social.Api Namespace


AccountManager.GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, Identifier)

AccountManager GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, Identifier) Sitecore Social Connected 2.0 API
Gets an account display name in a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    Identifier networkId
)
public string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    Identifier networkId
)
Parameters
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online String

             The account display name.

Implements
IAccountManager GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier)
Examples
View Colorized Copy to Clipboard Print
if (networkManager.CanGetAccountInfo(facebookNetworkId))
{
  var accountDisplayName = accountManager.GetNetworkAccountDisplayName(
    new AccountCredentials("8823491234+", "2384921348923====123432"),
    new ApplicationCredentials("jdfhaksu777232", "qieirqiwe83283"),
    facebookNetworkId);

  Console.WriteLine("The account's display name in Facebook: {0}", accountDisplayName);
}
if (networkManager.CanGetAccountInfo(facebookNetworkId))
{
  var accountDisplayName = accountManager.GetNetworkAccountDisplayName(
    new AccountCredentials("8823491234+", "2384921348923====123432"),
    new ApplicationCredentials("jdfhaksu777232", "qieirqiwe83283"),
    facebookNetworkId);

  Console.WriteLine("The account's display name in Facebook: {0}", accountDisplayName);
}
See Also
AccountManager Class
AccountManager Members
GetNetworkAccountDisplayName Overload
Sitecore.Social.Api Namespace


AccountManager.GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, String)

AccountManager GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, String) Sitecore Social Connected 2.0 API
Gets an account display name in a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    string networkName
)
public string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    string networkName
)
Parameters
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
networkName
Type:   Online System String
Name of the network.
Return Value
Type:   Online String

             The account display name.

Implements
IAccountManager GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String)
Examples
View Colorized Copy to Clipboard Print
if (networkManager.CanGetAccountInfo("Facebook"))
{
  var accountDisplayName = accountManager.GetNetworkAccountDisplayName(
    new AccountCredentials("8823491234+", "2384921348923====123432"),
    new ApplicationCredentials("jdfhaksu777232", "qieirqiwe83283"),
    "Facebook");

  Console.WriteLine("The account's display name in Facebook: {0}", accountDisplayName);
}
if (networkManager.CanGetAccountInfo("Facebook"))
{
  var accountDisplayName = accountManager.GetNetworkAccountDisplayName(
    new AccountCredentials("8823491234+", "2384921348923====123432"),
    new ApplicationCredentials("jdfhaksu777232", "qieirqiwe83283"),
    "Facebook");

  Console.WriteLine("The account's display name in Facebook: {0}", accountDisplayName);
}
See Also
AccountManager Class
AccountManager Members
GetNetworkAccountDisplayName Overload
Sitecore.Social.Api Namespace


ApplicationManager Class

ApplicationManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social network applications.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api ApplicationManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ApplicationManager : IApplicationManager
public class ApplicationManager : IApplicationManager
See Also
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager Members

ApplicationManager Members Sitecore Social Connected 2.0 API

The ApplicationManager type exposes the following members.
Constructors
 | Name | Description
Public method | ApplicationManager | Initializes a new instance of the ApplicationManager class.
Public method | ApplicationManager(INetworkManager, IApplicationBusinessManager) | Initializes a new instance of the ApplicationManager class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ApplicationManager Class
Sitecore.Social.Api Namespace


ApplicationManager Constructor

ApplicationManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ApplicationManager | Initializes a new instance of the ApplicationManager class.
Public method | ApplicationManager(INetworkManager, IApplicationBusinessManager) | Initializes a new instance of the ApplicationManager class.
Back to Top
See Also
ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager Constructor

ApplicationManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ApplicationManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationManager()
public ApplicationManager()
See Also
ApplicationManager Class
ApplicationManager Members
ApplicationManager Overload
Sitecore.Social.Api Namespace


ApplicationManager Constructor (INetworkManager, )

ApplicationManager Constructor (INetworkManager, ) Sitecore Social Connected 2.0 API
Initializes a new instance of the ApplicationManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationManager(
    INetworkManager networkManager,
    IApplicationBusinessManager applicationBusinessManager
)
public ApplicationManager(
    INetworkManager networkManager,
    IApplicationBusinessManager applicationBusinessManager
)
Parameters
networkManager
Type: Sitecore.Social.Domain INetworkManager
The network manager.
applicationBusinessManager
Type: IApplicationBusinessManager
The application business manager.
See Also
ApplicationManager Class
ApplicationManager Members
ApplicationManager Overload
Sitecore.Social.Api Namespace


ApplicationManager Methods

ApplicationManager Methods Sitecore Social Connected 2.0 API
The ApplicationManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ApplicationManager Class
Sitecore.Social.Api Namespace


ApplicationManager.GetApplication Method

ApplicationManager GetApplication Method Sitecore Social Connected 2.0 API
Gets an application by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Application GetApplication(
    Identifier applicationId
)
public Application GetApplication(
    Identifier applicationId
)
Parameters
applicationId
Type: Sitecore.Social.Domain.Model Identifier
The application id.
Return Value
Type: Application

            The application. If the application is not found Empty is returned.

Implements
IApplicationManager GetApplication(Identifier)
Examples
View Colorized Copy to Clipboard Print
var application = applicationManager.GetApplication(applicationId);
if (!application.IsEmpty)
{
  this.ShowApplication(application);
}
var application = applicationManager.GetApplication(applicationId);
if (!application.IsEmpty)
{
  this.ShowApplication(application);
}
See Also
ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager.GetApplicationContainer Method

ApplicationManager GetApplicationContainer Method Sitecore Social Connected 2.0 API
Gets the application container by account container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetApplicationContainer(
    string accountContainer
)
public string GetApplicationContainer(
    string accountContainer
)
Parameters
accountContainer
Type:   Online System String
The account container.
Return Value
Type:   Online String

             The application container. If the application container is not found string.Empty is returned.

Implements
IApplicationManager GetApplicationContainer(String)
Examples
View Colorized Copy to Clipboard Print
var applicationContainer = applicationManager.GetApplicationContainer("/sitecore/system/Social/Accounts");

Console.WriteLine("The application container for the account container /sitecore/system/Social/Accounts is: {0}", applicationContainer);
var applicationContainer = applicationManager.GetApplicationContainer("/sitecore/system/Social/Accounts");

Console.WriteLine("The application container for the account container /sitecore/system/Social/Accounts is: {0}", applicationContainer);
See Also
ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager.GetApplications Method

ApplicationManager GetApplications Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Back to Top
See Also
ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager.GetApplications Method (String)

ApplicationManager GetApplications Method (String) Sitecore Social Connected 2.0 API
Gets the applications by network name.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Application> GetApplications(
    string networkName
)
public IEnumerable<Application> GetApplications(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network (case-sensitive).
Return Value
Type:   Online IEnumerable  Application

            The application list. If no applications are found an empty list is returned.

Implements
IApplicationManager GetApplications(String)
Examples
View Colorized Copy to Clipboard Print
var applications = applicationManager.GetApplications("Facebook");
foreach (var application in applications)
{
  this.ShowApplication(application);
}
var applications = applicationManager.GetApplications("Facebook");
foreach (var application in applications)
{
  this.ShowApplication(application);
}
See Also
ApplicationManager Class
ApplicationManager Members
GetApplications Overload
Sitecore.Social.Api Namespace


ApplicationManager.GetApplications Method (Identifier)

ApplicationManager GetApplications Method (Identifier) Sitecore Social Connected 2.0 API
Gets the applications by network id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Application> GetApplications(
    Identifier networkId
)
public IEnumerable<Application> GetApplications(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
Id of the network.
Return Value
Type:   Online IEnumerable  Application

            The application list. If no applications are found an empty list is returned.

Implements
IApplicationManager GetApplications(Identifier)
Examples
View Colorized Copy to Clipboard Print
var facebookNetwork = networkManager.GetNetwork("Facebook");
var applications = applicationManager.GetApplications(facebookNetwork.Id);
foreach (var application in applications)
{
  this.ShowApplication(application);
}
var facebookNetwork = networkManager.GetNetwork("Facebook");
var applications = applicationManager.GetApplications(facebookNetwork.Id);
foreach (var application in applications)
{
  this.ShowApplication(application);
}
See Also
ApplicationManager Class
ApplicationManager Members
GetApplications Overload
Sitecore.Social.Api Namespace


ApplicationManager.GetApplicationsByContainer Method

ApplicationManager GetApplicationsByContainer Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.
Back to Top
See Also
ApplicationManager Class
ApplicationManager Members
Sitecore.Social.Api Namespace


ApplicationManager.GetApplicationsByContainer Method (String)

ApplicationManager GetApplicationsByContainer Method (String) Sitecore Social Connected 2.0 API
Gets the applications by container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer
)
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer
)
Parameters
applicationContainer
Type:   Online System String
The application container.
Return Value
Type:   Online IEnumerable  Application

            The application list. If no applications are found an empty list is returned.

Implements
IApplicationManager GetApplicationsByContainer(String)
Examples
View Colorized Copy to Clipboard Print
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default");
foreach (var application in applications)
{
  this.ShowApplication(application);
}
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default");
foreach (var application in applications)
{
  this.ShowApplication(application);
}
See Also
ApplicationManager Class
ApplicationManager Members
GetApplicationsByContainer Overload
Sitecore.Social.Api Namespace


ApplicationManager.GetApplicationsByContainer Method (String, Identifier)

ApplicationManager GetApplicationsByContainer Method (String, Identifier) Sitecore Social Connected 2.0 API
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    Identifier networkId
)
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    Identifier networkId
)
Parameters
applicationContainer
Type:   Online System String
The application container.
networkId
Type: Sitecore.Social.Domain.Model Identifier
Id of the network.
Return Value
Type:   Online IEnumerable  Application

            The application list. If no applications are found an empty list is returned.

Implements
IApplicationManager GetApplicationsByContainer(String, Identifier)
Examples
View Colorized Copy to Clipboard Print
var facebookNetwork = networkManager.GetNetwork("Facebook");
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default", facebookNetwork.Id);
foreach (var application in applications)
{
  this.ShowApplication(application);
}
var facebookNetwork = networkManager.GetNetwork("Facebook");
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default", facebookNetwork.Id);
foreach (var application in applications)
{
  this.ShowApplication(application);
}
See Also
ApplicationManager Class
ApplicationManager Members
GetApplicationsByContainer Overload
Sitecore.Social.Api Namespace


ApplicationManager.GetApplicationsByContainer Method (String, String)

ApplicationManager GetApplicationsByContainer Method (String, String) Sitecore Social Connected 2.0 API
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    string networkName
)
public IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    string networkName
)
Parameters
applicationContainer
Type:   Online System String
The application container.
networkName
Type:   Online System String
The name of the network (case-sensitive).
Return Value
Type:   Online IEnumerable  Application

            The application list. If no applications are found an empty list is returned.

Implements
IApplicationManager GetApplicationsByContainer(String, String)
Examples
View Colorized Copy to Clipboard Print
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default", "Facebook");
foreach (var application in applications)
{
  this.ShowApplication(application);
}
var applications = applicationManager.GetApplicationsByContainer("/sitecore/system/Social/Applications/Default", "Facebook");
foreach (var application in applications)
{
  this.ShowApplication(application);
}
See Also
ApplicationManager Class
ApplicationManager Members
GetApplicationsByContainer Overload
Sitecore.Social.Api Namespace


MessageManager Class

MessageManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social network messages.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api MessageManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MessageManager : IMessageManager
public class MessageManager : IMessageManager
See Also
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager Members

MessageManager Members Sitecore Social Connected 2.0 API

The MessageManager type exposes the following members.
Constructors
 | Name | Description
Public method | MessageManager | Initializes a new instance of the MessageManager class.
Public method | MessageManager(INetworkManager, IMessageBusinessManager) | Initializes a new instance of the MessageManager class.
Back to Top
Methods
 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMessage | Gets the message by id.
Public method | GetMessageComments | Gets the message comments.
Public method | GetMessages(PostingConfigurationSearchArgs) | Obsolete. Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessagesByAccount | Gets messages by account.
Public method | GetMessagesByContainer | Gets messages by container.
Public method | GetMessagesByCreatedDate | Gets messages created on a specific date.
Public method | GetMessagesByWorkflowState | Gets messages by workflow state.
Public method | GetMessagesCount | Gets number of messages attached to specific container.
Public method | GetMessagesReadyToPostAutomatically | Gets messages that are ready to be posted automatically.
Public method | GetMessageStatus | Gets the message status.
Public method | GetNotPostedMessages | Gets all messages that are not posted to a social network.
Public method | GetPostedMessages | Gets all messages posted to a social network.
Public method | GetPostedMessages(DateTime) | Gets messages posted to a social network on a specific date.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PostMessage(Identifier) | Posts the message to a social network.
Public method | PostMessage(Identifier, IDictionary String, String ) | Posts the message.
Public method | PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UpdateMessage | Updates the message.
Back to Top
See Also
MessageManager Class
Sitecore.Social.Api Namespace


MessageManager Constructor

MessageManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | MessageManager | Initializes a new instance of the MessageManager class.
Public method | MessageManager(INetworkManager, IMessageBusinessManager) | Initializes a new instance of the MessageManager class.
Back to Top
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager Constructor

MessageManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageManager()
public MessageManager()
See Also
MessageManager Class
MessageManager Members
MessageManager Overload
Sitecore.Social.Api Namespace


MessageManager Constructor (INetworkManager, )

MessageManager Constructor (INetworkManager, ) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageManager(
    INetworkManager networkManager,
    IMessageBusinessManager messageBusinessManager
)
public MessageManager(
    INetworkManager networkManager,
    IMessageBusinessManager messageBusinessManager
)
Parameters
networkManager
Type: Sitecore.Social.Domain INetworkManager
The network manager.
messageBusinessManager
Type: IMessageBusinessManager
The message business manager.
See Also
MessageManager Class
MessageManager Members
MessageManager Overload
Sitecore.Social.Api Namespace


MessageManager Methods

MessageManager Methods Sitecore Social Connected 2.0 API
The MessageManager type exposes the following members.
Methods
 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMessage | Gets the message by id.
Public method | GetMessageComments | Gets the message comments.
Public method | GetMessages(PostingConfigurationSearchArgs) | Obsolete. Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessagesByAccount | Gets messages by account.
Public method | GetMessagesByContainer | Gets messages by container.
Public method | GetMessagesByCreatedDate | Gets messages created on a specific date.
Public method | GetMessagesByWorkflowState | Gets messages by workflow state.
Public method | GetMessagesCount | Gets number of messages attached to specific container.
Public method | GetMessagesReadyToPostAutomatically | Gets messages that are ready to be posted automatically.
Public method | GetMessageStatus | Gets the message status.
Public method | GetNotPostedMessages | Gets all messages that are not posted to a social network.
Public method | GetPostedMessages | Gets all messages posted to a social network.
Public method | GetPostedMessages(DateTime) | Gets messages posted to a social network on a specific date.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PostMessage(Identifier) | Posts the message to a social network.
Public method | PostMessage(Identifier, IDictionary String, String ) | Posts the message.
Public method | PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UpdateMessage | Updates the message.
Back to Top
See Also
MessageManager Class
Sitecore.Social.Api Namespace


MessageManager.CreateMessage Method

MessageManager CreateMessage Method Sitecore Social Connected 2.0 API
Creates a message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CreateMessage(
    Message message
)
public void CreateMessage(
    Message message
)
Parameters
message
Type: Sitecore.Social.Domain.Model Message
The message to create.
Implements
IMessageManager CreateMessage(Message)
Exceptions
Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
Online System InvalidCastException | Invalid casts occured.
Online System FormatException | Invalid values are presented.
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException | Message data builder is not found.
Remarks
  • The Id field will contain identifier of the created message.
  •
             To post messages automatically on a goal triggering the following rule should be configured for the goal:

    • condition
      System: where true (actions always execute)
    • action
      Social: post associated messages
Examples
View Colorized Copy to Clipboard Print
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "<link linktype=\"internal\" url=\"/Home.aspx\" querystring=\"sc_lang=en\" target=\"\" id=\"{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}\" />",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "<image mediaid=\"{EBA7F6D5-8C28-4304-B976-12E9DDBCF32A}\" mediapath=\"/Images/hero3\" src=\"~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx\" />",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var contentPostingConfiguration = new ContentPostingConfiguration("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1", facebookAccountId);

var facebookMessage = new Message(facebookNetworkId, facebookMessageData, contentPostingConfiguration);

messageManager.CreateMessage(facebookMessage);

this.ShowMessage(facebookMessage);
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "<link linktype=\"internal\" url=\"/Home.aspx\" querystring=\"sc_lang=en\" target=\"\" id=\"{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}\" />",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "<image mediaid=\"{EBA7F6D5-8C28-4304-B976-12E9DDBCF32A}\" mediapath=\"/Images/hero3\" src=\"~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx\" />",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var contentPostingConfiguration = new ContentPostingConfiguration("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1", facebookAccountId);

var facebookMessage = new Message(facebookNetworkId, facebookMessageData, contentPostingConfiguration);

messageManager.CreateMessage(facebookMessage);

this.ShowMessage(facebookMessage);
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.DeleteMessage Method

MessageManager DeleteMessage Method Sitecore Social Connected 2.0 API
Deletes the message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeleteMessage(
    Identifier messageId
)
public void DeleteMessage(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Implements
IMessageManager DeleteMessage(Identifier)
Exceptions
Exception | Condition
ItemNotFoundException | Item is not found.
Examples
View Colorized Copy to Clipboard Print
messageManager.DeleteMessage(messageId);

Console.WriteLine("Deleted!");
messageManager.DeleteMessage(messageId);

Console.WriteLine("Deleted!");
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessage Method

MessageManager GetMessage Method Sitecore Social Connected 2.0 API
Gets the message by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message GetMessage(
    Identifier messageId
)
public Message GetMessage(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: Message

            The message. If message is not found Empty is returned.

Implements
IMessageManager GetMessage(Identifier)
Exceptions
Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException | Message data builder is not found.
Online System InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.
Examples
View Colorized Copy to Clipboard Print
var message = messageManager.GetMessage(messageId);

if (!message.IsEmpty)
{
  this.ShowMessage(message);
}
var message = messageManager.GetMessage(messageId);

if (!message.IsEmpty)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessageComments Method

MessageManager GetMessageComments Method Sitecore Social Connected 2.0 API
Gets the message comments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<MessageComment> GetMessageComments(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    string networkMessageId
)
public IEnumerable<MessageComment> GetMessageComments(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    string networkMessageId
)
Parameters
networkName
Type:   Online System String
Name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
networkMessageId
Type:   Online System String
The network message id.
Return Value
Type:   Online IEnumerable  MessageComment
The message comments list. If no comments are found an empty list is returned.
Implements
IMessageManager GetMessageComments(String, ApplicationCredentials, AccountCredentials, String)
Exceptions
Exception | Condition
Online System InvalidOperationException | If any of the input parameters is null or empty.
Online System InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.
Examples
View Colorized Copy to Clipboard Print
var messageComments = messageManager.GetMessageComments("Facebook", facebookApplicationCredentials, facebookAccountCredentials, "1282068888_4295686592014");

foreach (var messageComment in messageComments)
{
  this.ShowMessageComment(messageComment);
}
var messageComments = messageManager.GetMessageComments("Facebook", facebookApplicationCredentials, facebookAccountCredentials, "1282068888_4295686592014");

foreach (var messageComment in messageComments)
{
  this.ShowMessageComment(messageComment);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessages Method

MessageManager GetMessages Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetMessages(PostingConfigurationSearchArgs) | Obsolete. Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Back to Top
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessages Method (PostingConfigurationSearchArgs)

MessageManager GetMessages Method (PostingConfigurationSearchArgs) Sitecore Social Connected 2.0 API
Gets all messages containing specific search arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.MessageManager.GetMessagesByContainer",
    false)]
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.MessageManager.GetMessagesByContainer",
    false)]
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs
)
Parameters
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search arguments.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessages(PostingConfigurationSearchArgs)
Exceptions
Exception | Condition
Online System FormatException | Invalid search arguments values are presented.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationSearchArgsAdapterIsNotFoundException | Posting configuration search arguments adapter is not found.
Online System InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException | Message data builder is not found.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var contentMessages = messageManager.GetMessages(searchArgs);

Console.WriteLine("Content messages:");
foreach (var message in contentMessages)
{
  this.ShowMessage(message);
}
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var contentMessages = messageManager.GetMessages(searchArgs);

Console.WriteLine("Content messages:");
foreach (var message in contentMessages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
GetMessages Overload
Sitecore.Social.Api Namespace


MessageManager.GetMessages Method (PostingConfigurationSearchArgs, Identifier)

MessageManager GetMessages Method (PostingConfigurationSearchArgs, Identifier) Sitecore Social Connected 2.0 API
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.MessageManager.GetMessagesByContainer",
    false)]
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    Identifier networkId
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.MessageManager.GetMessagesByContainer",
    false)]
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    Identifier networkId
)
Parameters
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessages(PostingConfigurationSearchArgs, Identifier)
Exceptions
Exception | Condition
Online System FormatException | Invalid search arguments values are presented.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationSearchArgsAdapterIsNotFoundException | Posting configuration search arguments adapter is not found.
Online System InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException | Message data builder is not found.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var facebookMessages = messageManager.GetMessages(searchArgs, facebookId);

foreach (var message in facebookMessages)
{
  this.ShowMessage(message);
}
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var facebookMessages = messageManager.GetMessages(searchArgs, facebookId);

foreach (var message in facebookMessages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
GetMessages Overload
Sitecore.Social.Api Namespace


MessageManager.GetMessages Method (PostingConfigurationSearchArgs, String)

MessageManager GetMessages Method (PostingConfigurationSearchArgs, String) Sitecore Social Connected 2.0 API
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.MessageManager.GetMessagesByContainer",
    false)]
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    string networkName
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.MessageManager.GetMessagesByContainer",
    false)]
public IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    string networkName
)
Parameters
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
networkName
Type:   Online System String
The name of the network (case-sensitive).
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessages(PostingConfigurationSearchArgs, String)
Exceptions
Exception | Condition
Online System FormatException | Invalid search arguments values are presented.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationSearchArgsAdapterIsNotFoundException | Posting configuration search arguments adapter is not found.
Online System InvalidCastException | Invalid casts occured.
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException | Message data builder is not found.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
ItemNotFoundException | Item is not found.
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var facebookMessages = messageManager.GetMessages(searchArgs, "Facebook");

foreach (var message in facebookMessages)
{
  this.ShowMessage(message);
}
var searchArgs = new ContentPostingConfigurationSearchArgs("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

var facebookMessages = messageManager.GetMessages(searchArgs, "Facebook");

foreach (var message in facebookMessages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
GetMessages Overload
Sitecore.Social.Api Namespace


MessageManager.GetMessagesByAccount Method

MessageManager GetMessagesByAccount Method Sitecore Social Connected 2.0 API
Gets messages by account.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetMessagesByAccount(
    Identifier accountId
)
public IEnumerable<Message> GetMessagesByAccount(
    Identifier accountId
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessagesByAccount(Identifier)
Examples
View Colorized Copy to Clipboard Print
var messages = messageManager.GetMessagesByAccount(facebookAccountId);

foreach (var message in messages)
{
  this.ShowMessage(message);
}
var messages = messageManager.GetMessagesByAccount(facebookAccountId);

foreach (var message in messages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessagesByContainer Method

MessageManager GetMessagesByContainer Method Sitecore Social Connected 2.0 API
Gets messages by container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetMessagesByContainer(
    string container
)
public IEnumerable<Message> GetMessagesByContainer(
    string container
)
Parameters
container
Type:   Online System String
The container.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessagesByContainer(String)
Examples
View Colorized Copy to Clipboard Print
var homeItemMessages = messageManager.GetMessagesByContainer("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

foreach (var message in homeItemMessages)
{
  this.ShowMessage(message);
}
var homeItemMessages = messageManager.GetMessagesByContainer("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

foreach (var message in homeItemMessages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessagesByCreatedDate Method

MessageManager GetMessagesByCreatedDate Method Sitecore Social Connected 2.0 API
Gets messages created on a specific date.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetMessagesByCreatedDate(
    DateTime createdDate
)
public IEnumerable<Message> GetMessagesByCreatedDate(
    DateTime createdDate
)
Parameters
createdDate
Type:   Online System DateTime
The created date.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessagesByCreatedDate(DateTime)
Examples
View Colorized Copy to Clipboard Print
var yesterdayMessages = messageManager.GetMessagesByCreatedDate(DateTime.Now.AddDays(-1).Date);

foreach (var message in yesterdayMessages)
{
  this.ShowMessage(message);
}
var yesterdayMessages = messageManager.GetMessagesByCreatedDate(DateTime.Now.AddDays(-1).Date);

foreach (var message in yesterdayMessages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessagesByWorkflowState Method

MessageManager GetMessagesByWorkflowState Method Sitecore Social Connected 2.0 API
Gets messages by workflow state.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetMessagesByWorkflowState(
    Identifier workflowStateId
)
public IEnumerable<Message> GetMessagesByWorkflowState(
    Identifier workflowStateId
)
Parameters
workflowStateId
Type: Sitecore.Social.Domain.Model Identifier
The workflow state id.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessagesByWorkflowState(Identifier)
Examples
View Colorized Copy to Clipboard Print
var draftMessages = messageManager.GetMessagesByWorkflowState(draftStateId);

foreach (var draftMessage in draftMessages)
{
  this.ShowMessage(draftMessage);
}
var draftMessages = messageManager.GetMessagesByWorkflowState(draftStateId);

foreach (var draftMessage in draftMessages)
{
  this.ShowMessage(draftMessage);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessagesCount Method

MessageManager GetMessagesCount Method Sitecore Social Connected 2.0 API
Gets number of messages attached to specific container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetMessagesCount(
    string container
)
public int GetMessagesCount(
    string container
)
Parameters
container
Type:   Online System String
The container.
Return Value
Type:   Online Int32

             The number of messages attached to the specific container.

Implements
IMessageManager GetMessagesCount(String)
Examples
View Colorized Copy to Clipboard Print
var homeItemMessagesCount = messageManager.GetMessagesCount("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

Console.WriteLine("There are {0} messages attached to /sitecore/content/home item.", homeItemMessagesCount);
var homeItemMessagesCount = messageManager.GetMessagesCount("sitecore://master/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}?lang=en&ver=1");

Console.WriteLine("There are {0} messages attached to /sitecore/content/home item.", homeItemMessagesCount);
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessagesReadyToPostAutomatically Method

MessageManager GetMessagesReadyToPostAutomatically Method Sitecore Social Connected 2.0 API
Gets messages that are ready to be posted automatically.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetMessagesReadyToPostAutomatically(
    IEnumerable<Identifier> accountIds
)
public IEnumerable<Message> GetMessagesReadyToPostAutomatically(
    IEnumerable<Identifier> accountIds
)
Parameters
accountIds
Type:   Online System.Collections.Generic IEnumerable  Identifier
The account ids.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetMessagesReadyToPostAutomatically(IEnumerable Identifier )
Remarks

             This method will search messages by the following parameters:

  • Content posting configuration.
  • Content item is published.
  • "Post automatically" is checked.
  • Message is not in a workflow. Or message is in a final workflow state.
  • Message is not posted.
Examples
View Colorized Copy to Clipboard Print
var readyToPostAutomaticallyMessages = messageManager.GetMessagesReadyToPostAutomatically(accountIds);

foreach (var message in readyToPostAutomaticallyMessages)
{
  messageManager.PostMessage(message.Id);
}
var readyToPostAutomaticallyMessages = messageManager.GetMessagesReadyToPostAutomatically(accountIds);

foreach (var message in readyToPostAutomaticallyMessages)
{
  messageManager.PostMessage(message.Id);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetMessageStatus Method

MessageManager GetMessageStatus Method Sitecore Social Connected 2.0 API
Gets the message status.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatus GetMessageStatus(
    Identifier messageId
)
public MessageStatus GetMessageStatus(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: MessageStatus

             The MessageStatus. If the status is not defined Empty is returned.

Implements
IMessageManager GetMessageStatus(Identifier)
Exceptions
Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions MessageStatusBuilderIsNotFoundException | Message status builder is not found.
Examples
View Colorized Copy to Clipboard Print
var messageStatus = messageManager.GetMessageStatus(messageId);

if (!messageStatus.IsEmpty && (messageStatus.AccountStatus.PostingStatus is FailedPostingStatus))
{
  Console.WriteLine("Account Id: {0}, ErrorText: {1}", messageStatus.AccountStatus.AccountId, ((FailedPostingStatus)messageStatus.AccountStatus.PostingStatus).ErrorText);
}
var messageStatus = messageManager.GetMessageStatus(messageId);

if (!messageStatus.IsEmpty && (messageStatus.AccountStatus.PostingStatus is FailedPostingStatus))
{
  Console.WriteLine("Account Id: {0}, ErrorText: {1}", messageStatus.AccountStatus.AccountId, ((FailedPostingStatus)messageStatus.AccountStatus.PostingStatus).ErrorText);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetNotPostedMessages Method

MessageManager GetNotPostedMessages Method Sitecore Social Connected 2.0 API
Gets all messages that are not posted to a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetNotPostedMessages()
public IEnumerable<Message> GetNotPostedMessages()
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetNotPostedMessages
Examples
View Colorized Copy to Clipboard Print
var pendingMessages = messageManager.GetNotPostedMessages();

foreach (var message in pendingMessages)
{
  this.ShowMessage(message);
}
var pendingMessages = messageManager.GetNotPostedMessages();

foreach (var message in pendingMessages)
{
  this.ShowMessage(message);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetPostedMessages Method

MessageManager GetPostedMessages Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetPostedMessages | Gets all messages posted to a social network.
Public method | GetPostedMessages(DateTime) | Gets messages posted to a social network on a specific date.
Back to Top
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.GetPostedMessages Method

MessageManager GetPostedMessages Method Sitecore Social Connected 2.0 API
Gets all messages posted to a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetPostedMessages()
public IEnumerable<Message> GetPostedMessages()
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetPostedMessages
Examples
View Colorized Copy to Clipboard Print
var postedMessages = messageManager.GetPostedMessages();

foreach (var postedMessage in postedMessages)
{
  this.ShowMessage(postedMessage);

  messageStatisticsManager.RefreshMessageStatistics(postedMessage.Id);
}
var postedMessages = messageManager.GetPostedMessages();

foreach (var postedMessage in postedMessages)
{
  this.ShowMessage(postedMessage);

  messageStatisticsManager.RefreshMessageStatistics(postedMessage.Id);
}
See Also
MessageManager Class
MessageManager Members
GetPostedMessages Overload
Sitecore.Social.Api Namespace


MessageManager.GetPostedMessages Method (DateTime)

MessageManager GetPostedMessages Method (DateTime) Sitecore Social Connected 2.0 API
Gets messages posted to a social network on a specific date.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetPostedMessages(
    DateTime postedDate
)
public IEnumerable<Message> GetPostedMessages(
    DateTime postedDate
)
Parameters
postedDate
Type:   Online System DateTime
The posted date.
Return Value
Type:   Online IEnumerable  Message

             The messages list. If no messages are found an empty list is returned.

Implements
IMessageManager GetPostedMessages(DateTime)
Examples
View Colorized Copy to Clipboard Print
var postedMessages = messageManager.GetPostedMessages(DateTime.Today);

foreach (var postedMessage in postedMessages)
{
  this.ShowMessage(postedMessage);

  messageStatisticsManager.RefreshMessageStatistics(postedMessage.Id);
}
var postedMessages = messageManager.GetPostedMessages(DateTime.Today);

foreach (var postedMessage in postedMessages)
{
  this.ShowMessage(postedMessage);

  messageStatisticsManager.RefreshMessageStatistics(postedMessage.Id);
}
See Also
MessageManager Class
MessageManager Members
GetPostedMessages Overload
Sitecore.Social.Api Namespace


MessageManager.PostMessage Method

MessageManager PostMessage Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | PostMessage(Identifier) | Posts the message to a social network.
Public method | PostMessage(Identifier, IDictionary String, String ) | Posts the message.
Public method | PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Back to Top
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageManager.PostMessage Method (Identifier)

MessageManager PostMessage Method (Identifier) Sitecore Social Connected 2.0 API
Posts the message to a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PostMessage(
    Identifier messageId
)
public void PostMessage(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Implements
IMessageManager PostMessage(Identifier)
Exceptions
Exception | Condition
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
Online System InvalidCastException | Invalid casts occured.
Online System FormatException | Invalid values are presented.
Examples
View Colorized Copy to Clipboard Print
messageManager.PostMessage(messageId);

var messageStatus = messageManager.GetMessageStatus(messageId);
if (!messageStatus.IsEmpty && (messageStatus.AccountStatus.PostingStatus is FailedPostingStatus))
{
  Console.WriteLine("Account Id: {0}, ErrorText: {1}", messageStatus.AccountStatus.AccountId, ((FailedPostingStatus)messageStatus.AccountStatus.PostingStatus).ErrorText);
}
messageManager.PostMessage(messageId);

var messageStatus = messageManager.GetMessageStatus(messageId);
if (!messageStatus.IsEmpty && (messageStatus.AccountStatus.PostingStatus is FailedPostingStatus))
{
  Console.WriteLine("Account Id: {0}, ErrorText: {1}", messageStatus.AccountStatus.AccountId, ((FailedPostingStatus)messageStatus.AccountStatus.PostingStatus).ErrorText);
}
See Also
MessageManager Class
MessageManager Members
PostMessage Overload
Sitecore.Social.Api Namespace


MessageManager.PostMessage Method (Identifier, IDictionary(String, String))

MessageManager PostMessage Method (Identifier, IDictionary String, String ) Sitecore Social Connected 2.0 API
Posts the message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PostMessage(
    Identifier messageId,
    IDictionary<string, string> tokensToReplace
)
public void PostMessage(
    Identifier messageId,
    IDictionary<string, string> tokensToReplace
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
tokensToReplace
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The tokens to be replaced with the values during posting.
Implements
IMessageManager PostMessage(Identifier, IDictionary String, String )
Exceptions
Exception | Condition
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
Online System InvalidCastException | Invalid casts occured.
Online System FormatException | Invalid values are presented.
Examples
View Colorized Copy to Clipboard Print
var tokensToReplace = new Dictionary<string, string> { { "image", "http://domain/img.png" } };

messageManager.PostMessage(messageId, tokensToReplace);

var messageStatus = messageManager.GetMessageStatus(messageId);
if (!messageStatus.IsEmpty && (messageStatus.AccountStatus.PostingStatus is FailedPostingStatus))
{
  Console.WriteLine("Account Id: {0}, ErrorText: {1}", messageStatus.AccountStatus.AccountId, ((FailedPostingStatus)messageStatus.AccountStatus.PostingStatus).ErrorText);
}
var tokensToReplace = new Dictionary<string, string> { { "image", "http://domain/img.png" } };

messageManager.PostMessage(messageId, tokensToReplace);

var messageStatus = messageManager.GetMessageStatus(messageId);
if (!messageStatus.IsEmpty && (messageStatus.AccountStatus.PostingStatus is FailedPostingStatus))
{
  Console.WriteLine("Account Id: {0}, ErrorText: {1}", messageStatus.AccountStatus.AccountId, ((FailedPostingStatus)messageStatus.AccountStatus.PostingStatus).ErrorText);
}
See Also
MessageManager Class
MessageManager Members
PostMessage Overload
Sitecore.Social.Api Namespace


MessageManager.PostMessage Method (String, ApplicationCredentials, AccountCredentials, MessageData)

MessageManager PostMessage Method (String, ApplicationCredentials, AccountCredentials, MessageData) Sitecore Social Connected 2.0 API
Posts a message directly to a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostMessage(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
public string PostMessage(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
Parameters
networkName
Type:   Online System String
The network name. Case sensitive.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
messageData
Type: Sitecore.Social.Domain.Model MessageData
The message data.
Return Value
Type:   Online String
The message id at the social network.
Implements
IMessageManager PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData)
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AuthException] | Some problems during posting.
Examples
View Colorized Copy to Clipboard Print
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "http://social-local.com/?sc_lang=en&sc_camp=110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "http://social-local.com/~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var messageId = messageManager.PostMessage("Facebook", facebookApplicationCredentials, facebookAccountCredentials, facebookMessageData);
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "http://social-local.com/?sc_lang=en&sc_camp=110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "http://social-local.com/~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var messageId = messageManager.PostMessage("Facebook", facebookApplicationCredentials, facebookAccountCredentials, facebookMessageData);
See Also
MessageManager Class
MessageManager Members
PostMessage Overload
Sitecore.Social.Api Namespace


MessageManager.PostMessage Method (Identifier, ApplicationCredentials, AccountCredentials, MessageData)

MessageManager PostMessage Method (Identifier, ApplicationCredentials, AccountCredentials, MessageData) Sitecore Social Connected 2.0 API
Posts a message directly to a social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostMessage(
    Identifier networkId,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
public string PostMessage(
    Identifier networkId,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
messageData
Type: Sitecore.Social.Domain.Model MessageData
The message data.
Return Value
Type:   Online String
The message id at the social network.
Implements
IMessageManager PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData)
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AuthException] | Some problems during posting.
Sitecore.Social.BusinessLogic.Exceptions PostingIsNotMaintainedByProviderException | Posting is not maintained by provider.
Examples
View Colorized Copy to Clipboard Print
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "http://social-local.com/?sc_lang=en&sc_camp=110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "http://social-local.com/~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var messageId = messageManager.PostMessage(facebookNetworkId, facebookApplicationCredentials, facebookAccountCredentials, facebookMessageData);
var facebookMessageData = new FacebookMessageData
{
  CampaignId = campaignId,
  Link = "http://social-local.com/?sc_lang=en&sc_camp=110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9",
  LinkTitle = ".NET 4.5 is released",
  LinkDescription = "Latest news from .NET World",
  LinkImage = "http://social-local.com/~/media/EBA7F6D58C284304B97612E9DDBCF32A.ashx",
  Text = ".NET 4.5 is released. Enjoy it!"
};

var messageId = messageManager.PostMessage(facebookNetworkId, facebookApplicationCredentials, facebookAccountCredentials, facebookMessageData);
See Also
MessageManager Class
MessageManager Members
PostMessage Overload
Sitecore.Social.Api Namespace


MessageManager.UpdateMessage Method

MessageManager UpdateMessage Method Sitecore Social Connected 2.0 API
Updates the message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UpdateMessage(
    Message message
)
public void UpdateMessage(
    Message message
)
Parameters
message
Type: Sitecore.Social.Domain.Model Message
The message to update.
Implements
IMessageManager UpdateMessage(Message)
Exceptions
Exception | Condition
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException | Posting configuration builder is not found.
Online System InvalidCastException | Invalid casts occured.
Online System FormatException | Invalid values are presented.
ItemNotFoundException | Item is not found.
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException | Message data builder is not found.
Examples
View Colorized Copy to Clipboard Print
var facebookMessage = messageManager.GetMessage(facebookMessageId);

if (!facebookMessage.IsEmpty)
{
  var facebookMessageData = (FacebookMessageData)facebookMessage.MessageData;
  facebookMessageData.Text += "updated";
  facebookMessageData.LinkDescription += "updated";

  messageManager.UpdateMessage(facebookMessage);

  this.ShowMessage(facebookMessage);
}
var facebookMessage = messageManager.GetMessage(facebookMessageId);

if (!facebookMessage.IsEmpty)
{
  var facebookMessageData = (FacebookMessageData)facebookMessage.MessageData;
  facebookMessageData.Text += "updated";
  facebookMessageData.LinkDescription += "updated";

  messageManager.UpdateMessage(facebookMessage);

  this.ShowMessage(facebookMessage);
}
See Also
MessageManager Class
MessageManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager Class

MessageStatisticsManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social network message statistics.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api MessageStatisticsManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MessageStatisticsManager : IMessageStatisticsManager
public class MessageStatisticsManager : IMessageStatisticsManager
See Also
MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager Members

MessageStatisticsManager Members Sitecore Social Connected 2.0 API

The MessageStatisticsManager type exposes the following members.
Constructors
 | Name | Description
Public method | MessageStatisticsManager | Initializes a new instance of the MessageStatisticsManager class.
Public method | MessageStatisticsManager(IMessageStatisticsBusinessManager) | Initializes a new instance of the MessageStatisticsManager class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMessageStatistics | Gets message statistics.
Public method | GetStatisticsCounterNames(String) | Gets the statistics counters for the specific social network.
Public method | GetStatisticsCounterNames(Identifier) | Gets the statistics counters for the specific social network.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RefreshMessageStatistics(Identifier) | Refreshes message statistics.
Public method | RefreshMessageStatistics(Identifier, Boolean) | Refreshes message statistics. You can reset statistics refreshing.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageStatisticsManager Class
Sitecore.Social.Api Namespace


MessageStatisticsManager Constructor

MessageStatisticsManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | MessageStatisticsManager | Initializes a new instance of the MessageStatisticsManager class.
Public method | MessageStatisticsManager(IMessageStatisticsBusinessManager) | Initializes a new instance of the MessageStatisticsManager class.
Back to Top
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager Constructor

MessageStatisticsManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatisticsManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatisticsManager()
public MessageStatisticsManager()
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
MessageStatisticsManager Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager Constructor ()

MessageStatisticsManager Constructor () Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatisticsManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatisticsManager(
    IMessageStatisticsBusinessManager messageStatisticsBusinessManager
)
public MessageStatisticsManager(
    IMessageStatisticsBusinessManager messageStatisticsBusinessManager
)
Parameters
messageStatisticsBusinessManager
Type: IMessageStatisticsBusinessManager
The message statistics business manager.
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
MessageStatisticsManager Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager Methods

MessageStatisticsManager Methods Sitecore Social Connected 2.0 API
The MessageStatisticsManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMessageStatistics | Gets message statistics.
Public method | GetStatisticsCounterNames(String) | Gets the statistics counters for the specific social network.
Public method | GetStatisticsCounterNames(Identifier) | Gets the statistics counters for the specific social network.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RefreshMessageStatistics(Identifier) | Refreshes message statistics.
Public method | RefreshMessageStatistics(Identifier, Boolean) | Refreshes message statistics. You can reset statistics refreshing.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageStatisticsManager Class
Sitecore.Social.Api Namespace


MessageStatisticsManager.GetMessageStatistics Method

MessageStatisticsManager GetMessageStatistics Method Sitecore Social Connected 2.0 API
Gets message statistics.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatistics GetMessageStatistics(
    Identifier messageId
)
public MessageStatistics GetMessageStatistics(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: MessageStatistics

             The message statistics.

Implements
IMessageStatisticsManager GetMessageStatistics(Identifier)
Examples
View Colorized Copy to Clipboard Print
var messageStatistics = messageStatisticsManager.GetMessageStatistics(facebookMessageId);

if (!messageStatistics.IsEmpty)
{
  Console.WriteLine("MessageId: {0}, StartRefreshDate: {1}, LastRefreshDate: {2}", messageStatistics.MessageId, messageStatistics.StartRefreshDate, messageStatistics.LastRefreshDate);
  Console.WriteLine("AccountId: {0}", messageStatistics.AccountsStatistics.AccountId);

  foreach (var statisticsCounter in messageStatistics.AccountsStatistics.StatisticsCounters)
  {
    Console.WriteLine("Name: {0}, Number: {1}", statisticsCounter.Name, ((NumberCounter)statisticsCounter).Number);
  }
}
var messageStatistics = messageStatisticsManager.GetMessageStatistics(facebookMessageId);

if (!messageStatistics.IsEmpty)
{
  Console.WriteLine("MessageId: {0}, StartRefreshDate: {1}, LastRefreshDate: {2}", messageStatistics.MessageId, messageStatistics.StartRefreshDate, messageStatistics.LastRefreshDate);
  Console.WriteLine("AccountId: {0}", messageStatistics.AccountsStatistics.AccountId);

  foreach (var statisticsCounter in messageStatistics.AccountsStatistics.StatisticsCounters)
  {
    Console.WriteLine("Name: {0}, Number: {1}", statisticsCounter.Name, ((NumberCounter)statisticsCounter).Number);
  }
}
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager.GetStatisticsCounterNames Method

MessageStatisticsManager GetStatisticsCounterNames Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetStatisticsCounterNames(String) | Gets the statistics counters for the specific social network.
Public method | GetStatisticsCounterNames(Identifier) | Gets the statistics counters for the specific social network.
Back to Top
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager.GetStatisticsCounterNames Method (String)

MessageStatisticsManager GetStatisticsCounterNames Method (String) Sitecore Social Connected 2.0 API
Gets the statistics counters for the specific social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    string networkName
)
public IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online IEnumerable  StatisticsCounter

            The collection of statistics counters.

Implements
IMessageStatisticsManager GetStatisticsCounterNames(String)
Examples
View Colorized Copy to Clipboard Print
var counterNames = messageStatisticsManager.GetStatisticsCounterNames(networkId);
foreach (var counterName in counterNames)
{
   Console.WriteLine("Counter name: {0}, Counter display name: {1}", counterName.Name, counterName.DisplayName);
}
var counterNames = messageStatisticsManager.GetStatisticsCounterNames(networkId);
foreach (var counterName in counterNames)
{
   Console.WriteLine("Counter name: {0}, Counter display name: {1}", counterName.Name, counterName.DisplayName);
}
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
GetStatisticsCounterNames Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager.GetStatisticsCounterNames Method (Identifier)

MessageStatisticsManager GetStatisticsCounterNames Method (Identifier) Sitecore Social Connected 2.0 API
Gets the statistics counters for the specific social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    Identifier networkId
)
public IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online IEnumerable  StatisticsCounter
The collection of statistics counters.
Implements
IMessageStatisticsManager GetStatisticsCounterNames(Identifier)
Examples
View Colorized Copy to Clipboard Print
var counterNames = messageStatisticsManager.GetStatisticsCounterNames(networkId);
foreach (var counterName in counterNames)
{
   Console.WriteLine("Counter name: {0}, Counter display name: {1}", counterName.Name, counterName.DisplayName);
}
var counterNames = messageStatisticsManager.GetStatisticsCounterNames(networkId);
foreach (var counterName in counterNames)
{
   Console.WriteLine("Counter name: {0}, Counter display name: {1}", counterName.Name, counterName.DisplayName);
}
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
GetStatisticsCounterNames Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager.RefreshMessageStatistics Method

MessageStatisticsManager RefreshMessageStatistics Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | RefreshMessageStatistics(Identifier) | Refreshes message statistics.
Public method | RefreshMessageStatistics(Identifier, Boolean) | Refreshes message statistics. You can reset statistics refreshing.
Back to Top
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
Sitecore.Social.Api Namespace


MessageStatisticsManager.RefreshMessageStatistics Method (Identifier)

MessageStatisticsManager RefreshMessageStatistics Method (Identifier) Sitecore Social Connected 2.0 API
Refreshes message statistics.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RefreshMessageStatistics(
    Identifier messageId
)
public void RefreshMessageStatistics(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Implements
IMessageStatisticsManager RefreshMessageStatistics(Identifier)
Examples
View Colorized Copy to Clipboard Print
messageStatisticsManager.RefreshMessageStatistics(messageId);

var messageStatistics = messageStatisticsManager.GetMessageStatistics(messageId);

if (!messageStatistics.IsEmpty && (messageStatistics.AccountsStatistics.StatisticsStatus is UpdatedStatisticsStatus))
{
 Console.WriteLine("Account #{0} statistics is updated.", messageStatistics.AccountsStatistics.AccountId);
}
messageStatisticsManager.RefreshMessageStatistics(messageId);

var messageStatistics = messageStatisticsManager.GetMessageStatistics(messageId);

if (!messageStatistics.IsEmpty && (messageStatistics.AccountsStatistics.StatisticsStatus is UpdatedStatisticsStatus))
{
 Console.WriteLine("Account #{0} statistics is updated.", messageStatistics.AccountsStatistics.AccountId);
}
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
RefreshMessageStatistics Overload
Sitecore.Social.Api Namespace


MessageStatisticsManager.RefreshMessageStatistics Method (Identifier, Boolean)

MessageStatisticsManager RefreshMessageStatistics Method (Identifier, Boolean) Sitecore Social Connected 2.0 API
Refreshes message statistics. You can reset statistics refreshing.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RefreshMessageStatistics(
    Identifier messageId,
    bool resetStatisticsRefreshing
)
public void RefreshMessageStatistics(
    Identifier messageId,
    bool resetStatisticsRefreshing
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
resetStatisticsRefreshing
Type:   Online System Boolean
true if it needs to reset the statistics refreshing; otherwise, false.
Implements
IMessageStatisticsManager RefreshMessageStatistics(Identifier, Boolean)
Examples
View Colorized Copy to Clipboard Print
const bool ResetStatisticsRefreshing = true;
messageStatisticsManager.RefreshMessageStatistics(messageId, ResetStatisticsRefreshing);

var messageStatistics = messageStatisticsManager.GetMessageStatistics(messageId);

Console.WriteLine("A StartRefreshDate is changed: {0}", messageStatistics.StartRefreshDate);

if (!messageStatistics.IsEmpty && (messageStatistics.AccountsStatistics.StatisticsStatus is UpdatedStatisticsStatus))
{
  Console.WriteLine("Account #{0} statistics is updated.", messageStatistics.AccountsStatistics.AccountId);
}
const bool ResetStatisticsRefreshing = true;
messageStatisticsManager.RefreshMessageStatistics(messageId, ResetStatisticsRefreshing);

var messageStatistics = messageStatisticsManager.GetMessageStatistics(messageId);

Console.WriteLine("A StartRefreshDate is changed: {0}", messageStatistics.StartRefreshDate);

if (!messageStatistics.IsEmpty && (messageStatistics.AccountsStatistics.StatisticsStatus is UpdatedStatisticsStatus))
{
  Console.WriteLine("Account #{0} statistics is updated.", messageStatistics.AccountsStatistics.AccountId);
}
See Also
MessageStatisticsManager Class
MessageStatisticsManager Members
RefreshMessageStatistics Overload
Sitecore.Social.Api Namespace


NetworkManager Class

NetworkManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social networks.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api NetworkManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NetworkManager : INetworkManager
public class NetworkManager : INetworkManager
See Also
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager Members

NetworkManager Members Sitecore Social Connected 2.0 API

The NetworkManager type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkManager | Initializes a new instance of the NetworkManager class.
Public method | NetworkManager(INetworkBusinessManager) | Initializes a new instance of the NetworkManager class.
Back to Top
Methods
 | Name | Description
Public method | CanGetAccountInfo(String) | Determines whether it is possible to get a network account info.
Public method | CanGetAccountInfo(Identifier) | Determines whether it is possible to get a network account info.
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | CanRenewAccount(String) | Determines whether it is possible to renew a network account.
Public method | CanRenewAccount(Identifier) | Determines whether it is possible to renew a network account.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkManager Class
Sitecore.Social.Api Namespace


NetworkManager Constructor

NetworkManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | NetworkManager | Initializes a new instance of the NetworkManager class.
Public method | NetworkManager(INetworkBusinessManager) | Initializes a new instance of the NetworkManager class.
Back to Top
See Also
NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager Constructor

NetworkManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkManager()
public NetworkManager()
See Also
NetworkManager Class
NetworkManager Members
NetworkManager Overload
Sitecore.Social.Api Namespace


NetworkManager Constructor ()

NetworkManager Constructor () Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkManager(
    INetworkBusinessManager networkBusinessManager
)
public NetworkManager(
    INetworkBusinessManager networkBusinessManager
)
Parameters
networkBusinessManager
Type: INetworkBusinessManager
The network business manager.
See Also
NetworkManager Class
NetworkManager Members
NetworkManager Overload
Sitecore.Social.Api Namespace


NetworkManager Methods

NetworkManager Methods Sitecore Social Connected 2.0 API
The NetworkManager type exposes the following members.
Methods
 | Name | Description
Public method | CanGetAccountInfo(String) | Determines whether it is possible to get a network account info.
Public method | CanGetAccountInfo(Identifier) | Determines whether it is possible to get a network account info.
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | CanRenewAccount(String) | Determines whether it is possible to renew a network account.
Public method | CanRenewAccount(Identifier) | Determines whether it is possible to renew a network account.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkManager Class
Sitecore.Social.Api Namespace


NetworkManager.CanGetAccountInfo Method

NetworkManager CanGetAccountInfo Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CanGetAccountInfo(String) | Determines whether it is possible to get a network account info.
Public method | CanGetAccountInfo(Identifier) | Determines whether it is possible to get a network account info.
Back to Top
See Also
NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager.CanGetAccountInfo Method (String)

NetworkManager CanGetAccountInfo Method (String) Sitecore Social Connected 2.0 API
Determines whether it is possible to get a network account info.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanGetAccountInfo(
    string networkName
)
public bool CanGetAccountInfo(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name (case-sensitive).
Return Value
Type:   Online Boolean
true if it is possible to get the network account info; otherwise, false.

Remarks
false is returned, if the network is not found.
Implements
INetworkManager CanGetAccountInfo(String)
Examples
View Colorized Copy to Clipboard Print
var result = networkManager.CanGetAccountInfo("Facebook");

Console.WriteLine("Can get a network account info: {0}", result);
var result = networkManager.CanGetAccountInfo("Facebook");

Console.WriteLine("Can get a network account info: {0}", result);
See Also
NetworkManager Class
NetworkManager Members
CanGetAccountInfo Overload
Sitecore.Social.Api Namespace


NetworkManager.CanGetAccountInfo Method (Identifier)

NetworkManager CanGetAccountInfo Method (Identifier) Sitecore Social Connected 2.0 API
Determines whether it is possible to get a network account info.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanGetAccountInfo(
    Identifier networkId
)
public bool CanGetAccountInfo(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online Boolean
true if it is possible to get the network account info; otherwise, false.

Remarks
false is returned, if the network is not found.
Implements
INetworkManager CanGetAccountInfo(Identifier)
Examples
View Colorized Copy to Clipboard Print
var result = networkManager.CanGetAccountInfo(facebookId);

Console.WriteLine("Can get a network account info: {0}", result);
var result = networkManager.CanGetAccountInfo(facebookId);

Console.WriteLine("Can get a network account info: {0}", result);
See Also
NetworkManager Class
NetworkManager Members
CanGetAccountInfo Overload
Sitecore.Social.Api Namespace


NetworkManager.CanPostTo Method

NetworkManager CanPostTo Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Back to Top
See Also
NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager.CanPostTo Method (String)

NetworkManager CanPostTo Method (String) Sitecore Social Connected 2.0 API
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanPostTo(
    string networkName
)
public bool CanPostTo(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online Boolean
true if it is possible to post messages to the network; otherwise, false.

Remarks
false is returned, if the network is not found.
Implements
INetworkManager CanPostTo(String)
Examples
View Colorized Copy to Clipboard Print
var result = networkManager.CanPostTo("Facebook");

Console.WriteLine("Can post to network: {0}", result);
var result = networkManager.CanPostTo("Facebook");

Console.WriteLine("Can post to network: {0}", result);
See Also
NetworkManager Class
NetworkManager Members
CanPostTo Overload
Sitecore.Social.Api Namespace


NetworkManager.CanPostTo Method (Identifier)

NetworkManager CanPostTo Method (Identifier) Sitecore Social Connected 2.0 API
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanPostTo(
    Identifier networkId
)
public bool CanPostTo(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online Boolean
true if it is possible to post messages to the network; otherwise, false.

Remarks
false is returned, if the network is not found.
Implements
INetworkManager CanPostTo(Identifier)
Examples
View Colorized Copy to Clipboard Print
var result = networkManager.CanPostTo(facebookId);

Console.WriteLine("Can post to network: {0}", result);
var result = networkManager.CanPostTo(facebookId);

Console.WriteLine("Can post to network: {0}", result);
See Also
NetworkManager Class
NetworkManager Members
CanPostTo Overload
Sitecore.Social.Api Namespace


NetworkManager.CanRenewAccount Method

NetworkManager CanRenewAccount Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CanRenewAccount(String) | Determines whether it is possible to renew a network account.
Public method | CanRenewAccount(Identifier) | Determines whether it is possible to renew a network account.
Back to Top
See Also
NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager.CanRenewAccount Method (String)

NetworkManager CanRenewAccount Method (String) Sitecore Social Connected 2.0 API
Determines whether it is possible to renew a network account.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanRenewAccount(
    string networkName
)
public bool CanRenewAccount(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name (case-sensitive).
Return Value
Type:   Online Boolean
true if it is possible to renew the network account; otherwise, false.

Remarks
false is returned, if the network is not found.
Implements
INetworkManager CanRenewAccount(String)
Examples
View Colorized Copy to Clipboard Print
var result = networkManager.CanRenewAccount("Facebook");

Console.WriteLine("Can renew network account: {0}", result);
var result = networkManager.CanRenewAccount("Facebook");

Console.WriteLine("Can renew network account: {0}", result);
See Also
NetworkManager Class
NetworkManager Members
CanRenewAccount Overload
Sitecore.Social.Api Namespace


NetworkManager.CanRenewAccount Method (Identifier)

NetworkManager CanRenewAccount Method (Identifier) Sitecore Social Connected 2.0 API
Determines whether it is possible to renew a network account.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CanRenewAccount(
    Identifier networkId
)
public bool CanRenewAccount(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online Boolean
true if it is possible to renew the network account; otherwise, false.

Remarks
false is returned, if the network is not found.
Implements
INetworkManager CanRenewAccount(Identifier)
Examples
View Colorized Copy to Clipboard Print
var result = networkManager.CanRenewAccount(facebookId);

Console.WriteLine("Can renew network account: {0}", result);
var result = networkManager.CanRenewAccount(facebookId);

Console.WriteLine("Can renew network account: {0}", result);
See Also
NetworkManager Class
NetworkManager Members
CanRenewAccount Overload
Sitecore.Social.Api Namespace


NetworkManager.GetNetwork Method

NetworkManager GetNetwork Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Back to Top
See Also
NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


NetworkManager.GetNetwork Method (String)

NetworkManager GetNetwork Method (String) Sitecore Social Connected 2.0 API
Gets a network by name.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network GetNetwork(
    string networkName
)
public Network GetNetwork(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network (case-sensitive).
Return Value
Type: Network
The network. If the network is not found Empty is returned.
Implements
INetworkManager GetNetwork(String)
Examples
View Colorized Copy to Clipboard Print
var facebookNetwork = networkManager.GetNetwork("Facebook");
if (!facebookNetwork.IsEmpty)
{
  this.ShowNetwork(facebookNetwork);
}
var facebookNetwork = networkManager.GetNetwork("Facebook");
if (!facebookNetwork.IsEmpty)
{
  this.ShowNetwork(facebookNetwork);
}
See Also
NetworkManager Class
NetworkManager Members
GetNetwork Overload
Sitecore.Social.Api Namespace


NetworkManager.GetNetwork Method (Identifier)

NetworkManager GetNetwork Method (Identifier) Sitecore Social Connected 2.0 API
Gets a network by id.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network GetNetwork(
    Identifier networkId
)
public Network GetNetwork(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
Id of the network.
Return Value
Type: Network
The network. If the network is not found Empty is returned.
Implements
INetworkManager GetNetwork(Identifier)
Examples
View Colorized Copy to Clipboard Print
var facebookNetwork = networkManager.GetNetwork(facebookNetworkId);
if (!facebookNetwork.IsEmpty)
{
  this.ShowNetwork(facebookNetwork);
}
var facebookNetwork = networkManager.GetNetwork(facebookNetworkId);
if (!facebookNetwork.IsEmpty)
{
  this.ShowNetwork(facebookNetwork);
}
See Also
NetworkManager Class
NetworkManager Members
GetNetwork Overload
Sitecore.Social.Api Namespace


NetworkManager.GetNetworks Method

NetworkManager GetNetworks Method Sitecore Social Connected 2.0 API
Gets all registered networks.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Network> GetNetworks()
public IEnumerable<Network> GetNetworks()
Return Value
Type:   Online IEnumerable  Network
The network list. If there are no networks, an empty list is returned.
Implements
INetworkManager GetNetworks
Examples
View Colorized Copy to Clipboard Print
var networks = networkManager.GetNetworks();

foreach (var network in networks)
{
  this.ShowNetwork(network);
}
var networks = networkManager.GetNetworks();

foreach (var network in networks)
{
  this.ShowNetwork(network);
}
See Also
NetworkManager Class
NetworkManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager Class

PostingPreferenceManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to manage user’s posting preferences.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api PostingPreferenceManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PostingPreferenceManager : IPostingPreferenceManager
public class PostingPreferenceManager : IPostingPreferenceManager
Remarks

            Use it to manage posting preferences of the website visitors (whether or not they want messages to be posted automatically
            on their social network walls, for example, when you have configured Sitecore to post messages to the social network when
            a visitor achieves a goal on the website).

See Also
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager Members

PostingPreferenceManager Members Sitecore Social Connected 2.0 API

The PostingPreferenceManager type exposes the following members.
Constructors
 | Name | Description
Public method | PostingPreferenceManager | Initializes a new instance of the PostingPreferenceManager class.
Public method | PostingPreferenceManager(IPostingPreferenceBusinessManager, IMessageManager) | Initializes a new instance of the PostingPreferenceManager class.
Back to Top
Methods
 | Name | Description
Public method | AllowAutomaticPosting | Allows automatic message posting.
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
Public method | GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all messages attached to the specific container.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
Public method | SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences for all messages attached to the specific container.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingPreferenceManager Class
Sitecore.Social.Api Namespace


PostingPreferenceManager Constructor

PostingPreferenceManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | PostingPreferenceManager | Initializes a new instance of the PostingPreferenceManager class.
Public method | PostingPreferenceManager(IPostingPreferenceBusinessManager, IMessageManager) | Initializes a new instance of the PostingPreferenceManager class.
Back to Top
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager Constructor

PostingPreferenceManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingPreferenceManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingPreferenceManager()
public PostingPreferenceManager()
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
PostingPreferenceManager Overload
Sitecore.Social.Api Namespace


PostingPreferenceManager Constructor (, IMessageManager)

PostingPreferenceManager Constructor (, IMessageManager) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingPreferenceManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingPreferenceManager(
    IPostingPreferenceBusinessManager postingPreferenceBusinessManager,
    IMessageManager messageManager
)
public PostingPreferenceManager(
    IPostingPreferenceBusinessManager postingPreferenceBusinessManager,
    IMessageManager messageManager
)
Parameters
postingPreferenceBusinessManager
Type: IPostingPreferenceBusinessManager
The posting preference business manager.
messageManager
Type: Sitecore.Social.Domain IMessageManager
The message manager.
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
PostingPreferenceManager Overload
Sitecore.Social.Api Namespace


PostingPreferenceManager Methods

PostingPreferenceManager Methods Sitecore Social Connected 2.0 API
The PostingPreferenceManager type exposes the following members.
Methods
 | Name | Description
Public method | AllowAutomaticPosting | Allows automatic message posting.
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
Public method | GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all messages attached to the specific container.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
Public method | SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences for all messages attached to the specific container.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingPreferenceManager Class
Sitecore.Social.Api Namespace


PostingPreferenceManager.AllowAutomaticPosting Method

PostingPreferenceManager AllowAutomaticPosting Method Sitecore Social Connected 2.0 API
Allows automatic message posting.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllowAutomaticPosting(
    Identifier messageId,
    IPrincipal user
)
public bool AllowAutomaticPosting(
    Identifier messageId,
    IPrincipal user
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
user
Type:   Online System.Security.Principal IPrincipal
The user.
Return Value
Type:   Online Boolean
true if automatic posting is allowed, otherwise false.
Implements
IPostingPreferenceManager AllowAutomaticPosting(Identifier, IPrincipal)
Exceptions
Exception | Condition
Online System NotSupportedException | AutomaticPostingPreference is not supported
Examples
View Colorized Copy to Clipboard Print
var allowAutomaticPosting = postingPreferenceManager.AllowAutomaticPosting(messageId, user);

Console.WriteLine("Allow automatic posting: {0}", allowAutomaticPosting);
var allowAutomaticPosting = postingPreferenceManager.AllowAutomaticPosting(messageId, user);

Console.WriteLine("Allow automatic posting: {0}", allowAutomaticPosting);
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager.AllowAutomaticPostingByDefault Method

PostingPreferenceManager AllowAutomaticPostingByDefault Method Sitecore Social Connected 2.0 API
Determines if automatic posting is allowed by default.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllowAutomaticPostingByDefault()
public bool AllowAutomaticPostingByDefault()
Return Value
Type:   Online Boolean
true if automatic posting is allowed by default, otherwise false.

Implements
IPostingPreferenceManager AllowAutomaticPostingByDefault
Remarks

             The value is set in the [website_root]\app_config\include\sitecore.social.config file, in the "Social.AllowMessagePostingByDefault" setting

Examples
View Colorized Copy to Clipboard Print
var allowAutomaticPostingByDefault = postingPreferenceManager.AllowAutomaticPostingByDefault();

Console.WriteLine("Allow automatic posting by default: {0}", allowAutomaticPostingByDefault);
var allowAutomaticPostingByDefault = postingPreferenceManager.AllowAutomaticPostingByDefault();

Console.WriteLine("Allow automatic posting by default: {0}", allowAutomaticPostingByDefault);
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager.GetPostingPreference Method

PostingPreferenceManager GetPostingPreference Method Sitecore Social Connected 2.0 API
Gets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingPreference GetPostingPreference(
    IPrincipal user,
    Identifier messageId
)
public PostingPreference GetPostingPreference(
    IPrincipal user,
    Identifier messageId
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: PostingPreference

             The posting preference. If the posting preference is not found the Default value is used.

Implements
IPostingPreferenceManager GetPostingPreference(IPrincipal, Identifier)
Exceptions
Exception | Condition
Online System NotSupportedException | Automatic posting preference is not supported.
Examples
View Colorized Copy to Clipboard Print
var postingPreference = postingPreferenceManager.GetPostingPreference(user, messageId);

Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
var postingPreference = postingPreferenceManager.GetPostingPreference(user, messageId);

Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace
PostingPreference AutomaticPostingPreference
UserExtensions GetPostingPreference(IPrincipal, Identifier)


PostingPreferenceManager.GetPostingPreferences Method

PostingPreferenceManager GetPostingPreferences Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
Public method | GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all messages attached to the specific container.
Back to Top
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager.GetPostingPreferences Method (IPrincipal, PostingConfigurationSearchArgs)

PostingPreferenceManager GetPostingPreferences Method (IPrincipal, PostingConfigurationSearchArgs) Sitecore Social Connected 2.0 API
Gets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.PostingPreferenceManager.GetPostingPreferences(IPrincipal, string)",
    false)]
public IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.PostingPreferenceManager.GetPostingPreferences(IPrincipal, string)",
    false)]
public IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search arguments.
Return Value
Type:   Online IEnumerable  PostingPreference

             The posting preference list. If no preferences are found an empty list is returned.

Implements
IPostingPreferenceManager GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs)
Exceptions
Exception | Condition
Online System NotSupportedException | Automatic posting preference is not supported.
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

var postingPreferences = postingPreferenceManager.GetPostingPreferences(user, searchArgs);

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

var postingPreferences = postingPreferenceManager.GetPostingPreferences(user, searchArgs);

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
GetPostingPreferences Overload
Sitecore.Social.Api Namespace
UserExtensions GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs)


PostingPreferenceManager.GetPostingPreferences Method (IPrincipal, String)

PostingPreferenceManager GetPostingPreferences Method (IPrincipal, String) Sitecore Social Connected 2.0 API
Gets user's posting preferences for all messages attached to the specific container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    string container
)
public IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    string container
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
container
Type:   Online System String
The container.
Return Value
Type:   Online IEnumerable  PostingPreference

             The posting preference list. If no preferences are found an empty list is returned.

Implements
IPostingPreferenceManager GetPostingPreferences(IPrincipal, String)
Exceptions
Exception | Condition
Online System NotSupportedException | Automatic posting preference is not supported.
Examples
View Colorized Copy to Clipboard Print
var postingPreferences = postingPreferenceManager.GetPostingPreferences(user, "sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
var postingPreferences = postingPreferenceManager.GetPostingPreferences(user, "sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
GetPostingPreferences Overload
Sitecore.Social.Api Namespace
UserExtensions GetPostingPreferences(IPrincipal, String)


PostingPreferenceManager.SetPostingPreference Method

PostingPreferenceManager SetPostingPreference Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
Public method | SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences for all messages attached to the specific container.
Back to Top
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
Sitecore.Social.Api Namespace


PostingPreferenceManager.SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)

PostingPreferenceManager SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to the specific message.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetPostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
public void SetPostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
Implements
IPostingPreferenceManager SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference)
Exceptions
Exception | Condition
Online System Exception | Message is not found.
Online System Exception | Invalid message template.
Online System Exception | Unable to set preference to the anonymous user.
Online System NotSupportedException | Automatic posting preference is not supported.
Examples
View Colorized Copy to Clipboard Print
postingPreferenceManager.SetPostingPreference(user, messageId, AutomaticPostingPreference.Denied);
postingPreferenceManager.SetPostingPreference(user, messageId, AutomaticPostingPreference.Denied);
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
SetPostingPreference Overload
Sitecore.Social.Api Namespace
UserExtensions SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference)


PostingPreferenceManager.SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

PostingPreferenceManager SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to all the messages found by arguments.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.PostingPreferenceManager.GetPostingPreferences(IPrincipal, string, AutomaticPostingPreference)",
    false)]
public void SetPostingPreference(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.PostingPreferenceManager.GetPostingPreferences(IPrincipal, string, AutomaticPostingPreference)",
    false)]
public void SetPostingPreference(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
Implements
IPostingPreferenceManager SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)
Exceptions
Exception | Condition
Online System Exception | Unable to set preference to the anonymous user.
Online System NotSupportedException | Automatic posting preference is not supported.
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

postingPreferenceManager.SetPostingPreference(user, searchArgs, AutomaticPostingPreference.Denied);
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

postingPreferenceManager.SetPostingPreference(user, searchArgs, AutomaticPostingPreference.Denied);
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
SetPostingPreference Overload
Sitecore.Social.Api Namespace
UserExtensions SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)


PostingPreferenceManager.SetPostingPreference Method (IPrincipal, String, AutomaticPostingPreference)

PostingPreferenceManager SetPostingPreference Method (IPrincipal, String, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences for all messages attached to the specific container.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetPostingPreference(
    IPrincipal user,
    string container,
    AutomaticPostingPreference automaticPostingPreference
)
public void SetPostingPreference(
    IPrincipal user,
    string container,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
container
Type:   Online System String
The container.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
Implements
IPostingPreferenceManager SetPostingPreference(IPrincipal, String, AutomaticPostingPreference)
Exceptions
Exception | Condition
Online System Exception | Unable to set preference to the anonymous user.
Online System NotSupportedException | Automatic posting preference is not supported.
Examples
View Colorized Copy to Clipboard Print
postingPreferenceManager.SetPostingPreference(user, "sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1", AutomaticPostingPreference.Denied);
postingPreferenceManager.SetPostingPreference(user, "sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1", AutomaticPostingPreference.Denied);
See Also
PostingPreferenceManager Class
PostingPreferenceManager Members
SetPostingPreference Overload
Sitecore.Social.Api Namespace
UserExtensions SetPostingPreference(IPrincipal, String, AutomaticPostingPreference)


SocialProfileManager Class

SocialProfileManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to manage a social profile.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api SocialProfileManager

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SocialProfileManager : ISocialProfileManager
public class SocialProfileManager : ISocialProfileManager
See Also
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager Members

SocialProfileManager Members Sitecore Social Connected 2.0 API

The SocialProfileManager type exposes the following members.
Constructors
 | Name | Description
Public method | SocialProfileManager | Initializes a new instance of the SocialProfileManager class.
Public method | SocialProfileManager(ISocialProfileBusinessManager) | Initializes a new instance of the SocialProfileManager class.
Back to Top
Methods
 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSocialProfile | Gets a social profile.
Public method | GetSocialProfiles | Gets social profiles.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSocialProfileExists | Obsolete. Checks if a social profile exists.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RefreshSocialProfile(IPrincipal, String) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfile(IPrincipal, String, Boolean) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfiles(IPrincipal, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RefreshSocialProfiles(IPrincipal, Boolean, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | SocialProfileExists | Defines if there is a social profile in the specified network.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UpdateSocialProfile | Updates a social profile of the specified user.
Back to Top
See Also
SocialProfileManager Class
Sitecore.Social.Api Namespace


SocialProfileManager Constructor

SocialProfileManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | SocialProfileManager | Initializes a new instance of the SocialProfileManager class.
Public method | SocialProfileManager(ISocialProfileBusinessManager) | Initializes a new instance of the SocialProfileManager class.
Back to Top
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager Constructor

SocialProfileManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialProfileManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialProfileManager()
public SocialProfileManager()
See Also
SocialProfileManager Class
SocialProfileManager Members
SocialProfileManager Overload
Sitecore.Social.Api Namespace


SocialProfileManager Constructor ()

SocialProfileManager Constructor () Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialProfileManager class.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialProfileManager(
    ISocialProfileBusinessManager socialProfileBusinessManager
)
public SocialProfileManager(
    ISocialProfileBusinessManager socialProfileBusinessManager
)
Parameters
socialProfileBusinessManager
Type: ISocialProfileBusinessManager

            The social profile business manager.

See Also
SocialProfileManager Class
SocialProfileManager Members
SocialProfileManager Overload
Sitecore.Social.Api Namespace


SocialProfileManager Methods

SocialProfileManager Methods Sitecore Social Connected 2.0 API
The SocialProfileManager type exposes the following members.
Methods
 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSocialProfile | Gets a social profile.
Public method | GetSocialProfiles | Gets social profiles.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSocialProfileExists | Obsolete. Checks if a social profile exists.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RefreshSocialProfile(IPrincipal, String) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfile(IPrincipal, String, Boolean) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfiles(IPrincipal, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RefreshSocialProfiles(IPrincipal, Boolean, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | SocialProfileExists | Defines if there is a social profile in the specified network.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UpdateSocialProfile | Updates a social profile of the specified user.
Back to Top
See Also
SocialProfileManager Class
Sitecore.Social.Api Namespace


SocialProfileManager.AttachSocialProfile Method

SocialProfileManager AttachSocialProfile Method Sitecore Social Connected 2.0 API
Attaches a social profile to the specified user.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AttachSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
public void AttachSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

socialProfile
Type: Sitecore.Social.Domain.Model SocialProfile

            The social profile.

Implements
ISocialProfileManager AttachSocialProfile(IPrincipal, SocialProfile)
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountInUserDuplicatedException] | Following user already has another attached account of the same network.
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountInDomainDuplicatedException] | There is another user with the same account in domain.
Examples
View Colorized Copy to Clipboard Print
try
{
  var facebookProfile = new SocialProfile
  {
    AccountCredentials = new AccountCredentials
    {
      AccessToken = "239842+-02399==",
      AccessTokenSecret = "8282271371232=-29382855"
    },
    Email = "john.smith@fakedomain.com",
    FullName = "John Smith",
    NetworkAccountId = "888127718888463",
    ApplicationCredentials = new ApplicationCredentials
    {
      ApplicationKey = "jkdsf90392===399",
      ApplicationSecret = "128281--==39939"
    },
    NetworkName = "Facebook",
    Fields = new Dictionary<string, string>
    {
      {
        "timezone", "UTC+8"
      },
      {
        "gender", "male"
      }
    }
  };

  socialProfileManager.AttachSocialProfile(user, facebookProfile);
  this.ShowSocialProfile(facebookProfile);
}
catch (AccountInUserDuplicatedException)
{
  // Following user already has another attached account of the same network.
}
catch (AccountInDomainDuplicatedException)
{
  // There is another user with the same account in domain.
}
try
{
  var facebookProfile = new SocialProfile
  {
    AccountCredentials = new AccountCredentials
    {
      AccessToken = "239842+-02399==",
      AccessTokenSecret = "8282271371232=-29382855"
    },
    Email = "john.smith@fakedomain.com",
    FullName = "John Smith",
    NetworkAccountId = "888127718888463",
    ApplicationCredentials = new ApplicationCredentials
    {
      ApplicationKey = "jkdsf90392===399",
      ApplicationSecret = "128281--==39939"
    },
    NetworkName = "Facebook",
    Fields = new Dictionary<string, string>
    {
      {
        "timezone", "UTC+8"
      },
      {
        "gender", "male"
      }
    }
  };

  socialProfileManager.AttachSocialProfile(user, facebookProfile);
  this.ShowSocialProfile(facebookProfile);
}
catch (AccountInUserDuplicatedException)
{
  // Following user already has another attached account of the same network.
}
catch (AccountInDomainDuplicatedException)
{
  // There is another user with the same account in domain.
}
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.DetachSocialProfile Method

SocialProfileManager DetachSocialProfile Method Sitecore Social Connected 2.0 API
Removes a social profile from the specified user.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DetachSocialProfile(
    IPrincipal user,
    string networkName
)
public void DetachSocialProfile(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Implements
ISocialProfileManager DetachSocialProfile(IPrincipal, String)
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountIsNotExistException] | Following user has not account in this network.
Examples
View Colorized Copy to Clipboard Print
try
{
  socialProfileManager.DetachSocialProfile(user, "Facebook");
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
try
{
  socialProfileManager.DetachSocialProfile(user, "Facebook");
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.GetSocialProfile Method

SocialProfileManager GetSocialProfile Method Sitecore Social Connected 2.0 API
Gets a social profile.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialProfile GetSocialProfile(
    IPrincipal user,
    string networkName
)
public SocialProfile GetSocialProfile(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type: SocialProfile

            The social profile. If there are no profiles, an empty profile is returned.

Implements
ISocialProfileManager GetSocialProfile(IPrincipal, String)
Examples
View Colorized Copy to Clipboard Print
var facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");

if (!facebookSocialProfile.IsEmpty)
{
  this.ShowSocialProfile(facebookSocialProfile);
}
var facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");

if (!facebookSocialProfile.IsEmpty)
{
  this.ShowSocialProfile(facebookSocialProfile);
}
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.GetSocialProfiles Method

SocialProfileManager GetSocialProfiles Method Sitecore Social Connected 2.0 API
Gets social profiles.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SocialProfile> GetSocialProfiles(
    IPrincipal user
)
public IEnumerable<SocialProfile> GetSocialProfiles(
    IPrincipal user
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

Return Value
Type:   Online IEnumerable  SocialProfile

            The list of social profiles.

Implements
ISocialProfileManager GetSocialProfiles(IPrincipal)
Examples
View Colorized Copy to Clipboard Print
var socialProfiles = socialProfileManager.GetSocialProfiles(user);

foreach (var socialProfile in socialProfiles)
{
  this.ShowSocialProfile(socialProfile);
}
var socialProfiles = socialProfileManager.GetSocialProfiles(user);

foreach (var socialProfile in socialProfiles)
{
  this.ShowSocialProfile(socialProfile);
}
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.IsSocialProfileExists Method

SocialProfileManager IsSocialProfileExists Method Sitecore Social Connected 2.0 API
Checks if a social profile exists.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.SocialProfileManager.SocialProfileExists",
    true)]
public bool IsSocialProfileExists(
    IPrincipal user,
    string networkName
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.SocialProfileManager.SocialProfileExists",
    true)]
public bool IsSocialProfileExists(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type:   Online Boolean
true if the social profile exists; otherwise, false.

Implements
ISocialProfileManager IsSocialProfileExists(IPrincipal, String)
Examples
View Colorized Copy to Clipboard Print
var result = socialProfileManager.IsSocialProfileExists(user, "Facebook");

Console.WriteLine("The social profile exists: {0}", result);
var result = socialProfileManager.IsSocialProfileExists(user, "Facebook");

Console.WriteLine("The social profile exists: {0}", result);
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.RefreshSocialProfile Method

SocialProfileManager RefreshSocialProfile Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | RefreshSocialProfile(IPrincipal, String) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfile(IPrincipal, String, Boolean) | Refreshes the social profile attached to a user from the specified network.
Back to Top
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.RefreshSocialProfile Method (IPrincipal, String)

SocialProfileManager RefreshSocialProfile Method (IPrincipal, String) Sitecore Social Connected 2.0 API
Refreshes the social profile attached to a user from the specified network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RefreshSocialProfile(
    IPrincipal user,
    string networkName
)
public void RefreshSocialProfile(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
networkName
Type:   Online System String
The network name.
Implements
ISocialProfileManager RefreshSocialProfile(IPrincipal, String)
Remarks

            The expiration configuration of the social profile will be ignored and the social profile will be refreshed in any case.

Examples
View Colorized Copy to Clipboard Print
if (socialProfileManager.SocialProfileExists(user, "Facebook"))
{
  socialProfileManager.RefreshSocialProfile(user, "Facebook");
  this.ShowSocialProfile(socialProfileManager.GetSocialProfile(user, "Facebook"));
}
if (socialProfileManager.SocialProfileExists(user, "Facebook"))
{
  socialProfileManager.RefreshSocialProfile(user, "Facebook");
  this.ShowSocialProfile(socialProfileManager.GetSocialProfile(user, "Facebook"));
}
See Also
SocialProfileManager Class
SocialProfileManager Members
RefreshSocialProfile Overload
Sitecore.Social.Api Namespace


SocialProfileManager.RefreshSocialProfile Method (IPrincipal, String, Boolean)

SocialProfileManager RefreshSocialProfile Method (IPrincipal, String, Boolean) Sitecore Social Connected 2.0 API
Refreshes the social profile attached to a user from the specified network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RefreshSocialProfile(
    IPrincipal user,
    string networkName,
    bool refreshAsync
)
public void RefreshSocialProfile(
    IPrincipal user,
    string networkName,
    bool refreshAsync
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
networkName
Type:   Online System String
The network name.
refreshAsync
Type:   Online System Boolean
if set to true the social profile will be refreshed asynchronously.
Implements
ISocialProfileManager RefreshSocialProfile(IPrincipal, String, Boolean)
Remarks

            The expiration configuration of the social profile will be ignored and the social profile will be refreshed in any case.

Examples
View Colorized Copy to Clipboard Print
if (socialProfileManager.SocialProfileExists(user, "Facebook"))
{
  socialProfileManager.RefreshSocialProfile(user, "Facebook", true);
}
if (socialProfileManager.SocialProfileExists(user, "Facebook"))
{
  socialProfileManager.RefreshSocialProfile(user, "Facebook", true);
}
See Also
SocialProfileManager Class
SocialProfileManager Members
RefreshSocialProfile Overload
Sitecore.Social.Api Namespace


SocialProfileManager.RefreshSocialProfiles Method

SocialProfileManager RefreshSocialProfiles Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | RefreshSocialProfiles(IPrincipal, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RefreshSocialProfiles(IPrincipal, Boolean, Boolean) | Refreshes all social profiles attached to a user from social networks.
Back to Top
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.RefreshSocialProfiles Method (IPrincipal, Boolean)

SocialProfileManager RefreshSocialProfiles Method (IPrincipal, Boolean) Sitecore Social Connected 2.0 API
Refreshes all social profiles attached to a user from social networks.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync
)
public void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
refreshAsync
Type:   Online System Boolean
if set to true the social profiles will be refreshed asynchronously.
Implements
ISocialProfileManager RefreshSocialProfiles(IPrincipal, Boolean)
Remarks

             Only expired social profiles will be refreshed.
             The expiration configuration is defined in "Social.ProfileUpdating.DaysUserProfileExpiration" setting.

Examples
View Colorized Copy to Clipboard Print
socialProfileManager.RefreshSocialProfiles(user, false);

foreach (var socialProfile in socialProfileManager.GetSocialProfiles(user))
{
  this.ShowSocialProfile(socialProfile);
}
socialProfileManager.RefreshSocialProfiles(user, false);

foreach (var socialProfile in socialProfileManager.GetSocialProfiles(user))
{
  this.ShowSocialProfile(socialProfile);
}
See Also
SocialProfileManager Class
SocialProfileManager Members
RefreshSocialProfiles Overload
Sitecore.Social.Api Namespace


SocialProfileManager.RefreshSocialProfiles Method (IPrincipal, Boolean, Boolean)

SocialProfileManager RefreshSocialProfiles Method (IPrincipal, Boolean, Boolean) Sitecore Social Connected 2.0 API
Refreshes all social profiles attached to a user from social networks.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync,
    bool forceRefresh
)
public void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync,
    bool forceRefresh
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
refreshAsync
Type:   Online System Boolean
if set to true the social profiles will be refreshed asynchronously.
forceRefresh
Type:   Online System Boolean
if set to true the expiration configuration of the social profile will be ignored and the social profiles will be refreshed in any case.
Implements
ISocialProfileManager RefreshSocialProfiles(IPrincipal, Boolean, Boolean)
Examples
View Colorized Copy to Clipboard Print
socialProfileManager.RefreshSocialProfiles(user, false, true);

foreach (var socialProfile in socialProfileManager.GetSocialProfiles(user))
{
  this.ShowSocialProfile(socialProfile);
}
socialProfileManager.RefreshSocialProfiles(user, false, true);

foreach (var socialProfile in socialProfileManager.GetSocialProfiles(user))
{
  this.ShowSocialProfile(socialProfile);
}
See Also
SocialProfileManager Class
SocialProfileManager Members
RefreshSocialProfiles Overload
Sitecore.Social.Api Namespace


SocialProfileManager.RetrieveSocialProfile Method

SocialProfileManager RetrieveSocialProfile Method Sitecore Social Connected 2.0 API
Retrieves a social profile from the social network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialProfile RetrieveSocialProfile(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials
)
public SocialProfile RetrieveSocialProfile(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials
)
Parameters
networkName
Type:   Online System String
The name of the network (case-sensitive).
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
Return Value
Type: SocialProfile

             The social profile. If the request couldn't be executed, an Empty is returned.

Implements
ISocialProfileManager RetrieveSocialProfile(String, ApplicationCredentials, AccountCredentials)
Exceptions
Exception | Condition
Online System InvalidCastException | The network provider is not implemented IGetAccountInfo interface.
Examples
View Colorized Copy to Clipboard Print
if (!socialProfileManager.SocialProfileExists(user, "Facebook"))
{
  var applicationCredentials = new ApplicationCredentials
  {
    ApplicationKey = "sdhjkfvskdwe0001-23-=3",
    ApplicationSecret = "212dujjdasnkjdna38383"
  };

  var accountCredentials = new AccountCredentials
  {
    AccessToken = "nnvxmncvmzxcv,sdd002-304",
    AccessTokenSecret = "213980f90fsdfjhwqjwqeru093--1=2039="
  };

  var socialProfile = socialProfileManager.RetrieveSocialProfile("Facebook", applicationCredentials, accountCredentials);

  if (!socialProfile.IsEmpty)
  {
    socialProfileManager.AttachSocialProfile(user, socialProfile);

    this.ShowSocialProfile(socialProfile);
  }
}
if (!socialProfileManager.SocialProfileExists(user, "Facebook"))
{
  var applicationCredentials = new ApplicationCredentials
  {
    ApplicationKey = "sdhjkfvskdwe0001-23-=3",
    ApplicationSecret = "212dujjdasnkjdna38383"
  };

  var accountCredentials = new AccountCredentials
  {
    AccessToken = "nnvxmncvmzxcv,sdd002-304",
    AccessTokenSecret = "213980f90fsdfjhwqjwqeru093--1=2039="
  };

  var socialProfile = socialProfileManager.RetrieveSocialProfile("Facebook", applicationCredentials, accountCredentials);

  if (!socialProfile.IsEmpty)
  {
    socialProfileManager.AttachSocialProfile(user, socialProfile);

    this.ShowSocialProfile(socialProfile);
  }
}
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.SocialProfileExists Method

SocialProfileManager SocialProfileExists Method Sitecore Social Connected 2.0 API
Defines if there is a social profile in the specified network.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SocialProfileExists(
    IPrincipal user,
    string networkName
)
public bool SocialProfileExists(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online Boolean
true if the social profile exists; otherwise, false.

Implements
ISocialProfileManager SocialProfileExists(IPrincipal, String)
Examples
View Colorized Copy to Clipboard Print
var result = socialProfileManager.SocialProfileExists(user, "Facebook");

Console.WriteLine("The social profile exists: {0}", result);
var result = socialProfileManager.SocialProfileExists(user, "Facebook");

Console.WriteLine("The social profile exists: {0}", result);
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


SocialProfileManager.UpdateSocialProfile Method

SocialProfileManager UpdateSocialProfile Method Sitecore Social Connected 2.0 API
Updates a social profile of the specified user.

Namespace: Sitecore.Social.Api
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UpdateSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
public void UpdateSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

socialProfile
Type: Sitecore.Social.Domain.Model SocialProfile

            The social profile.

Implements
ISocialProfileManager UpdateSocialProfile(IPrincipal, SocialProfile)
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountIsNotExistException] | Following user has not account in this network.
Examples
View Colorized Copy to Clipboard Print
try
{
  var facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");

  if (!facebookSocialProfile.IsEmpty)
  {
    facebookSocialProfile.Email = facebookSocialProfile.Email + "updated";
    socialProfileManager.UpdateSocialProfile(user, facebookSocialProfile);
  }

  facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");
  this.ShowSocialProfile(facebookSocialProfile);
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
try
{
  var facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");

  if (!facebookSocialProfile.IsEmpty)
  {
    facebookSocialProfile.Email = facebookSocialProfile.Email + "updated";
    socialProfileManager.UpdateSocialProfile(user, facebookSocialProfile);
  }

  facebookSocialProfile = socialProfileManager.GetSocialProfile(user, "Facebook");
  this.ShowSocialProfile(facebookSocialProfile);
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
See Also
SocialProfileManager Class
SocialProfileManager Members
Sitecore.Social.Api Namespace


Sitecore.Social.Api.Extensions Namespace

Sitecore.Social.Api.Extensions Namespace Sitecore Social Connected 2.0 API
Provides a set of extension classes.
Classes
 | Class | Description
Public class | UserExtensions | Provides a set of static methods that are used to get extended user information.


UserExtensions Class

UserExtensions Class Sitecore Social Connected 2.0 API
Provides a set of static methods that are used to get extended user information.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Api.Extensions UserExtensions

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class UserExtensions
public static class UserExtensions
See Also
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions Members

UserExtensions Members Sitecore Social Connected 2.0 API

The UserExtensions type exposes the following members.
Methods
Name | Description
AttachSocialProfile | Attaches a social profile to the specified user.
DetachSocialProfile | Removes a social profile from the specified user.
GetPostingPreference | Gets user's posting preferences for the specific message.
GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all the messages attached to the specific container.
GetSocialProfile | Gets a social profile of the user in the specified network.
GetSocialProfiles | Gets all social profiles of the user.
IsSocialProfileExists | Obsolete. Defines if there is a social profile in the specified network.
SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences to all the messages found by arguments.
SocialProfileExists | Defines if there is a social profile in the specified network.
UpdateSocialProfile | Updates a social profile of the specified user.
Back to Top
See Also
UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


UserExtensions Methods

UserExtensions Methods Sitecore Social Connected 2.0 API
The UserExtensions type exposes the following members.
Methods
Name | Description
AttachSocialProfile | Attaches a social profile to the specified user.
DetachSocialProfile | Removes a social profile from the specified user.
GetPostingPreference | Gets user's posting preferences for the specific message.
GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all the messages attached to the specific container.
GetSocialProfile | Gets a social profile of the user in the specified network.
GetSocialProfiles | Gets all social profiles of the user.
IsSocialProfileExists | Obsolete. Defines if there is a social profile in the specified network.
SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences to all the messages found by arguments.
SocialProfileExists | Defines if there is a social profile in the specified network.
UpdateSocialProfile | Updates a social profile of the specified user.
Back to Top
See Also
UserExtensions Class
Sitecore.Social.Api.Extensions Namespace


UserExtensions.AttachSocialProfile Method

UserExtensions AttachSocialProfile Method Sitecore Social Connected 2.0 API
Attaches a social profile to the specified user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AttachSocialProfile(
    this IPrincipal user,
    SocialProfile socialProfile
)
public static void AttachSocialProfile(
    this IPrincipal user,
    SocialProfile socialProfile
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

socialProfile
Type: Sitecore.Social.Domain.Model SocialProfile

            The social profile.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountInUserDuplicatedException] | Following user already has another attached account of the same network.
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountInDomainDuplicatedException] | There is another user with the same account in domain.
Examples
View Colorized Copy to Clipboard Print
try
{
  var facebookProfile = new SocialProfile
  {
    AccountCredentials = new AccountCredentials
    {
      AccessToken = "239842+-02399==",
      AccessTokenSecret = "8282271371232=-29382855"
    },
    Email = "john.smith@fakedomain.com",
    FullName = "John Smith",
    NetworkAccountId = "888127718888463",
    ApplicationCredentials = new ApplicationCredentials
    {
      ApplicationKey = "jkdsf90392===399",
      ApplicationSecret = "128281--==39939"
    },
    NetworkName = "Facebook",
    Fields = new Dictionary<string, string>
    {
      {
        "timezone", "UTC+8"
      },
      {
        "gender", "male"
      }
    }
  };

  Sitecore.Context.User.AttachSocialProfile(facebookProfile);
  this.ShowSocialProfile(facebookProfile);
}
catch (AccountInUserDuplicatedException)
{
  // Following user already has another attached account of the same network.
}
catch (AccountInDomainDuplicatedException)
{
  // There is another user with the same account in domain.
}
try
{
  var facebookProfile = new SocialProfile
  {
    AccountCredentials = new AccountCredentials
    {
      AccessToken = "239842+-02399==",
      AccessTokenSecret = "8282271371232=-29382855"
    },
    Email = "john.smith@fakedomain.com",
    FullName = "John Smith",
    NetworkAccountId = "888127718888463",
    ApplicationCredentials = new ApplicationCredentials
    {
      ApplicationKey = "jkdsf90392===399",
      ApplicationSecret = "128281--==39939"
    },
    NetworkName = "Facebook",
    Fields = new Dictionary<string, string>
    {
      {
        "timezone", "UTC+8"
      },
      {
        "gender", "male"
      }
    }
  };

  Sitecore.Context.User.AttachSocialProfile(facebookProfile);
  this.ShowSocialProfile(facebookProfile);
}
catch (AccountInUserDuplicatedException)
{
  // Following user already has another attached account of the same network.
}
catch (AccountInDomainDuplicatedException)
{
  // There is another user with the same account in domain.
}
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.DetachSocialProfile Method

UserExtensions DetachSocialProfile Method Sitecore Social Connected 2.0 API
Removes a social profile from the specified user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DetachSocialProfile(
    this IPrincipal user,
    string networkName
)
public static void DetachSocialProfile(
    this IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountIsNotExistException] | Following user has not account in this network.
Examples
View Colorized Copy to Clipboard Print
try
{
  Sitecore.Context.User.DetachSocialProfile("Facebook");
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
try
{
  Sitecore.Context.User.DetachSocialProfile("Facebook");
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.GetPostingPreference Method

UserExtensions GetPostingPreference Method Sitecore Social Connected 2.0 API
Gets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PostingPreference GetPostingPreference(
    this IPrincipal user,
    Identifier messageId
)
public static PostingPreference GetPostingPreference(
    this IPrincipal user,
    Identifier messageId
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: PostingPreference

             The posting preference. If the posting preference is not found the Default value is used.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var postingPreference = Sitecore.Context.User.GetPostingPreference(messageId);

Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
var postingPreference = Sitecore.Context.User.GetPostingPreference(messageId);

Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace
PostingPreference AutomaticPostingPreference


UserExtensions.GetPostingPreferences Method

UserExtensions GetPostingPreferences Method Sitecore Social Connected 2.0 API
Overload List
Name | Description
GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all the messages attached to the specific container.
Back to Top
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.GetPostingPreferences Method (IPrincipal, PostingConfigurationSearchArgs)

UserExtensions GetPostingPreferences Method (IPrincipal, PostingConfigurationSearchArgs) Sitecore Social Connected 2.0 API
Gets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.Extensions.UserExtensions.GetPostingPreferences(string)",
    false)]
public static IEnumerable<PostingPreference> GetPostingPreferences(
    this IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.Extensions.UserExtensions.GetPostingPreferences(string)",
    false)]
public static IEnumerable<PostingPreference> GetPostingPreferences(
    this IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search arguments.
Return Value
Type:   Online IEnumerable  PostingPreference

             The posting preference list. If no preferences are found an empty list is returned.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

var postingPreferences = Sitecore.Context.User.GetPostingPreferences(searchArgs);

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

var postingPreferences = Sitecore.Context.User.GetPostingPreferences(searchArgs);

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
See Also
UserExtensions Class
UserExtensions Members
GetPostingPreferences Overload
Sitecore.Social.Api.Extensions Namespace


UserExtensions.GetPostingPreferences Method (IPrincipal, String)

UserExtensions GetPostingPreferences Method (IPrincipal, String) Sitecore Social Connected 2.0 API
Gets user's posting preferences for all the messages attached to the specific container.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<PostingPreference> GetPostingPreferences(
    this IPrincipal user,
    string container
)
public static IEnumerable<PostingPreference> GetPostingPreferences(
    this IPrincipal user,
    string container
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
container
Type:   Online System String
The container.
Return Value
Type:   Online IEnumerable  PostingPreference

             The posting preference list. If no preferences are found an empty list is returned.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var postingPreferences = Sitecore.Context.User.GetPostingPreferences("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
var postingPreferences = Sitecore.Context.User.GetPostingPreferences("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

foreach (var postingPreference in postingPreferences)
{
  Console.WriteLine("Message Id: {0}, Automatic Posting Preference: {1}", postingPreference.MessageId, postingPreference.AutomaticPostingPreference);
}
See Also
UserExtensions Class
UserExtensions Members
GetPostingPreferences Overload
Sitecore.Social.Api.Extensions Namespace


UserExtensions.GetSocialProfile Method

UserExtensions GetSocialProfile Method Sitecore Social Connected 2.0 API
Gets a social profile of the user in the specified network.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SocialProfile GetSocialProfile(
    this IPrincipal user,
    string networkName
)
public static SocialProfile GetSocialProfile(
    this IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type: SocialProfile

            The social profile. If there are no profiles, an empty profile is returned.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");

if (!facebookSocialProfile.IsEmpty)
{
  this.ShowSocialProfile(facebookSocialProfile);
}
var facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");

if (!facebookSocialProfile.IsEmpty)
{
  this.ShowSocialProfile(facebookSocialProfile);
}
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.GetSocialProfiles Method

UserExtensions GetSocialProfiles Method Sitecore Social Connected 2.0 API
Gets all social profiles of the user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<SocialProfile> GetSocialProfiles(
    this IPrincipal user
)
public static IEnumerable<SocialProfile> GetSocialProfiles(
    this IPrincipal user
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

Return Value
Type:   Online IEnumerable  SocialProfile

            The social profiles list. If there are no profiles, an empty list is returned.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var socialProfiles = Sitecore.Context.User.GetSocialProfiles();

foreach (var socialProfile in socialProfiles)
{
  this.ShowSocialProfile(socialProfile);
}
var socialProfiles = Sitecore.Context.User.GetSocialProfiles();

foreach (var socialProfile in socialProfiles)
{
  this.ShowSocialProfile(socialProfile);
}
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.IsSocialProfileExists Method

UserExtensions IsSocialProfileExists Method Sitecore Social Connected 2.0 API
Defines if there is a social profile in the specified network.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.Extensions.UserExtensions.SocialProfileExists",
    true)]
public static bool IsSocialProfileExists(
    this IPrincipal user,
    string networkName
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.Extensions.UserExtensions.SocialProfileExists",
    true)]
public static bool IsSocialProfileExists(
    this IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type:   Online Boolean
true if the social profile exists; otherwise, false.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var result = Sitecore.Context.User.IsSocialProfileExists("Facebook");

Console.WriteLine("The social profile exists: {0}", result);
var result = Sitecore.Context.User.IsSocialProfileExists("Facebook");

Console.WriteLine("The social profile exists: {0}", result);
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.SetPostingPreference Method

UserExtensions SetPostingPreference Method Sitecore Social Connected 2.0 API
Overload List
Name | Description
SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences to all the messages found by arguments.
Back to Top
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)

UserExtensions SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to the specific message.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetPostingPreference(
    this IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
public static void SetPostingPreference(
    this IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System Exception | Message is not found.
Online System Exception | Invalid message template.
Online System Exception | Unable to set preference to the anonymous user.
Examples
View Colorized Copy to Clipboard Print
Sitecore.Context.User.SetPostingPreference(messageId, AutomaticPostingPreference.Denied);
Sitecore.Context.User.SetPostingPreference(messageId, AutomaticPostingPreference.Denied);
See Also
UserExtensions Class
UserExtensions Members
SetPostingPreference Overload
Sitecore.Social.Api.Extensions Namespace


UserExtensions.SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

UserExtensions SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to all the messages found by arguments.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.Extensions.UserExtensions.GetPostingPreferences(string, AutomaticPostingPreference)",
    false)]
public static void SetPostingPreference(
    this IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Api.Extensions.UserExtensions.GetPostingPreferences(string, AutomaticPostingPreference)",
    false)]
public static void SetPostingPreference(
    this IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System Exception | Unable to set preference to the anonymous user.
Examples
View Colorized Copy to Clipboard Print
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

Sitecore.Context.User.SetPostingPreference(searchArgs, AutomaticPostingPreference.Denied);
var searchArgs = new GoalPostingConfigurationSearchArgs("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1");

Sitecore.Context.User.SetPostingPreference(searchArgs, AutomaticPostingPreference.Denied);
See Also
UserExtensions Class
UserExtensions Members
SetPostingPreference Overload
Sitecore.Social.Api.Extensions Namespace


UserExtensions.SetPostingPreference Method (IPrincipal, String, AutomaticPostingPreference)

UserExtensions SetPostingPreference Method (IPrincipal, String, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to all the messages found by arguments.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetPostingPreference(
    this IPrincipal user,
    string container,
    AutomaticPostingPreference automaticPostingPreference
)
public static void SetPostingPreference(
    this IPrincipal user,
    string container,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
container
Type:   Online System String
The container.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System Exception | Unable to set preference to the anonymous user.
Examples
View Colorized Copy to Clipboard Print
Sitecore.Context.User.SetPostingPreference("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1", AutomaticPostingPreference.Denied);
Sitecore.Context.User.SetPostingPreference("sitecore://master/{968897F1-328A-489D-88E8-BE78F4370958}?lang=en&ver=1", AutomaticPostingPreference.Denied);
See Also
UserExtensions Class
UserExtensions Members
SetPostingPreference Overload
Sitecore.Social.Api.Extensions Namespace


UserExtensions.SocialProfileExists Method

UserExtensions SocialProfileExists Method Sitecore Social Connected 2.0 API
Defines if there is a social profile in the specified network.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool SocialProfileExists(
    this IPrincipal user,
    string networkName
)
public static bool SocialProfileExists(
    this IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type:   Online Boolean
true if the social profile exists; otherwise, false.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var result = Sitecore.Context.User.SocialProfileExists("Facebook");

Console.WriteLine("The social profile exists: {0}", result);
var result = Sitecore.Context.User.SocialProfileExists("Facebook");

Console.WriteLine("The social profile exists: {0}", result);
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


UserExtensions.UpdateSocialProfile Method

UserExtensions UpdateSocialProfile Method Sitecore Social Connected 2.0 API
Updates a social profile of the specified user.

Namespace: Sitecore.Social.Api.Extensions
Assembly: Sitecore.Social.Api (in Sitecore.Social.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void UpdateSocialProfile(
    this IPrincipal user,
    SocialProfile socialProfile
)
public static void UpdateSocialProfile(
    this IPrincipal user,
    SocialProfile socialProfile
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

socialProfile
Type: Sitecore.Social.Domain.Model SocialProfile

            The social profile.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IPrincipal. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
[!:Sitecore.Social.NetworkProviders.Exceptions.AccountIsNotExistException] | Following user has not account in this network.
Examples
View Colorized Copy to Clipboard Print
try
{
  var facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");

  if (!facebookSocialProfile.IsEmpty)
  {
    facebookSocialProfile.Email = facebookSocialProfile.Email + "updated";
    Sitecore.Context.User.UpdateSocialProfile(facebookSocialProfile);
  }

  facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");
  this.ShowSocialProfile(facebookSocialProfile);
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
try
{
  var facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");

  if (!facebookSocialProfile.IsEmpty)
  {
    facebookSocialProfile.Email = facebookSocialProfile.Email + "updated";
    Sitecore.Context.User.UpdateSocialProfile(facebookSocialProfile);
  }

  facebookSocialProfile = Sitecore.Context.User.GetSocialProfile("Facebook");
  this.ShowSocialProfile(facebookSocialProfile);
}
catch (AccountIsNotExistException)
{
  // Following user has not account in this network.
}
See Also
UserExtensions Class
UserExtensions Members
Sitecore.Social.Api.Extensions Namespace


Sitecore.Social.BusinessLogic.Exceptions Namespace

Sitecore.Social.BusinessLogic.Exceptions Namespace Sitecore Social Connected 2.0 API
Provides a set of custom exception classes.
Classes
 | Class | Description
Public class | AccountBuilderIsNotFoundException | The exception that is thrown when the account builder is not found.
Public class | AccountContainerIsNotFoundException | The exception that is thrown when the account container is not found.
Public class | AccountInDomainDuplicatedException | The exception that is thrown when there is another user with the same account in domain.
Public class | AccountInUserDuplicatedException | The exception that is thrown when following user already has another attached account of the same network.
Public class | AccountIsNotExistException | The exception that is thrown when following user has not account of the network.
Public class | CannotReadAccountException | The exception that is thrown when the account item was found, but could not be read.
Public class | InterfaceIsNotSupportedByProviderException | The exception that is thrown when the network provider does not support the interface.
Public class | MessageDataBuilderIsNotFoundException | The exception that is thrown when the message data builder is not found.
Public class | MessageStatusBuilderIsNotFoundException | The exception that is thrown when the message status builder is not found.
Public class | PostingConfigurationBuilderIsNotFoundException | The exception that is thrown when the posting configuration builder is not found.
Public class | PostingConfigurationSearchArgsAdapterIsNotFoundException | The exception that is thrown when the posting configuration search arguments adapter is not found.
Public class | PostingIsNotMaintainedByProviderException | The exception that is thrown when posting is not maintained by the network provider.


AccountBuilderIsNotFoundException Class

AccountBuilderIsNotFoundException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the account builder is not found.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions AccountBuilderIsNotFoundException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AccountBuilderIsNotFoundException : Exception
[SerializableAttribute]
public class AccountBuilderIsNotFoundException : Exception
See Also
AccountBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Members

AccountBuilderIsNotFoundException Members Sitecore Social Connected 2.0 API

The AccountBuilderIsNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | AccountBuilderIsNotFoundException | Initializes a new instance of the AccountBuilderIsNotFoundException class.
Public method | AccountBuilderIsNotFoundException(ID) | Initializes a new instance of the AccountBuilderIsNotFoundException class with the account template ID.
Public method | AccountBuilderIsNotFoundException(String) | Initializes a new instance of the AccountBuilderIsNotFoundException class with a specified error message.
Public method | AccountBuilderIsNotFoundException(Type) | Initializes a new instance of the AccountBuilderIsNotFoundException class with the account type.
Protected method | AccountBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the AccountBuilderIsNotFoundException class with serialized data.
Public method | AccountBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the AccountBuilderIsNotFoundException class with the specified error message and the exception that caused this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor

AccountBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | AccountBuilderIsNotFoundException | Initializes a new instance of the AccountBuilderIsNotFoundException class.
Public method | AccountBuilderIsNotFoundException(ID) | Initializes a new instance of the AccountBuilderIsNotFoundException class with the account template ID.
Public method | AccountBuilderIsNotFoundException(String) | Initializes a new instance of the AccountBuilderIsNotFoundException class with a specified error message.
Public method | AccountBuilderIsNotFoundException(Type) | Initializes a new instance of the AccountBuilderIsNotFoundException class with the account type.
Protected method | AccountBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the AccountBuilderIsNotFoundException class with serialized data.
Public method | AccountBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the AccountBuilderIsNotFoundException class with the specified error message and the exception that caused this exception.
Back to Top
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor

AccountBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountBuilderIsNotFoundException()
public AccountBuilderIsNotFoundException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The account builder is not found."
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
AccountBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor ()

AccountBuilderIsNotFoundException Constructor () Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderIsNotFoundException class with the account template ID.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountBuilderIsNotFoundException(
    ID accountTemplateID
)
public AccountBuilderIsNotFoundException(
    ID accountTemplateID
)
Parameters
accountTemplateID
Type: ID
The account template ID.
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
AccountBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor (String)

AccountBuilderIsNotFoundException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountBuilderIsNotFoundException(
    string message
)
public AccountBuilderIsNotFoundException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
AccountBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor (Type)

AccountBuilderIsNotFoundException Constructor (Type) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderIsNotFoundException class with the account type.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountBuilderIsNotFoundException(
    Type accountType
)
public AccountBuilderIsNotFoundException(
    Type accountType
)
Parameters
accountType
Type:   Online System Type
Type of the account.
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
AccountBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

AccountBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AccountBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
protected AccountBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
AccountBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Constructor (String, Exception)

AccountBuilderIsNotFoundException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderIsNotFoundException class with the specified error message and the exception that caused this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountBuilderIsNotFoundException(
    string message,
    Exception inner
)
public AccountBuilderIsNotFoundException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
AccountBuilderIsNotFoundException Class
AccountBuilderIsNotFoundException Members
AccountBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Methods

AccountBuilderIsNotFoundException Methods Sitecore Social Connected 2.0 API
The AccountBuilderIsNotFoundException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Properties

AccountBuilderIsNotFoundException Properties Sitecore Social Connected 2.0 API
The AccountBuilderIsNotFoundException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountBuilderIsNotFoundException Events

AccountBuilderIsNotFoundException Events Sitecore Social Connected 2.0 API
The AccountBuilderIsNotFoundException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Class

AccountContainerIsNotFoundException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the account container is not found.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions AccountContainerIsNotFoundException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AccountContainerIsNotFoundException : Exception
[SerializableAttribute]
public class AccountContainerIsNotFoundException : Exception
See Also
AccountContainerIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace
Account AccountContainer


AccountContainerIsNotFoundException Members

AccountContainerIsNotFoundException Members Sitecore Social Connected 2.0 API

The AccountContainerIsNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | AccountContainerIsNotFoundException | Initializes a new instance of the AccountContainerIsNotFoundException class.
Public method | AccountContainerIsNotFoundException(String) | Initializes a new instance of the AccountContainerIsNotFoundException class with the account container value.
Protected method | AccountContainerIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the AccountContainerIsNotFoundException class with serialized data.
Public method | AccountContainerIsNotFoundException(String, Exception) | Initializes a new instance of the AccountContainerIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountContainerIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor

AccountContainerIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | AccountContainerIsNotFoundException | Initializes a new instance of the AccountContainerIsNotFoundException class.
Public method | AccountContainerIsNotFoundException(String) | Initializes a new instance of the AccountContainerIsNotFoundException class with the account container value.
Protected method | AccountContainerIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the AccountContainerIsNotFoundException class with serialized data.
Public method | AccountContainerIsNotFoundException(String, Exception) | Initializes a new instance of the AccountContainerIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
See Also
AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor

AccountContainerIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountContainerIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountContainerIsNotFoundException()
public AccountContainerIsNotFoundException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The account container is not found."
See Also
AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Members
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor (String)

AccountContainerIsNotFoundException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountContainerIsNotFoundException class with the account container value.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountContainerIsNotFoundException(
    string accountContainer
)
public AccountContainerIsNotFoundException(
    string accountContainer
)
Parameters
accountContainer
Type:   Online System String
The account container value.
See Also
AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Members
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor (SerializationInfo, StreamingContext)

AccountContainerIsNotFoundException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountContainerIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AccountContainerIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
protected AccountContainerIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Members
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Constructor (String, Exception)

AccountContainerIsNotFoundException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountContainerIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountContainerIsNotFoundException(
    string message,
    Exception inner
)
public AccountContainerIsNotFoundException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
AccountContainerIsNotFoundException Class
AccountContainerIsNotFoundException Members
AccountContainerIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Methods

AccountContainerIsNotFoundException Methods Sitecore Social Connected 2.0 API
The AccountContainerIsNotFoundException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountContainerIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Properties

AccountContainerIsNotFoundException Properties Sitecore Social Connected 2.0 API
The AccountContainerIsNotFoundException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountContainerIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountContainerIsNotFoundException Events

AccountContainerIsNotFoundException Events Sitecore Social Connected 2.0 API
The AccountContainerIsNotFoundException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountContainerIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException Class

AccountInDomainDuplicatedException Class Sitecore Social Connected 2.0 API
The exception that is thrown when there is another user with the same account in domain.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.Infrastructure.Exceptions SocialException
Sitecore.Social.BusinessLogic.Exceptions AccountInDomainDuplicatedException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AccountInDomainDuplicatedException : SocialException
public class AccountInDomainDuplicatedException : SocialException
See Also
AccountInDomainDuplicatedException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException Members

AccountInDomainDuplicatedException Members Sitecore Social Connected 2.0 API

The AccountInDomainDuplicatedException type exposes the following members.
Constructors
 | Name | Description
Public method | AccountInDomainDuplicatedException | Initializes a new instance of the AccountInDomainDuplicatedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message. (Inherited from SocialException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message. (Overrides SocialException SimpleMessage.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInDomainDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException Constructor

AccountInDomainDuplicatedException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountInDomainDuplicatedException class

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountInDomainDuplicatedException()
public AccountInDomainDuplicatedException()
See Also
AccountInDomainDuplicatedException Class
AccountInDomainDuplicatedException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException Methods

AccountInDomainDuplicatedException Methods Sitecore Social Connected 2.0 API
The AccountInDomainDuplicatedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInDomainDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException Properties

AccountInDomainDuplicatedException Properties Sitecore Social Connected 2.0 API
The AccountInDomainDuplicatedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message. (Inherited from SocialException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message. (Overrides SocialException SimpleMessage.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInDomainDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException.SimpleMessage Property

AccountInDomainDuplicatedException SimpleMessage Property Sitecore Social Connected 2.0 API
The simple message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string SimpleMessage { get; }
public override string SimpleMessage { get; }
Property Value
Type:   Online String
Implements
ISocialException SimpleMessage
See Also
AccountInDomainDuplicatedException Class
AccountInDomainDuplicatedException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInDomainDuplicatedException Events

AccountInDomainDuplicatedException Events Sitecore Social Connected 2.0 API
The AccountInDomainDuplicatedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInDomainDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException Class

AccountInUserDuplicatedException Class Sitecore Social Connected 2.0 API
The exception that is thrown when following user already has another attached account of the same network.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.Infrastructure.Exceptions SocialException
Sitecore.Social.BusinessLogic.Exceptions AccountInUserDuplicatedException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AccountInUserDuplicatedException : SocialException
public class AccountInUserDuplicatedException : SocialException
See Also
AccountInUserDuplicatedException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException Members

AccountInUserDuplicatedException Members Sitecore Social Connected 2.0 API

The AccountInUserDuplicatedException type exposes the following members.
Constructors
 | Name | Description
Public method | AccountInUserDuplicatedException | Initializes a new instance of the AccountInUserDuplicatedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message. (Inherited from SocialException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message. (Overrides SocialException SimpleMessage.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInUserDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException Constructor

AccountInUserDuplicatedException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountInUserDuplicatedException class

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountInUserDuplicatedException()
public AccountInUserDuplicatedException()
See Also
AccountInUserDuplicatedException Class
AccountInUserDuplicatedException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException Methods

AccountInUserDuplicatedException Methods Sitecore Social Connected 2.0 API
The AccountInUserDuplicatedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInUserDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException Properties

AccountInUserDuplicatedException Properties Sitecore Social Connected 2.0 API
The AccountInUserDuplicatedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message. (Inherited from SocialException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message. (Overrides SocialException SimpleMessage.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInUserDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException.SimpleMessage Property

AccountInUserDuplicatedException SimpleMessage Property Sitecore Social Connected 2.0 API
The simple message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string SimpleMessage { get; }
public override string SimpleMessage { get; }
Property Value
Type:   Online String
Implements
ISocialException SimpleMessage
See Also
AccountInUserDuplicatedException Class
AccountInUserDuplicatedException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountInUserDuplicatedException Events

AccountInUserDuplicatedException Events Sitecore Social Connected 2.0 API
The AccountInUserDuplicatedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountInUserDuplicatedException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException Class

AccountIsNotExistException Class Sitecore Social Connected 2.0 API
The exception that is thrown when following user has not account of the network.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.Infrastructure.Exceptions SocialException
Sitecore.Social.BusinessLogic.Exceptions AccountIsNotExistException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AccountIsNotExistException : SocialException
public class AccountIsNotExistException : SocialException
See Also
AccountIsNotExistException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException Members

AccountIsNotExistException Members Sitecore Social Connected 2.0 API

The AccountIsNotExistException type exposes the following members.
Constructors
 | Name | Description
Public method | AccountIsNotExistException | Initializes a new instance of the AccountIsNotExistException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message. (Inherited from SocialException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message. (Overrides SocialException SimpleMessage.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountIsNotExistException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException Constructor

AccountIsNotExistException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountIsNotExistException class

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountIsNotExistException()
public AccountIsNotExistException()
See Also
AccountIsNotExistException Class
AccountIsNotExistException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException Methods

AccountIsNotExistException Methods Sitecore Social Connected 2.0 API
The AccountIsNotExistException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountIsNotExistException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException Properties

AccountIsNotExistException Properties Sitecore Social Connected 2.0 API
The AccountIsNotExistException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message. (Inherited from SocialException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message. (Overrides SocialException SimpleMessage.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountIsNotExistException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException.SimpleMessage Property

AccountIsNotExistException SimpleMessage Property Sitecore Social Connected 2.0 API
The simple message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string SimpleMessage { get; }
public override string SimpleMessage { get; }
Property Value
Type:   Online String
Implements
ISocialException SimpleMessage
See Also
AccountIsNotExistException Class
AccountIsNotExistException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


AccountIsNotExistException Events

AccountIsNotExistException Events Sitecore Social Connected 2.0 API
The AccountIsNotExistException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AccountIsNotExistException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Class

CannotReadAccountException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the account item was found, but could not be read.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions CannotReadAccountException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CannotReadAccountException : Exception
[SerializableAttribute]
public class CannotReadAccountException : Exception
See Also
CannotReadAccountException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace
AccountBusinessManagerCreateAccount(Account)


CannotReadAccountException Members

CannotReadAccountException Members Sitecore Social Connected 2.0 API

The CannotReadAccountException type exposes the following members.
Constructors
 | Name | Description
Public method | CannotReadAccountException | Initializes a new instance of the CannotReadAccountException class.
Public method | CannotReadAccountException(String) | Initializes a new instance of the CannotReadAccountException class with a specified error message.
Protected method | CannotReadAccountException(SerializationInfo, StreamingContext) | Initializes a new instance of the CannotReadAccountException class with serialized data.
Public method | CannotReadAccountException(String, Exception) | Initializes a new instance of the CannotReadAccountException class with a specified error message and the exception that is the cause of this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CannotReadAccountException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor

CannotReadAccountException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CannotReadAccountException | Initializes a new instance of the CannotReadAccountException class.
Public method | CannotReadAccountException(String) | Initializes a new instance of the CannotReadAccountException class with a specified error message.
Protected method | CannotReadAccountException(SerializationInfo, StreamingContext) | Initializes a new instance of the CannotReadAccountException class with serialized data.
Public method | CannotReadAccountException(String, Exception) | Initializes a new instance of the CannotReadAccountException class with a specified error message and the exception that is the cause of this exception.
Back to Top
See Also
CannotReadAccountException Class
CannotReadAccountException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor

CannotReadAccountException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the CannotReadAccountException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CannotReadAccountException()
public CannotReadAccountException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "Could not read account."
See Also
CannotReadAccountException Class
CannotReadAccountException Members
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor (String)

CannotReadAccountException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the CannotReadAccountException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CannotReadAccountException(
    string message
)
public CannotReadAccountException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
CannotReadAccountException Class
CannotReadAccountException Members
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor (SerializationInfo, StreamingContext)

CannotReadAccountException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the CannotReadAccountException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CannotReadAccountException(
    SerializationInfo info,
    StreamingContext context
)
protected CannotReadAccountException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
CannotReadAccountException Class
CannotReadAccountException Members
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Constructor (String, Exception)

CannotReadAccountException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the CannotReadAccountException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CannotReadAccountException(
    string message,
    Exception inner
)
public CannotReadAccountException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
CannotReadAccountException Class
CannotReadAccountException Members
CannotReadAccountException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Methods

CannotReadAccountException Methods Sitecore Social Connected 2.0 API
The CannotReadAccountException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CannotReadAccountException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Properties

CannotReadAccountException Properties Sitecore Social Connected 2.0 API
The CannotReadAccountException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CannotReadAccountException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


CannotReadAccountException Events

CannotReadAccountException Events Sitecore Social Connected 2.0 API
The CannotReadAccountException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CannotReadAccountException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Class

InterfaceIsNotSupportedByProviderException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the network provider does not support the interface.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions InterfaceIsNotSupportedByProviderException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class InterfaceIsNotSupportedByProviderException : Exception
[SerializableAttribute]
public class InterfaceIsNotSupportedByProviderException : Exception
See Also
InterfaceIsNotSupportedByProviderException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Members

InterfaceIsNotSupportedByProviderException Members Sitecore Social Connected 2.0 API

The InterfaceIsNotSupportedByProviderException type exposes the following members.
Constructors
 | Name | Description
Public method | InterfaceIsNotSupportedByProviderException | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class.
Public method | InterfaceIsNotSupportedByProviderException(String) | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class with the specified error message.
Public method | InterfaceIsNotSupportedByProviderException(String, Exception) | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class with the specified error message and the exception that caused this exception.
Public method | InterfaceIsNotSupportedByProviderException(Type, Object) | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InterfaceIsNotSupportedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Constructor

InterfaceIsNotSupportedByProviderException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | InterfaceIsNotSupportedByProviderException | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class.
Public method | InterfaceIsNotSupportedByProviderException(String) | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class with the specified error message.
Public method | InterfaceIsNotSupportedByProviderException(String, Exception) | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class with the specified error message and the exception that caused this exception.
Public method | InterfaceIsNotSupportedByProviderException(Type, Object) | Initializes a new instance of the InterfaceIsNotSupportedByProviderException class.
Back to Top
See Also
InterfaceIsNotSupportedByProviderException Class
InterfaceIsNotSupportedByProviderException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Constructor

InterfaceIsNotSupportedByProviderException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the InterfaceIsNotSupportedByProviderException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InterfaceIsNotSupportedByProviderException()
public InterfaceIsNotSupportedByProviderException()
See Also
InterfaceIsNotSupportedByProviderException Class
InterfaceIsNotSupportedByProviderException Members
InterfaceIsNotSupportedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Constructor (String)

InterfaceIsNotSupportedByProviderException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the InterfaceIsNotSupportedByProviderException class with the specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InterfaceIsNotSupportedByProviderException(
    string message
)
public InterfaceIsNotSupportedByProviderException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
InterfaceIsNotSupportedByProviderException Class
InterfaceIsNotSupportedByProviderException Members
InterfaceIsNotSupportedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Constructor (String, Exception)

InterfaceIsNotSupportedByProviderException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the InterfaceIsNotSupportedByProviderException class with the specified error message and the exception that caused this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InterfaceIsNotSupportedByProviderException(
    string message,
    Exception inner
)
public InterfaceIsNotSupportedByProviderException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
InterfaceIsNotSupportedByProviderException Class
InterfaceIsNotSupportedByProviderException Members
InterfaceIsNotSupportedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Constructor (Type, Object)

InterfaceIsNotSupportedByProviderException Constructor (Type, Object) Sitecore Social Connected 2.0 API
Initializes a new instance of the InterfaceIsNotSupportedByProviderException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InterfaceIsNotSupportedByProviderException(
    Type interfaceType,
    Object providerType
)
public InterfaceIsNotSupportedByProviderException(
    Type interfaceType,
    Object providerType
)
Parameters
interfaceType
Type:   Online System Type
Type of the not supported interface.
providerType
Type:   Online System Object
Type of the provider.
See Also
InterfaceIsNotSupportedByProviderException Class
InterfaceIsNotSupportedByProviderException Members
InterfaceIsNotSupportedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Methods

InterfaceIsNotSupportedByProviderException Methods Sitecore Social Connected 2.0 API
The InterfaceIsNotSupportedByProviderException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
InterfaceIsNotSupportedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Properties

InterfaceIsNotSupportedByProviderException Properties Sitecore Social Connected 2.0 API
The InterfaceIsNotSupportedByProviderException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
InterfaceIsNotSupportedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


InterfaceIsNotSupportedByProviderException Events

InterfaceIsNotSupportedByProviderException Events Sitecore Social Connected 2.0 API
The InterfaceIsNotSupportedByProviderException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InterfaceIsNotSupportedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Class

MessageDataBuilderIsNotFoundException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the message data builder is not found.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions MessageDataBuilderIsNotFoundException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageDataBuilderIsNotFoundException : Exception
[SerializableAttribute]
public class MessageDataBuilderIsNotFoundException : Exception
See Also
MessageDataBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Members

MessageDataBuilderIsNotFoundException Members Sitecore Social Connected 2.0 API

The MessageDataBuilderIsNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | MessageDataBuilderIsNotFoundException | Initializes a new instance of the MessageDataBuilderIsNotFoundException class.
Public method | MessageDataBuilderIsNotFoundException(String) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message.
Public method | MessageDataBuilderIsNotFoundException(Type) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class the message type.
Protected method | MessageDataBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with serialized data.
Public method | MessageDataBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageDataBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor

MessageDataBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | MessageDataBuilderIsNotFoundException | Initializes a new instance of the MessageDataBuilderIsNotFoundException class.
Public method | MessageDataBuilderIsNotFoundException(String) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message.
Public method | MessageDataBuilderIsNotFoundException(Type) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class the message type.
Protected method | MessageDataBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with serialized data.
Public method | MessageDataBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
See Also
MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor

MessageDataBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageDataBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageDataBuilderIsNotFoundException()
public MessageDataBuilderIsNotFoundException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The message data builder is not found."
See Also
MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (String)

MessageDataBuilderIsNotFoundException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageDataBuilderIsNotFoundException(
    string message
)
public MessageDataBuilderIsNotFoundException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (Type)

MessageDataBuilderIsNotFoundException Constructor (Type) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageDataBuilderIsNotFoundException class the message type.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageDataBuilderIsNotFoundException(
    Type messageType
)
public MessageDataBuilderIsNotFoundException(
    Type messageType
)
Parameters
messageType
Type:   Online System Type
Type of the message.
See Also
MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

MessageDataBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageDataBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessageDataBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
protected MessageDataBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Constructor (String, Exception)

MessageDataBuilderIsNotFoundException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageDataBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageDataBuilderIsNotFoundException(
    string message,
    Exception inner
)
public MessageDataBuilderIsNotFoundException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
MessageDataBuilderIsNotFoundException Class
MessageDataBuilderIsNotFoundException Members
MessageDataBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Methods

MessageDataBuilderIsNotFoundException Methods Sitecore Social Connected 2.0 API
The MessageDataBuilderIsNotFoundException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageDataBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Properties

MessageDataBuilderIsNotFoundException Properties Sitecore Social Connected 2.0 API
The MessageDataBuilderIsNotFoundException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageDataBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageDataBuilderIsNotFoundException Events

MessageDataBuilderIsNotFoundException Events Sitecore Social Connected 2.0 API
The MessageDataBuilderIsNotFoundException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageDataBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Class

MessageStatusBuilderIsNotFoundException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the message status builder is not found.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions MessageStatusBuilderIsNotFoundException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageStatusBuilderIsNotFoundException : Exception
[SerializableAttribute]
public class MessageStatusBuilderIsNotFoundException : Exception
See Also
MessageStatusBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Members

MessageStatusBuilderIsNotFoundException Members Sitecore Social Connected 2.0 API

The MessageStatusBuilderIsNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | MessageStatusBuilderIsNotFoundException | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class.
Public method | MessageStatusBuilderIsNotFoundException(String) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message.
Protected method | MessageStatusBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with serialized data.
Public method | MessageStatusBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this error.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageStatusBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor

MessageStatusBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | MessageStatusBuilderIsNotFoundException | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class.
Public method | MessageStatusBuilderIsNotFoundException(String) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message.
Protected method | MessageStatusBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with serialized data.
Public method | MessageStatusBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this error.
Back to Top
See Also
MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor

MessageStatusBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatusBuilderIsNotFoundException()
public MessageStatusBuilderIsNotFoundException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The message status builder is not found."
See Also
MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Members
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor (String)

MessageStatusBuilderIsNotFoundException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatusBuilderIsNotFoundException(
    string message
)
public MessageStatusBuilderIsNotFoundException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Members
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

MessageStatusBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessageStatusBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
protected MessageStatusBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Members
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Constructor (String, Exception)

MessageStatusBuilderIsNotFoundException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatusBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this error.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatusBuilderIsNotFoundException(
    string message,
    Exception inner
)
public MessageStatusBuilderIsNotFoundException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
MessageStatusBuilderIsNotFoundException Class
MessageStatusBuilderIsNotFoundException Members
MessageStatusBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Methods

MessageStatusBuilderIsNotFoundException Methods Sitecore Social Connected 2.0 API
The MessageStatusBuilderIsNotFoundException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageStatusBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Properties

MessageStatusBuilderIsNotFoundException Properties Sitecore Social Connected 2.0 API
The MessageStatusBuilderIsNotFoundException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageStatusBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


MessageStatusBuilderIsNotFoundException Events

MessageStatusBuilderIsNotFoundException Events Sitecore Social Connected 2.0 API
The MessageStatusBuilderIsNotFoundException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageStatusBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Class

PostingConfigurationBuilderIsNotFoundException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the posting configuration builder is not found.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationBuilderIsNotFoundException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingConfigurationBuilderIsNotFoundException : Exception
[SerializableAttribute]
public class PostingConfigurationBuilderIsNotFoundException : Exception
See Also
PostingConfigurationBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Members

PostingConfigurationBuilderIsNotFoundException Members Sitecore Social Connected 2.0 API

The PostingConfigurationBuilderIsNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | PostingConfigurationBuilderIsNotFoundException | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class.
Public method | PostingConfigurationBuilderIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message.
Public method | PostingConfigurationBuilderIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with the posting configuration type.
Protected method | PostingConfigurationBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with serialized data.
Public method | PostingConfigurationBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor

PostingConfigurationBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | PostingConfigurationBuilderIsNotFoundException | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class.
Public method | PostingConfigurationBuilderIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message.
Public method | PostingConfigurationBuilderIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with the posting configuration type.
Protected method | PostingConfigurationBuilderIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with serialized data.
Public method | PostingConfigurationBuilderIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
See Also
PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor

PostingConfigurationBuilderIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationBuilderIsNotFoundException()
public PostingConfigurationBuilderIsNotFoundException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The posting configuration builder is not found."
See Also
PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (String)

PostingConfigurationBuilderIsNotFoundException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationBuilderIsNotFoundException(
    string message
)
public PostingConfigurationBuilderIsNotFoundException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (Type)

PostingConfigurationBuilderIsNotFoundException Constructor (Type) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with the posting configuration type.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationBuilderIsNotFoundException(
    Type postingConfigurationType
)
public PostingConfigurationBuilderIsNotFoundException(
    Type postingConfigurationType
)
Parameters
postingConfigurationType
Type:   Online System Type
Type of the posting configuration.
See Also
PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext)

PostingConfigurationBuilderIsNotFoundException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostingConfigurationBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
protected PostingConfigurationBuilderIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Constructor (String, Exception)

PostingConfigurationBuilderIsNotFoundException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationBuilderIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationBuilderIsNotFoundException(
    string message,
    Exception inner
)
public PostingConfigurationBuilderIsNotFoundException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
PostingConfigurationBuilderIsNotFoundException Class
PostingConfigurationBuilderIsNotFoundException Members
PostingConfigurationBuilderIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Methods

PostingConfigurationBuilderIsNotFoundException Methods Sitecore Social Connected 2.0 API
The PostingConfigurationBuilderIsNotFoundException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Properties

PostingConfigurationBuilderIsNotFoundException Properties Sitecore Social Connected 2.0 API
The PostingConfigurationBuilderIsNotFoundException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationBuilderIsNotFoundException Events

PostingConfigurationBuilderIsNotFoundException Events Sitecore Social Connected 2.0 API
The PostingConfigurationBuilderIsNotFoundException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationBuilderIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Class

PostingConfigurationSearchArgsAdapterIsNotFoundException Class Sitecore Social Connected 2.0 API
The exception that is thrown when the posting configuration search arguments adapter is not found.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions PostingConfigurationSearchArgsAdapterIsNotFoundException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingConfigurationSearchArgsAdapterIsNotFoundException : Exception
[SerializableAttribute]
public class PostingConfigurationSearchArgsAdapterIsNotFoundException : Exception
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Members

PostingConfigurationSearchArgsAdapterIsNotFoundException Members Sitecore Social Connected 2.0 API

The PostingConfigurationSearchArgsAdapterIsNotFoundException type exposes the following members.
Constructors
 | Name | Description
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with the type of posting configuration search args.
Protected method | PostingConfigurationSearchArgsAdapterIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with serialized data.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor

PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(Type) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with the type of posting configuration search args.
Protected method | PostingConfigurationSearchArgsAdapterIsNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with serialized data.
Public method | PostingConfigurationSearchArgsAdapterIsNotFoundException(String, Exception) | Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message and the exception that is the cause of this exception.
Back to Top
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor

PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationSearchArgsAdapterIsNotFoundException()
public PostingConfigurationSearchArgsAdapterIsNotFoundException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "The posting configuration search arguments adapter is not found."
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String)

PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    string message
)
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (Type)

PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (Type) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with the type of posting configuration search args.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    Type postingConfigurationSearchArgsType
)
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    Type postingConfigurationSearchArgsType
)
Parameters
postingConfigurationSearchArgsType
Type:   Online System Type
Type of the posting configuration search args.
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (SerializationInfo, StreamingContext)

PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostingConfigurationSearchArgsAdapterIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
protected PostingConfigurationSearchArgsAdapterIsNotFoundException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String, Exception)

PostingConfigurationSearchArgsAdapterIsNotFoundException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgsAdapterIsNotFoundException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    string message,
    Exception inner
)
public PostingConfigurationSearchArgsAdapterIsNotFoundException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
PostingConfigurationSearchArgsAdapterIsNotFoundException Members
PostingConfigurationSearchArgsAdapterIsNotFoundException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Methods

PostingConfigurationSearchArgsAdapterIsNotFoundException Methods Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgsAdapterIsNotFoundException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Properties

PostingConfigurationSearchArgsAdapterIsNotFoundException Properties Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgsAdapterIsNotFoundException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingConfigurationSearchArgsAdapterIsNotFoundException Events

PostingConfigurationSearchArgsAdapterIsNotFoundException Events Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgsAdapterIsNotFoundException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingConfigurationSearchArgsAdapterIsNotFoundException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Class

PostingIsNotMaintainedByProviderException Class Sitecore Social Connected 2.0 API
The exception that is thrown when posting is not maintained by the network provider.
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.BusinessLogic.Exceptions PostingIsNotMaintainedByProviderException

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingIsNotMaintainedByProviderException : Exception
[SerializableAttribute]
public class PostingIsNotMaintainedByProviderException : Exception
See Also
PostingIsNotMaintainedByProviderException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace
AccountBusinessManagerCreateAccount(Account)


PostingIsNotMaintainedByProviderException Members

PostingIsNotMaintainedByProviderException Members Sitecore Social Connected 2.0 API

The PostingIsNotMaintainedByProviderException type exposes the following members.
Constructors
 | Name | Description
Public method | PostingIsNotMaintainedByProviderException | Initializes a new instance of the PostingIsNotMaintainedByProviderException class.
Public method | PostingIsNotMaintainedByProviderException(String) | Initializes a new instance of the PostingIsNotMaintainedByProviderException class with a specified error message.
Protected method | PostingIsNotMaintainedByProviderException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingIsNotMaintainedByProviderException class with serialized data.
Public method | PostingIsNotMaintainedByProviderException(String, Exception) | Initializes a new instance of the PostingIsNotMaintainedByProviderException class with a specified error message and the exception that is the cause of this exception.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingIsNotMaintainedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Constructor

PostingIsNotMaintainedByProviderException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | PostingIsNotMaintainedByProviderException | Initializes a new instance of the PostingIsNotMaintainedByProviderException class.
Public method | PostingIsNotMaintainedByProviderException(String) | Initializes a new instance of the PostingIsNotMaintainedByProviderException class with a specified error message.
Protected method | PostingIsNotMaintainedByProviderException(SerializationInfo, StreamingContext) | Initializes a new instance of the PostingIsNotMaintainedByProviderException class with serialized data.
Public method | PostingIsNotMaintainedByProviderException(String, Exception) | Initializes a new instance of the PostingIsNotMaintainedByProviderException class with a specified error message and the exception that is the cause of this exception.
Back to Top
See Also
PostingIsNotMaintainedByProviderException Class
PostingIsNotMaintainedByProviderException Members
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Constructor

PostingIsNotMaintainedByProviderException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingIsNotMaintainedByProviderException class.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingIsNotMaintainedByProviderException()
public PostingIsNotMaintainedByProviderException()
Remarks
This constructor initializes the Message property of the new instance to a system-supplied message that describes the error, such as "Could not post on the wall."
See Also
PostingIsNotMaintainedByProviderException Class
PostingIsNotMaintainedByProviderException Members
PostingIsNotMaintainedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Constructor (String)

PostingIsNotMaintainedByProviderException Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingIsNotMaintainedByProviderException class with a specified error message.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingIsNotMaintainedByProviderException(
    string message
)
public PostingIsNotMaintainedByProviderException(
    string message
)
Parameters
message
Type:   Online System String
The message that describes the error.
See Also
PostingIsNotMaintainedByProviderException Class
PostingIsNotMaintainedByProviderException Members
PostingIsNotMaintainedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Constructor (SerializationInfo, StreamingContext)

PostingIsNotMaintainedByProviderException Constructor (SerializationInfo, StreamingContext) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingIsNotMaintainedByProviderException class with serialized data.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostingIsNotMaintainedByProviderException(
    SerializationInfo info,
    StreamingContext context
)
protected PostingIsNotMaintainedByProviderException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The object that holds the serialized object data.
context
Type:   Online System.Runtime.Serialization StreamingContext
The object that describes the source or destination of the serialized data.
See Also
PostingIsNotMaintainedByProviderException Class
PostingIsNotMaintainedByProviderException Members
PostingIsNotMaintainedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Constructor (String, Exception)

PostingIsNotMaintainedByProviderException Constructor (String, Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingIsNotMaintainedByProviderException class with a specified error message and the exception that is the cause of this exception.

Namespace: Sitecore.Social.BusinessLogic.Exceptions
Assembly: Sitecore.Social.BusinessLogic (in Sitecore.Social.BusinessLogic.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingIsNotMaintainedByProviderException(
    string message,
    Exception inner
)
public PostingIsNotMaintainedByProviderException(
    string message,
    Exception inner
)
Parameters
message
Type:   Online System String
The error message that explains the cause of this exception.
inner
Type:   Online System Exception
The exception that is the cause of the current exception, or a null reference.
See Also
PostingIsNotMaintainedByProviderException Class
PostingIsNotMaintainedByProviderException Members
PostingIsNotMaintainedByProviderException Overload
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Methods

PostingIsNotMaintainedByProviderException Methods Sitecore Social Connected 2.0 API
The PostingIsNotMaintainedByProviderException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingIsNotMaintainedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Properties

PostingIsNotMaintainedByProviderException Properties Sitecore Social Connected 2.0 API
The PostingIsNotMaintainedByProviderException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingIsNotMaintainedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


PostingIsNotMaintainedByProviderException Events

PostingIsNotMaintainedByProviderException Events Sitecore Social Connected 2.0 API
The PostingIsNotMaintainedByProviderException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PostingIsNotMaintainedByProviderException Class
Sitecore.Social.BusinessLogic.Exceptions Namespace


Sitecore.Social.Client.Api Namespace

Sitecore.Social.Client.Api Namespace Sitecore Social Connected 2.0 API
Provides classes that allow managing presentation layer actions (log in, requests to social networks, etc).
Classes
 | Class | Description
Public class | AccountClientManager | Defines the methods that are used to work with a social network account.
Public class | ConnectorClientManager | Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.
Public class | ExceptionClientManager | Represents receiving of exception information.
Public class | ExceptionInfo | Represents the information about exception.
Public class | SocialPageEventClientManager | Helps to enrich PageEvents with extra parameters.
Public class | SocialPageEventItem | Represents the PageEvent wrapper to store additional data.
Interfaces
 | Interface | Description
Public interface | IExceptionClientManager | Represents receiving of exception information.
Public interface | ISocialPageEventClientManager | Defines the methods to enrich PageEvents with extra parameters.


AccountClientManager Class

AccountClientManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to work with a social network account.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Api AccountClientManager

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AccountClientManager : IAccountClientManager
public class AccountClientManager : IAccountClientManager
See Also
AccountClientManager Members
Sitecore.Social.Client.Api Namespace


AccountClientManager Members

AccountClientManager Members Sitecore Social Connected 2.0 API

The AccountClientManager type exposes the following members.
Constructors
 | Name | Description
Public method | AccountClientManager | Initializes a new instance of the AccountClientManager class
Back to Top
Methods
 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountClientManager Class
Sitecore.Social.Client.Api Namespace


AccountClientManager Constructor

AccountClientManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountClientManager class

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountClientManager()
public AccountClientManager()
See Also
AccountClientManager Class
AccountClientManager Members
Sitecore.Social.Client.Api Namespace


AccountClientManager Methods

AccountClientManager Methods Sitecore Social Connected 2.0 API
The AccountClientManager type exposes the following members.
Methods
 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountClientManager Class
Sitecore.Social.Client.Api Namespace


AccountClientManager.BeginGetAccountCredentials Method

AccountClientManager BeginGetAccountCredentials Method Sitecore Social Connected 2.0 API
Initializes the process of receiving the social network account credentials.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BeginGetAccountCredentials(
    GetAccountCredentialsRequest request
)
public void BeginGetAccountCredentials(
    GetAccountCredentialsRequest request
)
Parameters
request
Type: Sitecore.Social.Client.Domain.Requests GetAccountCredentialsRequest
The account credentials request.
Implements
IAccountClientManager BeginGetAccountCredentials(GetAccountCredentialsRequest)
Remarks
  •  Use EndGetAccountCredentials(String) to receive the account credentials response by this request id.
  •  Use GetExceptionInfo(HttpRequest) to receive the exception information in a case of error.
Examples
View Colorized Copy to Clipboard Print
var newAccountName = accountNameTextBox.Text;

var facebookApplication = applicationManager.GetApplication(facebookApplicationId);

if (!facebookApplication.IsEmpty)
{
  var accountDataRequest = new GetAccountCredentialsRequest(
    "Facebook",
    facebookApplication.ApplicationCredentials,
    HttpContext.Current.Request.Url,
    new Dictionary<string, object>
      {
        { "ApplicationId", facebookApplicationId },
        { "AccountName", newAccountName }
      });

  // to get AccessToken without expiration
  accountDataRequest.Permissions.Add("offline_access", string.Empty);

  // to grant publish on the wall
  accountDataRequest.Permissions.Add("publish_stream", string.Empty);

  // to retreive user pages accessTokens
  accountDataRequest.Permissions.Add("manage_pages", string.Empty);

  // to get message statistics
  accountDataRequest.Permissions.Add("read_stream", string.Empty);

  accountClientManager.BeginGetAccountCredentials(accountDataRequest);
}
var newAccountName = accountNameTextBox.Text;

var facebookApplication = applicationManager.GetApplication(facebookApplicationId);

if (!facebookApplication.IsEmpty)
{
  var accountDataRequest = new GetAccountCredentialsRequest(
    "Facebook",
    facebookApplication.ApplicationCredentials,
    HttpContext.Current.Request.Url,
    new Dictionary<string, object>
      {
        { "ApplicationId", facebookApplicationId },
        { "AccountName", newAccountName }
      });

  // to get AccessToken without expiration
  accountDataRequest.Permissions.Add("offline_access", string.Empty);

  // to grant publish on the wall
  accountDataRequest.Permissions.Add("publish_stream", string.Empty);

  // to retreive user pages accessTokens
  accountDataRequest.Permissions.Add("manage_pages", string.Empty);

  // to get message statistics
  accountDataRequest.Permissions.Add("read_stream", string.Empty);

  accountClientManager.BeginGetAccountCredentials(accountDataRequest);
}
See Also
AccountClientManager Class
AccountClientManager Members
Sitecore.Social.Client.Api Namespace


AccountClientManager.EndGetAccountCredentials Method

AccountClientManager EndGetAccountCredentials Method Sitecore Social Connected 2.0 API
Returns the account credentials by request id.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GetAccountCredentialsResponse EndGetAccountCredentials(
    string requestId
)
public GetAccountCredentialsResponse EndGetAccountCredentials(
    string requestId
)
Parameters
requestId
Type:   Online System String
The request id returned in the query string at the end of the flow.
Return Value
Type: GetAccountCredentialsResponse

             The account credentials response.

Implements
IAccountClientManager EndGetAccountCredentials(String)
Remarks

             This method helps you to complete the process of receiving account credentials.
             At the end of the flow you'll be redirected to the CallbackPageUrl with the RequestIdParameterName parameter in a query string.
             Use this request id to receive the account credentials response.

Examples
View Colorized Copy to Clipboard Print
var requestId = HttpContext.Current.Request.QueryString[GetAccountCredentialsRequest.RequestIdParameterName];
var response = accountClientManager.EndGetAccountCredentials(requestId);

switch (response.Status)
{
  case GetAccountCredentialsResponseStatus.Done:
    var contextData = (Dictionary<string, object>)response.ContextData;

    var newAccount = new Account
      {
        AccountContainer = "/sitecore/system/Social/Accounts",
        AccountCredentials = response.AccountCredentials,
        ApplicationId = (Identifier)contextData["ApplicationId"],
        LastRenewalDate = DateTime.Now,
        Name = (string)contextData["AccountName"]
      };

    accountManager.CreateAccount(newAccount);
    this.ShowAccount(newAccount);
    break;
  case GetAccountCredentialsResponseStatus.Failed:
    var exceptionClientManager = new ExceptionClientManager();
    var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);
    this.ShowExceptionInfo(exceptionInfo);
    break;
  case GetAccountCredentialsResponseStatus.ResponseIsNotFound:
    Console.WriteLine("Session is expired or response is not found.");
    break;
}
var requestId = HttpContext.Current.Request.QueryString[GetAccountCredentialsRequest.RequestIdParameterName];
var response = accountClientManager.EndGetAccountCredentials(requestId);

switch (response.Status)
{
  case GetAccountCredentialsResponseStatus.Done:
    var contextData = (Dictionary<string, object>)response.ContextData;

    var newAccount = new Account
      {
        AccountContainer = "/sitecore/system/Social/Accounts",
        AccountCredentials = response.AccountCredentials,
        ApplicationId = (Identifier)contextData["ApplicationId"],
        LastRenewalDate = DateTime.Now,
        Name = (string)contextData["AccountName"]
      };

    accountManager.CreateAccount(newAccount);
    this.ShowAccount(newAccount);
    break;
  case GetAccountCredentialsResponseStatus.Failed:
    var exceptionClientManager = new ExceptionClientManager();
    var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);
    this.ShowExceptionInfo(exceptionInfo);
    break;
  case GetAccountCredentialsResponseStatus.ResponseIsNotFound:
    Console.WriteLine("Session is expired or response is not found.");
    break;
}
See Also
AccountClientManager Class
AccountClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Class

ConnectorClientManager Class Sitecore Social Connected 2.0 API
Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Api ConnectorClientManager

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConnectorClientManager : IConnectorClientManager
public class ConnectorClientManager : IConnectorClientManager
See Also
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Members

ConnectorClientManager Members Sitecore Social Connected 2.0 API

The ConnectorClientManager type exposes the following members.
Constructors
 | Name | Description
Public method | ConnectorClientManager | Initializes a new instance of the ConnectorClientManager class.
Public method | ConnectorClientManager(IConfigurationFactory, IUserManager, ISocialProfileManager) | Initializes a new instance of the ConnectorClientManager class with the specified parameters.
Back to Top
Methods
 | Name | Description
Public method | AttachToUser(String) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | AttachToUser(String, ApplicationCredentials) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)
Public method | AttachToUser(String, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)
Public method | AttachToUser(String, ApplicationCredentials, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LogOnUser(String) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, Boolean) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials, Boolean) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Protected property | ConfigurationFactory | Gets the configuration factory.
Protected property | SocialProfileManager | Gets the social profile manager.
Protected property | UserManager | Gets the user manager.
Back to Top
See Also
ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Constructor

ConnectorClientManager Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ConnectorClientManager | Initializes a new instance of the ConnectorClientManager class.
Public method | ConnectorClientManager(IConfigurationFactory, IUserManager, ISocialProfileManager) | Initializes a new instance of the ConnectorClientManager class with the specified parameters.
Back to Top
See Also
ConnectorClientManager Class
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Constructor

ConnectorClientManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ConnectorClientManager class.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConnectorClientManager()
public ConnectorClientManager()
See Also
ConnectorClientManager Class
ConnectorClientManager Members
ConnectorClientManager Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Constructor (IConfigurationFactory, , ISocialProfileManager)

ConnectorClientManager Constructor (IConfigurationFactory, , ISocialProfileManager) Sitecore Social Connected 2.0 API
Initializes a new instance of the ConnectorClientManager class with the specified parameters.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConnectorClientManager(
    IConfigurationFactory configurationFactory,
    IUserManager userManager,
    ISocialProfileManager socialProfileManager
)
public ConnectorClientManager(
    IConfigurationFactory configurationFactory,
    IUserManager userManager,
    ISocialProfileManager socialProfileManager
)
Parameters
configurationFactory
Type: Sitecore.Social.Configuration IConfigurationFactory
The configuration factory.
userManager
Type: IUserManager
The user manager.
socialProfileManager
Type: Sitecore.Social.Domain ISocialProfileManager
The social profile manager.
See Also
ConnectorClientManager Class
ConnectorClientManager Members
ConnectorClientManager Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Methods

ConnectorClientManager Methods Sitecore Social Connected 2.0 API
The ConnectorClientManager type exposes the following members.
Methods
 | Name | Description
Public method | AttachToUser(String) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | AttachToUser(String, ApplicationCredentials) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)
Public method | AttachToUser(String, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)
Public method | AttachToUser(String, ApplicationCredentials, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LogOnUser(String) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, Boolean) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials, Boolean) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.AttachToUser Method

ConnectorClientManager AttachToUser Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | AttachToUser(String) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | AttachToUser(String, ApplicationCredentials) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)
Public method | AttachToUser(String, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)
Public method | AttachToUser(String, ApplicationCredentials, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)
Back to Top
See Also
ConnectorClientManager Class
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.AttachToUser Method (String)

ConnectorClientManager AttachToUser Method (String) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AttachToUser(
    string networkName
)
public void AttachToUser(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network (case-sensitive).
Implements
IConnectorClientManager AttachToUser(String)
Remarks

            At the end of the flow you'll be redirected on the same page again.
            Use GetExceptionInfo(HttpRequest) to get exception information in a case of error.

Examples
Remarks

            An example of how to start the process of attaching a social profile.

View Colorized Copy to Clipboard Print
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook");
}
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook");
}
Remarks

            Example of how to finish the process of attaching a social profile.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.AttachToUser Method (String, ApplicationCredentials)

ConnectorClientManager AttachToUser Method (String, ApplicationCredentials) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
public void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
Implements
IConnectorClientManager AttachToUser(String, ApplicationCredentials)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            An example of how to start the process of attaching a social profile.

View Colorized Copy to Clipboard Print
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"));
}
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"));
}
Remarks

            Example of how to finish the process of attaching a social profile.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.AttachToUser Method (String, Boolean)

ConnectorClientManager AttachToUser Method (String, Boolean) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AttachToUser(
    string networkName,
    bool updateSocialProfileAsync
)
public void AttachToUser(
    string networkName,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
Implements
IConnectorClientManager AttachToUser(String, Boolean)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            An example of how to start the process of attaching a social profile.

View Colorized Copy to Clipboard Print
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook", true);
}
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook", true);
}
Remarks

            Example of how to finish the process of attaching a social profile.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.AttachToUser Method (String, ApplicationCredentials, Boolean)

ConnectorClientManager AttachToUser Method (String, ApplicationCredentials, Boolean) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
public void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
Implements
IConnectorClientManager AttachToUser(String, ApplicationCredentials, Boolean)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            An example of how to start the process of attaching a social profile.

View Colorized Copy to Clipboard Print
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"), true);
}
if (HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.AttachToUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"), true);
}
Remarks

            Example of how to finish the process of attaching a social profile.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.LogOnUser Method

ConnectorClientManager LogOnUser Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | LogOnUser(String) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, Boolean) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials, Boolean) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Back to Top
See Also
ConnectorClientManager Class
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.LogOnUser Method (String)

ConnectorClientManager LogOnUser Method (String) Sitecore Social Connected 2.0 API
Logs the user in the specified network. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void LogOnUser(
    string networkName
)
public void LogOnUser(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network (case-sensitive).
Implements
IConnectorClientManager LogOnUser(String)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            Example of how to start the login process.

View Colorized Copy to Clipboard Print
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook");
}
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook");
}
Remarks

            Example of how to finish the login process.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.LogOnUser Method (String, ApplicationCredentials)

ConnectorClientManager LogOnUser Method (String, ApplicationCredentials) Sitecore Social Connected 2.0 API
Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
public void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
Implements
IConnectorClientManager LogOnUser(String, ApplicationCredentials)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            Example of how to start the login process.

View Colorized Copy to Clipboard Print
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"));
}
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"));
}
Remarks

            Example of how to finish the login process.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.LogOnUser Method (String, Boolean)

ConnectorClientManager LogOnUser Method (String, Boolean) Sitecore Social Connected 2.0 API
Logs the user in the specified network. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void LogOnUser(
    string networkName,
    bool updateSocialProfileAsync
)
public void LogOnUser(
    string networkName,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
Implements
IConnectorClientManager LogOnUser(String, Boolean)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            Example of how to start the login process.

View Colorized Copy to Clipboard Print
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook", true);
}
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook", true);
}
Remarks

            Example of how to finish the login process.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.LogOnUser Method (String, ApplicationCredentials, Boolean)

ConnectorClientManager LogOnUser Method (String, ApplicationCredentials, Boolean) Sitecore Social Connected 2.0 API
Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
public void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
Implements
IConnectorClientManager LogOnUser(String, ApplicationCredentials, Boolean)
Remarks

            At the end of the flow you'll be redirected to the same page again.
            Use GetExceptionInfo(HttpRequest) to get the exception information in a case of error.

Examples
Remarks

            Example of how to start the login process.

View Colorized Copy to Clipboard Print
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"), true);
}
if (!HttpContext.Current.User.Identity.IsAuthenticated)
{
  connectorClientManager.LogOnUser("Facebook", new ApplicationCredentials("<application key>", "<application secret>"), true);
}
Remarks

            Example of how to finish the login process.

View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);

if (exceptionInfo.IsEmpty)
{
  var facebookProfile = HttpContext.Current.User.GetSocialProfile("Facebook");

  if (!facebookProfile.IsEmpty)
  {
    this.ShowSocialProfile(facebookProfile);
  }
}
else
{
  Console.WriteLine("Simple message: {0}\nDetailed message: {1}", exceptionInfo.SimpleMessage, exceptionInfo.DetailedMessage);
}
See Also
ConnectorClientManager Class
ConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Api Namespace


ConnectorClientManager Properties

ConnectorClientManager Properties Sitecore Social Connected 2.0 API
The ConnectorClientManager type exposes the following members.
Properties
 | Name | Description
Protected property | ConfigurationFactory | Gets the configuration factory.
Protected property | SocialProfileManager | Gets the social profile manager.
Protected property | UserManager | Gets the user manager.
Back to Top
See Also
ConnectorClientManager Class
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.ConfigurationFactory Property

ConnectorClientManager ConfigurationFactory Property Sitecore Social Connected 2.0 API
Gets the configuration factory.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IConfigurationFactory ConfigurationFactory { get; private set; }
protected IConfigurationFactory ConfigurationFactory { get; private set; }
Property Value
Type: IConfigurationFactory

            The configuration factory.

See Also
ConnectorClientManager Class
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.SocialProfileManager Property

ConnectorClientManager SocialProfileManager Property Sitecore Social Connected 2.0 API
Gets the social profile manager.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ISocialProfileManager SocialProfileManager { get; private set; }
protected ISocialProfileManager SocialProfileManager { get; private set; }
Property Value
Type: ISocialProfileManager

            The social profile manager.

See Also
ConnectorClientManager Class
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ConnectorClientManager.UserManager Property

ConnectorClientManager UserManager Property Sitecore Social Connected 2.0 API
Gets the user manager.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IUserManager UserManager { get; private set; }
protected IUserManager UserManager { get; private set; }
Property Value
Type: IUserManager

            The user manager.

See Also
ConnectorClientManager Class
ConnectorClientManager Members
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Class

ExceptionClientManager Class Sitecore Social Connected 2.0 API
Represents receiving of exception information.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Api ExceptionClientManager

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExceptionClientManager : IExceptionClientManager
public class ExceptionClientManager : IExceptionClientManager
See Also
ExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Members

ExceptionClientManager Members Sitecore Social Connected 2.0 API

The ExceptionClientManager type exposes the following members.
Constructors
 | Name | Description
Public method | ExceptionClientManager | Initializes a new instance of the ExceptionClientManager class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetExceptionInfo | Receives the exception information.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ExceptionClientManager Class
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Constructor

ExceptionClientManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ExceptionClientManager class

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionClientManager()
public ExceptionClientManager()
See Also
ExceptionClientManager Class
ExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


ExceptionClientManager Methods

ExceptionClientManager Methods Sitecore Social Connected 2.0 API
The ExceptionClientManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetExceptionInfo | Receives the exception information.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ExceptionClientManager Class
Sitecore.Social.Client.Api Namespace


ExceptionClientManager.GetExceptionInfo Method

ExceptionClientManager GetExceptionInfo Method Sitecore Social Connected 2.0 API
Receives the exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionInfo GetExceptionInfo(
    HttpRequest request
)
public ExceptionInfo GetExceptionInfo(
    HttpRequest request
)
Parameters
request
Type:   Online System.Web HttpRequest
The http request.
Return Value
Type: ExceptionInfo
The exception information.
Implements
IExceptionClientManager GetExceptionInfo(HttpRequest)
Examples
View Colorized Copy to Clipboard Print
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);
if (!exceptionInfo.IsEmpty)
{
  this.ShowExceptionInfo(exceptionInfo);
}
var exceptionClientManager = new ExceptionClientManager();
var exceptionInfo = exceptionClientManager.GetExceptionInfo(HttpContext.Current.Request);
if (!exceptionInfo.IsEmpty)
{
  this.ShowExceptionInfo(exceptionInfo);
}
See Also
ExceptionClientManager Class
ExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Class

ExceptionInfo Class Sitecore Social Connected 2.0 API
Represents the information about exception.
Inheritance Hierarchy
Online System Object
SocialExceptionInfo
Sitecore.Social.Client.Api ExceptionInfo

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ExceptionInfo : SocialExceptionInfo,
    IEmptyable
[SerializableAttribute]
public class ExceptionInfo : SocialExceptionInfo,
    IEmptyable
See Also
ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Members

ExceptionInfo Members Sitecore Social Connected 2.0 API

The ExceptionInfo type exposes the following members.
Constructors
 | Name | Description
Public method | ExceptionInfo | Initializes a new instance of the ExceptionInfo class.
Public method | ExceptionInfo(ISocialException) | Initializes a new instance of the ExceptionInfo class and fills the class with information from the provided ISocialException parameter.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the ExceptionInfo class whose value represents not found exception info.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo Constructor

ExceptionInfo Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ExceptionInfo | Initializes a new instance of the ExceptionInfo class.
Public method | ExceptionInfo(ISocialException) | Initializes a new instance of the ExceptionInfo class and fills the class with information from the provided ISocialException parameter.
Back to Top
See Also
ExceptionInfo Class
ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Constructor

ExceptionInfo Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ExceptionInfo class.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionInfo()
public ExceptionInfo()
See Also
ExceptionInfo Class
ExceptionInfo Members
ExceptionInfo Overload
Sitecore.Social.Client.Api Namespace


ExceptionInfo Constructor (ISocialException)

ExceptionInfo Constructor (ISocialException) Sitecore Social Connected 2.0 API
Initializes a new instance of the ExceptionInfo class and fills the class with information from the provided ISocialException parameter.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionInfo(
    ISocialException exception
)
public ExceptionInfo(
    ISocialException exception
)
Parameters
exception
Type: Sitecore.Social.Domain.Exceptions ISocialException
The exception.
See Also
ExceptionInfo Class
ExceptionInfo Members
ExceptionInfo Overload
Sitecore.Social.Client.Api Namespace


ExceptionInfo Fields

ExceptionInfo Fields Sitecore Social Connected 2.0 API
The ExceptionInfo type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the ExceptionInfo class whose value represents not found exception info.
Back to Top
See Also
ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo.Empty Field

ExceptionInfo Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the ExceptionInfo class whose value represents not found exception info.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ExceptionInfo Empty
public static readonly ExceptionInfo Empty
Field Value
Type: ExceptionInfo
See Also
ExceptionInfo Class
ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


ExceptionInfo Methods

ExceptionInfo Methods Sitecore Social Connected 2.0 API
The ExceptionInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo Properties

ExceptionInfo Properties Sitecore Social Connected 2.0 API
The ExceptionInfo type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
ExceptionInfo Class
Sitecore.Social.Client.Api Namespace


ExceptionInfo.IsEmpty Property

ExceptionInfo IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
ExceptionInfo Class
ExceptionInfo Members
Sitecore.Social.Client.Api Namespace


IExceptionClientManager Interface

IExceptionClientManager Interface Sitecore Social Connected 2.0 API
Represents receiving of exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IExceptionClientManager
public interface IExceptionClientManager
See Also
IExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


IExceptionClientManager Members

IExceptionClientManager Members Sitecore Social Connected 2.0 API

The IExceptionClientManager type exposes the following members.
Methods
 | Name | Description
Public method | GetExceptionInfo | Receives the exception information.
Back to Top
See Also
IExceptionClientManager Interface
Sitecore.Social.Client.Api Namespace


IExceptionClientManager Methods

IExceptionClientManager Methods Sitecore Social Connected 2.0 API
The IExceptionClientManager type exposes the following members.
Methods
 | Name | Description
Public method | GetExceptionInfo | Receives the exception information.
Back to Top
See Also
IExceptionClientManager Interface
Sitecore.Social.Client.Api Namespace


IExceptionClientManager.GetExceptionInfo Method

IExceptionClientManager GetExceptionInfo Method Sitecore Social Connected 2.0 API
Receives the exception information.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ExceptionInfo GetExceptionInfo(
    HttpRequest request
)
ExceptionInfo GetExceptionInfo(
    HttpRequest request
)
Parameters
request
Type:   Online System.Web HttpRequest
The http request.
Return Value
Type: ExceptionInfo
The exception information.
See Also
IExceptionClientManager Interface
IExceptionClientManager Members
Sitecore.Social.Client.Api Namespace


ISocialPageEventClientManager Interface

ISocialPageEventClientManager Interface Sitecore Social Connected 2.0 API
Defines the methods to enrich PageEvents with extra parameters.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISocialPageEventClientManager
public interface ISocialPageEventClientManager
See Also
ISocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


ISocialPageEventClientManager Members

ISocialPageEventClientManager Members Sitecore Social Connected 2.0 API

The ISocialPageEventClientManager type exposes the following members.
Methods
 | Name | Description
Public method | GetSocialPageEventParameters | Gets the social page event parameters.
Public method | TriggerSocialPageEvent | Registers the event parameters.
Back to Top
See Also
ISocialPageEventClientManager Interface
Sitecore.Social.Client.Api Namespace


ISocialPageEventClientManager Methods

ISocialPageEventClientManager Methods Sitecore Social Connected 2.0 API
The ISocialPageEventClientManager type exposes the following members.
Methods
 | Name | Description
Public method | GetSocialPageEventParameters | Gets the social page event parameters.
Public method | TriggerSocialPageEvent | Registers the event parameters.
Back to Top
See Also
ISocialPageEventClientManager Interface
Sitecore.Social.Client.Api Namespace


ISocialPageEventClientManager.GetSocialPageEventParameters Method

ISocialPageEventClientManager GetSocialPageEventParameters Method Sitecore Social Connected 2.0 API
Gets the social page event parameters.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDictionary<string, string> GetSocialPageEventParameters(
    SocialPageEventItem socialPageItem
)
IDictionary<string, string> GetSocialPageEventParameters(
    SocialPageEventItem socialPageItem
)
Parameters
socialPageItem
Type: Sitecore.Social.Client.Api SocialPageEventItem
The social page item.
Return Value
Type:   Online IDictionary    Online String,   Online String
The social page event parameters.
See Also
ISocialPageEventClientManager Interface
ISocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


ISocialPageEventClientManager.TriggerSocialPageEvent Method

ISocialPageEventClientManager TriggerSocialPageEvent Method Sitecore Social Connected 2.0 API
Registers the event parameters.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void TriggerSocialPageEvent(
    string pageEventName,
    IDictionary<string, string> parameters
)
void TriggerSocialPageEvent(
    string pageEventName,
    IDictionary<string, string> parameters
)
Parameters
pageEventName
Type:   Online System String
Name of the page event.
parameters
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The parameters.
See Also
ISocialPageEventClientManager Interface
ISocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


SocialPageEventClientManager Class

SocialPageEventClientManager Class Sitecore Social Connected 2.0 API
Helps to enrich PageEvents with extra parameters.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Api SocialPageEventClientManager

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SocialPageEventClientManager : ISocialPageEventClientManager
public class SocialPageEventClientManager : ISocialPageEventClientManager
See Also
SocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


SocialPageEventClientManager Members

SocialPageEventClientManager Members Sitecore Social Connected 2.0 API

The SocialPageEventClientManager type exposes the following members.
Constructors
 | Name | Description
Public method | SocialPageEventClientManager | Initializes a new instance of the SocialPageEventClientManager class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSocialPageEventParameters | Gets the social page event parameters.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TriggerSocialPageEvent | Registers the event parameters.
Back to Top
See Also
SocialPageEventClientManager Class
Sitecore.Social.Client.Api Namespace


SocialPageEventClientManager Constructor

SocialPageEventClientManager Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialPageEventClientManager class

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialPageEventClientManager()
public SocialPageEventClientManager()
See Also
SocialPageEventClientManager Class
SocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


SocialPageEventClientManager Methods

SocialPageEventClientManager Methods Sitecore Social Connected 2.0 API
The SocialPageEventClientManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSocialPageEventParameters | Gets the social page event parameters.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TriggerSocialPageEvent | Registers the event parameters.
Back to Top
See Also
SocialPageEventClientManager Class
Sitecore.Social.Client.Api Namespace


SocialPageEventClientManager.GetSocialPageEventParameters Method

SocialPageEventClientManager GetSocialPageEventParameters Method Sitecore Social Connected 2.0 API
Gets the social page event parameters.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> GetSocialPageEventParameters(
    SocialPageEventItem socialPageItem
)
public IDictionary<string, string> GetSocialPageEventParameters(
    SocialPageEventItem socialPageItem
)
Parameters
socialPageItem
Type: Sitecore.Social.Client.Api SocialPageEventItem
The social page item.
Return Value
Type:   Online IDictionary    Online String,   Online String
The social page event parameters.
Implements
ISocialPageEventClientManager GetSocialPageEventParameters(SocialPageEventItem)
Examples
View Colorized Copy to Clipboard Print
if (pageEventItem is SocialPageEventItem)
{
  var parameters = pageEventClientManager.GetSocialPageEventParameters(pageEventItem);

  foreach (var parameter in parameters)
  {
    Console.WriteLine("Parameter: {0}; with value: {1}", parameter.Key, parameter.Value);
  }
}
if (pageEventItem is SocialPageEventItem)
{
  var parameters = pageEventClientManager.GetSocialPageEventParameters(pageEventItem);

  foreach (var parameter in parameters)
  {
    Console.WriteLine("Parameter: {0}; with value: {1}", parameter.Key, parameter.Value);
  }
}
See Also
SocialPageEventClientManager Class
SocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


SocialPageEventClientManager.TriggerSocialPageEvent Method

SocialPageEventClientManager TriggerSocialPageEvent Method Sitecore Social Connected 2.0 API
Registers the event parameters.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TriggerSocialPageEvent(
    string pageEventName,
    IDictionary<string, string> parameters
)
public void TriggerSocialPageEvent(
    string pageEventName,
    IDictionary<string, string> parameters
)
Parameters
pageEventName
Type:   Online System String
Name of the page event.
parameters
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The parameters.
Implements
ISocialPageEventClientManager TriggerSocialPageEvent(String, IDictionary String, String )
Examples
View Colorized Copy to Clipboard Print
const string PageEventName = "Social Test Page Event";
var tokensToBeReplaced = new Dictionary<string, string> { { "testToken", "New Value" } };
pageEventClientManager.TriggerSocialPageEvent(PageEventName, tokensToBeReplaced);
const string PageEventName = "Social Test Page Event";
var tokensToBeReplaced = new Dictionary<string, string> { { "testToken", "New Value" } };
pageEventClientManager.TriggerSocialPageEvent(PageEventName, tokensToBeReplaced);
See Also
SocialPageEventClientManager Class
SocialPageEventClientManager Members
Sitecore.Social.Client.Api Namespace


SocialPageEventItem Class

SocialPageEventItem Class Sitecore Social Connected 2.0 API
Represents the PageEvent wrapper to store additional data.
Inheritance Hierarchy
Online System Object
CustomItemBase
CustomItem
PageEventItem
Sitecore.Social.Client.Api SocialPageEventItem

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SocialPageEventItem : PageEventItem
public class SocialPageEventItem : PageEventItem
See Also
SocialPageEventItem Members
Sitecore.Social.Client.Api Namespace


SocialPageEventItem Members

SocialPageEventItem Members Sitecore Social Connected 2.0 API

The SocialPageEventItem type exposes the following members.
Constructors
 | Name | Description
Public method | SocialPageEventItem | Initializes a new instance of the SocialPageEventItem class.
Back to Top
Methods
 | Name | Description
Public method | BeginEdit | (Inherited from CustomItemBase.)
Public method | EndEdit | (Inherited from CustomItemBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Category | (Inherited from PageEventItem.)
Public property | Data | Gets or sets the data.
Public property | Database | (Inherited from CustomItemBase.)
Public property | Description | (Inherited from PageEventItem.)
Public property | DisplayName | (Inherited from CustomItemBase.)
Public property | Icon | (Inherited from CustomItemBase.)
Public property | ID | (Inherited from CustomItemBase.)
Public property | InnerItem | (Inherited from CustomItemBase.)
Public property | IsAuthorFeedback | Obsolete. (Inherited from PageEventItem.)
Public property | IsDeployed | (Inherited from PageEventItem.)
Public property | IsFailure | (Inherited from PageEventItem.)
Public property | IsGoal | (Inherited from PageEventItem.)
Public property | IsSystem | (Inherited from PageEventItem.)
Public property | Item | (Inherited from CustomItem.)
Public property | Item | (Inherited from CustomItem.)
Public property | Item | (Inherited from CustomItem.)
Public property | Name | (Inherited from CustomItemBase.)
Public property | NameField | (Inherited from PageEventItem.)
Public property | Points | (Inherited from PageEventItem.)
Public property | Rule | (Inherited from PageEventItem.)
Back to Top
See Also
SocialPageEventItem Class
Sitecore.Social.Client.Api Namespace


SocialPageEventItem Constructor

SocialPageEventItem Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialPageEventItem class.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialPageEventItem(
    Item item
)
public SocialPageEventItem(
    Item item
)
Parameters
item
Type: Item
The item.
See Also
SocialPageEventItem Class
SocialPageEventItem Members
Sitecore.Social.Client.Api Namespace


SocialPageEventItem Methods

SocialPageEventItem Methods Sitecore Social Connected 2.0 API
The SocialPageEventItem type exposes the following members.
Methods
 | Name | Description
Public method | BeginEdit | (Inherited from CustomItemBase.)
Public method | EndEdit | (Inherited from CustomItemBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SocialPageEventItem Class
Sitecore.Social.Client.Api Namespace


SocialPageEventItem Properties

SocialPageEventItem Properties Sitecore Social Connected 2.0 API
The SocialPageEventItem type exposes the following members.
Properties
 | Name | Description
Public property | Category | (Inherited from PageEventItem.)
Public property | Data | Gets or sets the data.
Public property | Database | (Inherited from CustomItemBase.)
Public property | Description | (Inherited from PageEventItem.)
Public property | DisplayName | (Inherited from CustomItemBase.)
Public property | Icon | (Inherited from CustomItemBase.)
Public property | ID | (Inherited from CustomItemBase.)
Public property | InnerItem | (Inherited from CustomItemBase.)
Public property | IsAuthorFeedback | Obsolete. (Inherited from PageEventItem.)
Public property | IsDeployed | (Inherited from PageEventItem.)
Public property | IsFailure | (Inherited from PageEventItem.)
Public property | IsGoal | (Inherited from PageEventItem.)
Public property | IsSystem | (Inherited from PageEventItem.)
Public property | Item | (Inherited from CustomItem.)
Public property | Item | (Inherited from CustomItem.)
Public property | Item | (Inherited from CustomItem.)
Public property | Name | (Inherited from CustomItemBase.)
Public property | NameField | (Inherited from PageEventItem.)
Public property | Points | (Inherited from PageEventItem.)
Public property | Rule | (Inherited from PageEventItem.)
Back to Top
See Also
SocialPageEventItem Class
Sitecore.Social.Client.Api Namespace


SocialPageEventItem.Data Property

SocialPageEventItem Data Property Sitecore Social Connected 2.0 API
Gets or sets the data.

Namespace: Sitecore.Social.Client.Api
Assembly: Sitecore.Social.Client.Api (in Sitecore.Social.Client.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Data { get; set; }
public string Data { get; set; }
Property Value
Type:   Online String
The data.
See Also
SocialPageEventItem Class
SocialPageEventItem Members
Sitecore.Social.Client.Api Namespace


Sitecore.Social.Client.Domain Namespace

Sitecore.Social.Client.Domain Namespace Sitecore Social Connected 2.0 API
Provides a set of classes that extends domain's model.
Interfaces
 | Interface | Description
Public interface | IAccountClientManager | Defines the methods that are used to work with a social network account.
Public interface | IConnectorClientManager | Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.


IAccountClientManager Interface

IAccountClientManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to work with a social network account.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAccountClientManager
public interface IAccountClientManager
See Also
IAccountClientManager Members
Sitecore.Social.Client.Domain Namespace


IAccountClientManager Members

IAccountClientManager Members Sitecore Social Connected 2.0 API

The IAccountClientManager type exposes the following members.
Methods
 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.
Back to Top
See Also
IAccountClientManager Interface
Sitecore.Social.Client.Domain Namespace


IAccountClientManager Methods

IAccountClientManager Methods Sitecore Social Connected 2.0 API
The IAccountClientManager type exposes the following members.
Methods
 | Name | Description
Public method | BeginGetAccountCredentials | Initializes the process of receiving the social network account credentials.
Public method | EndGetAccountCredentials | Returns the account credentials by request id.
Back to Top
See Also
IAccountClientManager Interface
Sitecore.Social.Client.Domain Namespace


IAccountClientManager.BeginGetAccountCredentials Method

IAccountClientManager BeginGetAccountCredentials Method Sitecore Social Connected 2.0 API
Initializes the process of receiving the social network account credentials.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void BeginGetAccountCredentials(
    GetAccountCredentialsRequest request
)
void BeginGetAccountCredentials(
    GetAccountCredentialsRequest request
)
Parameters
request
Type: Sitecore.Social.Client.Domain.Requests GetAccountCredentialsRequest
The account credentials request.
See Also
IAccountClientManager Interface
IAccountClientManager Members
Sitecore.Social.Client.Domain Namespace


IAccountClientManager.EndGetAccountCredentials Method

IAccountClientManager EndGetAccountCredentials Method Sitecore Social Connected 2.0 API
Returns the account credentials by request id.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GetAccountCredentialsResponse EndGetAccountCredentials(
    string requestId
)
GetAccountCredentialsResponse EndGetAccountCredentials(
    string requestId
)
Parameters
requestId
Type:   Online System String
The request id returned in the query string at the end of the flow.
Return Value
Type: GetAccountCredentialsResponse
The account credentials response.
See Also
IAccountClientManager Interface
IAccountClientManager Members
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager Interface

IConnectorClientManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to log in users with social networks or attach social network profiles for existing users.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConnectorClientManager
public interface IConnectorClientManager
See Also
IConnectorClientManager Members
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager Members

IConnectorClientManager Members Sitecore Social Connected 2.0 API

Methods
 | Name | Description
Public method | AttachToUser(String) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | AttachToUser(String, ApplicationCredentials) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)
Public method | AttachToUser(String, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)
Public method | AttachToUser(String, ApplicationCredentials, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)
Public method | LogOnUser(String) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, Boolean) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials, Boolean) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Back to Top
See Also
IConnectorClientManager Interface
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager Methods

IConnectorClientManager Methods Sitecore Social Connected 2.0 API
Methods
 | Name | Description
Public method | AttachToUser(String) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | AttachToUser(String, ApplicationCredentials) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)
Public method | AttachToUser(String, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)
Public method | AttachToUser(String, ApplicationCredentials, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)
Public method | LogOnUser(String) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, Boolean) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials, Boolean) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Back to Top
See Also
IConnectorClientManager Interface
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.AttachToUser Method

IConnectorClientManager AttachToUser Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | AttachToUser(String) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)
Public method | AttachToUser(String, ApplicationCredentials) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)
Public method | AttachToUser(String, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)
Public method | AttachToUser(String, ApplicationCredentials, Boolean) | Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)
Back to Top
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.AttachToUser Method (String)

IConnectorClientManager AttachToUser Method (String) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String)

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AttachToUser(
    string networkName
)
void AttachToUser(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.AttachToUser Method (String, ApplicationCredentials)

IConnectorClientManager AttachToUser Method (String, ApplicationCredentials) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials)

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.AttachToUser Method (String, Boolean)

IConnectorClientManager AttachToUser Method (String, Boolean) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, Boolean)

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AttachToUser(
    string networkName,
    bool updateSocialProfileAsync
)
void AttachToUser(
    string networkName,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.AttachToUser Method (String, ApplicationCredentials, Boolean)

IConnectorClientManager AttachToUser Method (String, ApplicationCredentials, Boolean) Sitecore Social Connected 2.0 API
Attaches the specified network social profile to the logged in user. If the current user is not logged in, it tries to log in with LogOnUser(String, ApplicationCredentials, Boolean)

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
void AttachToUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
AttachToUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.LogOnUser Method

IConnectorClientManager LogOnUser Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | LogOnUser(String) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, Boolean) | Logs the user in the specified network. If the user account doesn’t exist, it will be created.
Public method | LogOnUser(String, ApplicationCredentials, Boolean) | Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.
Back to Top
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.LogOnUser Method (String)

IConnectorClientManager LogOnUser Method (String) Sitecore Social Connected 2.0 API
Logs the user in the specified network. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void LogOnUser(
    string networkName
)
void LogOnUser(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.LogOnUser Method (String, ApplicationCredentials)

IConnectorClientManager LogOnUser Method (String, ApplicationCredentials) Sitecore Social Connected 2.0 API
Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.LogOnUser Method (String, Boolean)

IConnectorClientManager LogOnUser Method (String, Boolean) Sitecore Social Connected 2.0 API
Logs the user in the specified network. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void LogOnUser(
    string networkName,
    bool updateSocialProfileAsync
)
void LogOnUser(
    string networkName,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Domain Namespace


IConnectorClientManager.LogOnUser Method (String, ApplicationCredentials, Boolean)

IConnectorClientManager LogOnUser Method (String, ApplicationCredentials, Boolean) Sitecore Social Connected 2.0 API
Logs the user in the specified network with the specified application credentials. If the user account doesn’t exist, it will be created.

Namespace: Sitecore.Social.Client.Domain
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
void LogOnUser(
    string networkName,
    ApplicationCredentials applicationCredentials,
    bool updateSocialProfileAsync
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
updateSocialProfileAsync
Type:   Online System Boolean
if set to true a social profile will be updated asynchronously.
See Also
IConnectorClientManager Interface
IConnectorClientManager Members
LogOnUser Overload
Sitecore.Social.Client.Domain Namespace


Sitecore.Social.Client.Domain.Requests Namespace

Sitecore.Social.Client.Domain.Requests Namespace Sitecore Social Connected 2.0 API
Provides classes that contain requests.
Classes
 | Class | Description
Public class | GetAccountCredentialsRequest | Represents the account credentials request.


GetAccountCredentialsRequest Class

GetAccountCredentialsRequest Class Sitecore Social Connected 2.0 API
Represents the account credentials request.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Domain.Requests GetAccountCredentialsRequest

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GetAccountCredentialsRequest
[SerializableAttribute]
public class GetAccountCredentialsRequest
See Also
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Members

GetAccountCredentialsRequest Members Sitecore Social Connected 2.0 API

The GetAccountCredentialsRequest type exposes the following members.
Constructors
 | Name | Description
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri) | Initializes a new instance of the GetAccountCredentialsRequest class.
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri, Object) | Initializes a new instance of the GetAccountCredentialsRequest class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
RequestIdParameterName | The request id parameter name
Back to Top
Properties
 | Name | Description
Public property | ApplicationCredentials | Gets the application credentials.
Public property | CallbackPageUrl | Gets the URL of the page to be redirected at the end of the flow.
Public property | ContextData | Gets the context data.
Public property | NetworkName | Gets the name of the network.
Public property | Permissions | Gets the permissions.
Public property | RequestId | Gets the request id.
Back to Top
See Also
GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Constructor

GetAccountCredentialsRequest Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri) | Initializes a new instance of the GetAccountCredentialsRequest class.
Public method | GetAccountCredentialsRequest(String, ApplicationCredentials, Uri, Object) | Initializes a new instance of the GetAccountCredentialsRequest class.
Back to Top
See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri)

GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri) Sitecore Social Connected 2.0 API
Initializes a new instance of the GetAccountCredentialsRequest class.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GetAccountCredentialsRequest(
    string networkName,
    ApplicationCredentials applicationCredentials,
    Uri callbackPageUrl
)
public GetAccountCredentialsRequest(
    string networkName,
    ApplicationCredentials applicationCredentials,
    Uri callbackPageUrl
)
Parameters
networkName
Type:   Online System String
The network name.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
callbackPageUrl
Type:   Online System Uri
The callback page url.
See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
GetAccountCredentialsRequest Overload
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri, Object)

GetAccountCredentialsRequest Constructor (String, ApplicationCredentials, Uri, Object) Sitecore Social Connected 2.0 API
Initializes a new instance of the GetAccountCredentialsRequest class.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GetAccountCredentialsRequest(
    string networkName,
    ApplicationCredentials applicationCredentials,
    Uri callbackPageUrl,
    Object contextData
)
public GetAccountCredentialsRequest(
    string networkName,
    ApplicationCredentials applicationCredentials,
    Uri callbackPageUrl,
    Object contextData
)
Parameters
networkName
Type:   Online System String

            The network name.

applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials

            The application credentials.

callbackPageUrl
Type:   Online System Uri

            The callback page url.

contextData
Type:   Online System Object

            The context data. It's recommended to be serializable.

See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
GetAccountCredentialsRequest Overload
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Fields

GetAccountCredentialsRequest Fields Sitecore Social Connected 2.0 API
The GetAccountCredentialsRequest type exposes the following members.
Fields
Name | Description
RequestIdParameterName | The request id parameter name
Back to Top
See Also
GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.RequestIdParameterName Field

GetAccountCredentialsRequest RequestIdParameterName Field Sitecore Social Connected 2.0 API
The request id parameter name

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string RequestIdParameterName
public static readonly string RequestIdParameterName
Field Value
Type:   Online String
See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Methods

GetAccountCredentialsRequest Methods Sitecore Social Connected 2.0 API
The GetAccountCredentialsRequest type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest Properties

GetAccountCredentialsRequest Properties Sitecore Social Connected 2.0 API
The GetAccountCredentialsRequest type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationCredentials | Gets the application credentials.
Public property | CallbackPageUrl | Gets the URL of the page to be redirected at the end of the flow.
Public property | ContextData | Gets the context data.
Public property | NetworkName | Gets the name of the network.
Public property | Permissions | Gets the permissions.
Public property | RequestId | Gets the request id.
Back to Top
See Also
GetAccountCredentialsRequest Class
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.ApplicationCredentials Property

GetAccountCredentialsRequest ApplicationCredentials Property Sitecore Social Connected 2.0 API
Gets the application credentials.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationCredentials ApplicationCredentials { get; private set; }
public ApplicationCredentials ApplicationCredentials { get; private set; }
Property Value
Type: ApplicationCredentials

            The application credentials.

See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.CallbackPageUrl Property

GetAccountCredentialsRequest CallbackPageUrl Property Sitecore Social Connected 2.0 API
Gets the URL of the page to be redirected at the end of the flow.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri CallbackPageUrl { get; private set; }
public Uri CallbackPageUrl { get; private set; }
Property Value
Type:   Online Uri

            The callback page URL.

See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.ContextData Property

GetAccountCredentialsRequest ContextData Property Sitecore Social Connected 2.0 API
Gets the context data.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ContextData { get; private set; }
public Object ContextData { get; private set; }
Property Value
Type:   Online Object

            The context data.

Remarks
During the receiving account credentials process you'll be redirected on a domain of social network and then redirected back.
            Use this storage if you want to keep any data during this process.
See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.NetworkName Property

GetAccountCredentialsRequest NetworkName Property Sitecore Social Connected 2.0 API
Gets the name of the network.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetworkName { get; private set; }
public string NetworkName { get; private set; }
Property Value
Type:   Online String

            The name of the network.

See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.Permissions Property

GetAccountCredentialsRequest Permissions Property Sitecore Social Connected 2.0 API
Gets the permissions.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Permissions { get; private set; }
public IDictionary<string, string> Permissions { get; private set; }
Property Value
Type:   Online IDictionary    Online String,   Online String

            The permissions.

See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


GetAccountCredentialsRequest.RequestId Property

GetAccountCredentialsRequest RequestId Property Sitecore Social Connected 2.0 API
Gets the request id.

Namespace: Sitecore.Social.Client.Domain.Requests
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestId { get; private set; }
public string RequestId { get; private set; }
Property Value
Type:   Online String

            The request id.

See Also
GetAccountCredentialsRequest Class
GetAccountCredentialsRequest Members
Sitecore.Social.Client.Domain.Requests Namespace


Sitecore.Social.Client.Domain.Responses Namespace

Sitecore.Social.Client.Domain.Responses Namespace Sitecore Social Connected 2.0 API
Provides classes that contain responses.
Classes
 | Class | Description
Public class | GetAccountCredentialsResponse | Represents the account credentials response.
Public class | ResponseStatus T | Represents the base class for API responses.
Enumerations
 | Enumeration | Description
Public enumeration | GetAccountCredentialsResponseStatus | Defines constants for account credentials response status.


GetAccountCredentialsResponse Class

GetAccountCredentialsResponse Class Sitecore Social Connected 2.0 API
Represents the account credentials response.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Domain.Responses ResponseStatus GetAccountCredentialsResponseStatus
Sitecore.Social.Client.Domain.Responses GetAccountCredentialsResponse

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GetAccountCredentialsResponse : ResponseStatus<GetAccountCredentialsResponseStatus>
[SerializableAttribute]
public class GetAccountCredentialsResponse : ResponseStatus<GetAccountCredentialsResponseStatus>
See Also
GetAccountCredentialsResponse Members
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Members

GetAccountCredentialsResponse Members Sitecore Social Connected 2.0 API

The GetAccountCredentialsResponse type exposes the following members.
Constructors
 | Name | Description
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials, Object) | Initializes a new instance of the GetAccountCredentialsResponse class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AccountCredentials | Gets the account credentials.
Public property | ContextData | Gets the context data.
Public property | Status | Gets the status. (Inherited from ResponseStatus T .)
Back to Top
See Also
GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor

GetAccountCredentialsResponse Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials) | Initializes a new instance of the GetAccountCredentialsResponse class.
Public method | GetAccountCredentialsResponse(GetAccountCredentialsResponseStatus, AccountCredentials, Object) | Initializes a new instance of the GetAccountCredentialsResponse class.
Back to Top
See Also
GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus)

GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus) Sitecore Social Connected 2.0 API
Initializes a new instance of the GetAccountCredentialsResponse class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status
)
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status
)
Parameters
status
Type: Sitecore.Social.Client.Domain.Responses GetAccountCredentialsResponseStatus
The status.
See Also
GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
GetAccountCredentialsResponse Overload
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials)

GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials) Sitecore Social Connected 2.0 API
Initializes a new instance of the GetAccountCredentialsResponse class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials accountCredentials
)
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials accountCredentials
)
Parameters
status
Type: Sitecore.Social.Client.Domain.Responses GetAccountCredentialsResponseStatus
The status.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
See Also
GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
GetAccountCredentialsResponse Overload
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials, Object)

GetAccountCredentialsResponse Constructor (GetAccountCredentialsResponseStatus, AccountCredentials, Object) Sitecore Social Connected 2.0 API
Initializes a new instance of the GetAccountCredentialsResponse class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials accountCredentials,
    Object contextData
)
public GetAccountCredentialsResponse(
    GetAccountCredentialsResponseStatus status,
    AccountCredentials accountCredentials,
    Object contextData
)
Parameters
status
Type: Sitecore.Social.Client.Domain.Responses GetAccountCredentialsResponseStatus
The status.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
contextData
Type:   Online System Object
The context data.
See Also
GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
GetAccountCredentialsResponse Overload
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Methods

GetAccountCredentialsResponse Methods Sitecore Social Connected 2.0 API
The GetAccountCredentialsResponse type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse Properties

GetAccountCredentialsResponse Properties Sitecore Social Connected 2.0 API
The GetAccountCredentialsResponse type exposes the following members.
Properties
 | Name | Description
Public property | AccountCredentials | Gets the account credentials.
Public property | ContextData | Gets the context data.
Public property | Status | Gets the status. (Inherited from ResponseStatus T .)
Back to Top
See Also
GetAccountCredentialsResponse Class
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse.AccountCredentials Property

GetAccountCredentialsResponse AccountCredentials Property Sitecore Social Connected 2.0 API
Gets the account credentials.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountCredentials AccountCredentials { get; private set; }
public AccountCredentials AccountCredentials { get; private set; }
Property Value
Type: AccountCredentials

            The account credentials.

See Also
GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponse.ContextData Property

GetAccountCredentialsResponse ContextData Property Sitecore Social Connected 2.0 API
Gets the context data.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ContextData { get; private set; }
public Object ContextData { get; private set; }
Property Value
Type:   Online Object

            The context data.

Remarks
During the receiving account credentials process you'll be redirected on a domain of social network and then redirected back.
            Use this storage if you want to keep any data during this process.
See Also
GetAccountCredentialsResponse Class
GetAccountCredentialsResponse Members
Sitecore.Social.Client.Domain.Responses Namespace


GetAccountCredentialsResponseStatus Enumeration

GetAccountCredentialsResponseStatus Enumeration Sitecore Social Connected 2.0 API
Defines constants for account credentials response status.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GetAccountCredentialsResponseStatus
[SerializableAttribute]
public enum GetAccountCredentialsResponseStatus
Members
Member name | Value | Description
Done | 0 | Account credentials received successfully.
Failed | 1 | Receiving failed.
ResponseIsNotFound | 2 | The response is not found
See Also
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Class

ResponseStatus T Class Sitecore Social Connected 2.0 API
Represents the base class for API responses.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Client.Domain.Responses ResponseStatus T
Sitecore.Social.Client.Domain.Responses GetAccountCredentialsResponse

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ResponseStatus<T>
where T : struct, new()
[SerializableAttribute]
public class ResponseStatus<T>
where T : struct, new()
Type Parameters
T
The response status type.
See Also
ResponseStatus T  Members
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Members

ResponseStatus T Members Sitecore Social Connected 2.0 API

The ResponseStatus T type exposes the following members.
Constructors
 | Name | Description
Public method | ResponseStatus T | Initializes a new instance of the ResponseStatus T class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Status | Gets the status.
Back to Top
See Also
ResponseStatus T Class
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Constructor

ResponseStatus T Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ResponseStatus T class.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseStatus(
    T status
)
public ResponseStatus(
    T status
)
Parameters
status
Type: T
The status.
See Also
ResponseStatus T  Class
ResponseStatus T  Members
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Methods

ResponseStatus T Methods Sitecore Social Connected 2.0 API
The ResponseStatus T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ResponseStatus T Class
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T) Properties

ResponseStatus T Properties Sitecore Social Connected 2.0 API
The ResponseStatus T type exposes the following members.
Properties
 | Name | Description
Public property | Status | Gets the status.
Back to Top
See Also
ResponseStatus T Class
Sitecore.Social.Client.Domain.Responses Namespace


ResponseStatus(T).Status Property

ResponseStatus T Status Property Sitecore Social Connected 2.0 API
Gets the status.

Namespace: Sitecore.Social.Client.Domain.Responses
Assembly: Sitecore.Social.Client.Domain (in Sitecore.Social.Client.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Status { get; private set; }
public T Status { get; private set; }
Property Value
Type: T

            The status.

See Also
ResponseStatus T  Class
ResponseStatus T  Members
Sitecore.Social.Client.Domain.Responses Namespace


Sitecore.Social.Configuration Namespace

Sitecore.Social.Configuration Namespace Sitecore Social Connected 2.0 API
Provides classes that allow reading the configuration.
Classes
 | Class | Description
Public class | ConfigurationCache | The configuration cache.
Public class | ConfigurationFactory | The configuration factory.
Interfaces
 | Interface | Description
Public interface | IConfigurationCache | The ConfigurationCache interface.
Public interface | IConfigurationFactory | The ConfigurationFactory interface.


ConfigurationCache Class

ConfigurationCache Class Sitecore Social Connected 2.0 API
The configuration cache.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration ConfigurationCache

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConfigurationCache : IConfigurationCache
public class ConfigurationCache : IConfigurationCache
See Also
ConfigurationCache Members
Sitecore.Social.Configuration Namespace


ConfigurationCache Members

ConfigurationCache Members Sitecore Social Connected 2.0 API

The ConfigurationCache type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigurationCache | Initializes a new instance of the ConfigurationCache class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists T | Checks if there is ConfigurationData in the cache.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get T | Gets ConfigurationData from the cache.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set | Sets ConfigurationData in the cache.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ConfigurationCache Class
Sitecore.Social.Configuration Namespace


ConfigurationCache Constructor

ConfigurationCache Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ConfigurationCache class.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigurationCache()
public ConfigurationCache()
See Also
ConfigurationCache Class
ConfigurationCache Members
Sitecore.Social.Configuration Namespace


ConfigurationCache Methods

ConfigurationCache Methods Sitecore Social Connected 2.0 API
The ConfigurationCache type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists T | Checks if there is ConfigurationData in the cache.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get T | Gets ConfigurationData from the cache.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set | Sets ConfigurationData in the cache.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ConfigurationCache Class
Sitecore.Social.Configuration Namespace


ConfigurationCache.Exists(T) Method

ConfigurationCache Exists T Method Sitecore Social Connected 2.0 API
Checks if there is ConfigurationData in the cache.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Exists<T>()
where T : ConfigurationData
public bool Exists<T>()
where T : ConfigurationData
Type Parameters
T

            The ConfigurationData type.

Return Value
Type:   Online Boolean

            The   Online Boolean.

Implements
IConfigurationCache Exists T
See Also
ConfigurationCache Class
ConfigurationCache Members
Sitecore.Social.Configuration Namespace


ConfigurationCache.Get(T) Method

ConfigurationCache Get T Method Sitecore Social Connected 2.0 API
Gets ConfigurationData from the cache.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Get<T>()
where T : ConfigurationData
public T Get<T>()
where T : ConfigurationData
Type Parameters
T

            The ConfigurationData type.

Return Value
Type: T

            The ConfigurationData.

Implements
IConfigurationCache Get T
See Also
ConfigurationCache Class
ConfigurationCache Members
Sitecore.Social.Configuration Namespace


ConfigurationCache.Set Method

ConfigurationCache Set Method Sitecore Social Connected 2.0 API
Sets ConfigurationData in the cache.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Set(
    ConfigurationData data
)
public void Set(
    ConfigurationData data
)
Parameters
data
Type: Sitecore.Social.Configuration.Model ConfigurationData

            The configuration data.

Implements
IConfigurationCache Set(ConfigurationData)
See Also
ConfigurationCache Class
ConfigurationCache Members
Sitecore.Social.Configuration Namespace


ConfigurationFactory Class

ConfigurationFactory Class Sitecore Social Connected 2.0 API
The configuration factory.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration ConfigurationFactory

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConfigurationFactory : IConfigurationFactory
public class ConfigurationFactory : IConfigurationFactory
See Also
ConfigurationFactory Members
Sitecore.Social.Configuration Namespace


ConfigurationFactory Members

ConfigurationFactory Members Sitecore Social Connected 2.0 API

The ConfigurationFactory type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigurationFactory | Initializes a new instance of the ConfigurationFactory class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get T | Gets ConfigurationData.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ConfigurationFactory Class
Sitecore.Social.Configuration Namespace


ConfigurationFactory Constructor

ConfigurationFactory Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ConfigurationFactory class.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigurationFactory(
    IConfigurationCache configurationCache
)
public ConfigurationFactory(
    IConfigurationCache configurationCache
)
Parameters
configurationCache
Type: Sitecore.Social.Configuration IConfigurationCache

            The configuration cache.

See Also
ConfigurationFactory Class
ConfigurationFactory Members
Sitecore.Social.Configuration Namespace


ConfigurationFactory Methods

ConfigurationFactory Methods Sitecore Social Connected 2.0 API
The ConfigurationFactory type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get T | Gets ConfigurationData.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ConfigurationFactory Class
Sitecore.Social.Configuration Namespace


ConfigurationFactory.Get(T) Method

ConfigurationFactory Get T Method Sitecore Social Connected 2.0 API
Gets ConfigurationData.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Get<T>()
where T : ConfigurationData
public T Get<T>()
where T : ConfigurationData
Type Parameters
T

             The ConfigurationData type.

Return Value
Type: T

             The ConfigurationData.

Implements
IConfigurationFactory Get T
Examples
View Colorized Copy to Clipboard Print
var networksConfiguration = ExecutingContext.Current.IoC.Get<IConfigurationFactory>().Get<NetworksConfiguration>();

foreach (var networkSettings in networksConfiguration.Networks)
{
  Console.WriteLine("network: {0}, itemId: {1}", networkSettings.Name, networkSettings.ItemId);
}
var networksConfiguration = ExecutingContext.Current.IoC.Get<IConfigurationFactory>().Get<NetworksConfiguration>();

foreach (var networkSettings in networksConfiguration.Networks)
{
  Console.WriteLine("network: {0}, itemId: {1}", networkSettings.Name, networkSettings.ItemId);
}
See Also
ConfigurationFactory Class
ConfigurationFactory Members
Sitecore.Social.Configuration Namespace


IConfigurationCache Interface

IConfigurationCache Interface Sitecore Social Connected 2.0 API
The ConfigurationCache interface.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigurationCache
public interface IConfigurationCache
See Also
IConfigurationCache Members
Sitecore.Social.Configuration Namespace


IConfigurationCache Members

IConfigurationCache Members Sitecore Social Connected 2.0 API

The IConfigurationCache type exposes the following members.
Methods
 | Name | Description
Public method | Exists T | Checks if there is ConfigurationData in the cache.
Public method | Get T | Gets ConfigurationData from the cache.
Public method | Set | Sets ConfigurationData in the cache.
Back to Top
See Also
IConfigurationCache Interface
Sitecore.Social.Configuration Namespace


IConfigurationCache Methods

IConfigurationCache Methods Sitecore Social Connected 2.0 API
The IConfigurationCache type exposes the following members.
Methods
 | Name | Description
Public method | Exists T | Checks if there is ConfigurationData in the cache.
Public method | Get T | Gets ConfigurationData from the cache.
Public method | Set | Sets ConfigurationData in the cache.
Back to Top
See Also
IConfigurationCache Interface
Sitecore.Social.Configuration Namespace


IConfigurationCache.Exists(T) Method

IConfigurationCache Exists T Method Sitecore Social Connected 2.0 API
Checks if there is ConfigurationData in the cache.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Exists<T>()
where T : ConfigurationData
bool Exists<T>()
where T : ConfigurationData
Type Parameters
T

            The ConfigurationData type.

Return Value
Type:   Online Boolean

            The   Online Boolean.

See Also
IConfigurationCache Interface
IConfigurationCache Members
Sitecore.Social.Configuration Namespace


IConfigurationCache.Get(T) Method

IConfigurationCache Get T Method Sitecore Social Connected 2.0 API
Gets ConfigurationData from the cache.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T Get<T>()
where T : ConfigurationData
T Get<T>()
where T : ConfigurationData
Type Parameters
T

            The ConfigurationData type.

Return Value
Type: T

            The ConfigurationData.

See Also
IConfigurationCache Interface
IConfigurationCache Members
Sitecore.Social.Configuration Namespace


IConfigurationCache.Set Method

IConfigurationCache Set Method Sitecore Social Connected 2.0 API
Sets ConfigurationData in the cache.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Set(
    ConfigurationData data
)
void Set(
    ConfigurationData data
)
Parameters
data
Type: Sitecore.Social.Configuration.Model ConfigurationData

            The configuration data.

See Also
IConfigurationCache Interface
IConfigurationCache Members
Sitecore.Social.Configuration Namespace


IConfigurationFactory Interface

IConfigurationFactory Interface Sitecore Social Connected 2.0 API
The ConfigurationFactory interface.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigurationFactory
public interface IConfigurationFactory
See Also
IConfigurationFactory Members
Sitecore.Social.Configuration Namespace


IConfigurationFactory Members

IConfigurationFactory Members Sitecore Social Connected 2.0 API

The IConfigurationFactory type exposes the following members.
Methods
 | Name | Description
Public method | Get T | Gets ConfigurationData.
Back to Top
See Also
IConfigurationFactory Interface
Sitecore.Social.Configuration Namespace


IConfigurationFactory Methods

IConfigurationFactory Methods Sitecore Social Connected 2.0 API
The IConfigurationFactory type exposes the following members.
Methods
 | Name | Description
Public method | Get T | Gets ConfigurationData.
Back to Top
See Also
IConfigurationFactory Interface
Sitecore.Social.Configuration Namespace


IConfigurationFactory.Get(T) Method

IConfigurationFactory Get T Method Sitecore Social Connected 2.0 API
Gets ConfigurationData.

Namespace: Sitecore.Social.Configuration
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T Get<T>()
where T : ConfigurationData
T Get<T>()
where T : ConfigurationData
Type Parameters
T

            The ConfigurationData type.

Return Value
Type: T

            The ConfigurationData.

See Also
IConfigurationFactory Interface
IConfigurationFactory Members
Sitecore.Social.Configuration Namespace


Sitecore.Social.Configuration.Model Namespace

Sitecore.Social.Configuration.Model Namespace Sitecore Social Connected 2.0 API
Provides classes that represent root configuration settings.
Classes
 | Class | Description
Public class | ApiConfiguration | The social api configuration.
Public class | ConfigurationData | The configuration data.
Public class | GenderRuleConfiguration | The gender rule configuration.
Public class | InterestedInRuleConfiguration | The "interested in" rule configuration.
Public class | NetworksConfiguration | The networks configuration.
Public class | PostingConfigurationsConfiguration | Represents posting configurations settings.
Public class | ProfileKeyMappingsConfiguration | The profile key mappings configuration.
Public class | SettingsConfiguration | The settings configuration.
Interfaces
 | Interface | Description
Public interface | IEmptyable | Defines the property that is used to check if an entity is empty.


ApiConfiguration Class

ApiConfiguration Class Sitecore Social Connected 2.0 API
The social api configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model ApiConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ApiConfiguration : ConfigurationData
[SerializableAttribute]
public class ApiConfiguration : ConfigurationData
See Also
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration Members

ApiConfiguration Members Sitecore Social Connected 2.0 API

The ApiConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | ApiConfiguration | Initializes a new instance of the ApiConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the ApiConfiguration class whose value represents a not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | AccountBuilders | Gets or sets the account builders.
Public property | DomainMessageBuilders | Gets or sets the domain message builders.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Public property | MessageDataBuilders | Gets or sets the message data builders.
Public property | MessageStatusBuilders | Gets or sets the message status builders.
Public property | PostingConfigurationBuilders | Gets or sets the posting configuration builders.
Public property | PostingConfigurationSearchArgsAdapters | Gets or sets the posting configuration search args adapters.
Back to Top
See Also
ApiConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration Constructor

ApiConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ApiConfiguration class.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApiConfiguration()
public ApiConfiguration()
See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration Fields

ApiConfiguration Fields Sitecore Social Connected 2.0 API
The ApiConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the ApiConfiguration class whose value represents a not defined configuration.
Back to Top
See Also
ApiConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.Empty Field

ApiConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the ApiConfiguration class whose value represents a not defined configuration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ApiConfiguration Empty
public static readonly ApiConfiguration Empty
Field Value
Type: ApiConfiguration
See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration Methods

ApiConfiguration Methods Sitecore Social Connected 2.0 API
The ApiConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ApiConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration Properties

ApiConfiguration Properties Sitecore Social Connected 2.0 API
The ApiConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | AccountBuilders | Gets or sets the account builders.
Public property | DomainMessageBuilders | Gets or sets the domain message builders.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Public property | MessageDataBuilders | Gets or sets the message data builders.
Public property | MessageStatusBuilders | Gets or sets the message status builders.
Public property | PostingConfigurationBuilders | Gets or sets the posting configuration builders.
Public property | PostingConfigurationSearchArgsAdapters | Gets or sets the posting configuration search args adapters.
Back to Top
See Also
ApiConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.AccountBuilders Property

ApiConfiguration AccountBuilders Property Sitecore Social Connected 2.0 API
Gets or sets the account builders.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<AccountBuilderSettings> AccountBuilders { get; set; }
public List<AccountBuilderSettings> AccountBuilders { get; set; }
Property Value
Type:   Online List  AccountBuilderSettings

            The account builders.

See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.DomainMessageBuilders Property

ApiConfiguration DomainMessageBuilders Property Sitecore Social Connected 2.0 API
Gets or sets the domain message builders.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<DomainMessageBuilderSettings> DomainMessageBuilders { get; set; }
public List<DomainMessageBuilderSettings> DomainMessageBuilders { get; set; }
Property Value
Type:   Online List  DomainMessageBuilderSettings

            The domain message builders.

See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.IsEmpty Property

ApiConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.MessageDataBuilders Property

ApiConfiguration MessageDataBuilders Property Sitecore Social Connected 2.0 API
Gets or sets the message data builders.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<MessageDataBuilderSettings> MessageDataBuilders { get; set; }
public List<MessageDataBuilderSettings> MessageDataBuilders { get; set; }
Property Value
Type:   Online List  MessageDataBuilderSettings

            The message data builders.

See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.MessageStatusBuilders Property

ApiConfiguration MessageStatusBuilders Property Sitecore Social Connected 2.0 API
Gets or sets the message status builders.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<MessageStatusBuilderSettings> MessageStatusBuilders { get; set; }
public List<MessageStatusBuilderSettings> MessageStatusBuilders { get; set; }
Property Value
Type:   Online List  MessageStatusBuilderSettings

            The message status builders.

See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.PostingConfigurationBuilders Property

ApiConfiguration PostingConfigurationBuilders Property Sitecore Social Connected 2.0 API
Gets or sets the posting configuration builders.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PostingConfigurationBuilderSettings> PostingConfigurationBuilders { get; set; }
public List<PostingConfigurationBuilderSettings> PostingConfigurationBuilders { get; set; }
Property Value
Type:   Online List  PostingConfigurationBuilderSettings

            The posting configuration builders.

See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ApiConfiguration.PostingConfigurationSearchArgsAdapters Property

ApiConfiguration PostingConfigurationSearchArgsAdapters Property Sitecore Social Connected 2.0 API
Gets or sets the posting configuration search args adapters.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PostingConfigurationSearchArgsAdapterSettings> PostingConfigurationSearchArgsAdapters { get; set; }
public List<PostingConfigurationSearchArgsAdapterSettings> PostingConfigurationSearchArgsAdapters { get; set; }
Property Value
Type:   Online List  PostingConfigurationSearchArgsAdapterSettings

            The posting configuration search args adapters.

See Also
ApiConfiguration Class
ApiConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ConfigurationData Class

ConfigurationData Class Sitecore Social Connected 2.0 API
The configuration data.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model ApiConfiguration
Sitecore.Social.Configuration.Model GenderRuleConfiguration
Sitecore.Social.Configuration.Model InterestedInRuleConfiguration
Sitecore.Social.Configuration.Model NetworksConfiguration
Sitecore.Social.Configuration.Model PostingConfigurationsConfiguration
Sitecore.Social.Configuration.Model ProfileKeyMappingsConfiguration
Sitecore.Social.Configuration.Model SettingsConfiguration
Sitecore.Social.Facebook.Configuration SettingsConfiguration
Sitecore.Social.GooglePlus.Configuration SettingsConfiguration
Sitecore.Social.Twitter.Configuration SettingsConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ConfigurationData : IEmptyable
[SerializableAttribute]
public abstract class ConfigurationData : IEmptyable
See Also
ConfigurationData Members
Sitecore.Social.Configuration.Model Namespace


ConfigurationData Members

ConfigurationData Members Sitecore Social Connected 2.0 API

The ConfigurationData type exposes the following members.
Constructors
 | Name | Description
Protected method | ConfigurationData | Initializes a new instance of the ConfigurationData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
ConfigurationData Class
Sitecore.Social.Configuration.Model Namespace


ConfigurationData Constructor

ConfigurationData Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ConfigurationData class

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigurationData()
protected ConfigurationData()
See Also
ConfigurationData Class
ConfigurationData Members
Sitecore.Social.Configuration.Model Namespace


ConfigurationData Methods

ConfigurationData Methods Sitecore Social Connected 2.0 API
The ConfigurationData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ConfigurationData Class
Sitecore.Social.Configuration.Model Namespace


ConfigurationData Properties

ConfigurationData Properties Sitecore Social Connected 2.0 API
The ConfigurationData type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
ConfigurationData Class
Sitecore.Social.Configuration.Model Namespace


ConfigurationData.IsEmpty Property

ConfigurationData IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsEmpty { get; }
public abstract bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
ConfigurationData Class
ConfigurationData Members
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration Class

GenderRuleConfiguration Class Sitecore Social Connected 2.0 API
The gender rule configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model GenderRuleConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GenderRuleConfiguration : ConfigurationData
[SerializableAttribute]
public class GenderRuleConfiguration : ConfigurationData
See Also
GenderRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration Members

GenderRuleConfiguration Members Sitecore Social Connected 2.0 API

The GenderRuleConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | GenderRuleConfiguration | Initializes a new instance of the GenderRuleConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the GenderRuleConfiguration class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
GenderRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration Constructor

GenderRuleConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the GenderRuleConfiguration class

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GenderRuleConfiguration()
public GenderRuleConfiguration()
See Also
GenderRuleConfiguration Class
GenderRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration Fields

GenderRuleConfiguration Fields Sitecore Social Connected 2.0 API
The GenderRuleConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the GenderRuleConfiguration class whose value represents not defined configuration.
Back to Top
See Also
GenderRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration.Empty Field

GenderRuleConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the GenderRuleConfiguration class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly GenderRuleConfiguration Empty
public static readonly GenderRuleConfiguration Empty
Field Value
Type: GenderRuleConfiguration
See Also
GenderRuleConfiguration Class
GenderRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration Methods

GenderRuleConfiguration Methods Sitecore Social Connected 2.0 API
The GenderRuleConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GenderRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration Properties

GenderRuleConfiguration Properties Sitecore Social Connected 2.0 API
The GenderRuleConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
GenderRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration.IsEmpty Property

GenderRuleConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
GenderRuleConfiguration Class
GenderRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


GenderRuleConfiguration.Networks Property

GenderRuleConfiguration Networks Property Sitecore Social Connected 2.0 API
Gets or sets the networks settings.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<NetworkSettings> Networks { get; set; }
public List<NetworkSettings> Networks { get; set; }
Property Value
Type:   Online List  NetworkSettings

            The networks settings.

See Also
GenderRuleConfiguration Class
GenderRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


IEmptyable Interface

IEmptyable Interface Sitecore Social Connected 2.0 API
Defines the property that is used to check if an entity is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEmptyable
public interface IEmptyable
See Also
IEmptyable Members
Sitecore.Social.Configuration.Model Namespace


IEmptyable Members

IEmptyable Members Sitecore Social Connected 2.0 API

The IEmptyable type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
IEmptyable Interface
Sitecore.Social.Configuration.Model Namespace


IEmptyable Properties

IEmptyable Properties Sitecore Social Connected 2.0 API
The IEmptyable type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
IEmptyable Interface
Sitecore.Social.Configuration.Model Namespace


IEmptyable.IsEmpty Property

IEmptyable IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsEmpty { get; }
bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

See Also
IEmptyable Interface
IEmptyable Members
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration Class

InterestedInRuleConfiguration Class Sitecore Social Connected 2.0 API
The "interested in" rule configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model InterestedInRuleConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class InterestedInRuleConfiguration : ConfigurationData
[SerializableAttribute]
public class InterestedInRuleConfiguration : ConfigurationData
See Also
InterestedInRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration Members

InterestedInRuleConfiguration Members Sitecore Social Connected 2.0 API

The InterestedInRuleConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | InterestedInRuleConfiguration | Initializes a new instance of the InterestedInRuleConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the InterestedInRuleConfiguration class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
InterestedInRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration Constructor

InterestedInRuleConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the InterestedInRuleConfiguration class

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InterestedInRuleConfiguration()
public InterestedInRuleConfiguration()
See Also
InterestedInRuleConfiguration Class
InterestedInRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration Fields

InterestedInRuleConfiguration Fields Sitecore Social Connected 2.0 API
The InterestedInRuleConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the InterestedInRuleConfiguration class whose value represents not defined configuration.
Back to Top
See Also
InterestedInRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration.Empty Field

InterestedInRuleConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the InterestedInRuleConfiguration class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly InterestedInRuleConfiguration Empty
public static readonly InterestedInRuleConfiguration Empty
Field Value
Type: InterestedInRuleConfiguration
See Also
InterestedInRuleConfiguration Class
InterestedInRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration Methods

InterestedInRuleConfiguration Methods Sitecore Social Connected 2.0 API
The InterestedInRuleConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
InterestedInRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration Properties

InterestedInRuleConfiguration Properties Sitecore Social Connected 2.0 API
The InterestedInRuleConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
InterestedInRuleConfiguration Class
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration.IsEmpty Property

InterestedInRuleConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
InterestedInRuleConfiguration Class
InterestedInRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


InterestedInRuleConfiguration.Networks Property

InterestedInRuleConfiguration Networks Property Sitecore Social Connected 2.0 API
Gets or sets the networks settings.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<NetworkSettings> Networks { get; set; }
public List<NetworkSettings> Networks { get; set; }
Property Value
Type:   Online List  NetworkSettings

            The networks settings.

See Also
InterestedInRuleConfiguration Class
InterestedInRuleConfiguration Members
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration Class

NetworksConfiguration Class Sitecore Social Connected 2.0 API
The networks configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model NetworksConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetworksConfiguration : ConfigurationData
[SerializableAttribute]
public class NetworksConfiguration : ConfigurationData
See Also
NetworksConfiguration Members
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration Members

NetworksConfiguration Members Sitecore Social Connected 2.0 API

The NetworksConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | NetworksConfiguration | Initializes a new instance of the NetworksConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the NetworksConfiguration class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
NetworksConfiguration Class
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration Constructor

NetworksConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworksConfiguration class.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworksConfiguration()
public NetworksConfiguration()
See Also
NetworksConfiguration Class
NetworksConfiguration Members
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration Fields

NetworksConfiguration Fields Sitecore Social Connected 2.0 API
The NetworksConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the NetworksConfiguration class whose value represents not defined configuration.
Back to Top
See Also
NetworksConfiguration Class
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration.Empty Field

NetworksConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the NetworksConfiguration class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NetworksConfiguration Empty
public static readonly NetworksConfiguration Empty
Field Value
Type: NetworksConfiguration
See Also
NetworksConfiguration Class
NetworksConfiguration Members
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration Methods

NetworksConfiguration Methods Sitecore Social Connected 2.0 API
The NetworksConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworksConfiguration Class
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration Properties

NetworksConfiguration Properties Sitecore Social Connected 2.0 API
The NetworksConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
NetworksConfiguration Class
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration.IsEmpty Property

NetworksConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
NetworksConfiguration Class
NetworksConfiguration Members
Sitecore.Social.Configuration.Model Namespace


NetworksConfiguration.Networks Property

NetworksConfiguration Networks Property Sitecore Social Connected 2.0 API
Gets or sets the networks settings.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<NetworkSettings> Networks { get; set; }
public List<NetworkSettings> Networks { get; set; }
Property Value
Type:   Online List  NetworkSettings

            The networks settings.

See Also
NetworksConfiguration Class
NetworksConfiguration Members
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration Class

PostingConfigurationsConfiguration Class Sitecore Social Connected 2.0 API
Represents posting configurations settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model PostingConfigurationsConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingConfigurationsConfiguration : ConfigurationData
[SerializableAttribute]
public class PostingConfigurationsConfiguration : ConfigurationData
See Also
PostingConfigurationsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration Members

PostingConfigurationsConfiguration Members Sitecore Social Connected 2.0 API

The PostingConfigurationsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | PostingConfigurationsConfiguration | Initializes a new instance of the PostingConfigurationsConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationsConfiguration class whose value represents not defined posting configurations.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | PostingConfigurations | Gets or sets the posting configurations settings.
Back to Top
See Also
PostingConfigurationsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration Constructor

PostingConfigurationsConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationsConfiguration class

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationsConfiguration()
public PostingConfigurationsConfiguration()
See Also
PostingConfigurationsConfiguration Class
PostingConfigurationsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration Fields

PostingConfigurationsConfiguration Fields Sitecore Social Connected 2.0 API
The PostingConfigurationsConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationsConfiguration class whose value represents not defined posting configurations.
Back to Top
See Also
PostingConfigurationsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration.Empty Field

PostingConfigurationsConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the PostingConfigurationsConfiguration class whose value represents not defined posting configurations.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly PostingConfigurationsConfiguration Empty
public static readonly PostingConfigurationsConfiguration Empty
Field Value
Type: PostingConfigurationsConfiguration
See Also
PostingConfigurationsConfiguration Class
PostingConfigurationsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration Methods

PostingConfigurationsConfiguration Methods Sitecore Social Connected 2.0 API
The PostingConfigurationsConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfigurationsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration Properties

PostingConfigurationsConfiguration Properties Sitecore Social Connected 2.0 API
The PostingConfigurationsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | PostingConfigurations | Gets or sets the posting configurations settings.
Back to Top
See Also
PostingConfigurationsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration.IsEmpty Property

PostingConfigurationsConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
PostingConfigurationsConfiguration Class
PostingConfigurationsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


PostingConfigurationsConfiguration.PostingConfigurations Property

PostingConfigurationsConfiguration PostingConfigurations Property Sitecore Social Connected 2.0 API
Gets or sets the posting configurations settings.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PostingConfigurationSettings> PostingConfigurations { get; set; }
public List<PostingConfigurationSettings> PostingConfigurations { get; set; }
Property Value
Type:   Online List  PostingConfigurationSettings

            The posting configurations settings.

See Also
PostingConfigurationsConfiguration Class
PostingConfigurationsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration Class

ProfileKeyMappingsConfiguration Class Sitecore Social Connected 2.0 API
The profile key mappings configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model ProfileKeyMappingsConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ProfileKeyMappingsConfiguration : ConfigurationData
[SerializableAttribute]
public class ProfileKeyMappingsConfiguration : ConfigurationData
See Also
ProfileKeyMappingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration Members

ProfileKeyMappingsConfiguration Members Sitecore Social Connected 2.0 API

The ProfileKeyMappingsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | ProfileKeyMappingsConfiguration | Initializes a new instance of the ProfileKeyMappingsConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the ProfileKeyMappingsConfiguration class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
ProfileKeyMappingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration Constructor

ProfileKeyMappingsConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ProfileKeyMappingsConfiguration class.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProfileKeyMappingsConfiguration()
public ProfileKeyMappingsConfiguration()
See Also
ProfileKeyMappingsConfiguration Class
ProfileKeyMappingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration Fields

ProfileKeyMappingsConfiguration Fields Sitecore Social Connected 2.0 API
The ProfileKeyMappingsConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the ProfileKeyMappingsConfiguration class whose value represents not defined configuration.
Back to Top
See Also
ProfileKeyMappingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration.Empty Field

ProfileKeyMappingsConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the ProfileKeyMappingsConfiguration class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ProfileKeyMappingsConfiguration Empty
public static readonly ProfileKeyMappingsConfiguration Empty
Field Value
Type: ProfileKeyMappingsConfiguration
See Also
ProfileKeyMappingsConfiguration Class
ProfileKeyMappingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration Methods

ProfileKeyMappingsConfiguration Methods Sitecore Social Connected 2.0 API
The ProfileKeyMappingsConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ProfileKeyMappingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration Properties

ProfileKeyMappingsConfiguration Properties Sitecore Social Connected 2.0 API
The ProfileKeyMappingsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | Networks | Gets or sets the networks settings.
Back to Top
See Also
ProfileKeyMappingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration.IsEmpty Property

ProfileKeyMappingsConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
ProfileKeyMappingsConfiguration Class
ProfileKeyMappingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


ProfileKeyMappingsConfiguration.Networks Property

ProfileKeyMappingsConfiguration Networks Property Sitecore Social Connected 2.0 API
Gets or sets the networks settings.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<NetworkSettings> Networks { get; set; }
public List<NetworkSettings> Networks { get; set; }
Property Value
Type:   Online List  NetworkSettings

            The networks settings.

See Also
ProfileKeyMappingsConfiguration Class
ProfileKeyMappingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration Class

SettingsConfiguration Class Sitecore Social Connected 2.0 API
The settings configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Configuration.Model SettingsConfiguration

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
See Also
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration Members

SettingsConfiguration Members Sitecore Social Connected 2.0 API

The SettingsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | SettingsConfiguration | Initializes a new instance of the SettingsConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | AddNetworkAccountWizardAuthenticationTimeout | Gets or sets the add network account wizard authentication timeout.
Public property | AllowMessagePostingByDefault | Gets or sets a value indicating whether to allow posting if the message PostingPreference has default value.
Public property | ConnectorAuthCompletedType | Gets or sets the type of the [!:Sitecore.Social.Client.Api.Connector.ConnectorAuthCompleted] instance.
Public property | DaysBeforeNetworkAccountPreExpirationLeft | Gets or sets the number of days before network account pre-expiration.
Public property | DaysUserProfileExpiration | Gets or sets the number of days before user profile expiration.
Public property | Domain | Gets or sets the domain.
Public property | EnableAccountRenewal | Gets or sets a value indicating whether account renewal is enabled.
Public property | EnableProfileUpdating | Gets or sets a value indicating whether profile updating is enabled.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | MessageBaseTemplateId | Gets or sets the message base template unique identifier.
Public property | MessagesByContainerCacheEnabled | Gets or sets a value indicating if messages by container cache is enabled.
Public property | MessagesByContainerCacheName | Gets or sets the name of the messages by container cache.
Public property | MessagesByContainerCacheSize | Gets or sets the size of the messages by container cache.
Public property | MessagesMasterSearchIndex | Gets or sets the name of the index to use in the repositories for items search in the master database.
Public property | MessagesRootPath | Gets or sets the messages root path.
Public property | MessageStatisticsStopRefreshAge | Gets or sets the number of hours the message statistics will not be updated after.
Public property | MessagesUpdateSearchIndexSyncronously | Gets or sets a value indicating whether to update an index immediately after an item is updated.
Public property | MessagesWebSearchIndex | Gets or sets the name of the index to use in the repositories for items search in the web database.
Public property | PostingConfigurationBaseTemplateId | Gets or sets the posting configuration base template unique identifier.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration Constructor

SettingsConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SettingsConfiguration class

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SettingsConfiguration()
public SettingsConfiguration()
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration Fields

SettingsConfiguration Fields Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents not defined configuration.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.Empty Field

SettingsConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the SettingsConfiguration class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SettingsConfiguration Empty
public static readonly SettingsConfiguration Empty
Field Value
Type: SettingsConfiguration
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration Methods

SettingsConfiguration Methods Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration Properties

SettingsConfiguration Properties Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | AddNetworkAccountWizardAuthenticationTimeout | Gets or sets the add network account wizard authentication timeout.
Public property | AllowMessagePostingByDefault | Gets or sets a value indicating whether to allow posting if the message PostingPreference has default value.
Public property | ConnectorAuthCompletedType | Gets or sets the type of the [!:Sitecore.Social.Client.Api.Connector.ConnectorAuthCompleted] instance.
Public property | DaysBeforeNetworkAccountPreExpirationLeft | Gets or sets the number of days before network account pre-expiration.
Public property | DaysUserProfileExpiration | Gets or sets the number of days before user profile expiration.
Public property | Domain | Gets or sets the domain.
Public property | EnableAccountRenewal | Gets or sets a value indicating whether account renewal is enabled.
Public property | EnableProfileUpdating | Gets or sets a value indicating whether profile updating is enabled.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides ConfigurationData IsEmpty.)
Public property | MessageBaseTemplateId | Gets or sets the message base template unique identifier.
Public property | MessagesByContainerCacheEnabled | Gets or sets a value indicating if messages by container cache is enabled.
Public property | MessagesByContainerCacheName | Gets or sets the name of the messages by container cache.
Public property | MessagesByContainerCacheSize | Gets or sets the size of the messages by container cache.
Public property | MessagesMasterSearchIndex | Gets or sets the name of the index to use in the repositories for items search in the master database.
Public property | MessagesRootPath | Gets or sets the messages root path.
Public property | MessageStatisticsStopRefreshAge | Gets or sets the number of hours the message statistics will not be updated after.
Public property | MessagesUpdateSearchIndexSyncronously | Gets or sets a value indicating whether to update an index immediately after an item is updated.
Public property | MessagesWebSearchIndex | Gets or sets the name of the index to use in the repositories for items search in the web database.
Public property | PostingConfigurationBaseTemplateId | Gets or sets the posting configuration base template unique identifier.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.AddNetworkAccountWizardAuthenticationTimeout Property

SettingsConfiguration AddNetworkAccountWizardAuthenticationTimeout Property Sitecore Social Connected 2.0 API
Gets or sets the add network account wizard authentication timeout.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AddNetworkAccountWizardAuthenticationTimeout { get; set; }
public int AddNetworkAccountWizardAuthenticationTimeout { get; set; }
Property Value
Type:   Online Int32

            The add network account wizard authentication timeout.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.AllowMessagePostingByDefault Property

SettingsConfiguration AllowMessagePostingByDefault Property Sitecore Social Connected 2.0 API
Gets or sets a value indicating whether to allow posting if the message PostingPreference has default value.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllowMessagePostingByDefault { get; set; }
public bool AllowMessagePostingByDefault { get; set; }
Property Value
Type:   Online Boolean
true if message posting is allowed by default; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.ConnectorAuthCompletedType Property

SettingsConfiguration ConnectorAuthCompletedType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the [!:Sitecore.Social.Client.Api.Connector.ConnectorAuthCompleted] instance.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConnectorAuthCompletedType { get; set; }
public string ConnectorAuthCompletedType { get; set; }
Property Value
Type:   Online String

            The type of the [!:Sitecore.Social.Client.Api.Connector.ConnectorAuthCompleted] instance.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.DaysBeforeNetworkAccountPreExpirationLeft Property

SettingsConfiguration DaysBeforeNetworkAccountPreExpirationLeft Property Sitecore Social Connected 2.0 API
Gets or sets the number of days before network account pre-expiration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DaysBeforeNetworkAccountPreExpirationLeft { get; set; }
public int DaysBeforeNetworkAccountPreExpirationLeft { get; set; }
Property Value
Type:   Online Int32

            The number of days before network account pre-expiration.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.DaysUserProfileExpiration Property

SettingsConfiguration DaysUserProfileExpiration Property Sitecore Social Connected 2.0 API
Gets or sets the number of days before user profile expiration.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DaysUserProfileExpiration { get; set; }
public int DaysUserProfileExpiration { get; set; }
Property Value
Type:   Online Int32

            The number of days before user profile expiration.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.Domain Property

SettingsConfiguration Domain Property Sitecore Social Connected 2.0 API
Gets or sets the domain.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Domain { get; set; }
public string Domain { get; set; }
Property Value
Type:   Online String

            The domain.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.EnableAccountRenewal Property

SettingsConfiguration EnableAccountRenewal Property Sitecore Social Connected 2.0 API
Gets or sets a value indicating whether account renewal is enabled.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EnableAccountRenewal { get; set; }
public bool EnableAccountRenewal { get; set; }
Property Value
Type:   Online Boolean
true if the account renewal is enabled; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.EnableProfileUpdating Property

SettingsConfiguration EnableProfileUpdating Property Sitecore Social Connected 2.0 API
Gets or sets a value indicating whether profile updating is enabled.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EnableProfileUpdating { get; set; }
public bool EnableProfileUpdating { get; set; }
Property Value
Type:   Online Boolean
true if the profile updating is enabled; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.IsEmpty Property

SettingsConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessageBaseTemplateId Property

SettingsConfiguration MessageBaseTemplateId Property Sitecore Social Connected 2.0 API
Gets or sets the message base template unique identifier.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessageBaseTemplateId { get; set; }
public string MessageBaseTemplateId { get; set; }
Property Value
Type:   Online String

            The message base template unique identifier.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesByContainerCacheEnabled Property

SettingsConfiguration MessagesByContainerCacheEnabled Property Sitecore Social Connected 2.0 API
Gets or sets a value indicating if messages by container cache is enabled.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MessagesByContainerCacheEnabled { get; set; }
public bool MessagesByContainerCacheEnabled { get; set; }
Property Value
Type:   Online Boolean
true if messages by container cache is enabled; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesByContainerCacheName Property

SettingsConfiguration MessagesByContainerCacheName Property Sitecore Social Connected 2.0 API
Gets or sets the name of the messages by container cache.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessagesByContainerCacheName { get; set; }
public string MessagesByContainerCacheName { get; set; }
Property Value
Type:   Online String

            The name of the messages by container cache.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesByContainerCacheSize Property

SettingsConfiguration MessagesByContainerCacheSize Property Sitecore Social Connected 2.0 API
Gets or sets the size of the messages by container cache.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessagesByContainerCacheSize { get; set; }
public string MessagesByContainerCacheSize { get; set; }
Property Value
Type:   Online String

            The size of the messages by container cache.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesMasterSearchIndex Property

SettingsConfiguration MessagesMasterSearchIndex Property Sitecore Social Connected 2.0 API
Gets or sets the name of the index to use in the repositories for items search in the master database.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessagesMasterSearchIndex { get; set; }
public string MessagesMasterSearchIndex { get; set; }
Property Value
Type:   Online String

            The name of the index.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesRootPath Property

SettingsConfiguration MessagesRootPath Property Sitecore Social Connected 2.0 API
Gets or sets the messages root path.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessagesRootPath { get; set; }
public string MessagesRootPath { get; set; }
Property Value
Type:   Online String

            The messages root path.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessageStatisticsStopRefreshAge Property

SettingsConfiguration MessageStatisticsStopRefreshAge Property Sitecore Social Connected 2.0 API
Gets or sets the number of hours the message statistics will not be updated after.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MessageStatisticsStopRefreshAge { get; set; }
public int MessageStatisticsStopRefreshAge { get; set; }
Property Value
Type:   Online Int32

            The number of hours the message statistics will not be updated after.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesUpdateSearchIndexSyncronously Property

SettingsConfiguration MessagesUpdateSearchIndexSyncronously Property Sitecore Social Connected 2.0 API
Gets or sets a value indicating whether to update an index immediately after an item is updated.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MessagesUpdateSearchIndexSyncronously { get; set; }
public bool MessagesUpdateSearchIndexSyncronously { get; set; }
Property Value
Type:   Online Boolean
true if update the index immediately; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.MessagesWebSearchIndex Property

SettingsConfiguration MessagesWebSearchIndex Property Sitecore Social Connected 2.0 API
Gets or sets the name of the index to use in the repositories for items search in the web database.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessagesWebSearchIndex { get; set; }
public string MessagesWebSearchIndex { get; set; }
Property Value
Type:   Online String

            The name of the index.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


SettingsConfiguration.PostingConfigurationBaseTemplateId Property

SettingsConfiguration PostingConfigurationBaseTemplateId Property Sitecore Social Connected 2.0 API
Gets or sets the posting configuration base template unique identifier.

Namespace: Sitecore.Social.Configuration.Model
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostingConfigurationBaseTemplateId { get; set; }
public string PostingConfigurationBaseTemplateId { get; set; }
Property Value
Type:   Online String

            The posting configuration base template unique identifier.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Configuration.Model Namespace


Sitecore.Social.Configuration.Model.Api Namespace

Sitecore.Social.Configuration.Model.Api Namespace Sitecore Social Connected 2.0 API
Provides classes that represent "socialApi" configuration settings
Classes
 | Class | Description
Public class | AccountBuilderSettings | Represents the account builder settings.
Public class | DomainMessageBuilderSettings | The domain message builder settings.
Public class | MessageDataBuilderSettings | The message data builder settings.
Public class | MessageStatusBuilderSettings | Represents the message status builder settings.
Public class | PostingConfigurationBuilderSettings | Represents the posting configuration builder settings.
Public class | PostingConfigurationSearchArgsAdapterSettings | Represents the posting configuration search args adapter settings.


AccountBuilderSettings Class

AccountBuilderSettings Class Sitecore Social Connected 2.0 API
Represents the account builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Api AccountBuilderSettings

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AccountBuilderSettings : IEmptyable
[SerializableAttribute]
public class AccountBuilderSettings : IEmptyable
See Also
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings Members

AccountBuilderSettings Members Sitecore Social Connected 2.0 API

The AccountBuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | AccountBuilderSettings | Initializes a new instance of the AccountBuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the AccountBuilderSettings class whose value represents a not defined account builder settings.
Back to Top
Properties
 | Name | Description
Public property | AccountTemplateID | Gets or sets the account template ID.
Public property | AccountType | Gets or sets the type of the account.
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Back to Top
See Also
AccountBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings Constructor

AccountBuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountBuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountBuilderSettings()
public AccountBuilderSettings()
See Also
AccountBuilderSettings Class
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings Fields

AccountBuilderSettings Fields Sitecore Social Connected 2.0 API
The AccountBuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the AccountBuilderSettings class whose value represents a not defined account builder settings.
Back to Top
See Also
AccountBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings.Empty Field

AccountBuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the AccountBuilderSettings class whose value represents a not defined account builder settings.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly AccountBuilderSettings Empty
public static readonly AccountBuilderSettings Empty
Field Value
Type: AccountBuilderSettings
See Also
AccountBuilderSettings Class
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings Methods

AccountBuilderSettings Methods Sitecore Social Connected 2.0 API
The AccountBuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings Properties

AccountBuilderSettings Properties Sitecore Social Connected 2.0 API
The AccountBuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | AccountTemplateID | Gets or sets the account template ID.
Public property | AccountType | Gets or sets the type of the account.
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Back to Top
See Also
AccountBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings.AccountTemplateID Property

AccountBuilderSettings AccountTemplateID Property Sitecore Social Connected 2.0 API
Gets or sets the account template ID.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountTemplateID { get; set; }
public string AccountTemplateID { get; set; }
Property Value
Type:   Online String

            The account template ID.

See Also
AccountBuilderSettings Class
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings.AccountType Property

AccountBuilderSettings AccountType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the account.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountType { get; set; }
public string AccountType { get; set; }
Property Value
Type:   Online String

            The type of the account.

See Also
AccountBuilderSettings Class
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings.BuilderType Property

AccountBuilderSettings BuilderType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the builder.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BuilderType { get; set; }
public string BuilderType { get; set; }
Property Value
Type:   Online String

            The type of the builder.

See Also
AccountBuilderSettings Class
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


AccountBuilderSettings.IsEmpty Property

AccountBuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
AccountBuilderSettings Class
AccountBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings Class

DomainMessageBuilderSettings Class Sitecore Social Connected 2.0 API
The domain message builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Api DomainMessageBuilderSettings

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DomainMessageBuilderSettings : IEmptyable
[SerializableAttribute]
public class DomainMessageBuilderSettings : IEmptyable
See Also
DomainMessageBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings Members

DomainMessageBuilderSettings Members Sitecore Social Connected 2.0 API

The DomainMessageBuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | DomainMessageBuilderSettings | Initializes a new instance of the DomainMessageBuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the DomainMessageBuilderSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | NetworkName | Gets or sets the name of the network.
Back to Top
See Also
DomainMessageBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings Constructor

DomainMessageBuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the DomainMessageBuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DomainMessageBuilderSettings()
public DomainMessageBuilderSettings()
See Also
DomainMessageBuilderSettings Class
DomainMessageBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings Fields

DomainMessageBuilderSettings Fields Sitecore Social Connected 2.0 API
The DomainMessageBuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the DomainMessageBuilderSettings class whose value represents not defined configuration.
Back to Top
See Also
DomainMessageBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings.Empty Field

DomainMessageBuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the DomainMessageBuilderSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DomainMessageBuilderSettings Empty
public static readonly DomainMessageBuilderSettings Empty
Field Value
Type: DomainMessageBuilderSettings
See Also
DomainMessageBuilderSettings Class
DomainMessageBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings Methods

DomainMessageBuilderSettings Methods Sitecore Social Connected 2.0 API
The DomainMessageBuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
DomainMessageBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings Properties

DomainMessageBuilderSettings Properties Sitecore Social Connected 2.0 API
The DomainMessageBuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | NetworkName | Gets or sets the name of the network.
Back to Top
See Also
DomainMessageBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings.BuilderType Property

DomainMessageBuilderSettings BuilderType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the builder.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BuilderType { get; set; }
public string BuilderType { get; set; }
Property Value
Type:   Online String

            The type of the builder.

See Also
DomainMessageBuilderSettings Class
DomainMessageBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings.IsEmpty Property

DomainMessageBuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
DomainMessageBuilderSettings Class
DomainMessageBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


DomainMessageBuilderSettings.NetworkName Property

DomainMessageBuilderSettings NetworkName Property Sitecore Social Connected 2.0 API
Gets or sets the name of the network.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetworkName { get; set; }
public string NetworkName { get; set; }
Property Value
Type:   Online String

            The name of the network.

See Also
DomainMessageBuilderSettings Class
DomainMessageBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings Class

MessageDataBuilderSettings Class Sitecore Social Connected 2.0 API
The message data builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Api MessageDataBuilderSettings

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageDataBuilderSettings : IEmptyable
[SerializableAttribute]
public class MessageDataBuilderSettings : IEmptyable
See Also
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings Members

MessageDataBuilderSettings Members Sitecore Social Connected 2.0 API

The MessageDataBuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | MessageDataBuilderSettings | Initializes a new instance of the MessageDataBuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessageDataBuilderSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageDataType | Gets or sets the type of the message data.
Public property | MessageItemBaseType | Gets or sets the type of the message item base.
Back to Top
See Also
MessageDataBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings Constructor

MessageDataBuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageDataBuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageDataBuilderSettings()
public MessageDataBuilderSettings()
See Also
MessageDataBuilderSettings Class
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings Fields

MessageDataBuilderSettings Fields Sitecore Social Connected 2.0 API
The MessageDataBuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessageDataBuilderSettings class whose value represents not defined configuration.
Back to Top
See Also
MessageDataBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings.Empty Field

MessageDataBuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessageDataBuilderSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessageDataBuilderSettings Empty
public static readonly MessageDataBuilderSettings Empty
Field Value
Type: MessageDataBuilderSettings
See Also
MessageDataBuilderSettings Class
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings Methods

MessageDataBuilderSettings Methods Sitecore Social Connected 2.0 API
The MessageDataBuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageDataBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings Properties

MessageDataBuilderSettings Properties Sitecore Social Connected 2.0 API
The MessageDataBuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageDataType | Gets or sets the type of the message data.
Public property | MessageItemBaseType | Gets or sets the type of the message item base.
Back to Top
See Also
MessageDataBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings.BuilderType Property

MessageDataBuilderSettings BuilderType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the builder.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BuilderType { get; set; }
public string BuilderType { get; set; }
Property Value
Type:   Online String

            The type of the builder.

See Also
MessageDataBuilderSettings Class
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings.IsEmpty Property

MessageDataBuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessageDataBuilderSettings Class
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings.MessageDataType Property

MessageDataBuilderSettings MessageDataType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the message data.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessageDataType { get; set; }
public string MessageDataType { get; set; }
Property Value
Type:   Online String

            The type of the message data.

See Also
MessageDataBuilderSettings Class
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageDataBuilderSettings.MessageItemBaseType Property

MessageDataBuilderSettings MessageItemBaseType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the message item base.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessageItemBaseType { get; set; }
public string MessageItemBaseType { get; set; }
Property Value
Type:   Online String

            The type of the message item base.

See Also
MessageDataBuilderSettings Class
MessageDataBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings Class

MessageStatusBuilderSettings Class Sitecore Social Connected 2.0 API
Represents the message status builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Api MessageStatusBuilderSettings

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageStatusBuilderSettings : IEmptyable
[SerializableAttribute]
public class MessageStatusBuilderSettings : IEmptyable
See Also
MessageStatusBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings Members

MessageStatusBuilderSettings Members Sitecore Social Connected 2.0 API

The MessageStatusBuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | MessageStatusBuilderSettings | Initializes a new instance of the MessageStatusBuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessageStatusBuilderSettings class whose value represents a not defined configuration settings.
Back to Top
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Public property | PostingConfigurationName | Gets or sets the name of the posting configuration.
Back to Top
See Also
MessageStatusBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings Constructor

MessageStatusBuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatusBuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatusBuilderSettings()
public MessageStatusBuilderSettings()
See Also
MessageStatusBuilderSettings Class
MessageStatusBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings Fields

MessageStatusBuilderSettings Fields Sitecore Social Connected 2.0 API
The MessageStatusBuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessageStatusBuilderSettings class whose value represents a not defined configuration settings.
Back to Top
See Also
MessageStatusBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings.Empty Field

MessageStatusBuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessageStatusBuilderSettings class whose value represents a not defined configuration settings.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessageStatusBuilderSettings Empty
public static readonly MessageStatusBuilderSettings Empty
Field Value
Type: MessageStatusBuilderSettings
See Also
MessageStatusBuilderSettings Class
MessageStatusBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings Methods

MessageStatusBuilderSettings Methods Sitecore Social Connected 2.0 API
The MessageStatusBuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageStatusBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings Properties

MessageStatusBuilderSettings Properties Sitecore Social Connected 2.0 API
The MessageStatusBuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Public property | PostingConfigurationName | Gets or sets the name of the posting configuration.
Back to Top
See Also
MessageStatusBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings.BuilderType Property

MessageStatusBuilderSettings BuilderType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the builder.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BuilderType { get; set; }
public string BuilderType { get; set; }
Property Value
Type:   Online String

            The type of the builder.

See Also
MessageStatusBuilderSettings Class
MessageStatusBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings.IsEmpty Property

MessageStatusBuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessageStatusBuilderSettings Class
MessageStatusBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


MessageStatusBuilderSettings.PostingConfigurationName Property

MessageStatusBuilderSettings PostingConfigurationName Property Sitecore Social Connected 2.0 API
Gets or sets the name of the posting configuration.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostingConfigurationName { get; set; }
public string PostingConfigurationName { get; set; }
Property Value
Type:   Online String

            The name of the posting configuration.

See Also
MessageStatusBuilderSettings Class
MessageStatusBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings Class

PostingConfigurationBuilderSettings Class Sitecore Social Connected 2.0 API
Represents the posting configuration builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Api PostingConfigurationBuilderSettings

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingConfigurationBuilderSettings : IEmptyable
[SerializableAttribute]
public class PostingConfigurationBuilderSettings : IEmptyable
See Also
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings Members

PostingConfigurationBuilderSettings Members Sitecore Social Connected 2.0 API

The PostingConfigurationBuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | PostingConfigurationBuilderSettings | Initializes a new instance of the PostingConfigurationBuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationBuilderSettings class whose value represents a not defined configuration settings.
Back to Top
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Public property | PostingConfigurationName | Gets or sets the name of the posting configuration.
Public property | PostingConfigurationType | Gets or sets the type of the posting configuration.
Back to Top
See Also
PostingConfigurationBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings Constructor

PostingConfigurationBuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationBuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationBuilderSettings()
public PostingConfigurationBuilderSettings()
See Also
PostingConfigurationBuilderSettings Class
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings Fields

PostingConfigurationBuilderSettings Fields Sitecore Social Connected 2.0 API
The PostingConfigurationBuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationBuilderSettings class whose value represents a not defined configuration settings.
Back to Top
See Also
PostingConfigurationBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings.Empty Field

PostingConfigurationBuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the PostingConfigurationBuilderSettings class whose value represents a not defined configuration settings.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly PostingConfigurationBuilderSettings Empty
public static readonly PostingConfigurationBuilderSettings Empty
Field Value
Type: PostingConfigurationBuilderSettings
See Also
PostingConfigurationBuilderSettings Class
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings Methods

PostingConfigurationBuilderSettings Methods Sitecore Social Connected 2.0 API
The PostingConfigurationBuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfigurationBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings Properties

PostingConfigurationBuilderSettings Properties Sitecore Social Connected 2.0 API
The PostingConfigurationBuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | BuilderType | Gets or sets the type of the builder.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Public property | PostingConfigurationName | Gets or sets the name of the posting configuration.
Public property | PostingConfigurationType | Gets or sets the type of the posting configuration.
Back to Top
See Also
PostingConfigurationBuilderSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings.BuilderType Property

PostingConfigurationBuilderSettings BuilderType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the builder.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BuilderType { get; set; }
public string BuilderType { get; set; }
Property Value
Type:   Online String

            The type of the builder.

See Also
PostingConfigurationBuilderSettings Class
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings.IsEmpty Property

PostingConfigurationBuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
PostingConfigurationBuilderSettings Class
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings.PostingConfigurationName Property

PostingConfigurationBuilderSettings PostingConfigurationName Property Sitecore Social Connected 2.0 API
Gets or sets the name of the posting configuration.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostingConfigurationName { get; set; }
public string PostingConfigurationName { get; set; }
Property Value
Type:   Online String

            The name of the posting configuration.

See Also
PostingConfigurationBuilderSettings Class
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationBuilderSettings.PostingConfigurationType Property

PostingConfigurationBuilderSettings PostingConfigurationType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the posting configuration.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostingConfigurationType { get; set; }
public string PostingConfigurationType { get; set; }
Property Value
Type:   Online String

            The type of the posting configuration.

See Also
PostingConfigurationBuilderSettings Class
PostingConfigurationBuilderSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings Class

PostingConfigurationSearchArgsAdapterSettings Class Sitecore Social Connected 2.0 API
Represents the posting configuration search args adapter settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Api PostingConfigurationSearchArgsAdapterSettings

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingConfigurationSearchArgsAdapterSettings : IEmptyable
[SerializableAttribute]
public class PostingConfigurationSearchArgsAdapterSettings : IEmptyable
See Also
PostingConfigurationSearchArgsAdapterSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings Members

PostingConfigurationSearchArgsAdapterSettings Members Sitecore Social Connected 2.0 API

The PostingConfigurationSearchArgsAdapterSettings type exposes the following members.
Constructors
 | Name | Description
Public method | PostingConfigurationSearchArgsAdapterSettings | Initializes a new instance of the PostingConfigurationSearchArgsAdapterSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationSearchArgsAdapterSettings class whose value represents a not defined configuration settings.
Back to Top
Properties
 | Name | Description
Public property | AdapterType | Gets or sets the type of the adapter.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Public property | SearchArgsType | Gets or sets the type of the search args.
Back to Top
See Also
PostingConfigurationSearchArgsAdapterSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings Constructor

PostingConfigurationSearchArgsAdapterSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgsAdapterSettings class

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationSearchArgsAdapterSettings()
public PostingConfigurationSearchArgsAdapterSettings()
See Also
PostingConfigurationSearchArgsAdapterSettings Class
PostingConfigurationSearchArgsAdapterSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings Fields

PostingConfigurationSearchArgsAdapterSettings Fields Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgsAdapterSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationSearchArgsAdapterSettings class whose value represents a not defined configuration settings.
Back to Top
See Also
PostingConfigurationSearchArgsAdapterSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings.Empty Field

PostingConfigurationSearchArgsAdapterSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the PostingConfigurationSearchArgsAdapterSettings class whose value represents a not defined configuration settings.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly PostingConfigurationSearchArgsAdapterSettings Empty
public static readonly PostingConfigurationSearchArgsAdapterSettings Empty
Field Value
Type: PostingConfigurationSearchArgsAdapterSettings
See Also
PostingConfigurationSearchArgsAdapterSettings Class
PostingConfigurationSearchArgsAdapterSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings Methods

PostingConfigurationSearchArgsAdapterSettings Methods Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgsAdapterSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfigurationSearchArgsAdapterSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings Properties

PostingConfigurationSearchArgsAdapterSettings Properties Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgsAdapterSettings type exposes the following members.
Properties
 | Name | Description
Public property | AdapterType | Gets or sets the type of the adapter.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not.
Public property | SearchArgsType | Gets or sets the type of the search args.
Back to Top
See Also
PostingConfigurationSearchArgsAdapterSettings Class
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings.AdapterType Property

PostingConfigurationSearchArgsAdapterSettings AdapterType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the adapter.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AdapterType { get; set; }
public string AdapterType { get; set; }
Property Value
Type:   Online String

            The type of the adapter.

See Also
PostingConfigurationSearchArgsAdapterSettings Class
PostingConfigurationSearchArgsAdapterSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings.IsEmpty Property

PostingConfigurationSearchArgsAdapterSettings IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
PostingConfigurationSearchArgsAdapterSettings Class
PostingConfigurationSearchArgsAdapterSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


PostingConfigurationSearchArgsAdapterSettings.SearchArgsType Property

PostingConfigurationSearchArgsAdapterSettings SearchArgsType Property Sitecore Social Connected 2.0 API
Gets or sets the type of the search args.

Namespace: Sitecore.Social.Configuration.Model.Api
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SearchArgsType { get; set; }
public string SearchArgsType { get; set; }
Property Value
Type:   Online String

            The type of the search args.

See Also
PostingConfigurationSearchArgsAdapterSettings Class
PostingConfigurationSearchArgsAdapterSettings Members
Sitecore.Social.Configuration.Model.Api Namespace


Sitecore.Social.Configuration.Model.GenderRule Namespace

Sitecore.Social.Configuration.Model.GenderRule Namespace Sitecore Social Connected 2.0 API
Provides classes that represent "socialGenderRule" settings.
Classes
 | Class | Description
Public class | GenderSettings | This class represents the gender sitecoreKey and values in the user profile.
Public class | NetworkSettings | The network settings.


GenderSettings Class

GenderSettings Class Sitecore Social Connected 2.0 API
This class represents the gender sitecoreKey and values in the user profile.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.GenderRule GenderSettings

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GenderSettings : IEmptyable
[SerializableAttribute]
public class GenderSettings : IEmptyable
See Also
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings Members

GenderSettings Members Sitecore Social Connected 2.0 API

The GenderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | GenderSettings | Initializes a new instance of the GenderSettings class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Public method | Equals(GenderSettings) | Checks if the current GenderSettings is equal to another one.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the GenderSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | FemaleValue | Gets or sets the female value.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MaleValue | Gets or sets the male value.
Public property | SitecoreKey | Gets or sets the sitecore key.
Back to Top
See Also
GenderSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings Constructor

GenderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the GenderSettings class

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GenderSettings()
public GenderSettings()
See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings Fields

GenderSettings Fields Sitecore Social Connected 2.0 API
The GenderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the GenderSettings class whose value represents not defined configuration.
Back to Top
See Also
GenderSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.Empty Field

GenderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the GenderSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly GenderSettings Empty
public static readonly GenderSettings Empty
Field Value
Type: GenderSettings
See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings Methods

GenderSettings Methods Sitecore Social Connected 2.0 API
The GenderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Public method | Equals(GenderSettings) | Checks if the current GenderSettings is equal to another one.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GenderSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.Equals Method

GenderSettings Equals Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Public method | Equals(GenderSettings) | Checks if the current GenderSettings is equal to another one.
Back to Top
See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.Equals Method (Object)

GenderSettings Equals Method (Object) Sitecore Social Connected 2.0 API
Determines whether the specified Online Object is equal to this instance.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Parameters
obj
Type:   Online System Object
The   Online Object to compare with this instance.
Return Value
Type:   Online Boolean
true if the specified   Online Object is equal to this instance; otherwise, false.

Exceptions
Exception | Condition
Online System InvalidCastException | The 'obj' argument is not an Identifier object.
See Also
GenderSettings Class
GenderSettings Members
Equals Overload
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.Equals Method (GenderSettings)

GenderSettings Equals Method (GenderSettings) Sitecore Social Connected 2.0 API
Checks if the current GenderSettings is equal to another one.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    GenderSettings other
)
public bool Equals(
    GenderSettings other
)
Parameters
other
Type: Sitecore.Social.Configuration.Model.GenderRule GenderSettings
The other GenderSettings.
Return Value
Type:   Online Boolean
true if the current GenderSettings is equal to another one, otherwise false.
See Also
GenderSettings Class
GenderSettings Members
Equals Overload
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.GetHashCode Method

GenderSettings GetHashCode Method Sitecore Social Connected 2.0 API
Returns a hash code for this instance.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Return Value
Type:   Online Int32

            A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings Properties

GenderSettings Properties Sitecore Social Connected 2.0 API
The GenderSettings type exposes the following members.
Properties
 | Name | Description
Public property | FemaleValue | Gets or sets the female value.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MaleValue | Gets or sets the male value.
Public property | SitecoreKey | Gets or sets the sitecore key.
Back to Top
See Also
GenderSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.FemaleValue Property

GenderSettings FemaleValue Property Sitecore Social Connected 2.0 API
Gets or sets the female value.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FemaleValue { get; set; }
public string FemaleValue { get; set; }
Property Value
Type:   Online String

            The female value.

See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.IsEmpty Property

GenderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.MaleValue Property

GenderSettings MaleValue Property Sitecore Social Connected 2.0 API
Gets or sets the male value.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MaleValue { get; set; }
public string MaleValue { get; set; }
Property Value
Type:   Online String

            The male value.

See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


GenderSettings.SitecoreKey Property

GenderSettings SitecoreKey Property Sitecore Social Connected 2.0 API
Gets or sets the sitecore key.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SitecoreKey { get; set; }
public string SitecoreKey { get; set; }
Property Value
Type:   Online String

            The sitecore key.

See Also
GenderSettings Class
GenderSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings Class

NetworkSettings Class Sitecore Social Connected 2.0 API
The network settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.GenderRule NetworkSettings

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetworkSettings : IEmptyable
[SerializableAttribute]
public class NetworkSettings : IEmptyable
See Also
NetworkSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings Members

NetworkSettings Members Sitecore Social Connected 2.0 API

The NetworkSettings type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkSettings | Initializes a new instance of the NetworkSettings class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the NetworkSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | Gender | Gets or sets the gender settings.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings Constructor

NetworkSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkSettings class.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkSettings()
public NetworkSettings()
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings Fields

NetworkSettings Fields Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the NetworkSettings class whose value represents not defined configuration.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings.Empty Field

NetworkSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the NetworkSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NetworkSettings Empty
public static readonly NetworkSettings Empty
Field Value
Type: NetworkSettings
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings Methods

NetworkSettings Methods Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings Properties

NetworkSettings Properties Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Properties
 | Name | Description
Public property | Gender | Gets or sets the gender settings.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings.Gender Property

NetworkSettings Gender Property Sitecore Social Connected 2.0 API
Gets or sets the gender settings.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GenderSettings Gender { get; set; }
public GenderSettings Gender { get; set; }
Property Value
Type: GenderSettings

            The gender settings.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings.IsEmpty Property

NetworkSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


NetworkSettings.Name Property

NetworkSettings Name Property Sitecore Social Connected 2.0 API
Gets or sets the name.

Namespace: Sitecore.Social.Configuration.Model.GenderRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String

            The name.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.GenderRule Namespace


Sitecore.Social.Configuration.Model.InterestedInRule Namespace

Sitecore.Social.Configuration.Model.InterestedInRule Namespace Sitecore Social Connected 2.0 API
Provides classes that represent "interestedInRule" settings.
Classes
 | Class | Description
Public class | NetworkSettings | The network.


NetworkSettings Class

NetworkSettings Class Sitecore Social Connected 2.0 API
The network.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.InterestedInRule NetworkSettings

Namespace: Sitecore.Social.Configuration.Model.InterestedInRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetworkSettings : IEmptyable
[SerializableAttribute]
public class NetworkSettings : IEmptyable
See Also
NetworkSettings Members
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings Members

NetworkSettings Members Sitecore Social Connected 2.0 API

The NetworkSettings type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkSettings | Initializes a new instance of the NetworkSettings class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty |
Back to Top
Properties
 | Name | Description
Public property | Fields |
Public property | IsEmpty |
Public property | Name |
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings Constructor

NetworkSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkSettings class.

Namespace: Sitecore.Social.Configuration.Model.InterestedInRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkSettings()
public NetworkSettings()
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings Fields

NetworkSettings Fields Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Fields
Name | Description
Empty |
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings.Empty Field

NetworkSettings Empty Field Sitecore Social Connected 2.0 API

[Missing <summary> documentation for "F:Sitecore.Social.Configuration.Model.InterestedInRule.NetworkSettings.Empty"]

Namespace: Sitecore.Social.Configuration.Model.InterestedInRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NetworkSettings Empty
public static readonly NetworkSettings Empty
Field Value
Type: NetworkSettings
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings Methods

NetworkSettings Methods Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings Properties

NetworkSettings Properties Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Properties
 | Name | Description
Public property | Fields |
Public property | IsEmpty |
Public property | Name |
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings.Fields Property

NetworkSettings Fields Property Sitecore Social Connected 2.0 API

[Missing <summary> documentation for "P:Sitecore.Social.Configuration.Model.InterestedInRule.NetworkSettings.Fields"]

Namespace: Sitecore.Social.Configuration.Model.InterestedInRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> Fields { get; set; }
public List<string> Fields { get; set; }
Property Value
Type:   Online List    Online String
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings.IsEmpty Property

NetworkSettings IsEmpty Property Sitecore Social Connected 2.0 API

[Missing <summary> documentation for "P:Sitecore.Social.Configuration.Model.InterestedInRule.NetworkSettings.IsEmpty"]

Namespace: Sitecore.Social.Configuration.Model.InterestedInRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
Implements
IEmptyable IsEmpty
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


NetworkSettings.Name Property

NetworkSettings Name Property Sitecore Social Connected 2.0 API

[Missing <summary> documentation for "P:Sitecore.Social.Configuration.Model.InterestedInRule.NetworkSettings.Name"]

Namespace: Sitecore.Social.Configuration.Model.InterestedInRule
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.InterestedInRule Namespace


Sitecore.Social.Configuration.Model.Networks Namespace

Sitecore.Social.Configuration.Model.Networks Namespace Sitecore Social Connected 2.0 API
Provides classes that represent "network" settings.
Classes
 | Class | Description
Public class | CampaignSettings | The campaign settings.
Public class | MessagePostingSettings | The message posting settings.
Public class | MessageSettings | The message settings.
Public class | NetworkSettings | The network settings.
Public class | PermissionBuilderSettings | The permission builder settings.
Public class | ProviderSettings | The provider settings.
Public class | PublisherSettings | The publisher settings.


CampaignSettings Class

CampaignSettings Class Sitecore Social Connected 2.0 API
The campaign settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks CampaignSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CampaignSettings : IEmptyable
[SerializableAttribute]
public class CampaignSettings : IEmptyable
See Also
CampaignSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings Members

CampaignSettings Members Sitecore Social Connected 2.0 API

The CampaignSettings type exposes the following members.
Constructors
 | Name | Description
Public method | CampaignSettings | Initializes a new instance of the CampaignSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the CampaignSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | ItemId | Gets or sets the item unique identifier.
Public property | PostingConfiguration | Gets or sets the posting configuration.
Back to Top
See Also
CampaignSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings Constructor

CampaignSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the CampaignSettings class

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CampaignSettings()
public CampaignSettings()
See Also
CampaignSettings Class
CampaignSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings Fields

CampaignSettings Fields Sitecore Social Connected 2.0 API
The CampaignSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the CampaignSettings class whose value represents not defined configuration.
Back to Top
See Also
CampaignSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings.Empty Field

CampaignSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the CampaignSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly CampaignSettings Empty
public static readonly CampaignSettings Empty
Field Value
Type: CampaignSettings
See Also
CampaignSettings Class
CampaignSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings Methods

CampaignSettings Methods Sitecore Social Connected 2.0 API
The CampaignSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
CampaignSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings Properties

CampaignSettings Properties Sitecore Social Connected 2.0 API
The CampaignSettings type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | ItemId | Gets or sets the item unique identifier.
Public property | PostingConfiguration | Gets or sets the posting configuration.
Back to Top
See Also
CampaignSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings.IsEmpty Property

CampaignSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
CampaignSettings Class
CampaignSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings.ItemId Property

CampaignSettings ItemId Property Sitecore Social Connected 2.0 API
Gets or sets the item unique identifier.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ItemId { get; set; }
public string ItemId { get; set; }
Property Value
Type:   Online String

            The item unique identifier.

See Also
CampaignSettings Class
CampaignSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


CampaignSettings.PostingConfiguration Property

CampaignSettings PostingConfiguration Property Sitecore Social Connected 2.0 API
Gets or sets the posting configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostingConfiguration { get; set; }
public string PostingConfiguration { get; set; }
Property Value
Type:   Online String

            The posting configuration.

See Also
CampaignSettings Class
CampaignSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings Class

MessagePostingSettings Class Sitecore Social Connected 2.0 API
The message posting settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks MessagePostingSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessagePostingSettings : IEmptyable
[SerializableAttribute]
public class MessagePostingSettings : IEmptyable
See Also
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings Members

MessagePostingSettings Members Sitecore Social Connected 2.0 API

The MessagePostingSettings type exposes the following members.
Constructors
 | Name | Description
Public method | MessagePostingSettings | Initializes a new instance of the MessagePostingSettings class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessagePostingSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | Campaigns | Gets or sets the campaigns settings.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Publisher | Gets or sets the publisher settings.
Public property | RootCampaignItemId | Gets or sets the root campaign item unique identifier.
Back to Top
See Also
MessagePostingSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings Constructor

MessagePostingSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessagePostingSettings class.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessagePostingSettings()
public MessagePostingSettings()
See Also
MessagePostingSettings Class
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings Fields

MessagePostingSettings Fields Sitecore Social Connected 2.0 API
The MessagePostingSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessagePostingSettings class whose value represents not defined configuration.
Back to Top
See Also
MessagePostingSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings.Empty Field

MessagePostingSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessagePostingSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessagePostingSettings Empty
public static readonly MessagePostingSettings Empty
Field Value
Type: MessagePostingSettings
See Also
MessagePostingSettings Class
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings Methods

MessagePostingSettings Methods Sitecore Social Connected 2.0 API
The MessagePostingSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessagePostingSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings Properties

MessagePostingSettings Properties Sitecore Social Connected 2.0 API
The MessagePostingSettings type exposes the following members.
Properties
 | Name | Description
Public property | Campaigns | Gets or sets the campaigns settings.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Publisher | Gets or sets the publisher settings.
Public property | RootCampaignItemId | Gets or sets the root campaign item unique identifier.
Back to Top
See Also
MessagePostingSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings.Campaigns Property

MessagePostingSettings Campaigns Property Sitecore Social Connected 2.0 API
Gets or sets the campaigns settings.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<CampaignSettings> Campaigns { get; set; }
public List<CampaignSettings> Campaigns { get; set; }
Property Value
Type:   Online List  CampaignSettings

            The campaigns settings.

See Also
MessagePostingSettings Class
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings.IsEmpty Property

MessagePostingSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessagePostingSettings Class
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings.Publisher Property

MessagePostingSettings Publisher Property Sitecore Social Connected 2.0 API
Gets or sets the publisher settings.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PublisherSettings Publisher { get; set; }
public PublisherSettings Publisher { get; set; }
Property Value
Type: PublisherSettings

            The publisher settings.

See Also
MessagePostingSettings Class
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessagePostingSettings.RootCampaignItemId Property

MessagePostingSettings RootCampaignItemId Property Sitecore Social Connected 2.0 API
Gets or sets the root campaign item unique identifier.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RootCampaignItemId { get; set; }
public string RootCampaignItemId { get; set; }
Property Value
Type:   Online String

            The root campaign item unique identifier.

See Also
MessagePostingSettings Class
MessagePostingSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings Class

MessageSettings Class Sitecore Social Connected 2.0 API
The message settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks MessageSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageSettings : IEmptyable
[SerializableAttribute]
public class MessageSettings : IEmptyable
See Also
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings Members

MessageSettings Members Sitecore Social Connected 2.0 API

The MessageSettings type exposes the following members.
Constructors
 | Name | Description
Public method | MessageSettings | Initializes a new instance of the MessageSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessageSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageTemplateId | Gets or sets the message template unique identifier.
Public property | Renderer | Gets or sets the renderer.
Public property | TextLimit | Gets or sets the text limit.
Public property | Type | Gets or sets the type.
Back to Top
See Also
MessageSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings Constructor

MessageSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageSettings class

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageSettings()
public MessageSettings()
See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings Fields

MessageSettings Fields Sitecore Social Connected 2.0 API
The MessageSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessageSettings class whose value represents not defined configuration.
Back to Top
See Also
MessageSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings.Empty Field

MessageSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessageSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessageSettings Empty
public static readonly MessageSettings Empty
Field Value
Type: MessageSettings
See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings Methods

MessageSettings Methods Sitecore Social Connected 2.0 API
The MessageSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings Properties

MessageSettings Properties Sitecore Social Connected 2.0 API
The MessageSettings type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageTemplateId | Gets or sets the message template unique identifier.
Public property | Renderer | Gets or sets the renderer.
Public property | TextLimit | Gets or sets the text limit.
Public property | Type | Gets or sets the type.
Back to Top
See Also
MessageSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings.IsEmpty Property

MessageSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings.MessageTemplateId Property

MessageSettings MessageTemplateId Property Sitecore Social Connected 2.0 API
Gets or sets the message template unique identifier.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessageTemplateId { get; set; }
public string MessageTemplateId { get; set; }
Property Value
Type:   Online String

            The message template unique identifier.

See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings.Renderer Property

MessageSettings Renderer Property Sitecore Social Connected 2.0 API
Gets or sets the renderer.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Renderer { get; set; }
public string Renderer { get; set; }
Property Value
Type:   Online String

            The renderer.

See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings.TextLimit Property

MessageSettings TextLimit Property Sitecore Social Connected 2.0 API
Gets or sets the text limit.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TextLimit { get; set; }
public string TextLimit { get; set; }
Property Value
Type:   Online String

            The text limit.

See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


MessageSettings.Type Property

MessageSettings Type Property Sitecore Social Connected 2.0 API
Gets or sets the type.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
Property Value
Type:   Online String

            The type.

See Also
MessageSettings Class
MessageSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings Class

NetworkSettings Class Sitecore Social Connected 2.0 API
The network settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks NetworkSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetworkSettings : IEmptyable
[SerializableAttribute]
public class NetworkSettings : IEmptyable
See Also
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings Members

NetworkSettings Members Sitecore Social Connected 2.0 API

The NetworkSettings type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkSettings | Initializes a new instance of the NetworkSettings class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the NetworkSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | AccountExpirationDays | Gets or sets the account expiration days.
Public property | Icon | Gets or sets the icon.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | ItemId | Gets or sets the item unique identifier.
Public property | Items | Gets or sets the items.
Public property | MessagePosting | Gets or sets the message posting settings.
Public property | Name | Gets or sets the name.
Public property | PermissionBuilders | Gets or sets the permission builders.
Public property | Prefix | Gets or sets the prefix.
Public property | Providers | Gets or sets the providers.
Public property | Url | Gets or sets the URL.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings Constructor

NetworkSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkSettings class.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkSettings()
public NetworkSettings()
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings Fields

NetworkSettings Fields Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the NetworkSettings class whose value represents not defined configuration.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Empty Field

NetworkSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the NetworkSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NetworkSettings Empty
public static readonly NetworkSettings Empty
Field Value
Type: NetworkSettings
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings Methods

NetworkSettings Methods Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings Properties

NetworkSettings Properties Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Properties
 | Name | Description
Public property | AccountExpirationDays | Gets or sets the account expiration days.
Public property | Icon | Gets or sets the icon.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | ItemId | Gets or sets the item unique identifier.
Public property | Items | Gets or sets the items.
Public property | MessagePosting | Gets or sets the message posting settings.
Public property | Name | Gets or sets the name.
Public property | PermissionBuilders | Gets or sets the permission builders.
Public property | Prefix | Gets or sets the prefix.
Public property | Providers | Gets or sets the providers.
Public property | Url | Gets or sets the URL.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.AccountExpirationDays Property

NetworkSettings AccountExpirationDays Property Sitecore Social Connected 2.0 API
Gets or sets the account expiration days.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountExpirationDays { get; set; }
public string AccountExpirationDays { get; set; }
Property Value
Type:   Online String

            The account expiration days.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Icon Property

NetworkSettings Icon Property Sitecore Social Connected 2.0 API
Gets or sets the icon.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Icon { get; set; }
public string Icon { get; set; }
Property Value
Type:   Online String

            The icon.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.IsEmpty Property

NetworkSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.ItemId Property

NetworkSettings ItemId Property Sitecore Social Connected 2.0 API
Gets or sets the item unique identifier.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ItemId { get; set; }
public string ItemId { get; set; }
Property Value
Type:   Online String

            The item unique identifier.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Items Property

NetworkSettings Items Property Sitecore Social Connected 2.0 API
Gets or sets the items.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<MessageSettings> Items { get; set; }
public List<MessageSettings> Items { get; set; }
Property Value
Type:   Online List  MessageSettings

            The items.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.MessagePosting Property

NetworkSettings MessagePosting Property Sitecore Social Connected 2.0 API
Gets or sets the message posting settings.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessagePostingSettings MessagePosting { get; set; }
public MessagePostingSettings MessagePosting { get; set; }
Property Value
Type: MessagePostingSettings

            The message posting settings.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Name Property

NetworkSettings Name Property Sitecore Social Connected 2.0 API
Gets or sets the name.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String

            The name.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.PermissionBuilders Property

NetworkSettings PermissionBuilders Property Sitecore Social Connected 2.0 API
Gets or sets the permission builders.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PermissionBuilderSettings> PermissionBuilders { get; set; }
public List<PermissionBuilderSettings> PermissionBuilders { get; set; }
Property Value
Type:   Online List  PermissionBuilderSettings

            The permission builders.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Prefix Property

NetworkSettings Prefix Property Sitecore Social Connected 2.0 API
Gets or sets the prefix.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Prefix { get; set; }
public string Prefix { get; set; }
Property Value
Type:   Online String

            The prefix.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Providers Property

NetworkSettings Providers Property Sitecore Social Connected 2.0 API
Gets or sets the providers.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<ProviderSettings> Providers { get; set; }
public List<ProviderSettings> Providers { get; set; }
Property Value
Type:   Online List  ProviderSettings

            The providers.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


NetworkSettings.Url Property

NetworkSettings Url Property Sitecore Social Connected 2.0 API
Gets or sets the URL.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Url { get; set; }
public string Url { get; set; }
Property Value
Type:   Online String

            The URL.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings Class

PermissionBuilderSettings Class Sitecore Social Connected 2.0 API
The permission builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks PermissionBuilderSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PermissionBuilderSettings : IEmptyable
[SerializableAttribute]
public class PermissionBuilderSettings : IEmptyable
See Also
PermissionBuilderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings Members

PermissionBuilderSettings Members Sitecore Social Connected 2.0 API

The PermissionBuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | PermissionBuilderSettings | Initializes a new instance of the PermissionBuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the PermissionBuilderSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
PermissionBuilderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings Constructor

PermissionBuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PermissionBuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PermissionBuilderSettings()
public PermissionBuilderSettings()
See Also
PermissionBuilderSettings Class
PermissionBuilderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings Fields

PermissionBuilderSettings Fields Sitecore Social Connected 2.0 API
The PermissionBuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the PermissionBuilderSettings class whose value represents not defined configuration.
Back to Top
See Also
PermissionBuilderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings.Empty Field

PermissionBuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the PermissionBuilderSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly PermissionBuilderSettings Empty
public static readonly PermissionBuilderSettings Empty
Field Value
Type: PermissionBuilderSettings
See Also
PermissionBuilderSettings Class
PermissionBuilderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings Methods

PermissionBuilderSettings Methods Sitecore Social Connected 2.0 API
The PermissionBuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PermissionBuilderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings Properties

PermissionBuilderSettings Properties Sitecore Social Connected 2.0 API
The PermissionBuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
PermissionBuilderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings.IsEmpty Property

PermissionBuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
PermissionBuilderSettings Class
PermissionBuilderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PermissionBuilderSettings.Type Property

PermissionBuilderSettings Type Property Sitecore Social Connected 2.0 API
Gets or sets the type.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
Property Value
Type:   Online String

            The type.

See Also
PermissionBuilderSettings Class
PermissionBuilderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings Class

ProviderSettings Class Sitecore Social Connected 2.0 API
The provider settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks ProviderSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ProviderSettings : IEmptyable
[SerializableAttribute]
public class ProviderSettings : IEmptyable
See Also
ProviderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings Members

ProviderSettings Members Sitecore Social Connected 2.0 API

The ProviderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | ProviderSettings | Initializes a new instance of the ProviderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the ProviderSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
ProviderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings Constructor

ProviderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ProviderSettings class

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProviderSettings()
public ProviderSettings()
See Also
ProviderSettings Class
ProviderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings Fields

ProviderSettings Fields Sitecore Social Connected 2.0 API
The ProviderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the ProviderSettings class whose value represents not defined configuration.
Back to Top
See Also
ProviderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings.Empty Field

ProviderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the ProviderSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ProviderSettings Empty
public static readonly ProviderSettings Empty
Field Value
Type: ProviderSettings
See Also
ProviderSettings Class
ProviderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings Methods

ProviderSettings Methods Sitecore Social Connected 2.0 API
The ProviderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ProviderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings Properties

ProviderSettings Properties Sitecore Social Connected 2.0 API
The ProviderSettings type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
ProviderSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings.IsEmpty Property

ProviderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
ProviderSettings Class
ProviderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


ProviderSettings.Type Property

ProviderSettings Type Property Sitecore Social Connected 2.0 API
Gets or sets the type.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
Property Value
Type:   Online String

            The type.

See Also
ProviderSettings Class
ProviderSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings Class

PublisherSettings Class Sitecore Social Connected 2.0 API
The publisher settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.Networks PublisherSettings

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PublisherSettings : IEmptyable
[SerializableAttribute]
public class PublisherSettings : IEmptyable
See Also
PublisherSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings Members

PublisherSettings Members Sitecore Social Connected 2.0 API

The PublisherSettings type exposes the following members.
Constructors
 | Name | Description
Public method | PublisherSettings | Initializes a new instance of the PublisherSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the PublisherSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
PublisherSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings Constructor

PublisherSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PublisherSettings class

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PublisherSettings()
public PublisherSettings()
See Also
PublisherSettings Class
PublisherSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings Fields

PublisherSettings Fields Sitecore Social Connected 2.0 API
The PublisherSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the PublisherSettings class whose value represents not defined configuration.
Back to Top
See Also
PublisherSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings.Empty Field

PublisherSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the PublisherSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly PublisherSettings Empty
public static readonly PublisherSettings Empty
Field Value
Type: PublisherSettings
See Also
PublisherSettings Class
PublisherSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings Methods

PublisherSettings Methods Sitecore Social Connected 2.0 API
The PublisherSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PublisherSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings Properties

PublisherSettings Properties Sitecore Social Connected 2.0 API
The PublisherSettings type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
PublisherSettings Class
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings.IsEmpty Property

PublisherSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
PublisherSettings Class
PublisherSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


PublisherSettings.Type Property

PublisherSettings Type Property Sitecore Social Connected 2.0 API
Gets or sets the type.

Namespace: Sitecore.Social.Configuration.Model.Networks
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
Property Value
Type:   Online String

            The type.

See Also
PublisherSettings Class
PublisherSettings Members
Sitecore.Social.Configuration.Model.Networks Namespace


Sitecore.Social.Configuration.Model.PostingConfigurations Namespace

Sitecore.Social.Configuration.Model.PostingConfigurations Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the "postingConfigurations" settings.
Classes
 | Class | Description
Public class | BuilderSettings | Represents builder settings.
Public class | PostingConfigurationSettings | Represents posting configuration settings.


BuilderSettings Class

BuilderSettings Class Sitecore Social Connected 2.0 API
Represents builder settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.PostingConfigurations BuilderSettings

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BuilderSettings : IEmptyable
[SerializableAttribute]
public class BuilderSettings : IEmptyable
See Also
BuilderSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings Members

BuilderSettings Members Sitecore Social Connected 2.0 API

The BuilderSettings type exposes the following members.
Constructors
 | Name | Description
Public method | BuilderSettings | Initializes a new instance of the BuilderSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the BuilderSettings class whose value represents not defined builder settings.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
BuilderSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings Constructor

BuilderSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the BuilderSettings class

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BuilderSettings()
public BuilderSettings()
See Also
BuilderSettings Class
BuilderSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings Fields

BuilderSettings Fields Sitecore Social Connected 2.0 API
The BuilderSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the BuilderSettings class whose value represents not defined builder settings.
Back to Top
See Also
BuilderSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings.Empty Field

BuilderSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the BuilderSettings class whose value represents not defined builder settings.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly BuilderSettings Empty
public static readonly BuilderSettings Empty
Field Value
Type: BuilderSettings
See Also
BuilderSettings Class
BuilderSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings Methods

BuilderSettings Methods Sitecore Social Connected 2.0 API
The BuilderSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
BuilderSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings Properties

BuilderSettings Properties Sitecore Social Connected 2.0 API
The BuilderSettings type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Type | Gets or sets the type.
Back to Top
See Also
BuilderSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings.IsEmpty Property

BuilderSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
BuilderSettings Class
BuilderSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


BuilderSettings.Type Property

BuilderSettings Type Property Sitecore Social Connected 2.0 API
Gets or sets the type.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
Property Value
Type:   Online String

            The type.

See Also
BuilderSettings Class
BuilderSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings Class

PostingConfigurationSettings Class Sitecore Social Connected 2.0 API
Represents posting configuration settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.PostingConfigurations PostingConfigurationSettings

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingConfigurationSettings : IEmptyable
[SerializableAttribute]
public class PostingConfigurationSettings : IEmptyable
See Also
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings Members

PostingConfigurationSettings Members Sitecore Social Connected 2.0 API

The PostingConfigurationSettings type exposes the following members.
Constructors
 | Name | Description
Public method | PostingConfigurationSettings | Initializes a new instance of the PostingConfigurationSettings class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationSettings class whose value represents not defined posting configuration settings.
Back to Top
Properties
 | Name | Description
Public property | Builder | Gets or sets the builder.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Public property | TemplateId | Gets or sets the template id.
Back to Top
See Also
PostingConfigurationSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings Constructor

PostingConfigurationSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSettings class.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfigurationSettings()
public PostingConfigurationSettings()
See Also
PostingConfigurationSettings Class
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings Fields

PostingConfigurationSettings Fields Sitecore Social Connected 2.0 API
The PostingConfigurationSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the PostingConfigurationSettings class whose value represents not defined posting configuration settings.
Back to Top
See Also
PostingConfigurationSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings.Empty Field

PostingConfigurationSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the PostingConfigurationSettings class whose value represents not defined posting configuration settings.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly PostingConfigurationSettings Empty
public static readonly PostingConfigurationSettings Empty
Field Value
Type: PostingConfigurationSettings
See Also
PostingConfigurationSettings Class
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings Methods

PostingConfigurationSettings Methods Sitecore Social Connected 2.0 API
The PostingConfigurationSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfigurationSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings Properties

PostingConfigurationSettings Properties Sitecore Social Connected 2.0 API
The PostingConfigurationSettings type exposes the following members.
Properties
 | Name | Description
Public property | Builder | Gets or sets the builder.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Public property | TemplateId | Gets or sets the template id.
Back to Top
See Also
PostingConfigurationSettings Class
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings.Builder Property

PostingConfigurationSettings Builder Property Sitecore Social Connected 2.0 API
Gets or sets the builder.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BuilderSettings Builder { get; set; }
public BuilderSettings Builder { get; set; }
Property Value
Type: BuilderSettings

            The builder.

See Also
PostingConfigurationSettings Class
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings.IsEmpty Property

PostingConfigurationSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
PostingConfigurationSettings Class
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings.Name Property

PostingConfigurationSettings Name Property Sitecore Social Connected 2.0 API
Gets or sets the name.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String

            The name.

See Also
PostingConfigurationSettings Class
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


PostingConfigurationSettings.TemplateId Property

PostingConfigurationSettings TemplateId Property Sitecore Social Connected 2.0 API
Gets or sets the template id.

Namespace: Sitecore.Social.Configuration.Model.PostingConfigurations
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TemplateId { get; set; }
public string TemplateId { get; set; }
Property Value
Type:   Online String

            The template id.

See Also
PostingConfigurationSettings Class
PostingConfigurationSettings Members
Sitecore.Social.Configuration.Model.PostingConfigurations Namespace


Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace

Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the "socialProfileKeyMappings" settings.
Classes
 | Class | Description
Public class | FieldSettings | The field settings.
Public class | NetworkSettings | The network settings.


FieldSettings Class

FieldSettings Class Sitecore Social Connected 2.0 API
The field settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.ProfileKeyMappings FieldSettings

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FieldSettings : IEmptyable
[SerializableAttribute]
public class FieldSettings : IEmptyable
See Also
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings Members

FieldSettings Members Sitecore Social Connected 2.0 API

The FieldSettings type exposes the following members.
Constructors
 | Name | Description
Public method | FieldSettings | Initializes a new instance of the FieldSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the FieldSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | Access | Gets or sets the access.
Public property | Enabled | Gets or sets the enabled value.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MainNetworkDataPropertyName | Gets or sets the name of the main network data property.
Public property | OriginalKey | Gets or sets the original key.
Public property | Permission | Gets or sets the permission.
Public property | SitecoreKey | Gets or sets the sitecore key.
Public property | Text | Gets or sets the text.
Public property | XmlPath | Gets or sets the XML path.
Back to Top
See Also
FieldSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings Constructor

FieldSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the FieldSettings class

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldSettings()
public FieldSettings()
See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings Fields

FieldSettings Fields Sitecore Social Connected 2.0 API
The FieldSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the FieldSettings class whose value represents not defined configuration.
Back to Top
See Also
FieldSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.Empty Field

FieldSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the FieldSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldSettings Empty
public static readonly FieldSettings Empty
Field Value
Type: FieldSettings
See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings Methods

FieldSettings Methods Sitecore Social Connected 2.0 API
The FieldSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
FieldSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings Properties

FieldSettings Properties Sitecore Social Connected 2.0 API
The FieldSettings type exposes the following members.
Properties
 | Name | Description
Public property | Access | Gets or sets the access.
Public property | Enabled | Gets or sets the enabled value.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MainNetworkDataPropertyName | Gets or sets the name of the main network data property.
Public property | OriginalKey | Gets or sets the original key.
Public property | Permission | Gets or sets the permission.
Public property | SitecoreKey | Gets or sets the sitecore key.
Public property | Text | Gets or sets the text.
Public property | XmlPath | Gets or sets the XML path.
Back to Top
See Also
FieldSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.Access Property

FieldSettings Access Property Sitecore Social Connected 2.0 API
Gets or sets the access.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Access { get; set; }
public string Access { get; set; }
Property Value
Type:   Online String

            The access.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.Enabled Property

FieldSettings Enabled Property Sitecore Social Connected 2.0 API
Gets or sets the enabled value.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Enabled { get; set; }
public string Enabled { get; set; }
Property Value
Type:   Online String

            The enabled value.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.IsEmpty Property

FieldSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.MainNetworkDataPropertyName Property

FieldSettings MainNetworkDataPropertyName Property Sitecore Social Connected 2.0 API
Gets or sets the name of the main network data property.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MainNetworkDataPropertyName { get; set; }
public string MainNetworkDataPropertyName { get; set; }
Property Value
Type:   Online String

            The name of the main network data property.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.OriginalKey Property

FieldSettings OriginalKey Property Sitecore Social Connected 2.0 API
Gets or sets the original key.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OriginalKey { get; set; }
public string OriginalKey { get; set; }
Property Value
Type:   Online String

            The original key.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.Permission Property

FieldSettings Permission Property Sitecore Social Connected 2.0 API
Gets or sets the permission.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Permission { get; set; }
public string Permission { get; set; }
Property Value
Type:   Online String

            The permission.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.SitecoreKey Property

FieldSettings SitecoreKey Property Sitecore Social Connected 2.0 API
Gets or sets the sitecore key.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SitecoreKey { get; set; }
public string SitecoreKey { get; set; }
Property Value
Type:   Online String

            The sitecore key.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.Text Property

FieldSettings Text Property Sitecore Social Connected 2.0 API
Gets or sets the text.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; set; }
public string Text { get; set; }
Property Value
Type:   Online String

            The text.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


FieldSettings.XmlPath Property

FieldSettings XmlPath Property Sitecore Social Connected 2.0 API
Gets or sets the XML path.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string XmlPath { get; set; }
public string XmlPath { get; set; }
Property Value
Type:   Online String

            The XML path.

See Also
FieldSettings Class
FieldSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings Class

NetworkSettings Class Sitecore Social Connected 2.0 API
The network settings.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model.ProfileKeyMappings NetworkSettings

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetworkSettings : IEmptyable
[SerializableAttribute]
public class NetworkSettings : IEmptyable
See Also
NetworkSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings Members

NetworkSettings Members Sitecore Social Connected 2.0 API

The NetworkSettings type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkSettings | Initializes a new instance of the NetworkSettings class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the FieldSettings class whose value represents not defined configuration.
Back to Top
Properties
 | Name | Description
Public property | Fields | Gets or sets the fields.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings Constructor

NetworkSettings Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkSettings class.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkSettings()
public NetworkSettings()
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings Fields

NetworkSettings Fields Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the FieldSettings class whose value represents not defined configuration.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings.Empty Field

NetworkSettings Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the FieldSettings class whose value represents not defined configuration.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NetworkSettings Empty
public static readonly NetworkSettings Empty
Field Value
Type: NetworkSettings
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings Methods

NetworkSettings Methods Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings Properties

NetworkSettings Properties Sitecore Social Connected 2.0 API
The NetworkSettings type exposes the following members.
Properties
 | Name | Description
Public property | Fields | Gets or sets the fields.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Back to Top
See Also
NetworkSettings Class
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings.Fields Property

NetworkSettings Fields Property Sitecore Social Connected 2.0 API
Gets or sets the fields.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<FieldSettings> Fields { get; set; }
public List<FieldSettings> Fields { get; set; }
Property Value
Type:   Online List  FieldSettings

            The fields.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings.IsEmpty Property

NetworkSettings IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


NetworkSettings.Name Property

NetworkSettings Name Property Sitecore Social Connected 2.0 API
Gets or sets the name.

Namespace: Sitecore.Social.Configuration.Model.ProfileKeyMappings
Assembly: Sitecore.Social.Configuration (in Sitecore.Social.Configuration.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String

            The name.

See Also
NetworkSettings Class
NetworkSettings Members
Sitecore.Social.Configuration.Model.ProfileKeyMappings Namespace


Sitecore.Social.Domain Namespace

Sitecore.Social.Domain Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the domain.
Interfaces
 | Interface | Description
Public interface | IAccountManager | Defines the methods that are used to get and create social accounts.
Public interface | IApplicationManager | Defines the methods that are used to manage social network applications.
Public interface | IEmptyable | Defines the property that is used to check if an entity is empty.
Public interface | IMessageManager | Defines the methods that are used to manage social network messages.
Public interface | IMessageStatisticsManager | Defines the methods that are used to manage social network message statistics.
Public interface | INetworkManager | Defines the methods that are used to manage social networks.
Public interface | IPostingPreferenceManager | Defines the methods that are used to manage user’s posting preferences.
Public interface | ISocialProfileManager | Defines the methods that are used to manage a social profile.


IAccountManager Interface

IAccountManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to get and create social accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAccountManager
public interface IAccountManager
See Also
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager Members

IAccountManager Members Sitecore Social Connected 2.0 API

The IAccountManager type exposes the following members.
Methods
 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.
Public method | GetAccountsByContainer | Gets the accounts by container.
Public method | GetDaysUntilRenewalRequired | Gets the number of days before the required renewal of an account.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier) | Gets an account display name in a social network.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String) | Gets an account display name in a social network.
Back to Top
See Also
IAccountManager Interface
Sitecore.Social.Domain Namespace


IAccountManager Methods

IAccountManager Methods Sitecore Social Connected 2.0 API
The IAccountManager type exposes the following members.
Methods
 | Name | Description
Public method | CreateAccount | Creates an account.
Public method | GetAccount | Gets an account by id.
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Public method | GetAccountsByApplication | Gets all accounts by application id. Returns a collection of accounts.
Public method | GetAccountsByContainer | Gets the accounts by container.
Public method | GetDaysUntilRenewalRequired | Gets the number of days before the required renewal of an account.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier) | Gets an account display name in a social network.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String) | Gets an account display name in a social network.
Back to Top
See Also
IAccountManager Interface
Sitecore.Social.Domain Namespace


IAccountManager.CreateAccount Method

IAccountManager CreateAccount Method Sitecore Social Connected 2.0 API
Creates an account.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void CreateAccount(
    Account account
)
void CreateAccount(
    Account account
)
Parameters
account
Type: Sitecore.Social.Domain.Model Account
The account to create.
Remarks
The Id field will contain identifier of the new account after creation.
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetAccount Method

IAccountManager GetAccount Method Sitecore Social Connected 2.0 API
Gets an account by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Account GetAccount(
    Identifier accountId
)
Account GetAccount(
    Identifier accountId
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
Return Value
Type: Account
The account. If the account is not found, an empty instance is returned.
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetAccounts Method

IAccountManager GetAccounts Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetAccounts(String) | Gets all accounts by network name. Returns a collection of accounts.
Public method | GetAccounts(Identifier) | Gets all accounts by network id. Returns a collection of accounts.
Back to Top
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetAccounts Method (String)

IAccountManager GetAccounts Method (String) Sitecore Social Connected 2.0 API
Gets all accounts by network name. Returns a collection of accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Account> GetAccounts(
    string networkName
)
IEnumerable<Account> GetAccounts(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network.
Return Value
Type:   Online IEnumerable  Account
The account list. If no accounts are found an empty list is returned.
See Also
IAccountManager Interface
IAccountManager Members
GetAccounts Overload
Sitecore.Social.Domain Namespace


IAccountManager.GetAccounts Method (Identifier)

IAccountManager GetAccounts Method (Identifier) Sitecore Social Connected 2.0 API
Gets all accounts by network id. Returns a collection of accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Account> GetAccounts(
    Identifier networkId
)
IEnumerable<Account> GetAccounts(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online IEnumerable  Account
The account list. If no accounts are found an empty list is returned.
See Also
IAccountManager Interface
IAccountManager Members
GetAccounts Overload
Sitecore.Social.Domain Namespace


IAccountManager.GetAccountsByApplication Method

IAccountManager GetAccountsByApplication Method Sitecore Social Connected 2.0 API
Gets all accounts by application id. Returns a collection of accounts.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Account> GetAccountsByApplication(
    Identifier applicationId
)
IEnumerable<Account> GetAccountsByApplication(
    Identifier applicationId
)
Parameters
applicationId
Type: Sitecore.Social.Domain.Model Identifier
The application id.
Return Value
Type:   Online IEnumerable  Account
The account list. If no accounts are found an empty list is returned.
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetAccountsByContainer Method

IAccountManager GetAccountsByContainer Method Sitecore Social Connected 2.0 API
Gets the accounts by container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Account> GetAccountsByContainer(
    string accountContainer
)
IEnumerable<Account> GetAccountsByContainer(
    string accountContainer
)
Parameters
accountContainer
Type:   Online System String
The account container.
Return Value
Type:   Online IEnumerable  Account
The account list. If no accounts are found an empty list is returned.
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetDaysUntilRenewalRequired Method

IAccountManager GetDaysUntilRenewalRequired Method Sitecore Social Connected 2.0 API
Gets the number of days before the required renewal of an account.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<int> GetDaysUntilRenewalRequired(
    Identifier accountId
)
Nullable<int> GetDaysUntilRenewalRequired(
    Identifier accountId
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
Return Value
Type:   Online Nullable    Online Int32
The number of days. If negative then account expired, if null then account renewal disabled or not needed.
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetNetworkAccountDisplayName Method

IAccountManager GetNetworkAccountDisplayName Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, Identifier) | Gets an account display name in a social network.
Public method | GetNetworkAccountDisplayName(AccountCredentials, ApplicationCredentials, String) | Gets an account display name in a social network.
Back to Top
See Also
IAccountManager Interface
IAccountManager Members
Sitecore.Social.Domain Namespace


IAccountManager.GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, Identifier)

IAccountManager GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, Identifier) Sitecore Social Connected 2.0 API
Gets an account display name in a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    Identifier networkId
)
string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    Identifier networkId
)
Parameters
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online String
The account display name.
See Also
IAccountManager Interface
IAccountManager Members
GetNetworkAccountDisplayName Overload
Sitecore.Social.Domain Namespace


IAccountManager.GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, String)

IAccountManager GetNetworkAccountDisplayName Method (AccountCredentials, ApplicationCredentials, String) Sitecore Social Connected 2.0 API
Gets an account display name in a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    string networkName
)
string GetNetworkAccountDisplayName(
    AccountCredentials accountCredentials,
    ApplicationCredentials applicationCredentials,
    string networkName
)
Parameters
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
networkName
Type:   Online System String
Name of the network.
Return Value
Type:   Online String
The account display name.
See Also
IAccountManager Interface
IAccountManager Members
GetNetworkAccountDisplayName Overload
Sitecore.Social.Domain Namespace


IApplicationManager Interface

IApplicationManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social network applications.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IApplicationManager
public interface IApplicationManager
See Also
IApplicationManager Members
Sitecore.Social.Domain Namespace


IApplicationManager Members

IApplicationManager Members Sitecore Social Connected 2.0 API

The IApplicationManager type exposes the following members.
Methods
 | Name | Description
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.
Back to Top
See Also
IApplicationManager Interface
Sitecore.Social.Domain Namespace


IApplicationManager Methods

IApplicationManager Methods Sitecore Social Connected 2.0 API
The IApplicationManager type exposes the following members.
Methods
 | Name | Description
Public method | GetApplication | Gets an application by id.
Public method | GetApplicationContainer | Gets the application container by account container.
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.
Back to Top
See Also
IApplicationManager Interface
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplication Method

IApplicationManager GetApplication Method Sitecore Social Connected 2.0 API
Gets an application by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Application GetApplication(
    Identifier applicationId
)
Application GetApplication(
    Identifier applicationId
)
Parameters
applicationId
Type: Sitecore.Social.Domain.Model Identifier
The application id.
Return Value
Type: Application
The application. If the application is not found Empty is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplicationContainer Method

IApplicationManager GetApplicationContainer Method Sitecore Social Connected 2.0 API
Gets the application container by account container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetApplicationContainer(
    string accountContainer
)
string GetApplicationContainer(
    string accountContainer
)
Parameters
accountContainer
Type:   Online System String
The account container.
Return Value
Type:   Online String
The application container. If the application container is not found string.Empty is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplications Method

IApplicationManager GetApplications Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetApplications(String) | Gets the applications by network name.
Public method | GetApplications(Identifier) | Gets the applications by network id.
Back to Top
See Also
IApplicationManager Interface
IApplicationManager Members
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplications Method (String)

IApplicationManager GetApplications Method (String) Sitecore Social Connected 2.0 API
Gets the applications by network name.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Application> GetApplications(
    string networkName
)
IEnumerable<Application> GetApplications(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network.
Return Value
Type:   Online IEnumerable  Application
The application list. If no applications are found an empty list is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
GetApplications Overload
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplications Method (Identifier)

IApplicationManager GetApplications Method (Identifier) Sitecore Social Connected 2.0 API
Gets the applications by network id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Application> GetApplications(
    Identifier networkId
)
IEnumerable<Application> GetApplications(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
Id of the network.
Return Value
Type:   Online IEnumerable  Application
The application list. If no applications are found an empty list is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
GetApplications Overload
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplicationsByContainer Method

IApplicationManager GetApplicationsByContainer Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetApplicationsByContainer(String) | Gets the applications by container.
Public method | GetApplicationsByContainer(String, Identifier) | Gets the applications of a specific network by the container.
Public method | GetApplicationsByContainer(String, String) | Gets the applications of a specific network by the container.
Back to Top
See Also
IApplicationManager Interface
IApplicationManager Members
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplicationsByContainer Method (String)

IApplicationManager GetApplicationsByContainer Method (String) Sitecore Social Connected 2.0 API
Gets the applications by container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer
)
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer
)
Parameters
applicationContainer
Type:   Online System String
The application container.
Return Value
Type:   Online IEnumerable  Application
The application list. If no applications are found an empty list is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
GetApplicationsByContainer Overload
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplicationsByContainer Method (String, Identifier)

IApplicationManager GetApplicationsByContainer Method (String, Identifier) Sitecore Social Connected 2.0 API
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    Identifier networkId
)
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    Identifier networkId
)
Parameters
applicationContainer
Type:   Online System String
The application container.
networkId
Type: Sitecore.Social.Domain.Model Identifier
Id of the network.
Return Value
Type:   Online IEnumerable  Application
The application list. If no applications are found an empty list is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
GetApplicationsByContainer Overload
Sitecore.Social.Domain Namespace


IApplicationManager.GetApplicationsByContainer Method (String, String)

IApplicationManager GetApplicationsByContainer Method (String, String) Sitecore Social Connected 2.0 API
Gets the applications of a specific network by the container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    string networkName
)
IEnumerable<Application> GetApplicationsByContainer(
    string applicationContainer,
    string networkName
)
Parameters
applicationContainer
Type:   Online System String
The application container.
networkName
Type:   Online System String
The name of the network.
Return Value
Type:   Online IEnumerable  Application
The application list. If no applications are found an empty list is returned.
See Also
IApplicationManager Interface
IApplicationManager Members
GetApplicationsByContainer Overload
Sitecore.Social.Domain Namespace


IEmptyable Interface

IEmptyable Interface Sitecore Social Connected 2.0 API
Defines the property that is used to check if an entity is empty.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEmptyable
public interface IEmptyable
See Also
IEmptyable Members
Sitecore.Social.Domain Namespace


IEmptyable Members

IEmptyable Members Sitecore Social Connected 2.0 API

The IEmptyable type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
IEmptyable Interface
Sitecore.Social.Domain Namespace


IEmptyable Properties

IEmptyable Properties Sitecore Social Connected 2.0 API
The IEmptyable type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Back to Top
See Also
IEmptyable Interface
Sitecore.Social.Domain Namespace


IEmptyable.IsEmpty Property

IEmptyable IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsEmpty { get; }
bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

See Also
IEmptyable Interface
IEmptyable Members
Sitecore.Social.Domain Namespace


IMessageManager Interface

IMessageManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social network messages.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessageManager
public interface IMessageManager
See Also
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager Members

IMessageManager Members Sitecore Social Connected 2.0 API

The IMessageManager type exposes the following members.
Methods
 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | GetMessage | Gets the message by id.
Public method | GetMessageComments | Gets the message comments.
Public method | GetMessages(PostingConfigurationSearchArgs) | Obsolete. Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessagesByAccount | Gets messages by account.
Public method | GetMessagesByContainer | Gets messages by container.
Public method | GetMessagesByCreatedDate | Gets messages created on a specific date.
Public method | GetMessagesByWorkflowState | Gets messages by workflow state.
Public method | GetMessagesCount | Gets number of messages attached to specific container.
Public method | GetMessagesReadyToPostAutomatically | Gets messages that are ready to be posted automatically.
Public method | GetMessageStatus | Gets the message status.
Public method | GetNotPostedMessages | Gets all messages that are not posted to a social network.
Public method | GetPostedMessages | Gets all messages posted to a social network.
Public method | GetPostedMessages(DateTime) | Gets messages posted to a social network on a specific date.
Public method | PostMessage(Identifier) | Posts the message to a social network.
Public method | PostMessage(Identifier, IDictionary String, String ) | Posts the message to a social network.
Public method | PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | UpdateMessage | Updates the message.
Back to Top
See Also
IMessageManager Interface
Sitecore.Social.Domain Namespace


IMessageManager Methods

IMessageManager Methods Sitecore Social Connected 2.0 API
The IMessageManager type exposes the following members.
Methods
 | Name | Description
Public method | CreateMessage | Creates a message.
Public method | DeleteMessage | Deletes the message.
Public method | GetMessage | Gets the message by id.
Public method | GetMessageComments | Gets the message comments.
Public method | GetMessages(PostingConfigurationSearchArgs) | Obsolete. Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessagesByAccount | Gets messages by account.
Public method | GetMessagesByContainer | Gets messages by container.
Public method | GetMessagesByCreatedDate | Gets messages created on a specific date.
Public method | GetMessagesByWorkflowState | Gets messages by workflow state.
Public method | GetMessagesCount | Gets number of messages attached to specific container.
Public method | GetMessagesReadyToPostAutomatically | Gets messages that are ready to be posted automatically.
Public method | GetMessageStatus | Gets the message status.
Public method | GetNotPostedMessages | Gets all messages that are not posted to a social network.
Public method | GetPostedMessages | Gets all messages posted to a social network.
Public method | GetPostedMessages(DateTime) | Gets messages posted to a social network on a specific date.
Public method | PostMessage(Identifier) | Posts the message to a social network.
Public method | PostMessage(Identifier, IDictionary String, String ) | Posts the message to a social network.
Public method | PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | UpdateMessage | Updates the message.
Back to Top
See Also
IMessageManager Interface
Sitecore.Social.Domain Namespace


IMessageManager.CreateMessage Method

IMessageManager CreateMessage Method Sitecore Social Connected 2.0 API
Creates a message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void CreateMessage(
    Message message
)
void CreateMessage(
    Message message
)
Parameters
message
Type: Sitecore.Social.Domain.Model Message
The message to create.
Remarks
The Id field will contain identifier of the created message.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.DeleteMessage Method

IMessageManager DeleteMessage Method Sitecore Social Connected 2.0 API
Deletes the message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DeleteMessage(
    Identifier messageId
)
void DeleteMessage(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessage Method

IMessageManager GetMessage Method Sitecore Social Connected 2.0 API
Gets the message by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Message GetMessage(
    Identifier messageId
)
Message GetMessage(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: Message
The message. If message is not found Empty is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessageComments Method

IMessageManager GetMessageComments Method Sitecore Social Connected 2.0 API
Gets the message comments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<MessageComment> GetMessageComments(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    string networkMessageId
)
IEnumerable<MessageComment> GetMessageComments(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    string networkMessageId
)
Parameters
networkName
Type:   Online System String
Name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
networkMessageId
Type:   Online System String
The network message id.
Return Value
Type:   Online IEnumerable  MessageComment
The message comments list. If no comments are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessages Method

IMessageManager GetMessages Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetMessages(PostingConfigurationSearchArgs) | Obsolete. Gets all messages containing specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, Identifier) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Public method | GetMessages(PostingConfigurationSearchArgs, String) | Obsolete. Gets all messages by network ID which contain specific search arguments.
Back to Top
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessages Method (PostingConfigurationSearchArgs)

IMessageManager GetMessages Method (PostingConfigurationSearchArgs) Sitecore Social Connected 2.0 API
Gets all messages containing specific search arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IMessageManager.GetMessagesByContainer",
    false)]
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IMessageManager.GetMessagesByContainer",
    false)]
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs
)
Parameters
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search arguments.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
GetMessages Overload
Sitecore.Social.Domain Namespace


IMessageManager.GetMessages Method (PostingConfigurationSearchArgs, Identifier)

IMessageManager GetMessages Method (PostingConfigurationSearchArgs, Identifier) Sitecore Social Connected 2.0 API
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IMessageManager.GetMessagesByContainer",
    false)]
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    Identifier networkId
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IMessageManager.GetMessagesByContainer",
    false)]
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    Identifier networkId
)
Parameters
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
GetMessages Overload
Sitecore.Social.Domain Namespace


IMessageManager.GetMessages Method (PostingConfigurationSearchArgs, String)

IMessageManager GetMessages Method (PostingConfigurationSearchArgs, String) Sitecore Social Connected 2.0 API
Gets all messages by network ID which contain specific search arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IMessageManager.GetMessagesByContainer",
    false)]
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    string networkName
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IMessageManager.GetMessagesByContainer",
    false)]
IEnumerable<Message> GetMessages(
    PostingConfigurationSearchArgs searchArgs,
    string networkName
)
Parameters
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
networkName
Type:   Online System String
The name of the network.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
GetMessages Overload
Sitecore.Social.Domain Namespace


IMessageManager.GetMessagesByAccount Method

IMessageManager GetMessagesByAccount Method Sitecore Social Connected 2.0 API
Gets messages by account.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetMessagesByAccount(
    Identifier accountId
)
IEnumerable<Message> GetMessagesByAccount(
    Identifier accountId
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessagesByContainer Method

IMessageManager GetMessagesByContainer Method Sitecore Social Connected 2.0 API
Gets messages by container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetMessagesByContainer(
    string container
)
IEnumerable<Message> GetMessagesByContainer(
    string container
)
Parameters
container
Type:   Online System String
The container.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessagesByCreatedDate Method

IMessageManager GetMessagesByCreatedDate Method Sitecore Social Connected 2.0 API
Gets messages created on a specific date.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetMessagesByCreatedDate(
    DateTime createdDate
)
IEnumerable<Message> GetMessagesByCreatedDate(
    DateTime createdDate
)
Parameters
createdDate
Type:   Online System DateTime
The created date.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessagesByWorkflowState Method

IMessageManager GetMessagesByWorkflowState Method Sitecore Social Connected 2.0 API
Gets messages by workflow state.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetMessagesByWorkflowState(
    Identifier workflowStateId
)
IEnumerable<Message> GetMessagesByWorkflowState(
    Identifier workflowStateId
)
Parameters
workflowStateId
Type: Sitecore.Social.Domain.Model Identifier
The workflow state id.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessagesCount Method

IMessageManager GetMessagesCount Method Sitecore Social Connected 2.0 API
Gets number of messages attached to specific container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int GetMessagesCount(
    string container
)
int GetMessagesCount(
    string container
)
Parameters
container
Type:   Online System String
The container.
Return Value
Type:   Online Int32
The number of messages attached to the specific container.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessagesReadyToPostAutomatically Method

IMessageManager GetMessagesReadyToPostAutomatically Method Sitecore Social Connected 2.0 API
Gets messages that are ready to be posted automatically.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetMessagesReadyToPostAutomatically(
    IEnumerable<Identifier> accountIds
)
IEnumerable<Message> GetMessagesReadyToPostAutomatically(
    IEnumerable<Identifier> accountIds
)
Parameters
accountIds
Type:   Online System.Collections.Generic IEnumerable  Identifier
The account ids.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
Remarks

            This method will search messages by the following parameters:

  • Content posting configuration.
  • Content item is published.
  • "Post automatically" is checked.
  • Message is not in a workflow. Or message is in a final workflow state.
  • Message is not posted.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetMessageStatus Method

IMessageManager GetMessageStatus Method Sitecore Social Connected 2.0 API
Gets the message status.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageStatus GetMessageStatus(
    Identifier messageId
)
MessageStatus GetMessageStatus(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: MessageStatus
The MessageStatus. If the status is not defined Empty is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetNotPostedMessages Method

IMessageManager GetNotPostedMessages Method Sitecore Social Connected 2.0 API
Gets all messages that are not posted to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetNotPostedMessages()
IEnumerable<Message> GetNotPostedMessages()
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetPostedMessages Method

IMessageManager GetPostedMessages Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetPostedMessages | Gets all messages posted to a social network.
Public method | GetPostedMessages(DateTime) | Gets messages posted to a social network on a specific date.
Back to Top
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.GetPostedMessages Method

IMessageManager GetPostedMessages Method Sitecore Social Connected 2.0 API
Gets all messages posted to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetPostedMessages()
IEnumerable<Message> GetPostedMessages()
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
GetPostedMessages Overload
Sitecore.Social.Domain Namespace


IMessageManager.GetPostedMessages Method (DateTime)

IMessageManager GetPostedMessages Method (DateTime) Sitecore Social Connected 2.0 API
Gets messages posted to a social network on a specific date.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Message> GetPostedMessages(
    DateTime postedDate
)
IEnumerable<Message> GetPostedMessages(
    DateTime postedDate
)
Parameters
postedDate
Type:   Online System DateTime
The posted date.
Return Value
Type:   Online IEnumerable  Message
The messages list. If no messages are found an empty list is returned.
See Also
IMessageManager Interface
IMessageManager Members
GetPostedMessages Overload
Sitecore.Social.Domain Namespace


IMessageManager.PostMessage Method

IMessageManager PostMessage Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | PostMessage(Identifier) | Posts the message to a social network.
Public method | PostMessage(Identifier, IDictionary String, String ) | Posts the message to a social network.
Public method | PostMessage(String, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Public method | PostMessage(Identifier, ApplicationCredentials, AccountCredentials, MessageData) | Posts a message directly to a social network.
Back to Top
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageManager.PostMessage Method (Identifier)

IMessageManager PostMessage Method (Identifier) Sitecore Social Connected 2.0 API
Posts the message to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PostMessage(
    Identifier messageId
)
void PostMessage(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
See Also
IMessageManager Interface
IMessageManager Members
PostMessage Overload
Sitecore.Social.Domain Namespace


IMessageManager.PostMessage Method (Identifier, IDictionary(String, String))

IMessageManager PostMessage Method (Identifier, IDictionary String, String ) Sitecore Social Connected 2.0 API
Posts the message to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PostMessage(
    Identifier messageId,
    IDictionary<string, string> tokensToReplace
)
void PostMessage(
    Identifier messageId,
    IDictionary<string, string> tokensToReplace
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
tokensToReplace
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The tokens to be replaced with the values during posting.
See Also
IMessageManager Interface
IMessageManager Members
PostMessage Overload
Sitecore.Social.Domain Namespace


IMessageManager.PostMessage Method (String, ApplicationCredentials, AccountCredentials, MessageData)

IMessageManager PostMessage Method (String, ApplicationCredentials, AccountCredentials, MessageData) Sitecore Social Connected 2.0 API
Posts a message directly to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string PostMessage(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
string PostMessage(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
Parameters
networkName
Type:   Online System String
The network name.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
messageData
Type: Sitecore.Social.Domain.Model MessageData
The message data.
Return Value
Type:   Online String
The message id at the social network.
See Also
IMessageManager Interface
IMessageManager Members
PostMessage Overload
Sitecore.Social.Domain Namespace


IMessageManager.PostMessage Method (Identifier, ApplicationCredentials, AccountCredentials, MessageData)

IMessageManager PostMessage Method (Identifier, ApplicationCredentials, AccountCredentials, MessageData) Sitecore Social Connected 2.0 API
Posts a message directly to a social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string PostMessage(
    Identifier networkId,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
string PostMessage(
    Identifier networkId,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials,
    MessageData messageData
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
messageData
Type: Sitecore.Social.Domain.Model MessageData
The message data.
Return Value
Type:   Online String
The message id at the social network.
See Also
IMessageManager Interface
IMessageManager Members
PostMessage Overload
Sitecore.Social.Domain Namespace


IMessageManager.UpdateMessage Method

IMessageManager UpdateMessage Method Sitecore Social Connected 2.0 API
Updates the message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateMessage(
    Message message
)
void UpdateMessage(
    Message message
)
Parameters
message
Type: Sitecore.Social.Domain.Model Message
The message to update.
See Also
IMessageManager Interface
IMessageManager Members
Sitecore.Social.Domain Namespace


IMessageStatisticsManager Interface

IMessageStatisticsManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social network message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessageStatisticsManager
public interface IMessageStatisticsManager
See Also
IMessageStatisticsManager Members
Sitecore.Social.Domain Namespace


IMessageStatisticsManager Members

IMessageStatisticsManager Members Sitecore Social Connected 2.0 API

The IMessageStatisticsManager type exposes the following members.
Methods
 | Name | Description
Public method | GetMessageStatistics | Gets message statistics.
Public method | GetStatisticsCounterNames(String) | Gets the statistics counters for the specific social network.
Public method | GetStatisticsCounterNames(Identifier) | Gets the statistics counters for the specific social network.
Public method | RefreshMessageStatistics(Identifier) | Refreshes message statistics.
Public method | RefreshMessageStatistics(Identifier, Boolean) | Refreshes message statistics.
Back to Top
See Also
IMessageStatisticsManager Interface
Sitecore.Social.Domain Namespace


IMessageStatisticsManager Methods

IMessageStatisticsManager Methods Sitecore Social Connected 2.0 API
The IMessageStatisticsManager type exposes the following members.
Methods
 | Name | Description
Public method | GetMessageStatistics | Gets message statistics.
Public method | GetStatisticsCounterNames(String) | Gets the statistics counters for the specific social network.
Public method | GetStatisticsCounterNames(Identifier) | Gets the statistics counters for the specific social network.
Public method | RefreshMessageStatistics(Identifier) | Refreshes message statistics.
Public method | RefreshMessageStatistics(Identifier, Boolean) | Refreshes message statistics.
Back to Top
See Also
IMessageStatisticsManager Interface
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.GetMessageStatistics Method

IMessageStatisticsManager GetMessageStatistics Method Sitecore Social Connected 2.0 API
Gets message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageStatistics GetMessageStatistics(
    Identifier messageId
)
MessageStatistics GetMessageStatistics(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: MessageStatistics
The message statistics.
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.GetStatisticsCounterNames Method

IMessageStatisticsManager GetStatisticsCounterNames Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetStatisticsCounterNames(String) | Gets the statistics counters for the specific social network.
Public method | GetStatisticsCounterNames(Identifier) | Gets the statistics counters for the specific social network.
Back to Top
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.GetStatisticsCounterNames Method (String)

IMessageStatisticsManager GetStatisticsCounterNames Method (String) Sitecore Social Connected 2.0 API
Gets the statistics counters for the specific social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    string networkName
)
IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online IEnumerable  StatisticsCounter
The collection of statistics counters.
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
GetStatisticsCounterNames Overload
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.GetStatisticsCounterNames Method (Identifier)

IMessageStatisticsManager GetStatisticsCounterNames Method (Identifier) Sitecore Social Connected 2.0 API
Gets the statistics counters for the specific social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    Identifier networkId
)
IEnumerable<StatisticsCounter> GetStatisticsCounterNames(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online IEnumerable  StatisticsCounter
The collection of statistics counters.
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
GetStatisticsCounterNames Overload
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.RefreshMessageStatistics Method

IMessageStatisticsManager RefreshMessageStatistics Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | RefreshMessageStatistics(Identifier) | Refreshes message statistics.
Public method | RefreshMessageStatistics(Identifier, Boolean) | Refreshes message statistics.
Back to Top
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.RefreshMessageStatistics Method (Identifier)

IMessageStatisticsManager RefreshMessageStatistics Method (Identifier) Sitecore Social Connected 2.0 API
Refreshes message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RefreshMessageStatistics(
    Identifier messageId
)
void RefreshMessageStatistics(
    Identifier messageId
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
RefreshMessageStatistics Overload
Sitecore.Social.Domain Namespace


IMessageStatisticsManager.RefreshMessageStatistics Method (Identifier, Boolean)

IMessageStatisticsManager RefreshMessageStatistics Method (Identifier, Boolean) Sitecore Social Connected 2.0 API
Refreshes message statistics.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RefreshMessageStatistics(
    Identifier messageId,
    bool resetStatisticsRefreshing
)
void RefreshMessageStatistics(
    Identifier messageId,
    bool resetStatisticsRefreshing
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
resetStatisticsRefreshing
Type:   Online System Boolean
true if it needs to reset the statistics refreshing; otherwise, false.
See Also
IMessageStatisticsManager Interface
IMessageStatisticsManager Members
RefreshMessageStatistics Overload
Sitecore.Social.Domain Namespace


INetworkManager Interface

INetworkManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to manage social networks.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface INetworkManager
public interface INetworkManager
See Also
INetworkManager Members
Sitecore.Social.Domain Namespace


INetworkManager Members

INetworkManager Members Sitecore Social Connected 2.0 API

The INetworkManager type exposes the following members.
Methods
 | Name | Description
Public method | CanGetAccountInfo(String) | Determines whether it is possible to get a network account info.
Public method | CanGetAccountInfo(Identifier) | Determines whether it is possible to get a network account info.
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | CanRenewAccount(String) | Determines whether it is possible to renew a network account.
Public method | CanRenewAccount(Identifier) | Determines whether it is possible to renew a network account.
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.
Back to Top
See Also
INetworkManager Interface
Sitecore.Social.Domain Namespace


INetworkManager Methods

INetworkManager Methods Sitecore Social Connected 2.0 API
The INetworkManager type exposes the following members.
Methods
 | Name | Description
Public method | CanGetAccountInfo(String) | Determines whether it is possible to get a network account info.
Public method | CanGetAccountInfo(Identifier) | Determines whether it is possible to get a network account info.
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Public method | CanRenewAccount(String) | Determines whether it is possible to renew a network account.
Public method | CanRenewAccount(Identifier) | Determines whether it is possible to renew a network account.
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Public method | GetNetworks | Gets all registered networks.
Back to Top
See Also
INetworkManager Interface
Sitecore.Social.Domain Namespace


INetworkManager.CanGetAccountInfo Method

INetworkManager CanGetAccountInfo Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CanGetAccountInfo(String) | Determines whether it is possible to get a network account info.
Public method | CanGetAccountInfo(Identifier) | Determines whether it is possible to get a network account info.
Back to Top
See Also
INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


INetworkManager.CanGetAccountInfo Method (String)

INetworkManager CanGetAccountInfo Method (String) Sitecore Social Connected 2.0 API
Determines whether it is possible to get a network account info.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanGetAccountInfo(
    string networkName
)
bool CanGetAccountInfo(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online Boolean
true if it is possible to get the network account info; otherwise, false.

Remarks
false is returned, if the network is not found.
See Also
INetworkManager Interface
INetworkManager Members
CanGetAccountInfo Overload
Sitecore.Social.Domain Namespace


INetworkManager.CanGetAccountInfo Method (Identifier)

INetworkManager CanGetAccountInfo Method (Identifier) Sitecore Social Connected 2.0 API
Determines whether it is possible to get a network account info.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanGetAccountInfo(
    Identifier networkId
)
bool CanGetAccountInfo(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online Boolean
true if it is possible to get the network account info; otherwise, false.

Remarks
false is returned, if the network is not found.
See Also
INetworkManager Interface
INetworkManager Members
CanGetAccountInfo Overload
Sitecore.Social.Domain Namespace


INetworkManager.CanPostTo Method

INetworkManager CanPostTo Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CanPostTo(String) | Determines whether it is possible to post messages to the network.
Public method | CanPostTo(Identifier) | Determines whether it is possible to post messages to the network.
Back to Top
See Also
INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


INetworkManager.CanPostTo Method (String)

INetworkManager CanPostTo Method (String) Sitecore Social Connected 2.0 API
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanPostTo(
    string networkName
)
bool CanPostTo(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online Boolean
true if it is possible to post messages to the network; otherwise, false.

Remarks
false is returned, if the network is not found.
See Also
INetworkManager Interface
INetworkManager Members
CanPostTo Overload
Sitecore.Social.Domain Namespace


INetworkManager.CanPostTo Method (Identifier)

INetworkManager CanPostTo Method (Identifier) Sitecore Social Connected 2.0 API
Determines whether it is possible to post messages to the network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanPostTo(
    Identifier networkId
)
bool CanPostTo(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online Boolean
true if it is possible to post messages to the network; otherwise, false.

Remarks
false is returned, if the network is not found.
See Also
INetworkManager Interface
INetworkManager Members
CanPostTo Overload
Sitecore.Social.Domain Namespace


INetworkManager.CanRenewAccount Method

INetworkManager CanRenewAccount Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | CanRenewAccount(String) | Determines whether it is possible to renew a network account.
Public method | CanRenewAccount(Identifier) | Determines whether it is possible to renew a network account.
Back to Top
See Also
INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


INetworkManager.CanRenewAccount Method (String)

INetworkManager CanRenewAccount Method (String) Sitecore Social Connected 2.0 API
Determines whether it is possible to renew a network account.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanRenewAccount(
    string networkName
)
bool CanRenewAccount(
    string networkName
)
Parameters
networkName
Type:   Online System String
The network name.
Return Value
Type:   Online Boolean
true if it is possible to renew the network account; otherwise, false.

Remarks
false is returned, if the network is not found.
See Also
INetworkManager Interface
INetworkManager Members
CanRenewAccount Overload
Sitecore.Social.Domain Namespace


INetworkManager.CanRenewAccount Method (Identifier)

INetworkManager CanRenewAccount Method (Identifier) Sitecore Social Connected 2.0 API
Determines whether it is possible to renew a network account.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanRenewAccount(
    Identifier networkId
)
bool CanRenewAccount(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
Return Value
Type:   Online Boolean
true if it is possible to renew the network account; otherwise, false.

Remarks
false is returned, if the network is not found.
See Also
INetworkManager Interface
INetworkManager Members
CanRenewAccount Overload
Sitecore.Social.Domain Namespace


INetworkManager.GetNetwork Method

INetworkManager GetNetwork Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetNetwork(String) | Gets a network by name.
Public method | GetNetwork(Identifier) | Gets a network by id.
Back to Top
See Also
INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


INetworkManager.GetNetwork Method (String)

INetworkManager GetNetwork Method (String) Sitecore Social Connected 2.0 API
Gets a network by name.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Network GetNetwork(
    string networkName
)
Network GetNetwork(
    string networkName
)
Parameters
networkName
Type:   Online System String
The name of the network.
Return Value
Type: Network
The network. If the network is not found Empty is returned.
See Also
INetworkManager Interface
INetworkManager Members
GetNetwork Overload
Sitecore.Social.Domain Namespace


INetworkManager.GetNetwork Method (Identifier)

INetworkManager GetNetwork Method (Identifier) Sitecore Social Connected 2.0 API
Gets a network by id.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Network GetNetwork(
    Identifier networkId
)
Network GetNetwork(
    Identifier networkId
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
Id of the network.
Return Value
Type: Network
The network. If the network is not found Empty is returned.
See Also
INetworkManager Interface
INetworkManager Members
GetNetwork Overload
Sitecore.Social.Domain Namespace


INetworkManager.GetNetworks Method

INetworkManager GetNetworks Method Sitecore Social Connected 2.0 API
Gets all registered networks.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Network> GetNetworks()
IEnumerable<Network> GetNetworks()
Return Value
Type:   Online IEnumerable  Network
The network list. If there are no networks, an empty list is returned.
See Also
INetworkManager Interface
INetworkManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager Interface

IPostingPreferenceManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to manage user’s posting preferences.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPostingPreferenceManager
public interface IPostingPreferenceManager
See Also
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager Members

IPostingPreferenceManager Members Sitecore Social Connected 2.0 API

The IPostingPreferenceManager type exposes the following members.
Methods
 | Name | Description
Public method | AllowAutomaticPosting | Allows automatic message posting.
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
Public method | GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all messages attached to the specific container.
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
Public method | SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences for all messages attached to the specific container.
Back to Top
See Also
IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace


IPostingPreferenceManager Methods

IPostingPreferenceManager Methods Sitecore Social Connected 2.0 API
The IPostingPreferenceManager type exposes the following members.
Methods
 | Name | Description
Public method | AllowAutomaticPosting | Allows automatic message posting.
Public method | AllowAutomaticPostingByDefault | Determines if automatic posting is allowed by default.
Public method | GetPostingPreference | Gets user's posting preferences for the specific message.
Public method | GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
Public method | GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all messages attached to the specific container.
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
Public method | SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences for all messages attached to the specific container.
Back to Top
See Also
IPostingPreferenceManager Interface
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.AllowAutomaticPosting Method

IPostingPreferenceManager AllowAutomaticPosting Method Sitecore Social Connected 2.0 API
Allows automatic message posting.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool AllowAutomaticPosting(
    Identifier messageId,
    IPrincipal user
)
bool AllowAutomaticPosting(
    Identifier messageId,
    IPrincipal user
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
user
Type:   Online System.Security.Principal IPrincipal
The user.
Return Value
Type:   Online Boolean
true if automatic posting is allowed, otherwise false.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.AllowAutomaticPostingByDefault Method

IPostingPreferenceManager AllowAutomaticPostingByDefault Method Sitecore Social Connected 2.0 API
Determines if automatic posting is allowed by default.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool AllowAutomaticPostingByDefault()
bool AllowAutomaticPostingByDefault()
Return Value
Type:   Online Boolean
true if automatic posting is allowed by default, otherwise false.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.GetPostingPreference Method

IPostingPreferenceManager GetPostingPreference Method Sitecore Social Connected 2.0 API
Gets user's posting preferences for the specific message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
PostingPreference GetPostingPreference(
    IPrincipal user,
    Identifier messageId
)
PostingPreference GetPostingPreference(
    IPrincipal user,
    Identifier messageId
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
Return Value
Type: PostingPreference
The posting preference. If the posting preference is not found the Default value is used.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace
PostingPreference AutomaticPostingPreference


IPostingPreferenceManager.GetPostingPreferences Method

IPostingPreferenceManager GetPostingPreferences Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GetPostingPreferences(IPrincipal, PostingConfigurationSearchArgs) | Obsolete. Gets user's posting preferences for all messages found by arguments.
Public method | GetPostingPreferences(IPrincipal, String) | Gets user's posting preferences for all messages attached to the specific container.
Back to Top
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.GetPostingPreferences Method (IPrincipal, PostingConfigurationSearchArgs)

IPostingPreferenceManager GetPostingPreferences Method (IPrincipal, PostingConfigurationSearchArgs) Sitecore Social Connected 2.0 API
Gets user's posting preferences for all messages found by arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IPostingPreferenceManager.GetPostingPreferences(IPrincipal, string)",
    false)]
IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IPostingPreferenceManager.GetPostingPreferences(IPrincipal, string)",
    false)]
IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search arguments.
Return Value
Type:   Online IEnumerable  PostingPreference
The posting preference list. If no preferences are found an empty list is returned.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
GetPostingPreferences Overload
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.GetPostingPreferences Method (IPrincipal, String)

IPostingPreferenceManager GetPostingPreferences Method (IPrincipal, String) Sitecore Social Connected 2.0 API
Gets user's posting preferences for all messages attached to the specific container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    string container
)
IEnumerable<PostingPreference> GetPostingPreferences(
    IPrincipal user,
    string container
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
container
Type:   Online System String
The container.
Return Value
Type:   Online IEnumerable  PostingPreference

            The posting preference list. If no preferences are found an empty list is returned.

See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
GetPostingPreferences Overload
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.SetPostingPreference Method

IPostingPreferenceManager SetPostingPreference Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | SetPostingPreference(IPrincipal, Identifier, AutomaticPostingPreference) | Sets user's posting preferences to the specific message.
Public method | SetPostingPreference(IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) | Obsolete. Sets user's posting preferences to all the messages found by arguments.
Public method | SetPostingPreference(IPrincipal, String, AutomaticPostingPreference) | Sets user's posting preferences for all messages attached to the specific container.
Back to Top
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference)

IPostingPreferenceManager SetPostingPreference Method (IPrincipal, Identifier, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to the specific message.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetPostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
void SetPostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
SetPostingPreference Overload
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference)

IPostingPreferenceManager SetPostingPreference Method (IPrincipal, PostingConfigurationSearchArgs, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences to all the messages found by arguments.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IPostingPreferenceManager.GetPostingPreferences(IPrincipal, string, AutomaticPostingPreference)",
    false)]
void SetPostingPreference(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.IPostingPreferenceManager.GetPostingPreferences(IPrincipal, string, AutomaticPostingPreference)",
    false)]
void SetPostingPreference(
    IPrincipal user,
    PostingConfigurationSearchArgs searchArgs,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
searchArgs
Type: Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
The search args.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
SetPostingPreference Overload
Sitecore.Social.Domain Namespace


IPostingPreferenceManager.SetPostingPreference Method (IPrincipal, String, AutomaticPostingPreference)

IPostingPreferenceManager SetPostingPreference Method (IPrincipal, String, AutomaticPostingPreference) Sitecore Social Connected 2.0 API
Sets user's posting preferences for all messages attached to the specific container.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetPostingPreference(
    IPrincipal user,
    string container,
    AutomaticPostingPreference automaticPostingPreference
)
void SetPostingPreference(
    IPrincipal user,
    string container,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
container
Type:   Online System String
The container.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
See Also
IPostingPreferenceManager Interface
IPostingPreferenceManager Members
SetPostingPreference Overload
Sitecore.Social.Domain Namespace


ISocialProfileManager Interface

ISocialProfileManager Interface Sitecore Social Connected 2.0 API
Defines the methods that are used to manage a social profile.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISocialProfileManager
public interface ISocialProfileManager
See Also
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager Members

ISocialProfileManager Members Sitecore Social Connected 2.0 API

The ISocialProfileManager type exposes the following members.
Methods
 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | GetSocialProfile | Gets a social profile of the user in the specified network.
Public method | GetSocialProfiles | Gets all social profiles of the user.
Public method | IsSocialProfileExists | Obsolete. Defines if there is a social profile in the specified network.
Public method | RefreshSocialProfile(IPrincipal, String) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfile(IPrincipal, String, Boolean) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfiles(IPrincipal, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RefreshSocialProfiles(IPrincipal, Boolean, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | SocialProfileExists | Defines if there is a social profile in the specified network.
Public method | UpdateSocialProfile | Updates a social profile of the specified user.
Back to Top
See Also
ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


ISocialProfileManager Methods

ISocialProfileManager Methods Sitecore Social Connected 2.0 API
The ISocialProfileManager type exposes the following members.
Methods
 | Name | Description
Public method | AttachSocialProfile | Attaches a social profile to the specified user.
Public method | DetachSocialProfile | Removes a social profile from the specified user.
Public method | GetSocialProfile | Gets a social profile of the user in the specified network.
Public method | GetSocialProfiles | Gets all social profiles of the user.
Public method | IsSocialProfileExists | Obsolete. Defines if there is a social profile in the specified network.
Public method | RefreshSocialProfile(IPrincipal, String) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfile(IPrincipal, String, Boolean) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfiles(IPrincipal, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RefreshSocialProfiles(IPrincipal, Boolean, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RetrieveSocialProfile | Retrieves a social profile from the social network.
Public method | SocialProfileExists | Defines if there is a social profile in the specified network.
Public method | UpdateSocialProfile | Updates a social profile of the specified user.
Back to Top
See Also
ISocialProfileManager Interface
Sitecore.Social.Domain Namespace


ISocialProfileManager.AttachSocialProfile Method

ISocialProfileManager AttachSocialProfile Method Sitecore Social Connected 2.0 API
Attaches a social profile to the specified user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AttachSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
void AttachSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

socialProfile
Type: Sitecore.Social.Domain.Model SocialProfile

            The social profile.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.DetachSocialProfile Method

ISocialProfileManager DetachSocialProfile Method Sitecore Social Connected 2.0 API
Removes a social profile from the specified user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DetachSocialProfile(
    IPrincipal user,
    string networkName
)
void DetachSocialProfile(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.GetSocialProfile Method

ISocialProfileManager GetSocialProfile Method Sitecore Social Connected 2.0 API
Gets a social profile of the user in the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
SocialProfile GetSocialProfile(
    IPrincipal user,
    string networkName
)
SocialProfile GetSocialProfile(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type: SocialProfile

            The social profile. If there are no profiles, an empty profile is returned.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.GetSocialProfiles Method

ISocialProfileManager GetSocialProfiles Method Sitecore Social Connected 2.0 API
Gets all social profiles of the user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<SocialProfile> GetSocialProfiles(
    IPrincipal user
)
IEnumerable<SocialProfile> GetSocialProfiles(
    IPrincipal user
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

Return Value
Type:   Online IEnumerable  SocialProfile

            The social profiles list. If there are no profiles, an empty list is returned.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.IsSocialProfileExists Method

ISocialProfileManager IsSocialProfileExists Method Sitecore Social Connected 2.0 API
Defines if there is a social profile in the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.ISocialProfileManager.SocialProfileExists",
    true)]
bool IsSocialProfileExists(
    IPrincipal user,
    string networkName
)
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.ISocialProfileManager.SocialProfileExists",
    true)]
bool IsSocialProfileExists(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type:   Online Boolean
true if the social profile exists; otherwise, false.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.RefreshSocialProfile Method

ISocialProfileManager RefreshSocialProfile Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | RefreshSocialProfile(IPrincipal, String) | Refreshes the social profile attached to a user from the specified network.
Public method | RefreshSocialProfile(IPrincipal, String, Boolean) | Refreshes the social profile attached to a user from the specified network.
Back to Top
See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.RefreshSocialProfile Method (IPrincipal, String)

ISocialProfileManager RefreshSocialProfile Method (IPrincipal, String) Sitecore Social Connected 2.0 API
Refreshes the social profile attached to a user from the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RefreshSocialProfile(
    IPrincipal user,
    string networkName
)
void RefreshSocialProfile(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
networkName
Type:   Online System String
The network name.
Remarks

            The expiration configuration of the social profile will be ignored and the social profile will be refreshed in any case.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
RefreshSocialProfile Overload
Sitecore.Social.Domain Namespace


ISocialProfileManager.RefreshSocialProfile Method (IPrincipal, String, Boolean)

ISocialProfileManager RefreshSocialProfile Method (IPrincipal, String, Boolean) Sitecore Social Connected 2.0 API
Refreshes the social profile attached to a user from the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RefreshSocialProfile(
    IPrincipal user,
    string networkName,
    bool refreshAsync
)
void RefreshSocialProfile(
    IPrincipal user,
    string networkName,
    bool refreshAsync
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
networkName
Type:   Online System String
The network name.
refreshAsync
Type:   Online System Boolean
if set to true the social profile will be refreshed asynchronously.
Remarks

            The expiration configuration of the social profile will be ignored and the social profile will be refreshed in any case.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
RefreshSocialProfile Overload
Sitecore.Social.Domain Namespace


ISocialProfileManager.RefreshSocialProfiles Method

ISocialProfileManager RefreshSocialProfiles Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | RefreshSocialProfiles(IPrincipal, Boolean) | Refreshes all social profiles attached to a user from social networks.
Public method | RefreshSocialProfiles(IPrincipal, Boolean, Boolean) | Refreshes all social profiles attached to a user from social networks.
Back to Top
See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.RefreshSocialProfiles Method (IPrincipal, Boolean)

ISocialProfileManager RefreshSocialProfiles Method (IPrincipal, Boolean) Sitecore Social Connected 2.0 API
Refreshes all social profiles attached to a user from social networks.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync
)
void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
refreshAsync
Type:   Online System Boolean
if set to true the social profiles will be refreshed asynchronously.
Remarks

            Only expired social profiles will be refreshed.
            The expiration configuration is defined in "Social.ProfileUpdating.DaysUserProfileExpiration" setting.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
RefreshSocialProfiles Overload
Sitecore.Social.Domain Namespace


ISocialProfileManager.RefreshSocialProfiles Method (IPrincipal, Boolean, Boolean)

ISocialProfileManager RefreshSocialProfiles Method (IPrincipal, Boolean, Boolean) Sitecore Social Connected 2.0 API
Refreshes all social profiles attached to a user from social networks.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync,
    bool forceRefresh
)
void RefreshSocialProfiles(
    IPrincipal user,
    bool refreshAsync,
    bool forceRefresh
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
refreshAsync
Type:   Online System Boolean
if set to true the social profiles will be refreshed asynchronously.
forceRefresh
Type:   Online System Boolean
if set to true the expiration configuration of the social profile will be ignored and the social profiles will be refreshed in any case.
See Also
ISocialProfileManager Interface
ISocialProfileManager Members
RefreshSocialProfiles Overload
Sitecore.Social.Domain Namespace


ISocialProfileManager.RetrieveSocialProfile Method

ISocialProfileManager RetrieveSocialProfile Method Sitecore Social Connected 2.0 API
Retrieves a social profile from the social network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
SocialProfile RetrieveSocialProfile(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials
)
SocialProfile RetrieveSocialProfile(
    string networkName,
    ApplicationCredentials applicationCredentials,
    AccountCredentials accountCredentials
)
Parameters
networkName
Type:   Online System String
The name of the network.
applicationCredentials
Type: Sitecore.Social.Domain.Model ApplicationCredentials
The application credentials.
accountCredentials
Type: Sitecore.Social.Domain.Model AccountCredentials
The account credentials.
Return Value
Type: SocialProfile
The social profile. If the request couldn't be executed, an Empty is returned.
See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.SocialProfileExists Method

ISocialProfileManager SocialProfileExists Method Sitecore Social Connected 2.0 API
Defines if there is a social profile in the specified network.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SocialProfileExists(
    IPrincipal user,
    string networkName
)
bool SocialProfileExists(
    IPrincipal user,
    string networkName
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

networkName
Type:   Online System String

            The network name.

Return Value
Type:   Online Boolean
true if the social profile exists; otherwise, false.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


ISocialProfileManager.UpdateSocialProfile Method

ISocialProfileManager UpdateSocialProfile Method Sitecore Social Connected 2.0 API
Updates a social profile of the specified user.

Namespace: Sitecore.Social.Domain
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
void UpdateSocialProfile(
    IPrincipal user,
    SocialProfile socialProfile
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal

            The user.

socialProfile
Type: Sitecore.Social.Domain.Model SocialProfile

            The social profile.

See Also
ISocialProfileManager Interface
ISocialProfileManager Members
Sitecore.Social.Domain Namespace


Sitecore.Social.Domain.Exceptions Namespace

Sitecore.Social.Domain.Exceptions Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the domain exceptions.
Interfaces
 | Interface | Description
Public interface | ISocialException | Represents an interface of the Social exception.


ISocialException Interface

ISocialException Interface Sitecore Social Connected 2.0 API
Represents an interface of the Social exception.

Namespace: Sitecore.Social.Domain.Exceptions
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISocialException
public interface ISocialException
See Also
ISocialException Members
Sitecore.Social.Domain.Exceptions Namespace


ISocialException Members

ISocialException Members Sitecore Social Connected 2.0 API

The ISocialException type exposes the following members.
Properties
 | Name | Description
Public property | DetailedMessage | The detailed message.
Public property | SimpleMessage | The simple message.
Back to Top
See Also
ISocialException Interface
Sitecore.Social.Domain.Exceptions Namespace


ISocialException Properties

ISocialException Properties Sitecore Social Connected 2.0 API
The ISocialException type exposes the following members.
Properties
 | Name | Description
Public property | DetailedMessage | The detailed message.
Public property | SimpleMessage | The simple message.
Back to Top
See Also
ISocialException Interface
Sitecore.Social.Domain.Exceptions Namespace


ISocialException.DetailedMessage Property

ISocialException DetailedMessage Property Sitecore Social Connected 2.0 API
The detailed message.

Namespace: Sitecore.Social.Domain.Exceptions
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string DetailedMessage { get; set; }
string DetailedMessage { get; set; }
Property Value
Type:   Online String
See Also
ISocialException Interface
ISocialException Members
Sitecore.Social.Domain.Exceptions Namespace


ISocialException.SimpleMessage Property

ISocialException SimpleMessage Property Sitecore Social Connected 2.0 API
The simple message.

Namespace: Sitecore.Social.Domain.Exceptions
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string SimpleMessage { get; }
string SimpleMessage { get; }
Property Value
Type:   Online String
See Also
ISocialException Interface
ISocialException Members
Sitecore.Social.Domain.Exceptions Namespace


Sitecore.Social.Domain.Model Namespace

Sitecore.Social.Domain.Model Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the domain's model.
Classes
 | Class | Description
Public class | Account | Represents the abstract account entity.
Public class | AccountCredentials | Represents the social network account credentials.
Public class | AccountStatistics | Represents the social network statistics by account entity.
Public class | AccountStatus | Represents the message posting status to the account.
Public class | Application | Represents the social network application entity.
Public class | ApplicationCredentials | Represents the social network application credentials.
Public class | ContainerPostingConfiguration | Represents an abstract class for posting configurations with a container.
Public class | ContentPostingConfiguration | Represents content posting configuration.
Public class | DonePostingStatus | Represents the successfully posted message's account status.
Public class | EmptyIdentifier | Represents an empty non-typed identifier.
Public class | FailedPostingStatus | Represents the failed posting message's account status.
Public class | FailedStatisticsStatus | Represents a failed statistics status.
Public class | GoalPostingConfiguration | Represents a goal posting configuration.
Public class | Identifier | Represents an abstract class of identifiers.
Public class | Message | Represents a social network message.
Public class | MessageComment | Represents a social network message comment.
Public class | MessageData | Represents a social network message data.
Public class | MessageStatistics | Represents a social network message statistics.
Public class | MessageStatus | Represents social message status.
Public class | Network | Represents the social network entity.
Public class | NetworkAccount | Represents the social network account entity.
Public class | NumberCounter | Represents the statistics number counter.
Public class | PostingConfiguration | Represents an abstract class of posting configurations.
Public class | PostingPreference | Represents user's posting preference for the specific message.
Public class | PostingStatus | Represents an abstract class of message's account posting statuses.
Public class | SocialMarketerAccount | Represents the social marketer account entity.
Public class | SocialProfile | Represents a social profile.
Public class | StatisticsCounter | Represents the statistics counter.
Public class | StatisticsStatus | Represents a statistics status.
Public class | UpdatedStatisticsStatus | Represents an updated statistics status.
Enumerations
 | Enumeration | Description
Public enumeration | AutomaticPostingPreference | Defines constants for automatic posting preference.


Account Class

Account Class Sitecore Social Connected 2.0 API
Represents the abstract account entity.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Account
Sitecore.Social.Domain.Model NetworkAccount
Sitecore.Social.Domain.Model SocialMarketerAccount

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Account : IEmptyable
[SerializableAttribute]
public abstract class Account : IEmptyable
See Also
Account Members
Sitecore.Social.Domain.Model Namespace


Account Members

Account Members Sitecore Social Connected 2.0 API

The Account type exposes the following members.
Constructors
 | Name | Description
Protected method | Account | Initializes a new instance of the Account class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AccountContainer | Gets or sets the account container.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageLanguage | Gets or sets the message language.
Public property | Name | Gets or sets the name.
Public property | ReviewingRoles | Gets the reviewing roles.
Public property | ReviewingWorkflowId | Gets or sets the reviewing workflow id.
Back to Top
See Also
Account Class
Sitecore.Social.Domain.Model Namespace


Account Constructor

Account Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the Account class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Account()
protected Account()
See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account Methods

Account Methods Sitecore Social Connected 2.0 API
The Account type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
Account Class
Sitecore.Social.Domain.Model Namespace


Account Properties

Account Properties Sitecore Social Connected 2.0 API
The Account type exposes the following members.
Properties
 | Name | Description
Public property | AccountContainer | Gets or sets the account container.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageLanguage | Gets or sets the message language.
Public property | Name | Gets or sets the name.
Public property | ReviewingRoles | Gets the reviewing roles.
Public property | ReviewingWorkflowId | Gets or sets the reviewing workflow id.
Back to Top
See Also
Account Class
Sitecore.Social.Domain.Model Namespace


Account.AccountContainer Property

Account AccountContainer Property Sitecore Social Connected 2.0 API
Gets or sets the account container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountContainer { get; set; }
public string AccountContainer { get; set; }
Property Value
Type:   Online String

            The account container.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.Description Property

Account Description Property Sitecore Social Connected 2.0 API
Gets or sets the description.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
Property Value
Type:   Online String

            The description.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.Id Property

Account Id Property Sitecore Social Connected 2.0 API
Gets or sets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier Id { get; set; }
public Identifier Id { get; set; }
Property Value
Type: Identifier

            The id.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.IsEmpty Property

Account IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsEmpty { get; }
public abstract bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.MessageLanguage Property

Account MessageLanguage Property Sitecore Social Connected 2.0 API
Gets or sets the message language.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MessageLanguage { get; set; }
public string MessageLanguage { get; set; }
Property Value
Type:   Online String

            The message language.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.Name Property

Account Name Property Sitecore Social Connected 2.0 API
Gets or sets the name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String

            The name.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.ReviewingRoles Property

Account ReviewingRoles Property Sitecore Social Connected 2.0 API
Gets the reviewing roles.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<string> ReviewingRoles { get; private set; }
public ICollection<string> ReviewingRoles { get; private set; }
Property Value
Type:   Online ICollection    Online String

            The reviewing roles.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


Account.ReviewingWorkflowId Property

Account ReviewingWorkflowId Property Sitecore Social Connected 2.0 API
Gets or sets the reviewing workflow id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier ReviewingWorkflowId { get; set; }
public Identifier ReviewingWorkflowId { get; set; }
Property Value
Type: Identifier

            The reviewing workflow id.

See Also
Account Class
Account Members
Sitecore.Social.Domain.Model Namespace


AccountCredentials Class

AccountCredentials Class Sitecore Social Connected 2.0 API
Represents the social network account credentials.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model AccountCredentials

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AccountCredentials
[SerializableAttribute]
public class AccountCredentials
See Also
AccountCredentials Members
Sitecore.Social.Domain.Model Namespace
NetworkAccount AccountCredentials
SocialProfile AccountCredentials


AccountCredentials Members

AccountCredentials Members Sitecore Social Connected 2.0 API

The AccountCredentials type exposes the following members.
Constructors
 | Name | Description
Public method | AccountCredentials | Initializes a new instance of the AccountCredentials class.
Public method | AccountCredentials(String, String) | Initializes a new instance of the AccountCredentials class with the specific parameters.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AccessToken | Gets or sets the access token.
Public property | AccessTokenSecret | Gets or sets the access token secret.
Back to Top
See Also
AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials Constructor

AccountCredentials Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | AccountCredentials | Initializes a new instance of the AccountCredentials class.
Public method | AccountCredentials(String, String) | Initializes a new instance of the AccountCredentials class with the specific parameters.
Back to Top
See Also
AccountCredentials Class
AccountCredentials Members
Sitecore.Social.Domain.Model Namespace


AccountCredentials Constructor

AccountCredentials Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountCredentials class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountCredentials()
public AccountCredentials()
See Also
AccountCredentials Class
AccountCredentials Members
AccountCredentials Overload
Sitecore.Social.Domain.Model Namespace


AccountCredentials Constructor (String, String)

AccountCredentials Constructor (String, String) Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountCredentials class with the specific parameters.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountCredentials(
    string accessToken,
    string accessTokenSecret
)
public AccountCredentials(
    string accessToken,
    string accessTokenSecret
)
Parameters
accessToken
Type:   Online System String
The access token.
accessTokenSecret
Type:   Online System String
The access token secret.
See Also
AccountCredentials Class
AccountCredentials Members
AccountCredentials Overload
Sitecore.Social.Domain.Model Namespace


AccountCredentials Methods

AccountCredentials Methods Sitecore Social Connected 2.0 API
The AccountCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials Properties

AccountCredentials Properties Sitecore Social Connected 2.0 API
The AccountCredentials type exposes the following members.
Properties
 | Name | Description
Public property | AccessToken | Gets or sets the access token.
Public property | AccessTokenSecret | Gets or sets the access token secret.
Back to Top
See Also
AccountCredentials Class
Sitecore.Social.Domain.Model Namespace


AccountCredentials.AccessToken Property

AccountCredentials AccessToken Property Sitecore Social Connected 2.0 API
Gets or sets the access token.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccessToken { get; set; }
public string AccessToken { get; set; }
Property Value
Type:   Online String

            The access token.

See Also
AccountCredentials Class
AccountCredentials Members
Sitecore.Social.Domain.Model Namespace


AccountCredentials.AccessTokenSecret Property

AccountCredentials AccessTokenSecret Property Sitecore Social Connected 2.0 API
Gets or sets the access token secret.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccessTokenSecret { get; set; }
public string AccessTokenSecret { get; set; }
Property Value
Type:   Online String

            The access token secret.

See Also
AccountCredentials Class
AccountCredentials Members
Sitecore.Social.Domain.Model Namespace


AccountStatistics Class

AccountStatistics Class Sitecore Social Connected 2.0 API
Represents the social network statistics by account entity.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model AccountStatistics

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AccountStatistics : IEmptyable
[SerializableAttribute]
public class AccountStatistics : IEmptyable
See Also
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace
MessageStatistics AccountsStatistics


AccountStatistics Members

AccountStatistics Members Sitecore Social Connected 2.0 API

The AccountStatistics type exposes the following members.
Constructors
 | Name | Description
Public method | AccountStatistics | Initializes a new instance of the AccountStatistics class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the AccountStatistics class whose value represents not defined account statistics.
Back to Top
Properties
 | Name | Description
Public property | AccountId | Gets the account id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | StatisticsCounters | Gets the statistics counters.
Public property | StatisticsStatus | Gets the statistics status.
Back to Top
See Also
AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics Constructor

AccountStatistics Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountStatistics(
    Identifier accountId,
    StatisticsStatus statisticsStatus,
    IEnumerable<StatisticsCounter> statisticsCounters
)
public AccountStatistics(
    Identifier accountId,
    StatisticsStatus statisticsStatus,
    IEnumerable<StatisticsCounter> statisticsCounters
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
statisticsStatus
Type: Sitecore.Social.Domain.Model StatisticsStatus
The statistics status.
statisticsCounters
Type:   Online System.Collections.Generic IEnumerable  StatisticsCounter
The statistics counters.
See Also
AccountStatistics Class
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace


AccountStatistics Fields

AccountStatistics Fields Sitecore Social Connected 2.0 API
The AccountStatistics type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the AccountStatistics class whose value represents not defined account statistics.
Back to Top
See Also
AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics.Empty Field

AccountStatistics Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the AccountStatistics class whose value represents not defined account statistics.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly AccountStatistics Empty
public static readonly AccountStatistics Empty
Field Value
Type: AccountStatistics
See Also
AccountStatistics Class
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace


AccountStatistics Methods

AccountStatistics Methods Sitecore Social Connected 2.0 API
The AccountStatistics type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics Properties

AccountStatistics Properties Sitecore Social Connected 2.0 API
The AccountStatistics type exposes the following members.
Properties
 | Name | Description
Public property | AccountId | Gets the account id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | StatisticsCounters | Gets the statistics counters.
Public property | StatisticsStatus | Gets the statistics status.
Back to Top
See Also
AccountStatistics Class
Sitecore.Social.Domain.Model Namespace


AccountStatistics.AccountId Property

AccountStatistics AccountId Property Sitecore Social Connected 2.0 API
Gets the account id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier AccountId { get; private set; }
public Identifier AccountId { get; private set; }
Property Value
Type: Identifier

            The account id.

See Also
AccountStatistics Class
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace


AccountStatistics.IsEmpty Property

AccountStatistics IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
AccountStatistics Class
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace


AccountStatistics.StatisticsCounters Property

AccountStatistics StatisticsCounters Property Sitecore Social Connected 2.0 API
Gets the statistics counters.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<StatisticsCounter> StatisticsCounters { get; private set; }
public IEnumerable<StatisticsCounter> StatisticsCounters { get; private set; }
Property Value
Type:   Online IEnumerable  StatisticsCounter

            The statistics counters.

See Also
AccountStatistics Class
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace


AccountStatistics.StatisticsStatus Property

AccountStatistics StatisticsStatus Property Sitecore Social Connected 2.0 API
Gets the statistics status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatisticsStatus StatisticsStatus { get; private set; }
public StatisticsStatus StatisticsStatus { get; private set; }
Property Value
Type: StatisticsStatus

            The statistics status.

See Also
AccountStatistics Class
AccountStatistics Members
Sitecore.Social.Domain.Model Namespace


AccountStatus Class

AccountStatus Class Sitecore Social Connected 2.0 API
Represents the message posting status to the account.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model AccountStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AccountStatus : IEmptyable
[SerializableAttribute]
public class AccountStatus : IEmptyable
See Also
AccountStatus Members
Sitecore.Social.Domain.Model Namespace
MessageStatus AccountStatus


AccountStatus Members

AccountStatus Members Sitecore Social Connected 2.0 API

The AccountStatus type exposes the following members.
Constructors
 | Name | Description
Public method | AccountStatus | Initializes a new instance of the AccountStatus class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the AccountStatus class whose value represents not defined account status.
Back to Top
Properties
 | Name | Description
Public property | AccountId | Gets the account id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | PostingStatus | Gets the posting status.
Back to Top
See Also
AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatus Constructor

AccountStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the AccountStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountStatus(
    Identifier accountId,
    PostingStatus postingStatus
)
public AccountStatus(
    Identifier accountId,
    PostingStatus postingStatus
)
Parameters
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
postingStatus
Type: Sitecore.Social.Domain.Model PostingStatus
The posting status.
See Also
AccountStatus Class
AccountStatus Members
Sitecore.Social.Domain.Model Namespace


AccountStatus Fields

AccountStatus Fields Sitecore Social Connected 2.0 API
The AccountStatus type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the AccountStatus class whose value represents not defined account status.
Back to Top
See Also
AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatus.Empty Field

AccountStatus Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the AccountStatus class whose value represents not defined account status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly AccountStatus Empty
public static readonly AccountStatus Empty
Field Value
Type: AccountStatus
See Also
AccountStatus Class
AccountStatus Members
Sitecore.Social.Domain.Model Namespace


AccountStatus Methods

AccountStatus Methods Sitecore Social Connected 2.0 API
The AccountStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatus Properties

AccountStatus Properties Sitecore Social Connected 2.0 API
The AccountStatus type exposes the following members.
Properties
 | Name | Description
Public property | AccountId | Gets the account id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | PostingStatus | Gets the posting status.
Back to Top
See Also
AccountStatus Class
Sitecore.Social.Domain.Model Namespace


AccountStatus.AccountId Property

AccountStatus AccountId Property Sitecore Social Connected 2.0 API
Gets the account id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier AccountId { get; private set; }
public Identifier AccountId { get; private set; }
Property Value
Type: Identifier

            The account id.

See Also
AccountStatus Class
AccountStatus Members
Sitecore.Social.Domain.Model Namespace


AccountStatus.IsEmpty Property

AccountStatus IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
AccountStatus Class
AccountStatus Members
Sitecore.Social.Domain.Model Namespace


AccountStatus.PostingStatus Property

AccountStatus PostingStatus Property Sitecore Social Connected 2.0 API
Gets the posting status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingStatus PostingStatus { get; private set; }
public PostingStatus PostingStatus { get; private set; }
Property Value
Type: PostingStatus

            The posting status.

See Also
AccountStatus Class
AccountStatus Members
Sitecore.Social.Domain.Model Namespace


Application Class

Application Class Sitecore Social Connected 2.0 API
Represents the social network application entity.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Application

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Application : IEmptyable
[SerializableAttribute]
public class Application : IEmptyable
See Also
Application Members
Sitecore.Social.Domain.Model Namespace
Application ApplicationCredentials


Application Members

Application Members Sitecore Social Connected 2.0 API

The Application type exposes the following members.
Constructors
 | Name | Description
Public method | Application | Initializes a new instance of the Application class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the Application class whose value represents not found application.
Back to Top
Properties
 | Name | Description
Public property | ApplicationContainer | Gets or sets the application container.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Public property | NetworkId | Gets or sets the network id.
Back to Top
See Also
Application Class
Sitecore.Social.Domain.Model Namespace


Application Constructor

Application Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the Application class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Application()
public Application()
See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application Fields

Application Fields Sitecore Social Connected 2.0 API
The Application type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the Application class whose value represents not found application.
Back to Top
See Also
Application Class
Sitecore.Social.Domain.Model Namespace


Application.Empty Field

Application Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the Application class whose value represents not found application.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Application Empty
public static readonly Application Empty
Field Value
Type: Application
See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application Methods

Application Methods Sitecore Social Connected 2.0 API
The Application type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
Application Class
Sitecore.Social.Domain.Model Namespace


Application Properties

Application Properties Sitecore Social Connected 2.0 API
The Application type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationContainer | Gets or sets the application container.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets or sets the name.
Public property | NetworkId | Gets or sets the network id.
Back to Top
See Also
Application Class
Sitecore.Social.Domain.Model Namespace


Application.ApplicationContainer Property

Application ApplicationContainer Property Sitecore Social Connected 2.0 API
Gets or sets the application container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ApplicationContainer { get; set; }
public string ApplicationContainer { get; set; }
Property Value
Type:   Online String

            The application container.

See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application.ApplicationCredentials Property

Application ApplicationCredentials Property Sitecore Social Connected 2.0 API
Gets or sets application credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationCredentials ApplicationCredentials { get; set; }
public ApplicationCredentials ApplicationCredentials { get; set; }
Property Value
Type: ApplicationCredentials

            The application credentials.

See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application.Id Property

Application Id Property Sitecore Social Connected 2.0 API
Gets or sets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier Id { get; set; }
public Identifier Id { get; set; }
Property Value
Type: Identifier

            The id.

See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application.IsEmpty Property

Application IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application.Name Property

Application Name Property Sitecore Social Connected 2.0 API
Gets or sets the name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Property Value
Type:   Online String

            The name.

See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


Application.NetworkId Property

Application NetworkId Property Sitecore Social Connected 2.0 API
Gets or sets the network id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier NetworkId { get; set; }
public Identifier NetworkId { get; set; }
Property Value
Type: Identifier

            The network id.

See Also
Application Class
Application Members
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Class

ApplicationCredentials Class Sitecore Social Connected 2.0 API
Represents the social network application credentials.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model ApplicationCredentials

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ApplicationCredentials
[SerializableAttribute]
public class ApplicationCredentials
See Also
ApplicationCredentials Members
Sitecore.Social.Domain.Model Namespace
Application ApplicationCredentials
SocialProfile ApplicationCredentials


ApplicationCredentials Members

ApplicationCredentials Members Sitecore Social Connected 2.0 API

The ApplicationCredentials type exposes the following members.
Constructors
 | Name | Description
Public method | ApplicationCredentials | Initializes a new instance of the ApplicationCredentials class.
Public method | ApplicationCredentials(String, String) | Initializes a new instance of the ApplicationCredentials class with the specific parameters.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationKey | Gets or sets the application key.
Public property | ApplicationSecret | Gets or sets the application secret.
Back to Top
See Also
ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Constructor

ApplicationCredentials Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ApplicationCredentials | Initializes a new instance of the ApplicationCredentials class.
Public method | ApplicationCredentials(String, String) | Initializes a new instance of the ApplicationCredentials class with the specific parameters.
Back to Top
See Also
ApplicationCredentials Class
ApplicationCredentials Members
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Constructor

ApplicationCredentials Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ApplicationCredentials class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationCredentials()
public ApplicationCredentials()
See Also
ApplicationCredentials Class
ApplicationCredentials Members
ApplicationCredentials Overload
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Constructor (String, String)

ApplicationCredentials Constructor (String, String) Sitecore Social Connected 2.0 API
Initializes a new instance of the ApplicationCredentials class with the specific parameters.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationCredentials(
    string applicationKey,
    string applicationSecret
)
public ApplicationCredentials(
    string applicationKey,
    string applicationSecret
)
Parameters
applicationKey
Type:   Online System String
The application key.
applicationSecret
Type:   Online System String
The application secret.
See Also
ApplicationCredentials Class
ApplicationCredentials Members
ApplicationCredentials Overload
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Methods

ApplicationCredentials Methods Sitecore Social Connected 2.0 API
The ApplicationCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials Properties

ApplicationCredentials Properties Sitecore Social Connected 2.0 API
The ApplicationCredentials type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationKey | Gets or sets the application key.
Public property | ApplicationSecret | Gets or sets the application secret.
Back to Top
See Also
ApplicationCredentials Class
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials.ApplicationKey Property

ApplicationCredentials ApplicationKey Property Sitecore Social Connected 2.0 API
Gets or sets the application key.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ApplicationKey { get; set; }
public string ApplicationKey { get; set; }
Property Value
Type:   Online String

            The application key.

See Also
ApplicationCredentials Class
ApplicationCredentials Members
Sitecore.Social.Domain.Model Namespace


ApplicationCredentials.ApplicationSecret Property

ApplicationCredentials ApplicationSecret Property Sitecore Social Connected 2.0 API
Gets or sets the application secret.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ApplicationSecret { get; set; }
public string ApplicationSecret { get; set; }
Property Value
Type:   Online String

            The application secret.

See Also
ApplicationCredentials Class
ApplicationCredentials Members
Sitecore.Social.Domain.Model Namespace


AutomaticPostingPreference Enumeration

AutomaticPostingPreference Enumeration Sitecore Social Connected 2.0 API
Defines constants for automatic posting preference.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum AutomaticPostingPreference
[SerializableAttribute]
public enum AutomaticPostingPreference
Members
Member name | Value | Description
Default | 0 | Use default automatic posting preference.
Allowed | 1 | The automatic posting is allowed.
Denied | 2 | The automatic posting is denied.
See Also
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Class

ContainerPostingConfiguration Class Sitecore Social Connected 2.0 API
Represents an abstract class for posting configurations with a container.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingConfiguration
Sitecore.Social.Domain.Model ContainerPostingConfiguration
Sitecore.Social.Domain.Model ContentPostingConfiguration
Sitecore.Social.Domain.Model GoalPostingConfiguration

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ContainerPostingConfiguration : PostingConfiguration
[SerializableAttribute]
public abstract class ContainerPostingConfiguration : PostingConfiguration
See Also
ContainerPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Sitecore.Social.Domain.Model ContentPostingConfiguration
Sitecore.Social.Domain.Model GoalPostingConfiguration


ContainerPostingConfiguration Members

ContainerPostingConfiguration Members Sitecore Social Connected 2.0 API

The ContainerPostingConfiguration type exposes the following members.
Constructors
 | Name | Description
Protected method | ContainerPostingConfiguration(String) | Initializes a new instance of the ContainerPostingConfiguration class.
Protected method | ContainerPostingConfiguration(String, Boolean) | Initializes a new instance of the ContainerPostingConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Container | Gets the container.
Public property | ContainerPublished | Gets or sets a value indicating whether the container is published.
Back to Top
See Also
ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Constructor

ContainerPostingConfiguration Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Protected method | ContainerPostingConfiguration(String) | Initializes a new instance of the ContainerPostingConfiguration class.
Protected method | ContainerPostingConfiguration(String, Boolean) | Initializes a new instance of the ContainerPostingConfiguration class.
Back to Top
See Also
ContainerPostingConfiguration Class
ContainerPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Constructor (String)

ContainerPostingConfiguration Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the ContainerPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ContainerPostingConfiguration(
    string container
)
protected ContainerPostingConfiguration(
    string container
)
Parameters
container
Type:   Online System String
The container.
See Also
ContainerPostingConfiguration Class
ContainerPostingConfiguration Members
ContainerPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Constructor (String, Boolean)

ContainerPostingConfiguration Constructor (String, Boolean) Sitecore Social Connected 2.0 API
Initializes a new instance of the ContainerPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ContainerPostingConfiguration(
    string container,
    bool containerPublished
)
protected ContainerPostingConfiguration(
    string container,
    bool containerPublished
)
Parameters
container
Type:   Online System String
The container.
containerPublished
Type:   Online System Boolean
true if the container is published; otherwise, false.
See Also
ContainerPostingConfiguration Class
ContainerPostingConfiguration Members
ContainerPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Methods

ContainerPostingConfiguration Methods Sitecore Social Connected 2.0 API
The ContainerPostingConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration Properties

ContainerPostingConfiguration Properties Sitecore Social Connected 2.0 API
The ContainerPostingConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | Container | Gets the container.
Public property | ContainerPublished | Gets or sets a value indicating whether the container is published.
Back to Top
See Also
ContainerPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration.Container Property

ContainerPostingConfiguration Container Property Sitecore Social Connected 2.0 API
Gets the container.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Container { get; private set; }
public string Container { get; private set; }
Property Value
Type:   Online String

            The container.

See Also
ContainerPostingConfiguration Class
ContainerPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContainerPostingConfiguration.ContainerPublished Property

ContainerPostingConfiguration ContainerPublished Property Sitecore Social Connected 2.0 API
Gets or sets a value indicating whether the container is published.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainerPublished { get; set; }
public bool ContainerPublished { get; set; }
Property Value
Type:   Online Boolean
true if the container is published; otherwise, false.

See Also
ContainerPostingConfiguration Class
ContainerPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Class

ContentPostingConfiguration Class Sitecore Social Connected 2.0 API
Represents content posting configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingConfiguration
Sitecore.Social.Domain.Model ContainerPostingConfiguration
Sitecore.Social.Domain.Model ContentPostingConfiguration

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ContentPostingConfiguration : ContainerPostingConfiguration
[SerializableAttribute]
public class ContentPostingConfiguration : ContainerPostingConfiguration
See Also
ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Message PostingConfiguration


ContentPostingConfiguration Members

ContentPostingConfiguration Members Sitecore Social Connected 2.0 API

The ContentPostingConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | ContentPostingConfiguration(String, Identifier) | Initializes a new instance of the ContentPostingConfiguration class.
Public method | ContentPostingConfiguration(String, Identifier, Boolean) | Initializes a new instance of the ContentPostingConfiguration class.
Public method | ContentPostingConfiguration(String, Identifier, Boolean, Boolean) | Initializes a new instance of the ContentPostingConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AccountId | Gets the identifier of the account assigned to the message.
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)
Public property | ContainerPublished | Gets or sets a value indicating whether the container is published. (Inherited from ContainerPostingConfiguration.)
Public property | PostAutomatically | Gets a value indicating whether the related message should be posted automatically to the social network after the content is published to the website.
Public property | PostOnContentPublishing | Obsolete. Gets a value indicating whether the related message should be posted to the social network when the content is published to the website.
Back to Top
See Also
ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor

ContentPostingConfiguration Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ContentPostingConfiguration(String, Identifier) | Initializes a new instance of the ContentPostingConfiguration class.
Public method | ContentPostingConfiguration(String, Identifier, Boolean) | Initializes a new instance of the ContentPostingConfiguration class.
Public method | ContentPostingConfiguration(String, Identifier, Boolean, Boolean) | Initializes a new instance of the ContentPostingConfiguration class.
Back to Top
See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor (String, Identifier)

ContentPostingConfiguration Constructor (String, Identifier) Sitecore Social Connected 2.0 API
Initializes a new instance of the ContentPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentPostingConfiguration(
    string contentContainer,
    Identifier accountId
)
public ContentPostingConfiguration(
    string contentContainer,
    Identifier accountId
)
Parameters
contentContainer
Type:   Online System String
The content container.
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
ContentPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor (String, Identifier, Boolean)

ContentPostingConfiguration Constructor (String, Identifier, Boolean) Sitecore Social Connected 2.0 API
Initializes a new instance of the ContentPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentPostingConfiguration(
    string contentContainer,
    Identifier accountId,
    bool postOnContentPublishing
)
public ContentPostingConfiguration(
    string contentContainer,
    Identifier accountId,
    bool postOnContentPublishing
)
Parameters
contentContainer
Type:   Online System String
The content container.
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
postOnContentPublishing
Type:   Online System Boolean
If checked, the related message will be posted to the social network when the content is published to the website.
See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
ContentPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Constructor (String, Identifier, Boolean, Boolean)

ContentPostingConfiguration Constructor (String, Identifier, Boolean, Boolean) Sitecore Social Connected 2.0 API
Initializes a new instance of the ContentPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentPostingConfiguration(
    string contentContainer,
    Identifier accountId,
    bool postAutomatically,
    bool contentContainerPublished
)
public ContentPostingConfiguration(
    string contentContainer,
    Identifier accountId,
    bool postAutomatically,
    bool contentContainerPublished
)
Parameters
contentContainer
Type:   Online System String
The content container.
accountId
Type: Sitecore.Social.Domain.Model Identifier
The account id.
postAutomatically
Type:   Online System Boolean
If checked, the related message will be posted automatically to the social network after the content is published to the website.
contentContainerPublished
Type:   Online System Boolean
true if the content container is published; otherwise, false.
See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
ContentPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Methods

ContentPostingConfiguration Methods Sitecore Social Connected 2.0 API
The ContentPostingConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration Properties

ContentPostingConfiguration Properties Sitecore Social Connected 2.0 API
The ContentPostingConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | AccountId | Gets the identifier of the account assigned to the message.
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)
Public property | ContainerPublished | Gets or sets a value indicating whether the container is published. (Inherited from ContainerPostingConfiguration.)
Public property | PostAutomatically | Gets a value indicating whether the related message should be posted automatically to the social network after the content is published to the website.
Public property | PostOnContentPublishing | Obsolete. Gets a value indicating whether the related message should be posted to the social network when the content is published to the website.
Back to Top
See Also
ContentPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration.AccountId Property

ContentPostingConfiguration AccountId Property Sitecore Social Connected 2.0 API
Gets the identifier of the account assigned to the message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier AccountId { get; private set; }
public Identifier AccountId { get; private set; }
Property Value
Type: Identifier

            The account identifier.

See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration.PostAutomatically Property

ContentPostingConfiguration PostAutomatically Property Sitecore Social Connected 2.0 API
Gets a value indicating whether the related message should be posted automatically to the social network after the content is published to the website.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool PostAutomatically { get; private set; }
public bool PostAutomatically { get; private set; }
Property Value
Type:   Online Boolean

            If true, the related message will be posted automatically to the social network after the content is published to the website. Otherwise, false.

See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


ContentPostingConfiguration.PostOnContentPublishing Property

ContentPostingConfiguration PostOnContentPublishing Property Sitecore Social Connected 2.0 API
Gets a value indicating whether the related message should be posted to the social network when the content is published to the website.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.Model.ContentPostingConfiguration.PostAutomatically")]
public bool PostOnContentPublishing { get; private set; }
[ObsoleteAttribute("The recommended alternative is Sitecore.Social.Domain.Model.ContentPostingConfiguration.PostAutomatically")]
public bool PostOnContentPublishing { get; private set; }
Property Value
Type:   Online Boolean

            If true, the related message will be posted to the social network when the content is published to the website. Otherwise, false.

See Also
ContentPostingConfiguration Class
ContentPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Class

DonePostingStatus Class Sitecore Social Connected 2.0 API
Represents the successfully posted message's account status.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingStatus
Sitecore.Social.Domain.Model DonePostingStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DonePostingStatus : PostingStatus
[SerializableAttribute]
public class DonePostingStatus : PostingStatus
See Also
DonePostingStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatus PostingStatus


DonePostingStatus Members

DonePostingStatus Members Sitecore Social Connected 2.0 API

The DonePostingStatus type exposes the following members.
Constructors
 | Name | Description
Public method | DonePostingStatus | Initializes a new instance of the DonePostingStatus class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | NetworkMessageId | Gets the id of the message in the social network.
Back to Top
See Also
DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Constructor

DonePostingStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the DonePostingStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DonePostingStatus(
    string networkMessageId
)
public DonePostingStatus(
    string networkMessageId
)
Parameters
networkMessageId
Type:   Online System String
The id of the message in the social network.
See Also
DonePostingStatus Class
DonePostingStatus Members
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Methods

DonePostingStatus Methods Sitecore Social Connected 2.0 API
The DonePostingStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


DonePostingStatus Properties

DonePostingStatus Properties Sitecore Social Connected 2.0 API
The DonePostingStatus type exposes the following members.
Properties
 | Name | Description
Public property | NetworkMessageId | Gets the id of the message in the social network.
Back to Top
See Also
DonePostingStatus Class
Sitecore.Social.Domain.Model Namespace


DonePostingStatus.NetworkMessageId Property

DonePostingStatus NetworkMessageId Property Sitecore Social Connected 2.0 API
Gets the id of the message in the social network.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetworkMessageId { get; private set; }
public string NetworkMessageId { get; private set; }
Property Value
Type:   Online String

            The network message id.

See Also
DonePostingStatus Class
DonePostingStatus Members
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier Class

EmptyIdentifier Class Sitecore Social Connected 2.0 API
Represents an empty non-typed identifier.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Identifier
Sitecore.Social.Domain.Model EmptyIdentifier

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class EmptyIdentifier : Identifier
[SerializableAttribute]
public class EmptyIdentifier : Identifier
See Also
EmptyIdentifier Members
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier Members

EmptyIdentifier Members Sitecore Social Connected 2.0 API

The EmptyIdentifier type exposes the following members.
Constructors
 | Name | Description
Public method | EmptyIdentifier | Initializes a new instance of the EmptyIdentifier class.
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Inherited from Identifier.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Inherited from Identifier.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Identifier IsEmpty.)
Public property | OriginalType | Gets the original type. (Overrides Identifier OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)
Back to Top
See Also
EmptyIdentifier Class
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier Constructor

EmptyIdentifier Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the EmptyIdentifier class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EmptyIdentifier()
public EmptyIdentifier()
Remarks
  • The StringValue field will be initialized with   Online Empty.
See Also
EmptyIdentifier Class
EmptyIdentifier Members
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier Methods

EmptyIdentifier Methods Sitecore Social Connected 2.0 API
The EmptyIdentifier type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Inherited from Identifier.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Inherited from Identifier.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
See Also
EmptyIdentifier Class
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier Properties

EmptyIdentifier Properties Sitecore Social Connected 2.0 API
The EmptyIdentifier type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Identifier IsEmpty.)
Public property | OriginalType | Gets the original type. (Overrides Identifier OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)
Back to Top
See Also
EmptyIdentifier Class
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier.IsEmpty Property

EmptyIdentifier IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true.

Implements
IEmptyable IsEmpty
See Also
EmptyIdentifier Class
EmptyIdentifier Members
Sitecore.Social.Domain.Model Namespace


EmptyIdentifier.OriginalType Property

EmptyIdentifier OriginalType Property Sitecore Social Connected 2.0 API
Gets the original type.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type OriginalType { get; }
public override Type OriginalType { get; }
Property Value
Type:   Online Type

            The EmptyIdentifier.

See Also
EmptyIdentifier Class
EmptyIdentifier Members
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Class

FailedPostingStatus Class Sitecore Social Connected 2.0 API
Represents the failed posting message's account status.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingStatus
Sitecore.Social.Domain.Model FailedPostingStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FailedPostingStatus : PostingStatus
[SerializableAttribute]
public class FailedPostingStatus : PostingStatus
See Also
FailedPostingStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatus PostingStatus


FailedPostingStatus Members

FailedPostingStatus Members Sitecore Social Connected 2.0 API

The FailedPostingStatus type exposes the following members.
Constructors
 | Name | Description
Public method | FailedPostingStatus | Initializes a new instance of the FailedPostingStatus class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ErrorText | Gets the error text.
Back to Top
See Also
FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Constructor

FailedPostingStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the FailedPostingStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FailedPostingStatus(
    string errorText
)
public FailedPostingStatus(
    string errorText
)
Parameters
errorText
Type:   Online System String
The error text.
See Also
FailedPostingStatus Class
FailedPostingStatus Members
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Methods

FailedPostingStatus Methods Sitecore Social Connected 2.0 API
The FailedPostingStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus Properties

FailedPostingStatus Properties Sitecore Social Connected 2.0 API
The FailedPostingStatus type exposes the following members.
Properties
 | Name | Description
Public property | ErrorText | Gets the error text.
Back to Top
See Also
FailedPostingStatus Class
Sitecore.Social.Domain.Model Namespace


FailedPostingStatus.ErrorText Property

FailedPostingStatus ErrorText Property Sitecore Social Connected 2.0 API
Gets the error text.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ErrorText { get; private set; }
public string ErrorText { get; private set; }
Property Value
Type:   Online String

            The error text.

See Also
FailedPostingStatus Class
FailedPostingStatus Members
Sitecore.Social.Domain.Model Namespace


FailedStatisticsStatus Class

FailedStatisticsStatus Class Sitecore Social Connected 2.0 API
Represents a failed statistics status.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsStatus
Sitecore.Social.Domain.Model FailedStatisticsStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FailedStatisticsStatus : StatisticsStatus
[SerializableAttribute]
public class FailedStatisticsStatus : StatisticsStatus
See Also
FailedStatisticsStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics StatisticsStatus


FailedStatisticsStatus Members

FailedStatisticsStatus Members Sitecore Social Connected 2.0 API

The FailedStatisticsStatus type exposes the following members.
Constructors
 | Name | Description
Public method | FailedStatisticsStatus | Initializes a new instance of the FailedStatisticsStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
FailedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


FailedStatisticsStatus Constructor

FailedStatisticsStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the FailedStatisticsStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FailedStatisticsStatus()
public FailedStatisticsStatus()
See Also
FailedStatisticsStatus Class
FailedStatisticsStatus Members
Sitecore.Social.Domain.Model Namespace


FailedStatisticsStatus Methods

FailedStatisticsStatus Methods Sitecore Social Connected 2.0 API
The FailedStatisticsStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
FailedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Class

GoalPostingConfiguration Class Sitecore Social Connected 2.0 API
Represents a goal posting configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingConfiguration
Sitecore.Social.Domain.Model ContainerPostingConfiguration
Sitecore.Social.Domain.Model GoalPostingConfiguration

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GoalPostingConfiguration : ContainerPostingConfiguration
[SerializableAttribute]
public class GoalPostingConfiguration : ContainerPostingConfiguration
See Also
GoalPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Message PostingConfiguration


GoalPostingConfiguration Members

GoalPostingConfiguration Members Sitecore Social Connected 2.0 API

The GoalPostingConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | GoalPostingConfiguration(String) | Initializes a new instance of the GoalPostingConfiguration class.
Public method | GoalPostingConfiguration(String, Boolean) | Initializes a new instance of the GoalPostingConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)
Public property | ContainerPublished | Gets or sets a value indicating whether the container is published. (Inherited from ContainerPostingConfiguration.)
Back to Top
See Also
GoalPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Constructor

GoalPostingConfiguration Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | GoalPostingConfiguration(String) | Initializes a new instance of the GoalPostingConfiguration class.
Public method | GoalPostingConfiguration(String, Boolean) | Initializes a new instance of the GoalPostingConfiguration class.
Back to Top
See Also
GoalPostingConfiguration Class
GoalPostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Constructor (String)

GoalPostingConfiguration Constructor (String) Sitecore Social Connected 2.0 API
Initializes a new instance of the GoalPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoalPostingConfiguration(
    string goalContainer
)
public GoalPostingConfiguration(
    string goalContainer
)
Parameters
goalContainer
Type:   Online System String
The goal container.
See Also
GoalPostingConfiguration Class
GoalPostingConfiguration Members
GoalPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Constructor (String, Boolean)

GoalPostingConfiguration Constructor (String, Boolean) Sitecore Social Connected 2.0 API
Initializes a new instance of the GoalPostingConfiguration class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoalPostingConfiguration(
    string goalContainer,
    bool goalContainerPublished
)
public GoalPostingConfiguration(
    string goalContainer,
    bool goalContainerPublished
)
Parameters
goalContainer
Type:   Online System String
The goal container.
goalContainerPublished
Type:   Online System Boolean
true if the goal container is published; otherwise, false.
See Also
GoalPostingConfiguration Class
GoalPostingConfiguration Members
GoalPostingConfiguration Overload
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Methods

GoalPostingConfiguration Methods Sitecore Social Connected 2.0 API
The GoalPostingConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GoalPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


GoalPostingConfiguration Properties

GoalPostingConfiguration Properties Sitecore Social Connected 2.0 API
The GoalPostingConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfiguration.)
Public property | ContainerPublished | Gets or sets a value indicating whether the container is published. (Inherited from ContainerPostingConfiguration.)
Back to Top
See Also
GoalPostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


Identifier Class

Identifier Class Sitecore Social Connected 2.0 API
Represents an abstract class of identifiers.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Identifier
Sitecore.Social.Domain.Model EmptyIdentifier
Sitecore.Social.Infrastructure.Identifiers GuidIdentifier
Sitecore.Social.Infrastructure.Identifiers IDIdentifier

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Identifier : IEquatable<Identifier>,
    IEmptyable
[SerializableAttribute]
public abstract class Identifier : IEquatable<Identifier>,
    IEmptyable
See Also
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier Members

Identifier Members Sitecore Social Connected 2.0 API

The Identifier type exposes the following members.
Constructors
 | Name | Description
Protected method | Identifier | Initializes a new instance of the Identifier class.
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
Operators
Name | Description
Equality | Compares two identifiers.
Inequality | Compares two identifiers.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | OriginalType | Gets the original type.
Public property | StringValue | Gets the string value.
Back to Top
See Also
Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier Constructor

Identifier Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the Identifier class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Identifier(
    string value
)
protected Identifier(
    string value
)
Parameters
value
Type:   Online System String
The string value.
See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier Methods

Identifier Methods Sitecore Social Connected 2.0 API
The Identifier type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
See Also
Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier.Equals Method

Identifier Equals Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one.
Back to Top
See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier.Equals Method (Object)

Identifier Equals Method (Object) Sitecore Social Connected 2.0 API
Determines whether the specified Online Object is equal to this instance.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Parameters
obj
Type:   Online System Object
The   Online Object to compare with this instance.
Return Value
Type:   Online Boolean
true if the specified   Online Object is equal to this instance; otherwise, false.

Exceptions
Exception | Condition
Online System InvalidCastException | The 'obj' argument is not an Identifier object.
See Also
Identifier Class
Identifier Members
Equals Overload
Sitecore.Social.Domain.Model Namespace


Identifier.Equals Method (Identifier)

Identifier Equals Method (Identifier) Sitecore Social Connected 2.0 API
Checks if the current identifier is equal to another one.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Equals(
    Identifier other
)
public virtual bool Equals(
    Identifier other
)
Parameters
other
Type: Sitecore.Social.Domain.Model Identifier
The other identifier.
Return Value
Type:   Online Boolean
true if the current identifier is equal to another one, otherwise false.
Implements
  Online IEquatable T  Equals(T)
See Also
Identifier Class
Identifier Members
Equals Overload
Sitecore.Social.Domain.Model Namespace


Identifier.GetHashCode Method

Identifier GetHashCode Method Sitecore Social Connected 2.0 API
Returns a hash code for this instance.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Return Value
Type:   Online Int32

            A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier.ToString Method

Identifier ToString Method Sitecore Social Connected 2.0 API
Returns a Online String that represents this instance.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Return Value
Type:   Online String

            A   Online String that represents this instance.

See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier Operators

Identifier Operators Sitecore Social Connected 2.0 API
The Identifier type exposes the following members.
Operators
Name | Description
Equality | Compares two identifiers.
Inequality | Compares two identifiers.
Back to Top
See Also
Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier.Equality Operator

Identifier Equality Operator Sitecore Social Connected 2.0 API
Compares two identifiers.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    Identifier id1,
    Identifier id2
)
public static bool operator ==(
    Identifier id1,
    Identifier id2
)
Parameters
id1
Type: Sitecore.Social.Domain.Model Identifier
The id1.
id2
Type: Sitecore.Social.Domain.Model Identifier
The id2.
Return Value
Type:   Online Boolean
true if id1 is equal to id2, otherwise false.
See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier.Inequality Operator

Identifier Inequality Operator Sitecore Social Connected 2.0 API
Compares two identifiers.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    Identifier id1,
    Identifier id2
)
public static bool operator !=(
    Identifier id1,
    Identifier id2
)
Parameters
id1
Type: Sitecore.Social.Domain.Model Identifier
The id1.
id2
Type: Sitecore.Social.Domain.Model Identifier
The id2.
Return Value
Type:   Online Boolean
true if id1 is not equal to id2, otherwise false.
See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier Properties

Identifier Properties Sitecore Social Connected 2.0 API
The Identifier type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | OriginalType | Gets the original type.
Public property | StringValue | Gets the string value.
Back to Top
See Also
Identifier Class
Sitecore.Social.Domain.Model Namespace


Identifier.IsEmpty Property

Identifier IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsEmpty { get; }
public abstract bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier.OriginalType Property

Identifier OriginalType Property Sitecore Social Connected 2.0 API
Gets the original type.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Type OriginalType { get; }
public abstract Type OriginalType { get; }
Property Value
Type:   Online Type

            The original type.

See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Identifier.StringValue Property

Identifier StringValue Property Sitecore Social Connected 2.0 API
Gets the string value.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StringValue { get; private set; }
public string StringValue { get; private set; }
Property Value
Type:   Online String

            The string value.

See Also
Identifier Class
Identifier Members
Sitecore.Social.Domain.Model Namespace


Message Class

Message Class Sitecore Social Connected 2.0 API
Represents a social network message.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Message

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Message : IEmptyable
[SerializableAttribute]
public class Message : IEmptyable
See Also
Message Members
Sitecore.Social.Domain.Model Namespace


Message Members

Message Members Sitecore Social Connected 2.0 API

The Message type exposes the following members.
Constructors
 | Name | Description
Public method | Message | Initializes a new instance of the Message class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the Message class whose value represents not found message.
Back to Top
Properties
 | Name | Description
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageData | Gets the message data.
Public property | NetworkId | Gets the network id.
Public property | PostingConfiguration | Gets the posting configuration.
Back to Top
See Also
Message Class
Sitecore.Social.Domain.Model Namespace


Message Constructor

Message Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the Message class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    Identifier networkId,
    MessageData messageData,
    PostingConfiguration postingConfiguration
)
public Message(
    Identifier networkId,
    MessageData messageData,
    PostingConfiguration postingConfiguration
)
Parameters
networkId
Type: Sitecore.Social.Domain.Model Identifier
The network id.
messageData
Type: Sitecore.Social.Domain.Model MessageData
The message data.
postingConfiguration
Type: Sitecore.Social.Domain.Model PostingConfiguration
The posting configuration.
See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


Message Fields

Message Fields Sitecore Social Connected 2.0 API
The Message type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the Message class whose value represents not found message.
Back to Top
See Also
Message Class
Sitecore.Social.Domain.Model Namespace


Message.Empty Field

Message Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the Message class whose value represents not found message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Message Empty
public static readonly Message Empty
Field Value
Type: Message
See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


Message Methods

Message Methods Sitecore Social Connected 2.0 API
The Message type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
Message Class
Sitecore.Social.Domain.Model Namespace


Message Properties

Message Properties Sitecore Social Connected 2.0 API
The Message type exposes the following members.
Properties
 | Name | Description
Public property | Id | Gets or sets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageData | Gets the message data.
Public property | NetworkId | Gets the network id.
Public property | PostingConfiguration | Gets the posting configuration.
Back to Top
See Also
Message Class
Sitecore.Social.Domain.Model Namespace


Message.Id Property

Message Id Property Sitecore Social Connected 2.0 API
Gets or sets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier Id { get; set; }
public Identifier Id { get; set; }
Property Value
Type: Identifier

            The id.

See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


Message.IsEmpty Property

Message IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


Message.MessageData Property

Message MessageData Property Sitecore Social Connected 2.0 API
Gets the message data.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageData MessageData { get; private set; }
public MessageData MessageData { get; private set; }
Property Value
Type: MessageData

            The message data.

See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


Message.NetworkId Property

Message NetworkId Property Sitecore Social Connected 2.0 API
Gets the network id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier NetworkId { get; private set; }
public Identifier NetworkId { get; private set; }
Property Value
Type: Identifier

            The network id.

See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


Message.PostingConfiguration Property

Message PostingConfiguration Property Sitecore Social Connected 2.0 API
Gets the posting configuration.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingConfiguration PostingConfiguration { get; private set; }
public PostingConfiguration PostingConfiguration { get; private set; }
Property Value
Type: PostingConfiguration

            The posting configuration.

See Also
Message Class
Message Members
Sitecore.Social.Domain.Model Namespace


MessageComment Class

MessageComment Class Sitecore Social Connected 2.0 API
Represents a social network message comment.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageComment

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageComment : IEmptyable
[SerializableAttribute]
public class MessageComment : IEmptyable
See Also
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment Members

MessageComment Members Sitecore Social Connected 2.0 API

The MessageComment type exposes the following members.
Constructors
 | Name | Description
Public method | MessageComment | Initializes a new instance of the MessageComment class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessageComment class whose value represents not found message.
Back to Top
Properties
 | Name | Description
Public property | AuthorName | Gets or sets the name of the author.
Public property | CreatedDate | Gets or sets the comment created date.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | NetworkCommentId | Gets or sets the social network comment id.
Public property | Text | Gets or sets the message text.
Back to Top
See Also
MessageComment Class
Sitecore.Social.Domain.Model Namespace


MessageComment Constructor

MessageComment Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageComment class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageComment()
public MessageComment()
See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment Fields

MessageComment Fields Sitecore Social Connected 2.0 API
The MessageComment type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessageComment class whose value represents not found message.
Back to Top
See Also
MessageComment Class
Sitecore.Social.Domain.Model Namespace


MessageComment.Empty Field

MessageComment Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessageComment class whose value represents not found message.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessageComment Empty
public static readonly MessageComment Empty
Field Value
Type: MessageComment
See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment Methods

MessageComment Methods Sitecore Social Connected 2.0 API
The MessageComment type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageComment Class
Sitecore.Social.Domain.Model Namespace


MessageComment Properties

MessageComment Properties Sitecore Social Connected 2.0 API
The MessageComment type exposes the following members.
Properties
 | Name | Description
Public property | AuthorName | Gets or sets the name of the author.
Public property | CreatedDate | Gets or sets the comment created date.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | NetworkCommentId | Gets or sets the social network comment id.
Public property | Text | Gets or sets the message text.
Back to Top
See Also
MessageComment Class
Sitecore.Social.Domain.Model Namespace


MessageComment.AuthorName Property

MessageComment AuthorName Property Sitecore Social Connected 2.0 API
Gets or sets the name of the author.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AuthorName { get; set; }
public string AuthorName { get; set; }
Property Value
Type:   Online String

            The name of the author.

See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment.CreatedDate Property

MessageComment CreatedDate Property Sitecore Social Connected 2.0 API
Gets or sets the comment created date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime CreatedDate { get; set; }
public DateTime CreatedDate { get; set; }
Property Value
Type:   Online DateTime

            The message created date.

See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment.IsEmpty Property

MessageComment IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment.NetworkCommentId Property

MessageComment NetworkCommentId Property Sitecore Social Connected 2.0 API
Gets or sets the social network comment id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetworkCommentId { get; set; }
public string NetworkCommentId { get; set; }
Property Value
Type:   Online String

            The social network comment id.

See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageComment.Text Property

MessageComment Text Property Sitecore Social Connected 2.0 API
Gets or sets the message text.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; set; }
public string Text { get; set; }
Property Value
Type:   Online String

            The text.

See Also
MessageComment Class
MessageComment Members
Sitecore.Social.Domain.Model Namespace


MessageData Class

MessageData Class Sitecore Social Connected 2.0 API
Represents a social network message data.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageData
Sitecore.Social.Facebook.Api.Model FacebookMessageData
Sitecore.Social.SocialMarketer.Api.Model SocialMarketerMessageData
Sitecore.Social.Twitter.Api.Model TwitterMessageData

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageData
[SerializableAttribute]
public class MessageData
See Also
MessageData Members
Sitecore.Social.Domain.Model Namespace
Message MessageData


MessageData Members

MessageData Members Sitecore Social Connected 2.0 API

The MessageData type exposes the following members.
Constructors
 | Name | Description
Public method | MessageData | Initializes a new instance of the MessageData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id.
Public property | CreatedDate | Gets or sets the Created date.
Public property | DisplayName | Gets or sets the display name.
Public property | Link | Gets or sets the link.
Public property | PostedDate | Gets or sets the Posted date.
Public property | Text | Gets or sets the text.
Back to Top
See Also
MessageData Class
Sitecore.Social.Domain.Model Namespace


MessageData Constructor

MessageData Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageData class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageData()
public MessageData()
See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageData Methods

MessageData Methods Sitecore Social Connected 2.0 API
The MessageData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageData Class
Sitecore.Social.Domain.Model Namespace


MessageData Properties

MessageData Properties Sitecore Social Connected 2.0 API
The MessageData type exposes the following members.
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id.
Public property | CreatedDate | Gets or sets the Created date.
Public property | DisplayName | Gets or sets the display name.
Public property | Link | Gets or sets the link.
Public property | PostedDate | Gets or sets the Posted date.
Public property | Text | Gets or sets the text.
Back to Top
See Also
MessageData Class
Sitecore.Social.Domain.Model Namespace


MessageData.CampaignId Property

MessageData CampaignId Property Sitecore Social Connected 2.0 API
Gets or sets the campaign id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier CampaignId { get; set; }
public Identifier CampaignId { get; set; }
Property Value
Type: Identifier

            The campaign id.

See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageData.CreatedDate Property

MessageData CreatedDate Property Sitecore Social Connected 2.0 API
Gets or sets the Created date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CreatedDate { get; set; }
public Nullable<DateTime> CreatedDate { get; set; }
Property Value
Type:   Online Nullable    Online DateTime

            The Created date.

See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageData.DisplayName Property

MessageData DisplayName Property Sitecore Social Connected 2.0 API
Gets or sets the display name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DisplayName { get; set; }
public string DisplayName { get; set; }
Property Value
Type:   Online String

            The name.

See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageData.Link Property

MessageData Link Property Sitecore Social Connected 2.0 API
Gets or sets the link.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Link { get; set; }
public string Link { get; set; }
Property Value
Type:   Online String

            The link.

See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageData.PostedDate Property

MessageData PostedDate Property Sitecore Social Connected 2.0 API
Gets or sets the Posted date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> PostedDate { get; set; }
public Nullable<DateTime> PostedDate { get; set; }
Property Value
Type:   Online Nullable    Online DateTime

            The Posted date.

See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageData.Text Property

MessageData Text Property Sitecore Social Connected 2.0 API
Gets or sets the text.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; set; }
public string Text { get; set; }
Property Value
Type:   Online String

            The text.

See Also
MessageData Class
MessageData Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics Class

MessageStatistics Class Sitecore Social Connected 2.0 API
Represents a social network message statistics.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageStatistics

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageStatistics : IEmptyable
[SerializableAttribute]
public class MessageStatistics : IEmptyable
See Also
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics Members

MessageStatistics Members Sitecore Social Connected 2.0 API

The MessageStatistics type exposes the following members.
Constructors
 | Name | Description
Public method | MessageStatistics(Identifier, AccountStatistics) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, AccountStatistics, Nullable DateTime ) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, AccountStatistics, Nullable DateTime , Nullable DateTime ) | Initializes a new instance of the MessageStatistics class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessageStatistics class whose value represents not found message statistics.
Back to Top
Properties
 | Name | Description
Public property | AccountsStatistics | Gets the account statistics.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | LastRefreshDate | Gets the statistics last refresh date.
Public property | MessageId | Gets the message id.
Public property | StartRefreshDate | Gets the start refresh date.
Back to Top
See Also
MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor

MessageStatistics Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | MessageStatistics(Identifier, AccountStatistics) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, AccountStatistics, Nullable DateTime ) | Initializes a new instance of the MessageStatistics class.
Public method | MessageStatistics(Identifier, AccountStatistics, Nullable DateTime , Nullable DateTime ) | Initializes a new instance of the MessageStatistics class.
Back to Top
See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor (Identifier, AccountStatistics)

MessageStatistics Constructor (Identifier, AccountStatistics) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatistics(
    Identifier messageId,
    AccountStatistics accountStatistics
)
public MessageStatistics(
    Identifier messageId,
    AccountStatistics accountStatistics
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
accountStatistics
Type: Sitecore.Social.Domain.Model AccountStatistics
The account statistics.
See Also
MessageStatistics Class
MessageStatistics Members
MessageStatistics Overload
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor (Identifier, AccountStatistics, Nullable(DateTime))

MessageStatistics Constructor (Identifier, AccountStatistics, Nullable DateTime ) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatistics(
    Identifier messageId,
    AccountStatistics accountStatistics,
    Nullable<DateTime> startRefreshDate
)
public MessageStatistics(
    Identifier messageId,
    AccountStatistics accountStatistics,
    Nullable<DateTime> startRefreshDate
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
accountStatistics
Type: Sitecore.Social.Domain.Model AccountStatistics
The account statistics.
startRefreshDate
Type:   Online System Nullable    Online DateTime
The start refresh date.
See Also
MessageStatistics Class
MessageStatistics Members
MessageStatistics Overload
Sitecore.Social.Domain.Model Namespace


MessageStatistics Constructor (Identifier, AccountStatistics, Nullable(DateTime), Nullable(DateTime))

MessageStatistics Constructor (Identifier, AccountStatistics, Nullable DateTime , Nullable DateTime ) Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatistics class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatistics(
    Identifier messageId,
    AccountStatistics accountStatistics,
    Nullable<DateTime> startRefreshDate,
    Nullable<DateTime> lastRefreshDate
)
public MessageStatistics(
    Identifier messageId,
    AccountStatistics accountStatistics,
    Nullable<DateTime> startRefreshDate,
    Nullable<DateTime> lastRefreshDate
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
accountStatistics
Type: Sitecore.Social.Domain.Model AccountStatistics
The account statistics.
startRefreshDate
Type:   Online System Nullable    Online DateTime
The start refresh date.
lastRefreshDate
Type:   Online System Nullable    Online DateTime
The last refresh date.
See Also
MessageStatistics Class
MessageStatistics Members
MessageStatistics Overload
Sitecore.Social.Domain.Model Namespace


MessageStatistics Fields

MessageStatistics Fields Sitecore Social Connected 2.0 API
The MessageStatistics type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessageStatistics class whose value represents not found message statistics.
Back to Top
See Also
MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics.Empty Field

MessageStatistics Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessageStatistics class whose value represents not found message statistics.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessageStatistics Empty
public static readonly MessageStatistics Empty
Field Value
Type: MessageStatistics
See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics Methods

MessageStatistics Methods Sitecore Social Connected 2.0 API
The MessageStatistics type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics Properties

MessageStatistics Properties Sitecore Social Connected 2.0 API
The MessageStatistics type exposes the following members.
Properties
 | Name | Description
Public property | AccountsStatistics | Gets the account statistics.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | LastRefreshDate | Gets the statistics last refresh date.
Public property | MessageId | Gets the message id.
Public property | StartRefreshDate | Gets the start refresh date.
Back to Top
See Also
MessageStatistics Class
Sitecore.Social.Domain.Model Namespace


MessageStatistics.AccountsStatistics Property

MessageStatistics AccountsStatistics Property Sitecore Social Connected 2.0 API
Gets the account statistics.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountStatistics AccountsStatistics { get; private set; }
public AccountStatistics AccountsStatistics { get; private set; }
Property Value
Type: AccountStatistics

            The account statistics.

See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics.IsEmpty Property

MessageStatistics IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics.LastRefreshDate Property

MessageStatistics LastRefreshDate Property Sitecore Social Connected 2.0 API
Gets the statistics last refresh date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> LastRefreshDate { get; private set; }
public Nullable<DateTime> LastRefreshDate { get; private set; }
Property Value
Type:   Online Nullable    Online DateTime

            The last refresh date.

See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics.MessageId Property

MessageStatistics MessageId Property Sitecore Social Connected 2.0 API
Gets the message id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier MessageId { get; private set; }
public Identifier MessageId { get; private set; }
Property Value
Type: Identifier

            The message id.

See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatistics.StartRefreshDate Property

MessageStatistics StartRefreshDate Property Sitecore Social Connected 2.0 API
Gets the start refresh date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> StartRefreshDate { get; private set; }
public Nullable<DateTime> StartRefreshDate { get; private set; }
Property Value
Type:   Online Nullable    Online DateTime

            The start refresh date.

See Also
MessageStatistics Class
MessageStatistics Members
Sitecore.Social.Domain.Model Namespace


MessageStatus Class

MessageStatus Class Sitecore Social Connected 2.0 API
Represents social message status.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageStatus : IEmptyable
[SerializableAttribute]
public class MessageStatus : IEmptyable
See Also
MessageStatus Members
Sitecore.Social.Domain.Model Namespace


MessageStatus Members

MessageStatus Members Sitecore Social Connected 2.0 API

The MessageStatus type exposes the following members.
Constructors
 | Name | Description
Public method | MessageStatus | Initializes a new instance of the MessageStatus class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the MessageStatus class whose value represents not found message status.
Back to Top
Properties
 | Name | Description
Public property | AccountStatus | Gets the account status.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageId | Gets the message id.
Back to Top
See Also
MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus Constructor

MessageStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the MessageStatus class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageStatus(
    Identifier messageId,
    AccountStatus accountStatus
)
public MessageStatus(
    Identifier messageId,
    AccountStatus accountStatus
)
Parameters
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
accountStatus
Type: Sitecore.Social.Domain.Model AccountStatus
The account status.
See Also
MessageStatus Class
MessageStatus Members
Sitecore.Social.Domain.Model Namespace


MessageStatus Fields

MessageStatus Fields Sitecore Social Connected 2.0 API
The MessageStatus type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the MessageStatus class whose value represents not found message status.
Back to Top
See Also
MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus.Empty Field

MessageStatus Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the MessageStatus class whose value represents not found message status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly MessageStatus Empty
public static readonly MessageStatus Empty
Field Value
Type: MessageStatus
See Also
MessageStatus Class
MessageStatus Members
Sitecore.Social.Domain.Model Namespace


MessageStatus Methods

MessageStatus Methods Sitecore Social Connected 2.0 API
The MessageStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus Properties

MessageStatus Properties Sitecore Social Connected 2.0 API
The MessageStatus type exposes the following members.
Properties
 | Name | Description
Public property | AccountStatus | Gets the account status.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | MessageId | Gets the message id.
Back to Top
See Also
MessageStatus Class
Sitecore.Social.Domain.Model Namespace


MessageStatus.AccountStatus Property

MessageStatus AccountStatus Property Sitecore Social Connected 2.0 API
Gets the account status.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountStatus AccountStatus { get; private set; }
public AccountStatus AccountStatus { get; private set; }
Property Value
Type: AccountStatus

            The account status.

See Also
MessageStatus Class
MessageStatus Members
Sitecore.Social.Domain.Model Namespace


MessageStatus.IsEmpty Property

MessageStatus IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
MessageStatus Class
MessageStatus Members
Sitecore.Social.Domain.Model Namespace


MessageStatus.MessageId Property

MessageStatus MessageId Property Sitecore Social Connected 2.0 API
Gets the message id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier MessageId { get; private set; }
public Identifier MessageId { get; private set; }
Property Value
Type: Identifier

            The message id.

See Also
MessageStatus Class
MessageStatus Members
Sitecore.Social.Domain.Model Namespace


Network Class

Network Class Sitecore Social Connected 2.0 API
Represents the social network entity.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Network

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Network : IEmptyable
[SerializableAttribute]
public class Network : IEmptyable
See Also
Network Members
Sitecore.Social.Domain.Model Namespace


Network Members

Network Members Sitecore Social Connected 2.0 API

The Network type exposes the following members.
Constructors
 | Name | Description
Public method | Network(Identifier, String, String) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String, Nullable Int32 ) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String, Nullable Int32 , String) | Initializes a new instance of the Network class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the Network class whose value represents not found network.
Back to Top
Properties
 | Name | Description
Public property | AccountExpirationDays | Gets the number of days that the account expires in.
Public property | DisplayName | Gets the display name.
Public property | Icon | Gets the icon.
Public property | Id | Gets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets the unique name of the network.
Public property | Order | Gets or sets the order.
Public property | Prefix | Gets the prefix.
Public property | Url | Gets the URL.
Back to Top
See Also
Network Class
Sitecore.Social.Domain.Model Namespace


Network Constructor

Network Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | Network(Identifier, String, String) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String, Nullable Int32 ) | Initializes a new instance of the Network class.
Public method | Network(Identifier, String, String, Uri, String, Nullable Int32 , String) | Initializes a new instance of the Network class.
Back to Top
See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String)

Network Constructor (Identifier, String, String) Sitecore Social Connected 2.0 API
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network(
    Identifier id,
    string name,
    string prefix
)
public Network(
    Identifier id,
    string name,
    string prefix
)
Parameters
id
Type: Sitecore.Social.Domain.Model Identifier
The id.
name
Type:   Online System String
The name.
prefix
Type:   Online System String
The prefix.
See Also
Network Class
Network Members
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String, Uri)

Network Constructor (Identifier, String, String, Uri) Sitecore Social Connected 2.0 API
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url
)
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url
)
Parameters
id
Type: Sitecore.Social.Domain.Model Identifier
The id.
name
Type:   Online System String
The name.
prefix
Type:   Online System String
The prefix.
url
Type:   Online System Uri
The URL.
See Also
Network Class
Network Members
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String, Uri, String)

Network Constructor (Identifier, String, String, Uri, String) Sitecore Social Connected 2.0 API
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon
)
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon
)
Parameters
id
Type: Sitecore.Social.Domain.Model Identifier
The id.
name
Type:   Online System String
The name.
prefix
Type:   Online System String
The prefix.
url
Type:   Online System Uri
The URL.
icon
Type:   Online System String
The icon.
See Also
Network Class
Network Members
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String, Uri, String, Nullable(Int32))

Network Constructor (Identifier, String, String, Uri, String, Nullable Int32 ) Sitecore Social Connected 2.0 API
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon,
    Nullable<int> accountExpirationDays
)
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon,
    Nullable<int> accountExpirationDays
)
Parameters
id
Type: Sitecore.Social.Domain.Model Identifier
The id.
name
Type:   Online System String
The name.
prefix
Type:   Online System String
The prefix.
url
Type:   Online System Uri
The URL.
icon
Type:   Online System String
The icon.
accountExpirationDays
Type:   Online System Nullable    Online Int32
The account expiration days.
See Also
Network Class
Network Members
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Constructor (Identifier, String, String, Uri, String, Nullable(Int32), String)

Network Constructor (Identifier, String, String, Uri, String, Nullable Int32 , String) Sitecore Social Connected 2.0 API
Initializes a new instance of the Network class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon,
    Nullable<int> accountExpirationDays,
    string displayName
)
public Network(
    Identifier id,
    string name,
    string prefix,
    Uri url,
    string icon,
    Nullable<int> accountExpirationDays,
    string displayName
)
Parameters
id
Type: Sitecore.Social.Domain.Model Identifier
The id.
name
Type:   Online System String
The name.
prefix
Type:   Online System String
The prefix.
url
Type:   Online System Uri
The URL.
icon
Type:   Online System String
The icon.
accountExpirationDays
Type:   Online System Nullable    Online Int32
The account expiration days.
displayName
Type:   Online System String
The display name.
See Also
Network Class
Network Members
Network Overload
Sitecore.Social.Domain.Model Namespace


Network Fields

Network Fields Sitecore Social Connected 2.0 API
The Network type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the Network class whose value represents not found network.
Back to Top
See Also
Network Class
Sitecore.Social.Domain.Model Namespace


Network.Empty Field

Network Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the Network class whose value represents not found network.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Network Empty
public static readonly Network Empty
Field Value
Type: Network
See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network Methods

Network Methods Sitecore Social Connected 2.0 API
The Network type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
Network Class
Sitecore.Social.Domain.Model Namespace


Network Properties

Network Properties Sitecore Social Connected 2.0 API
The Network type exposes the following members.
Properties
 | Name | Description
Public property | AccountExpirationDays | Gets the number of days that the account expires in.
Public property | DisplayName | Gets the display name.
Public property | Icon | Gets the icon.
Public property | Id | Gets the id.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | Name | Gets the unique name of the network.
Public property | Order | Gets or sets the order.
Public property | Prefix | Gets the prefix.
Public property | Url | Gets the URL.
Back to Top
See Also
Network Class
Sitecore.Social.Domain.Model Namespace


Network.AccountExpirationDays Property

Network AccountExpirationDays Property Sitecore Social Connected 2.0 API
Gets the number of days that the account expires in.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> AccountExpirationDays { get; private set; }
public Nullable<int> AccountExpirationDays { get; private set; }
Property Value
Type:   Online Nullable    Online Int32

            The number of days that the account expired in.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.DisplayName Property

Network DisplayName Property Sitecore Social Connected 2.0 API
Gets the display name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DisplayName { get; private set; }
public string DisplayName { get; private set; }
Property Value
Type:   Online String

            The display name.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.Icon Property

Network Icon Property Sitecore Social Connected 2.0 API
Gets the icon.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Icon { get; private set; }
public string Icon { get; private set; }
Property Value
Type:   Online String

            The icon.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.Id Property

Network Id Property Sitecore Social Connected 2.0 API
Gets the id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier Id { get; private set; }
public Identifier Id { get; private set; }
Property Value
Type: Identifier

            The id.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.IsEmpty Property

Network IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.Name Property

Network Name Property Sitecore Social Connected 2.0 API
Gets the unique name of the network.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; private set; }
public string Name { get; private set; }
Property Value
Type:   Online String

            The network name.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.Order Property

Network Order Property Sitecore Social Connected 2.0 API
Gets or sets the order.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; set; }
public int Order { get; set; }
Property Value
Type:   Online Int32
See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.Prefix Property

Network Prefix Property Sitecore Social Connected 2.0 API
Gets the prefix.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Prefix { get; private set; }
public string Prefix { get; private set; }
Property Value
Type:   Online String

            The prefix.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


Network.Url Property

Network Url Property Sitecore Social Connected 2.0 API
Gets the URL.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri Url { get; private set; }
public Uri Url { get; private set; }
Property Value
Type:   Online Uri

            The URL.

See Also
Network Class
Network Members
Sitecore.Social.Domain.Model Namespace


NetworkAccount Class

NetworkAccount Class Sitecore Social Connected 2.0 API
Represents the social network account entity.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Account
Sitecore.Social.Domain.Model NetworkAccount

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetworkAccount : Account
[SerializableAttribute]
public class NetworkAccount : Account
See Also
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace
NetworkAccount AccountCredentials


NetworkAccount Members

NetworkAccount Members Sitecore Social Connected 2.0 API

The NetworkAccount type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkAccount | Initializes a new instance of the NetworkAccount class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the NetworkAccount class whose value represents not found network account.
Back to Top
Properties
 | Name | Description
Public property | AccountContainer | Gets or sets the account container. (Inherited from Account.)
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationId | Gets or sets the application id.
Public property | Description | Gets or sets the description. (Inherited from Account.)
Public property | Id | Gets or sets the id. (Inherited from Account.)
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Account IsEmpty.)
Public property | LastRenewalDate | Gets or sets the last renewal date.
Public property | MessageLanguage | Gets or sets the message language. (Inherited from Account.)
Public property | Name | Gets or sets the name. (Inherited from Account.)
Public property | ReviewingRoles | Gets the reviewing roles. (Inherited from Account.)
Public property | ReviewingWorkflowId | Gets or sets the reviewing workflow id. (Inherited from Account.)
Back to Top
See Also
NetworkAccount Class
Sitecore.Social.Domain.Model Namespace


NetworkAccount Constructor

NetworkAccount Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NetworkAccount class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkAccount()
public NetworkAccount()
See Also
NetworkAccount Class
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace


NetworkAccount Fields

NetworkAccount Fields Sitecore Social Connected 2.0 API
The NetworkAccount type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the NetworkAccount class whose value represents not found network account.
Back to Top
See Also
NetworkAccount Class
Sitecore.Social.Domain.Model Namespace


NetworkAccount.Empty Field

NetworkAccount Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the NetworkAccount class whose value represents not found network account.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NetworkAccount Empty
public static readonly NetworkAccount Empty
Field Value
Type: NetworkAccount
See Also
NetworkAccount Class
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace


NetworkAccount Methods

NetworkAccount Methods Sitecore Social Connected 2.0 API
The NetworkAccount type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NetworkAccount Class
Sitecore.Social.Domain.Model Namespace


NetworkAccount Properties

NetworkAccount Properties Sitecore Social Connected 2.0 API
The NetworkAccount type exposes the following members.
Properties
 | Name | Description
Public property | AccountContainer | Gets or sets the account container. (Inherited from Account.)
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationId | Gets or sets the application id.
Public property | Description | Gets or sets the description. (Inherited from Account.)
Public property | Id | Gets or sets the id. (Inherited from Account.)
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Account IsEmpty.)
Public property | LastRenewalDate | Gets or sets the last renewal date.
Public property | MessageLanguage | Gets or sets the message language. (Inherited from Account.)
Public property | Name | Gets or sets the name. (Inherited from Account.)
Public property | ReviewingRoles | Gets the reviewing roles. (Inherited from Account.)
Public property | ReviewingWorkflowId | Gets or sets the reviewing workflow id. (Inherited from Account.)
Back to Top
See Also
NetworkAccount Class
Sitecore.Social.Domain.Model Namespace


NetworkAccount.AccountCredentials Property

NetworkAccount AccountCredentials Property Sitecore Social Connected 2.0 API
Gets or sets account credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountCredentials AccountCredentials { get; set; }
public AccountCredentials AccountCredentials { get; set; }
Property Value
Type: AccountCredentials

            The account credentials.

See Also
NetworkAccount Class
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace


NetworkAccount.ApplicationId Property

NetworkAccount ApplicationId Property Sitecore Social Connected 2.0 API
Gets or sets the application id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier ApplicationId { get; set; }
public Identifier ApplicationId { get; set; }
Property Value
Type: Identifier

            The application id.

See Also
NetworkAccount Class
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace


NetworkAccount.IsEmpty Property

NetworkAccount IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
NetworkAccount Class
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace


NetworkAccount.LastRenewalDate Property

NetworkAccount LastRenewalDate Property Sitecore Social Connected 2.0 API
Gets or sets the last renewal date.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> LastRenewalDate { get; set; }
public Nullable<DateTime> LastRenewalDate { get; set; }
Property Value
Type:   Online Nullable    Online DateTime

            The last renewal date.

See Also
NetworkAccount Class
NetworkAccount Members
Sitecore.Social.Domain.Model Namespace


NumberCounter Class

NumberCounter Class Sitecore Social Connected 2.0 API
Represents the statistics number counter.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsCounter
Sitecore.Social.Domain.Model NumberCounter
Sitecore.Social.Facebook.Api.Model CommentsCounter
Sitecore.Social.Facebook.Api.Model LikesCounter
Sitecore.Social.Twitter.Api.Model TweetsCounter

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NumberCounter : StatisticsCounter
[SerializableAttribute]
public class NumberCounter : StatisticsCounter
See Also
NumberCounter Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics StatisticsCounters


NumberCounter Members

NumberCounter Members Sitecore Social Connected 2.0 API

The NumberCounter type exposes the following members.
Constructors
 | Name | Description
Public method | NumberCounter | Initializes a new instance of the NumberCounter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value.
Back to Top
See Also
NumberCounter Class
Sitecore.Social.Domain.Model Namespace


NumberCounter Constructor

NumberCounter Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the NumberCounter class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumberCounter(
    string name,
    string displayName,
    int number
)
public NumberCounter(
    string name,
    string displayName,
    int number
)
Parameters
name
Type:   Online System String
The statistics name.
displayName
Type:   Online System String
The display name.
number
Type:   Online System Int32
The number.
See Also
NumberCounter Class
NumberCounter Members
Sitecore.Social.Domain.Model Namespace


NumberCounter Methods

NumberCounter Methods Sitecore Social Connected 2.0 API
The NumberCounter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
NumberCounter Class
Sitecore.Social.Domain.Model Namespace


NumberCounter Properties

NumberCounter Properties Sitecore Social Connected 2.0 API
The NumberCounter type exposes the following members.
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value.
Back to Top
See Also
NumberCounter Class
Sitecore.Social.Domain.Model Namespace


NumberCounter.Number Property

NumberCounter Number Property Sitecore Social Connected 2.0 API
Gets the statistics numerical value.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Number { get; private set; }
public int Number { get; private set; }
Property Value
Type:   Online Int32

            The number.

See Also
NumberCounter Class
NumberCounter Members
Sitecore.Social.Domain.Model Namespace


PostingConfiguration Class

PostingConfiguration Class Sitecore Social Connected 2.0 API
Represents an abstract class of posting configurations.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingConfiguration
Sitecore.Social.Domain.Model ContainerPostingConfiguration

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class PostingConfiguration
[SerializableAttribute]
public abstract class PostingConfiguration
See Also
PostingConfiguration Members
Sitecore.Social.Domain.Model Namespace
Message PostingConfiguration


PostingConfiguration Members

PostingConfiguration Members Sitecore Social Connected 2.0 API

The PostingConfiguration type exposes the following members.
Constructors
 | Name | Description
Protected method | PostingConfiguration | Initializes a new instance of the PostingConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


PostingConfiguration Constructor

PostingConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfiguration class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostingConfiguration()
protected PostingConfiguration()
See Also
PostingConfiguration Class
PostingConfiguration Members
Sitecore.Social.Domain.Model Namespace


PostingConfiguration Methods

PostingConfiguration Methods Sitecore Social Connected 2.0 API
The PostingConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfiguration Class
Sitecore.Social.Domain.Model Namespace


PostingPreference Class

PostingPreference Class Sitecore Social Connected 2.0 API
Represents user's posting preference for the specific message.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingPreference

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PostingPreference
[SerializableAttribute]
public class PostingPreference
See Also
PostingPreference Members
Sitecore.Social.Domain.Model Namespace
PostingPreference AutomaticPostingPreference


PostingPreference Members

PostingPreference Members Sitecore Social Connected 2.0 API

The PostingPreference type exposes the following members.
Constructors
 | Name | Description
Public method | PostingPreference | Initializes a new instance of the PostingPreference class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AutomaticPostingPreference | Gets the automatic posting preference.
Public property | MessageId | Gets the message id.
Public property | User | Gets the user.
Back to Top
See Also
PostingPreference Class
Sitecore.Social.Domain.Model Namespace


PostingPreference Constructor

PostingPreference Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingPreference class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
public PostingPreference(
    IPrincipal user,
    Identifier messageId,
    AutomaticPostingPreference automaticPostingPreference
)
Parameters
user
Type:   Online System.Security.Principal IPrincipal
The user.
messageId
Type: Sitecore.Social.Domain.Model Identifier
The message id.
automaticPostingPreference
Type: Sitecore.Social.Domain.Model AutomaticPostingPreference
The automatic posting preference.
See Also
PostingPreference Class
PostingPreference Members
Sitecore.Social.Domain.Model Namespace


PostingPreference Methods

PostingPreference Methods Sitecore Social Connected 2.0 API
The PostingPreference type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingPreference Class
Sitecore.Social.Domain.Model Namespace


PostingPreference Properties

PostingPreference Properties Sitecore Social Connected 2.0 API
The PostingPreference type exposes the following members.
Properties
 | Name | Description
Public property | AutomaticPostingPreference | Gets the automatic posting preference.
Public property | MessageId | Gets the message id.
Public property | User | Gets the user.
Back to Top
See Also
PostingPreference Class
Sitecore.Social.Domain.Model Namespace


PostingPreference.AutomaticPostingPreference Property

PostingPreference AutomaticPostingPreference Property Sitecore Social Connected 2.0 API
Gets the automatic posting preference.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AutomaticPostingPreference AutomaticPostingPreference { get; private set; }
public AutomaticPostingPreference AutomaticPostingPreference { get; private set; }
Property Value
Type: AutomaticPostingPreference

            The automatic posting preference.

See Also
PostingPreference Class
PostingPreference Members
Sitecore.Social.Domain.Model Namespace


PostingPreference.MessageId Property

PostingPreference MessageId Property Sitecore Social Connected 2.0 API
Gets the message id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Identifier MessageId { get; private set; }
public Identifier MessageId { get; private set; }
Property Value
Type: Identifier

            The message id.

See Also
PostingPreference Class
PostingPreference Members
Sitecore.Social.Domain.Model Namespace


PostingPreference.User Property

PostingPreference User Property Sitecore Social Connected 2.0 API
Gets the user.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPrincipal User { get; private set; }
public IPrincipal User { get; private set; }
Property Value
Type:   Online IPrincipal

            The user.

See Also
PostingPreference Class
PostingPreference Members
Sitecore.Social.Domain.Model Namespace


PostingStatus Class

PostingStatus Class Sitecore Social Connected 2.0 API
Represents an abstract class of message's account posting statuses.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model PostingStatus
Sitecore.Social.Domain.Model DonePostingStatus
Sitecore.Social.Domain.Model FailedPostingStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class PostingStatus
[SerializableAttribute]
public abstract class PostingStatus
See Also
PostingStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatus PostingStatus


PostingStatus Members

PostingStatus Members Sitecore Social Connected 2.0 API

The PostingStatus type exposes the following members.
Constructors
 | Name | Description
Protected method | PostingStatus | Initializes a new instance of the PostingStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingStatus Class
Sitecore.Social.Domain.Model Namespace


PostingStatus Constructor

PostingStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostingStatus()
protected PostingStatus()
See Also
PostingStatus Class
PostingStatus Members
Sitecore.Social.Domain.Model Namespace


PostingStatus Methods

PostingStatus Methods Sitecore Social Connected 2.0 API
The PostingStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingStatus Class
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount Class

SocialMarketerAccount Class Sitecore Social Connected 2.0 API
Represents the social marketer account entity.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Account
Sitecore.Social.Domain.Model SocialMarketerAccount

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SocialMarketerAccount : Account
[SerializableAttribute]
public class SocialMarketerAccount : Account
See Also
SocialMarketerAccount Members
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount Members

SocialMarketerAccount Members Sitecore Social Connected 2.0 API

The SocialMarketerAccount type exposes the following members.
Constructors
 | Name | Description
Public method | SocialMarketerAccount | Initializes a new instance of the SocialMarketerAccount class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the SocialMarketerAccount class whose value represents not found social marketer account.
Back to Top
Properties
 | Name | Description
Public property | AccountContainer | Gets or sets the account container. (Inherited from Account.)
Public property | Description | Gets or sets the description. (Inherited from Account.)
Public property | Id | Gets or sets the id. (Inherited from Account.)
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Account IsEmpty.)
Public property | MessageLanguage | Gets or sets the message language. (Inherited from Account.)
Public property | Name | Gets or sets the name. (Inherited from Account.)
Public property | ReviewingRoles | Gets the reviewing roles. (Inherited from Account.)
Public property | ReviewingWorkflowId | Gets or sets the reviewing workflow id. (Inherited from Account.)
Back to Top
See Also
SocialMarketerAccount Class
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount Constructor

SocialMarketerAccount Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialMarketerAccount class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialMarketerAccount()
public SocialMarketerAccount()
See Also
SocialMarketerAccount Class
SocialMarketerAccount Members
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount Fields

SocialMarketerAccount Fields Sitecore Social Connected 2.0 API
The SocialMarketerAccount type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the SocialMarketerAccount class whose value represents not found social marketer account.
Back to Top
See Also
SocialMarketerAccount Class
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount.Empty Field

SocialMarketerAccount Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the SocialMarketerAccount class whose value represents not found social marketer account.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SocialMarketerAccount Empty
public static readonly SocialMarketerAccount Empty
Field Value
Type: SocialMarketerAccount
See Also
SocialMarketerAccount Class
SocialMarketerAccount Members
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount Methods

SocialMarketerAccount Methods Sitecore Social Connected 2.0 API
The SocialMarketerAccount type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SocialMarketerAccount Class
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount Properties

SocialMarketerAccount Properties Sitecore Social Connected 2.0 API
The SocialMarketerAccount type exposes the following members.
Properties
 | Name | Description
Public property | AccountContainer | Gets or sets the account container. (Inherited from Account.)
Public property | Description | Gets or sets the description. (Inherited from Account.)
Public property | Id | Gets or sets the id. (Inherited from Account.)
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Account IsEmpty.)
Public property | MessageLanguage | Gets or sets the message language. (Inherited from Account.)
Public property | Name | Gets or sets the name. (Inherited from Account.)
Public property | ReviewingRoles | Gets the reviewing roles. (Inherited from Account.)
Public property | ReviewingWorkflowId | Gets or sets the reviewing workflow id. (Inherited from Account.)
Back to Top
See Also
SocialMarketerAccount Class
Sitecore.Social.Domain.Model Namespace


SocialMarketerAccount.IsEmpty Property

SocialMarketerAccount IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
SocialMarketerAccount Class
SocialMarketerAccount Members
Sitecore.Social.Domain.Model Namespace


SocialProfile Class

SocialProfile Class Sitecore Social Connected 2.0 API
Represents a social profile.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model SocialProfile

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SocialProfile : IEmptyable
[SerializableAttribute]
public class SocialProfile : IEmptyable
See Also
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile Members

SocialProfile Members Sitecore Social Connected 2.0 API

The SocialProfile type exposes the following members.
Constructors
 | Name | Description
Public method | SocialProfile | Initializes a new instance of the SocialProfile class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the SocialProfile class whose value represents not found social profile.
Back to Top
Properties
 | Name | Description
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Email | Gets or sets an email address.
Public property | Fields | Gets or sets profile fields.
Public property | FullName | Gets or sets a full name.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | NetworkAccountId | Gets or sets a network account id.
Public property | NetworkName | Gets or sets a network name.
Public property | User | Gets or sets the user.
Back to Top
See Also
SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile Constructor

SocialProfile Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialProfile class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialProfile()
public SocialProfile()
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile Fields

SocialProfile Fields Sitecore Social Connected 2.0 API
The SocialProfile type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the SocialProfile class whose value represents not found social profile.
Back to Top
See Also
SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile.Empty Field

SocialProfile Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the SocialProfile class whose value represents not found social profile.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SocialProfile Empty
public static readonly SocialProfile Empty
Field Value
Type: SocialProfile
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile Methods

SocialProfile Methods Sitecore Social Connected 2.0 API
The SocialProfile type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile Properties

SocialProfile Properties Sitecore Social Connected 2.0 API
The SocialProfile type exposes the following members.
Properties
 | Name | Description
Public property | AccountCredentials | Gets or sets account credentials.
Public property | ApplicationCredentials | Gets or sets application credentials.
Public property | Email | Gets or sets an email address.
Public property | Fields | Gets or sets profile fields.
Public property | FullName | Gets or sets a full name.
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty.
Public property | NetworkAccountId | Gets or sets a network account id.
Public property | NetworkName | Gets or sets a network name.
Public property | User | Gets or sets the user.
Back to Top
See Also
SocialProfile Class
Sitecore.Social.Domain.Model Namespace


SocialProfile.AccountCredentials Property

SocialProfile AccountCredentials Property Sitecore Social Connected 2.0 API
Gets or sets account credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountCredentials AccountCredentials { get; set; }
public AccountCredentials AccountCredentials { get; set; }
Property Value
Type: AccountCredentials
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.ApplicationCredentials Property

SocialProfile ApplicationCredentials Property Sitecore Social Connected 2.0 API
Gets or sets application credentials.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationCredentials ApplicationCredentials { get; set; }
public ApplicationCredentials ApplicationCredentials { get; set; }
Property Value
Type: ApplicationCredentials
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.Email Property

SocialProfile Email Property Sitecore Social Connected 2.0 API
Gets or sets an email address.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Email { get; set; }
public string Email { get; set; }
Property Value
Type:   Online String
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.Fields Property

SocialProfile Fields Property Sitecore Social Connected 2.0 API
Gets or sets profile fields.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Fields { get; set; }
public IDictionary<string, string> Fields { get; set; }
Property Value
Type:   Online IDictionary    Online String,   Online String
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.FullName Property

SocialProfile FullName Property Sitecore Social Connected 2.0 API
Gets or sets a full name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FullName { get; set; }
public string FullName { get; set; }
Property Value
Type:   Online String
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.IsEmpty Property

SocialProfile IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Property Value
Type:   Online Boolean
Implements
IEmptyable IsEmpty
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.NetworkAccountId Property

SocialProfile NetworkAccountId Property Sitecore Social Connected 2.0 API
Gets or sets a network account id.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetworkAccountId { get; set; }
public string NetworkAccountId { get; set; }
Property Value
Type:   Online String
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.NetworkName Property

SocialProfile NetworkName Property Sitecore Social Connected 2.0 API
Gets or sets a network name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetworkName { get; set; }
public string NetworkName { get; set; }
Property Value
Type:   Online String
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


SocialProfile.User Property

SocialProfile User Property Sitecore Social Connected 2.0 API
Gets or sets the user.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPrincipal User { get; set; }
public IPrincipal User { get; set; }
Property Value
Type:   Online IPrincipal
See Also
SocialProfile Class
SocialProfile Members
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Class

StatisticsCounter Class Sitecore Social Connected 2.0 API
Represents the statistics counter.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsCounter
Sitecore.Social.Domain.Model NumberCounter

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class StatisticsCounter
[SerializableAttribute]
public abstract class StatisticsCounter
See Also
StatisticsCounter Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics StatisticsCounters


StatisticsCounter Members

StatisticsCounter Members Sitecore Social Connected 2.0 API

The StatisticsCounter type exposes the following members.
Constructors
 | Name | Description
Protected method | StatisticsCounter | Initializes a new instance of the StatisticsCounter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name.
Public property | Name | Gets the statistics counter name.
Back to Top
See Also
StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Constructor

StatisticsCounter Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the StatisticsCounter class.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StatisticsCounter(
    string name,
    string displayName
)
protected StatisticsCounter(
    string name,
    string displayName
)
Parameters
name
Type:   Online System String
The name.
displayName
Type:   Online System String
The display name.
See Also
StatisticsCounter Class
StatisticsCounter Members
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Methods

StatisticsCounter Methods Sitecore Social Connected 2.0 API
The StatisticsCounter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounter Properties

StatisticsCounter Properties Sitecore Social Connected 2.0 API
The StatisticsCounter type exposes the following members.
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name.
Public property | Name | Gets the statistics counter name.
Back to Top
See Also
StatisticsCounter Class
Sitecore.Social.Domain.Model Namespace


StatisticsCounter.DisplayName Property

StatisticsCounter DisplayName Property Sitecore Social Connected 2.0 API
Gets the statistics counter display name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DisplayName { get; private set; }
public string DisplayName { get; private set; }
Property Value
Type:   Online String

            The statistics counter display name.

See Also
StatisticsCounter Class
StatisticsCounter Members
Sitecore.Social.Domain.Model Namespace


StatisticsCounter.Name Property

StatisticsCounter Name Property Sitecore Social Connected 2.0 API
Gets the statistics counter name.

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; private set; }
public string Name { get; private set; }
Property Value
Type:   Online String

            The statistics counter name.

See Also
StatisticsCounter Class
StatisticsCounter Members
Sitecore.Social.Domain.Model Namespace


StatisticsStatus Class

StatisticsStatus Class Sitecore Social Connected 2.0 API
Represents a statistics status.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsStatus
Sitecore.Social.Domain.Model FailedStatisticsStatus
Sitecore.Social.Domain.Model UpdatedStatisticsStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class StatisticsStatus
[SerializableAttribute]
public abstract class StatisticsStatus
See Also
StatisticsStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics StatisticsStatus


StatisticsStatus Members

StatisticsStatus Members Sitecore Social Connected 2.0 API

The StatisticsStatus type exposes the following members.
Constructors
 | Name | Description
Protected method | StatisticsStatus | Initializes a new instance of the StatisticsStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
StatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


StatisticsStatus Constructor

StatisticsStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the StatisticsStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StatisticsStatus()
protected StatisticsStatus()
See Also
StatisticsStatus Class
StatisticsStatus Members
Sitecore.Social.Domain.Model Namespace


StatisticsStatus Methods

StatisticsStatus Methods Sitecore Social Connected 2.0 API
The StatisticsStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
StatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


UpdatedStatisticsStatus Class

UpdatedStatisticsStatus Class Sitecore Social Connected 2.0 API
Represents an updated statistics status.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsStatus
Sitecore.Social.Domain.Model UpdatedStatisticsStatus

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class UpdatedStatisticsStatus : StatisticsStatus
[SerializableAttribute]
public class UpdatedStatisticsStatus : StatisticsStatus
See Also
UpdatedStatisticsStatus Members
Sitecore.Social.Domain.Model Namespace
AccountStatistics StatisticsStatus


UpdatedStatisticsStatus Members

UpdatedStatisticsStatus Members Sitecore Social Connected 2.0 API

The UpdatedStatisticsStatus type exposes the following members.
Constructors
 | Name | Description
Public method | UpdatedStatisticsStatus | Initializes a new instance of the UpdatedStatisticsStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
UpdatedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


UpdatedStatisticsStatus Constructor

UpdatedStatisticsStatus Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the UpdatedStatisticsStatus class

Namespace: Sitecore.Social.Domain.Model
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdatedStatisticsStatus()
public UpdatedStatisticsStatus()
See Also
UpdatedStatisticsStatus Class
UpdatedStatisticsStatus Members
Sitecore.Social.Domain.Model Namespace


UpdatedStatisticsStatus Methods

UpdatedStatisticsStatus Methods Sitecore Social Connected 2.0 API
The UpdatedStatisticsStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
UpdatedStatisticsStatus Class
Sitecore.Social.Domain.Model Namespace


Sitecore.Social.Domain.SearchArgs Namespace

Sitecore.Social.Domain.SearchArgs Namespace Sitecore Social Connected 2.0 API
Provides classes that contain the domain's search arguments.
Classes
 | Class | Description
Public class | ContainerPostingConfigurationSearchArgs | Obsolete. Represents an abstract class of search by container posting configuration arguments.
Public class | ContentPostingConfigurationSearchArgs | Obsolete. Represents search by content posting configuration arguments.
Public class | GoalPostingConfigurationSearchArgs | Obsolete. Represents search by goal posting configuration arguments.
Public class | PostingConfigurationSearchArgs | Obsolete. Represents an abstract class of search by posting configuration arguments.


ContainerPostingConfigurationSearchArgs Class

ContainerPostingConfigurationSearchArgs Class Sitecore Social Connected 2.0 API
Represents an abstract class of search by container posting configuration arguments.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs ContainerPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs ContentPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs GoalPostingConfigurationSearchArgs

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute]
public abstract class ContainerPostingConfigurationSearchArgs : PostingConfigurationSearchArgs
[SerializableAttribute]
[ObsoleteAttribute]
public abstract class ContainerPostingConfigurationSearchArgs : PostingConfigurationSearchArgs
See Also
ContainerPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager GetMessages(PostingConfigurationSearchArgs)


ContainerPostingConfigurationSearchArgs Members

ContainerPostingConfigurationSearchArgs Members Sitecore Social Connected 2.0 API

The ContainerPostingConfigurationSearchArgs type exposes the following members.
Constructors
 | Name | Description
Protected method | ContainerPostingConfigurationSearchArgs | Initializes a new instance of the ContainerPostingConfigurationSearchArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Container | Gets the container.
Back to Top
See Also
ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContainerPostingConfigurationSearchArgs Constructor

ContainerPostingConfigurationSearchArgs Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ContainerPostingConfigurationSearchArgs class.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ContainerPostingConfigurationSearchArgs(
    string container
)
protected ContainerPostingConfigurationSearchArgs(
    string container
)
Parameters
container
Type:   Online System String
The container.
See Also
ContainerPostingConfigurationSearchArgs Class
ContainerPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace


ContainerPostingConfigurationSearchArgs Methods

ContainerPostingConfigurationSearchArgs Methods Sitecore Social Connected 2.0 API
The ContainerPostingConfigurationSearchArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContainerPostingConfigurationSearchArgs Properties

ContainerPostingConfigurationSearchArgs Properties Sitecore Social Connected 2.0 API
The ContainerPostingConfigurationSearchArgs type exposes the following members.
Properties
 | Name | Description
Public property | Container | Gets the container.
Back to Top
See Also
ContainerPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContainerPostingConfigurationSearchArgs.Container Property

ContainerPostingConfigurationSearchArgs Container Property Sitecore Social Connected 2.0 API
Gets the container.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Container { get; private set; }
public string Container { get; private set; }
Property Value
Type:   Online String

            The container.

See Also
ContainerPostingConfigurationSearchArgs Class
ContainerPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Class

ContentPostingConfigurationSearchArgs Class Sitecore Social Connected 2.0 API
Represents search by content posting configuration arguments.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs ContainerPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs ContentPostingConfigurationSearchArgs

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute]
public class ContentPostingConfigurationSearchArgs : ContainerPostingConfigurationSearchArgs
[SerializableAttribute]
[ObsoleteAttribute]
public class ContentPostingConfigurationSearchArgs : ContainerPostingConfigurationSearchArgs
See Also
ContentPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager GetMessages(PostingConfigurationSearchArgs)


ContentPostingConfigurationSearchArgs Members

ContentPostingConfigurationSearchArgs Members Sitecore Social Connected 2.0 API

The ContentPostingConfigurationSearchArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ContentPostingConfigurationSearchArgs | Initializes a new instance of the ContentPostingConfigurationSearchArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)
Back to Top
See Also
ContentPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Constructor

ContentPostingConfigurationSearchArgs Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ContentPostingConfigurationSearchArgs class.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentPostingConfigurationSearchArgs(
    string contentContainer
)
public ContentPostingConfigurationSearchArgs(
    string contentContainer
)
Parameters
contentContainer
Type:   Online System String
The content container.
See Also
ContentPostingConfigurationSearchArgs Class
ContentPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Methods

ContentPostingConfigurationSearchArgs Methods Sitecore Social Connected 2.0 API
The ContentPostingConfigurationSearchArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ContentPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


ContentPostingConfigurationSearchArgs Properties

ContentPostingConfigurationSearchArgs Properties Sitecore Social Connected 2.0 API
The ContentPostingConfigurationSearchArgs type exposes the following members.
Properties
 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)
Back to Top
See Also
ContentPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Class

GoalPostingConfigurationSearchArgs Class Sitecore Social Connected 2.0 API
Represents search by goal posting configuration arguments.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs ContainerPostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs GoalPostingConfigurationSearchArgs

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute]
public class GoalPostingConfigurationSearchArgs : ContainerPostingConfigurationSearchArgs
[SerializableAttribute]
[ObsoleteAttribute]
public class GoalPostingConfigurationSearchArgs : ContainerPostingConfigurationSearchArgs
See Also
GoalPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager GetMessages(PostingConfigurationSearchArgs)


GoalPostingConfigurationSearchArgs Members

GoalPostingConfigurationSearchArgs Members Sitecore Social Connected 2.0 API

The GoalPostingConfigurationSearchArgs type exposes the following members.
Constructors
 | Name | Description
Public method | GoalPostingConfigurationSearchArgs | Initializes a new instance of the GoalPostingConfigurationSearchArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)
Back to Top
See Also
GoalPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Constructor

GoalPostingConfigurationSearchArgs Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the GoalPostingConfigurationSearchArgs class.

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoalPostingConfigurationSearchArgs(
    string goalContainer
)
public GoalPostingConfigurationSearchArgs(
    string goalContainer
)
Parameters
goalContainer
Type:   Online System String
The goal container.
See Also
GoalPostingConfigurationSearchArgs Class
GoalPostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Methods

GoalPostingConfigurationSearchArgs Methods Sitecore Social Connected 2.0 API
The GoalPostingConfigurationSearchArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GoalPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


GoalPostingConfigurationSearchArgs Properties

GoalPostingConfigurationSearchArgs Properties Sitecore Social Connected 2.0 API
The GoalPostingConfigurationSearchArgs type exposes the following members.
Properties
 | Name | Description
Public property | Container | Gets the container. (Inherited from ContainerPostingConfigurationSearchArgs.)
Back to Top
See Also
GoalPostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


PostingConfigurationSearchArgs Class

PostingConfigurationSearchArgs Class Sitecore Social Connected 2.0 API
Represents an abstract class of search by posting configuration arguments.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.SearchArgs PostingConfigurationSearchArgs
Sitecore.Social.Domain.SearchArgs ContainerPostingConfigurationSearchArgs

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[ObsoleteAttribute]
public abstract class PostingConfigurationSearchArgs
[SerializableAttribute]
[ObsoleteAttribute]
public abstract class PostingConfigurationSearchArgs
See Also
PostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace
IMessageManager GetMessages(PostingConfigurationSearchArgs)


PostingConfigurationSearchArgs Members

PostingConfigurationSearchArgs Members Sitecore Social Connected 2.0 API

The PostingConfigurationSearchArgs type exposes the following members.
Constructors
 | Name | Description
Protected method | PostingConfigurationSearchArgs | Initializes a new instance of the PostingConfigurationSearchArgs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


PostingConfigurationSearchArgs Constructor

PostingConfigurationSearchArgs Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the PostingConfigurationSearchArgs class

Namespace: Sitecore.Social.Domain.SearchArgs
Assembly: Sitecore.Social.Domain (in Sitecore.Social.Domain.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostingConfigurationSearchArgs()
protected PostingConfigurationSearchArgs()
See Also
PostingConfigurationSearchArgs Class
PostingConfigurationSearchArgs Members
Sitecore.Social.Domain.SearchArgs Namespace


PostingConfigurationSearchArgs Methods

PostingConfigurationSearchArgs Methods Sitecore Social Connected 2.0 API
The PostingConfigurationSearchArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
PostingConfigurationSearchArgs Class
Sitecore.Social.Domain.SearchArgs Namespace


Sitecore.Social.Facebook.Api.Model Namespace

Sitecore.Social.Facebook.Api.Model Namespace Sitecore Social Connected 2.0 API
Provides classes that extend domain's model with Facebook specific entities.
Classes
 | Class | Description
Public class | CommentsCounter | Represents the comments counter.
Public class | FacebookMessageData | Represents Facebook message data.
Public class | LikesCounter | Represents the likes counter


CommentsCounter Class

CommentsCounter Class Sitecore Social Connected 2.0 API
Represents the comments counter.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsCounter
Sitecore.Social.Domain.Model NumberCounter
Sitecore.Social.Facebook.Api.Model CommentsCounter

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CommentsCounter : NumberCounter
[SerializableAttribute]
public class CommentsCounter : NumberCounter
See Also
CommentsCounter Members
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Members

CommentsCounter Members Sitecore Social Connected 2.0 API

The CommentsCounter type exposes the following members.
Constructors
 | Name | Description
Public method | CommentsCounter | Initializes a new instance of the CommentsCounter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)
Back to Top
See Also
CommentsCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Constructor

CommentsCounter Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the CommentsCounter class.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CommentsCounter(
    string displayName,
    int number
)
public CommentsCounter(
    string displayName,
    int number
)
Parameters
displayName
Type:   Online System String
The display name.
number
Type:   Online System Int32
The number.
See Also
CommentsCounter Class
CommentsCounter Members
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Methods

CommentsCounter Methods Sitecore Social Connected 2.0 API
The CommentsCounter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
CommentsCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


CommentsCounter Properties

CommentsCounter Properties Sitecore Social Connected 2.0 API
The CommentsCounter type exposes the following members.
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)
Back to Top
See Also
CommentsCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Class

FacebookMessageData Class Sitecore Social Connected 2.0 API
Represents Facebook message data.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageData
Sitecore.Social.Facebook.Api.Model FacebookMessageData

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FacebookMessageData : MessageData
[SerializableAttribute]
public class FacebookMessageData : MessageData
See Also
FacebookMessageData Members
Sitecore.Social.Facebook.Api.Model Namespace
Message MessageData


FacebookMessageData Members

FacebookMessageData Members Sitecore Social Connected 2.0 API

The FacebookMessageData type exposes the following members.
Constructors
 | Name | Description
Public method | FacebookMessageData | Initializes a new instance of the FacebookMessageData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | CreatedDate | Gets or sets the Created date. (Inherited from MessageData.)
Public property | DisplayName | Gets or sets the display name. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | LinkDescription | Gets or sets the link description.
Public property | LinkImage | Gets or sets the link image.
Public property | LinkTitle | Gets or sets the link title.
Public property | PostedDate | Gets or sets the Posted date. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)
Back to Top
See Also
FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Constructor

FacebookMessageData Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the FacebookMessageData class

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FacebookMessageData()
public FacebookMessageData()
See Also
FacebookMessageData Class
FacebookMessageData Members
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Methods

FacebookMessageData Methods Sitecore Social Connected 2.0 API
The FacebookMessageData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData Properties

FacebookMessageData Properties Sitecore Social Connected 2.0 API
The FacebookMessageData type exposes the following members.
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | CreatedDate | Gets or sets the Created date. (Inherited from MessageData.)
Public property | DisplayName | Gets or sets the display name. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | LinkDescription | Gets or sets the link description.
Public property | LinkImage | Gets or sets the link image.
Public property | LinkTitle | Gets or sets the link title.
Public property | PostedDate | Gets or sets the Posted date. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)
Back to Top
See Also
FacebookMessageData Class
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData.LinkDescription Property

FacebookMessageData LinkDescription Property Sitecore Social Connected 2.0 API
Gets or sets the link description.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LinkDescription { get; set; }
public string LinkDescription { get; set; }
Property Value
Type:   Online String

            The link description.

See Also
FacebookMessageData Class
FacebookMessageData Members
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData.LinkImage Property

FacebookMessageData LinkImage Property Sitecore Social Connected 2.0 API
Gets or sets the link image.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LinkImage { get; set; }
public string LinkImage { get; set; }
Property Value
Type:   Online String

            The link image.

See Also
FacebookMessageData Class
FacebookMessageData Members
Sitecore.Social.Facebook.Api.Model Namespace


FacebookMessageData.LinkTitle Property

FacebookMessageData LinkTitle Property Sitecore Social Connected 2.0 API
Gets or sets the link title.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LinkTitle { get; set; }
public string LinkTitle { get; set; }
Property Value
Type:   Online String

            The link title.

See Also
FacebookMessageData Class
FacebookMessageData Members
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Class

LikesCounter Class Sitecore Social Connected 2.0 API
Represents the likes counter
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsCounter
Sitecore.Social.Domain.Model NumberCounter
Sitecore.Social.Facebook.Api.Model LikesCounter

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LikesCounter : NumberCounter
[SerializableAttribute]
public class LikesCounter : NumberCounter
See Also
LikesCounter Members
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Members

LikesCounter Members Sitecore Social Connected 2.0 API

The LikesCounter type exposes the following members.
Constructors
 | Name | Description
Public method | LikesCounter | Initializes a new instance of the LikesCounter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)
Back to Top
See Also
LikesCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Constructor

LikesCounter Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the LikesCounter class.

Namespace: Sitecore.Social.Facebook.Api.Model
Assembly: Sitecore.Social.Facebook.Api (in Sitecore.Social.Facebook.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LikesCounter(
    string displayName,
    int number
)
public LikesCounter(
    string displayName,
    int number
)
Parameters
displayName
Type:   Online System String
The display name.
number
Type:   Online System Int32
The number.
See Also
LikesCounter Class
LikesCounter Members
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Methods

LikesCounter Methods Sitecore Social Connected 2.0 API
The LikesCounter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
LikesCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


LikesCounter Properties

LikesCounter Properties Sitecore Social Connected 2.0 API
The LikesCounter type exposes the following members.
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)
Back to Top
See Also
LikesCounter Class
Sitecore.Social.Facebook.Api.Model Namespace


Sitecore.Social.Facebook.Configuration Namespace

Sitecore.Social.Facebook.Configuration Namespace Sitecore Social Connected 2.0 API
Provides classes that allow reading the Facebook specific configuration.
Classes
 | Class | Description
Public class | SettingsConfiguration | Facebook settings configuration.


SettingsConfiguration Class

SettingsConfiguration Class Sitecore Social Connected 2.0 API
Facebook settings configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Facebook.Configuration SettingsConfiguration

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
See Also
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration Members

SettingsConfiguration Members Sitecore Social Connected 2.0 API

The SettingsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | SettingsConfiguration | Initializes a new instance of the SettingsConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.
Back to Top
Properties
 | Name | Description
Public property | DefaultLikeGoal | Gets or sets the default like goal.
Public property | HasWriteAccess | Gets or sets the value that indicates whether an application has write access to Facebook or not.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Public property | IsOfflineAccess | Gets or sets the value that indicates whether Social Connector will request the Facebook “offline_access” permission or not.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration Constructor

SettingsConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SettingsConfiguration class

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SettingsConfiguration()
public SettingsConfiguration()
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration Fields

SettingsConfiguration Fields Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration.Empty Field

SettingsConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SettingsConfiguration Empty
public static readonly SettingsConfiguration Empty
Field Value
Type: SettingsConfiguration
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration Methods

SettingsConfiguration Methods Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration Properties

SettingsConfiguration Properties Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | DefaultLikeGoal | Gets or sets the default like goal.
Public property | HasWriteAccess | Gets or sets the value that indicates whether an application has write access to Facebook or not.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Public property | IsOfflineAccess | Gets or sets the value that indicates whether Social Connector will request the Facebook “offline_access” permission or not.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration.DefaultLikeGoal Property

SettingsConfiguration DefaultLikeGoal Property Sitecore Social Connected 2.0 API
Gets or sets the default like goal.

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DefaultLikeGoal { get; set; }
public string DefaultLikeGoal { get; set; }
Property Value
Type:   Online String

            The default like goal.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration.HasWriteAccess Property

SettingsConfiguration HasWriteAccess Property Sitecore Social Connected 2.0 API
Gets or sets the value that indicates whether an application has write access to Facebook or not.

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasWriteAccess { get; set; }
public bool HasWriteAccess { get; set; }
Property Value
Type:   Online Boolean
true if the application has write access; otherwise, false.

Remarks

            Enables your application to post content, comments, and likes to a user's timeline and to the timelines of user's friends.
            With this permission, you can post a content to the user's timeline at any time, without requesting offline_access.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration.IsEmpty Property

SettingsConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


SettingsConfiguration.IsOfflineAccess Property

SettingsConfiguration IsOfflineAccess Property Sitecore Social Connected 2.0 API
Gets or sets the value that indicates whether Social Connector will request the Facebook “offline_access” permission or not.

Namespace: Sitecore.Social.Facebook.Configuration
Assembly: Sitecore.Social.Facebook (in Sitecore.Social.Facebook.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsOfflineAccess { get; set; }
public bool IsOfflineAccess { get; set; }
Property Value
Type:   Online Boolean
true to get offline access token; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Facebook.Configuration Namespace


Sitecore.Social.GooglePlus.Configuration Namespace

Sitecore.Social.GooglePlus.Configuration Namespace Sitecore Social Connected 2.0 API
Provides classes that allow reading the Google+ specific configuration
Classes
 | Class | Description
Public class | SettingsConfiguration | Google+ settings configuration.


SettingsConfiguration Class

SettingsConfiguration Class Sitecore Social Connected 2.0 API
Google+ settings configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.GooglePlus.Configuration SettingsConfiguration

Namespace: Sitecore.Social.GooglePlus.Configuration
Assembly: Sitecore.Social.GooglePlus (in Sitecore.Social.GooglePlus.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
See Also
SettingsConfiguration Members
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration Members

SettingsConfiguration Members Sitecore Social Connected 2.0 API

The SettingsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | SettingsConfiguration | Initializes a new instance of the SettingsConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Public property | IsOfflineAccess | Gets or sets the value that indicates whether Social Connector will request the Google+ “offline_access” permission or not.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration Constructor

SettingsConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SettingsConfiguration class

Namespace: Sitecore.Social.GooglePlus.Configuration
Assembly: Sitecore.Social.GooglePlus (in Sitecore.Social.GooglePlus.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SettingsConfiguration()
public SettingsConfiguration()
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration Fields

SettingsConfiguration Fields Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration.Empty Field

SettingsConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.

Namespace: Sitecore.Social.GooglePlus.Configuration
Assembly: Sitecore.Social.GooglePlus (in Sitecore.Social.GooglePlus.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SettingsConfiguration Empty
public static readonly SettingsConfiguration Empty
Field Value
Type: SettingsConfiguration
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration Methods

SettingsConfiguration Methods Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration Properties

SettingsConfiguration Properties Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Public property | IsOfflineAccess | Gets or sets the value that indicates whether Social Connector will request the Google+ “offline_access” permission or not.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration.IsEmpty Property

SettingsConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.GooglePlus.Configuration
Assembly: Sitecore.Social.GooglePlus (in Sitecore.Social.GooglePlus.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.GooglePlus.Configuration Namespace


SettingsConfiguration.IsOfflineAccess Property

SettingsConfiguration IsOfflineAccess Property Sitecore Social Connected 2.0 API
Gets or sets the value that indicates whether Social Connector will request the Google+ “offline_access” permission or not.

Namespace: Sitecore.Social.GooglePlus.Configuration
Assembly: Sitecore.Social.GooglePlus (in Sitecore.Social.GooglePlus.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsOfflineAccess { get; set; }
public bool IsOfflineAccess { get; set; }
Property Value
Type:   Online Boolean
true to get offline access token; otherwise, false.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.GooglePlus.Configuration Namespace


Sitecore.Social.Infrastructure Namespace

Sitecore.Social.Infrastructure Namespace Sitecore Social Connected 2.0 API
Provides the infrastructure classes.
Classes
 | Class | Description
Public class | ExecutingContext | Social module executing context
Public class | HttpRequestExecutingContext | Http request executing context
Public class | ManagedThreadExecutingContext | Managed thread executing context.


ExecutingContext Class

ExecutingContext Class Sitecore Social Connected 2.0 API
Social module executing context
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure ExecutingContext
Sitecore.Social.Infrastructure HttpRequestExecutingContext
Sitecore.Social.Infrastructure ManagedThreadExecutingContext

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ExecutingContext
public abstract class ExecutingContext
See Also
ExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ExecutingContext Members

ExecutingContext Members Sitecore Social Connected 2.0 API

The ExecutingContext type exposes the following members.
Constructors
 | Name | Description
Protected method | ExecutingContext | Initializes a new instance of the ExecutingContext class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
 | Current | Gets or sets the current Social executing context.
Public property | IoC | Gets the dependency resolver.
Public property | RenewingNetworkAccountIdList | Gets the list of network account IDs which are being renewed currently.
Back to Top
See Also
ExecutingContext Class
Sitecore.Social.Infrastructure Namespace


ExecutingContext Constructor

ExecutingContext Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ExecutingContext class

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ExecutingContext()
protected ExecutingContext()
See Also
ExecutingContext Class
ExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ExecutingContext Methods

ExecutingContext Methods Sitecore Social Connected 2.0 API
The ExecutingContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ExecutingContext Class
Sitecore.Social.Infrastructure Namespace


ExecutingContext Properties

ExecutingContext Properties Sitecore Social Connected 2.0 API
The ExecutingContext type exposes the following members.
Properties
 | Name | Description
 | Current | Gets or sets the current Social executing context.
Public property | IoC | Gets the dependency resolver.
Public property | RenewingNetworkAccountIdList | Gets the list of network account IDs which are being renewed currently.
Back to Top
See Also
ExecutingContext Class
Sitecore.Social.Infrastructure Namespace


ExecutingContext.Current Property

ExecutingContext Current Property Sitecore Social Connected 2.0 API
Gets or sets the current Social executing context.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ExecutingContext Current { get; set; }
public static ExecutingContext Current { get; set; }
Property Value
Type: ExecutingContext

            The ExecutingContext.

Remarks

            If the context is not defined, the default context is created and returned:
            - HttpRequestExecutingContext for the http request;
            - ManagedThreadExecutingContext in another case.

See Also
ExecutingContext Class
ExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ExecutingContext.IoC Property

ExecutingContext IoC Property Sitecore Social Connected 2.0 API
Gets the dependency resolver.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IKernel IoC { get; }
public abstract IKernel IoC { get; }
Property Value
Type: IKernel
See Also
ExecutingContext Class
ExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ExecutingContext.RenewingNetworkAccountIdList Property

ExecutingContext RenewingNetworkAccountIdList Property Sitecore Social Connected 2.0 API
Gets the list of network account IDs which are being renewed currently.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IList<string> RenewingNetworkAccountIdList { get; }
public abstract IList<string> RenewingNetworkAccountIdList { get; }
Property Value
Type:   Online IList    Online String
See Also
ExecutingContext Class
ExecutingContext Members
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext Class

HttpRequestExecutingContext Class Sitecore Social Connected 2.0 API
Http request executing context
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure ExecutingContext
Sitecore.Social.Infrastructure HttpRequestExecutingContext

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HttpRequestExecutingContext : ExecutingContext
public class HttpRequestExecutingContext : ExecutingContext
See Also
HttpRequestExecutingContext Members
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext Members

HttpRequestExecutingContext Members Sitecore Social Connected 2.0 API

The HttpRequestExecutingContext type exposes the following members.
Constructors
 | Name | Description
Public method | HttpRequestExecutingContext | Initializes a new instance of the HttpRequestExecutingContext class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
IoCApplicationKey | The key to get IoC from the Application object.
RenewingNetworkAccountIdListSessionKey | The key to get RenewingNetworkAccountIdList from the session.
Back to Top
Properties
 | Name | Description
Public property | IoC | Gets the Ninject dependency resolver. (Overrides ExecutingContext IoC.)
Public property | RenewingNetworkAccountIdList | Gets the list of network account IDs which are being renewed currently. (Overrides ExecutingContext RenewingNetworkAccountIdList.)
Back to Top
See Also
HttpRequestExecutingContext Class
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext Constructor

HttpRequestExecutingContext Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the HttpRequestExecutingContext class

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HttpRequestExecutingContext()
public HttpRequestExecutingContext()
See Also
HttpRequestExecutingContext Class
HttpRequestExecutingContext Members
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext Fields

HttpRequestExecutingContext Fields Sitecore Social Connected 2.0 API
The HttpRequestExecutingContext type exposes the following members.
Fields
Name | Description
IoCApplicationKey | The key to get IoC from the Application object.
RenewingNetworkAccountIdListSessionKey | The key to get RenewingNetworkAccountIdList from the session.
Back to Top
See Also
HttpRequestExecutingContext Class
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext.IoCApplicationKey Field

HttpRequestExecutingContext IoCApplicationKey Field Sitecore Social Connected 2.0 API
The key to get IoC from the Application object.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string IoCApplicationKey
public const string IoCApplicationKey
Field Value
Type:   Online String
See Also
HttpRequestExecutingContext Class
HttpRequestExecutingContext Members
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext.RenewingNetworkAccountIdListSessionKey Field

HttpRequestExecutingContext RenewingNetworkAccountIdListSessionKey Field Sitecore Social Connected 2.0 API
The key to get RenewingNetworkAccountIdList from the session.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RenewingNetworkAccountIdListSessionKey
public const string RenewingNetworkAccountIdListSessionKey
Field Value
Type:   Online String
See Also
HttpRequestExecutingContext Class
HttpRequestExecutingContext Members
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext Methods

HttpRequestExecutingContext Methods Sitecore Social Connected 2.0 API
The HttpRequestExecutingContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
HttpRequestExecutingContext Class
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext Properties

HttpRequestExecutingContext Properties Sitecore Social Connected 2.0 API
The HttpRequestExecutingContext type exposes the following members.
Properties
 | Name | Description
Public property | IoC | Gets the Ninject dependency resolver. (Overrides ExecutingContext IoC.)
Public property | RenewingNetworkAccountIdList | Gets the list of network account IDs which are being renewed currently. (Overrides ExecutingContext RenewingNetworkAccountIdList.)
Back to Top
See Also
HttpRequestExecutingContext Class
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext.IoC Property

HttpRequestExecutingContext IoC Property Sitecore Social Connected 2.0 API
Gets the Ninject dependency resolver.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IKernel IoC { get; }
public override IKernel IoC { get; }
Property Value
Type: IKernel
See Also
HttpRequestExecutingContext Class
HttpRequestExecutingContext Members
Sitecore.Social.Infrastructure Namespace


HttpRequestExecutingContext.RenewingNetworkAccountIdList Property

HttpRequestExecutingContext RenewingNetworkAccountIdList Property Sitecore Social Connected 2.0 API
Gets the list of network account IDs which are being renewed currently.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IList<string> RenewingNetworkAccountIdList { get; }
public override IList<string> RenewingNetworkAccountIdList { get; }
Property Value
Type:   Online IList    Online String
See Also
HttpRequestExecutingContext Class
HttpRequestExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext Class

ManagedThreadExecutingContext Class Sitecore Social Connected 2.0 API
Managed thread executing context.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure ExecutingContext
Sitecore.Social.Infrastructure ManagedThreadExecutingContext

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ManagedThreadExecutingContext : ExecutingContext
public class ManagedThreadExecutingContext : ExecutingContext
See Also
ManagedThreadExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext Members

ManagedThreadExecutingContext Members Sitecore Social Connected 2.0 API

The ManagedThreadExecutingContext type exposes the following members.
Constructors
 | Name | Description
Public method | ManagedThreadExecutingContext | Initializes a new instance of the ManagedThreadExecutingContext class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IoC | Gets the dependency resolver. (Overrides ExecutingContext IoC.)
Public property | RenewingNetworkAccountIdList | Gets the list of network account IDs which are being renewed currently. (Overrides ExecutingContext RenewingNetworkAccountIdList.)
Back to Top
See Also
ManagedThreadExecutingContext Class
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext Constructor

ManagedThreadExecutingContext Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the ManagedThreadExecutingContext class

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ManagedThreadExecutingContext()
public ManagedThreadExecutingContext()
See Also
ManagedThreadExecutingContext Class
ManagedThreadExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext Methods

ManagedThreadExecutingContext Methods Sitecore Social Connected 2.0 API
The ManagedThreadExecutingContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ManagedThreadExecutingContext Class
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext Properties

ManagedThreadExecutingContext Properties Sitecore Social Connected 2.0 API
The ManagedThreadExecutingContext type exposes the following members.
Properties
 | Name | Description
Public property | IoC | Gets the dependency resolver. (Overrides ExecutingContext IoC.)
Public property | RenewingNetworkAccountIdList | Gets the list of network account IDs which are being renewed currently. (Overrides ExecutingContext RenewingNetworkAccountIdList.)
Back to Top
See Also
ManagedThreadExecutingContext Class
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext.IoC Property

ManagedThreadExecutingContext IoC Property Sitecore Social Connected 2.0 API
Gets the dependency resolver.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IKernel IoC { get; }
public override IKernel IoC { get; }
Property Value
Type: IKernel
See Also
ManagedThreadExecutingContext Class
ManagedThreadExecutingContext Members
Sitecore.Social.Infrastructure Namespace


ManagedThreadExecutingContext.RenewingNetworkAccountIdList Property

ManagedThreadExecutingContext RenewingNetworkAccountIdList Property Sitecore Social Connected 2.0 API
Gets the list of network account IDs which are being renewed currently.

Namespace: Sitecore.Social.Infrastructure
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IList<string> RenewingNetworkAccountIdList { get; }
public override IList<string> RenewingNetworkAccountIdList { get; }
Property Value
Type:   Online IList    Online String
See Also
ManagedThreadExecutingContext Class
ManagedThreadExecutingContext Members
Sitecore.Social.Infrastructure Namespace


Sitecore.Social.Infrastructure.Exceptions Namespace

Sitecore.Social.Infrastructure.Exceptions Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the infrastructure exceptions.
Classes
 | Class | Description
Public class | SocialException | The base class of the social module exceptions


SocialException Class

SocialException Class Sitecore Social Connected 2.0 API
The base class of the social module exceptions
Inheritance Hierarchy
Online System Object
Online System Exception
Sitecore.Social.Infrastructure.Exceptions SocialException
Sitecore.Social.BusinessLogic.Exceptions AccountInDomainDuplicatedException
Sitecore.Social.BusinessLogic.Exceptions AccountInUserDuplicatedException
Sitecore.Social.BusinessLogic.Exceptions AccountIsNotExistException

Namespace: Sitecore.Social.Infrastructure.Exceptions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SocialException : Exception,
    ISocialException
[SerializableAttribute]
public class SocialException : Exception,
    ISocialException
See Also
SocialException Members
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Members

SocialException Members Sitecore Social Connected 2.0 API

The SocialException type exposes the following members.
Constructors
 | Name | Description
Public method | SocialException | Initializes a new instance of the SocialException class.
Public method | SocialException(Exception) | Initializes a new instance of the SocialException class with the specified inner exception.
Public method | SocialException(Exception, String) | Initializes a new instance of the SocialException class with the specified network name.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message.
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message.
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SocialException Class
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Constructor

SocialException Constructor Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | SocialException | Initializes a new instance of the SocialException class.
Public method | SocialException(Exception) | Initializes a new instance of the SocialException class with the specified inner exception.
Public method | SocialException(Exception, String) | Initializes a new instance of the SocialException class with the specified network name.
Back to Top
See Also
SocialException Class
SocialException Members
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Constructor

SocialException Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialException class.

Namespace: Sitecore.Social.Infrastructure.Exceptions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialException()
public SocialException()
See Also
SocialException Class
SocialException Members
SocialException Overload
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Constructor (Exception)

SocialException Constructor (Exception) Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialException class with the specified inner exception.

Namespace: Sitecore.Social.Infrastructure.Exceptions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialException(
    Exception innerException
)
public SocialException(
    Exception innerException
)
Parameters
innerException
Type:   Online System Exception
The inner exception.
See Also
SocialException Class
SocialException Members
SocialException Overload
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Constructor (Exception, String)

SocialException Constructor (Exception, String) Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialException class with the specified network name.

Namespace: Sitecore.Social.Infrastructure.Exceptions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialException(
    Exception innerException,
    string networkName
)
public SocialException(
    Exception innerException,
    string networkName
)
Parameters
innerException
Type:   Online System Exception
The inner exception.
networkName
Type:   Online System String
Name of the network.
See Also
SocialException Class
SocialException Members
SocialException Overload
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Methods

SocialException Methods Sitecore Social Connected 2.0 API
The SocialException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SocialException Class
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Properties

SocialException Properties Sitecore Social Connected 2.0 API
The SocialException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | DetailedMessage | The detailed message.
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | SimpleMessage | The simple message.
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SocialException Class
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException.DetailedMessage Property

SocialException DetailedMessage Property Sitecore Social Connected 2.0 API
The detailed message.

Namespace: Sitecore.Social.Infrastructure.Exceptions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DetailedMessage { get; set; }
public string DetailedMessage { get; set; }
Property Value
Type:   Online String
Implements
ISocialException DetailedMessage
See Also
SocialException Class
SocialException Members
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException.SimpleMessage Property

SocialException SimpleMessage Property Sitecore Social Connected 2.0 API
The simple message.

Namespace: Sitecore.Social.Infrastructure.Exceptions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string SimpleMessage { get; }
public virtual string SimpleMessage { get; }
Property Value
Type:   Online String
Implements
ISocialException SimpleMessage
See Also
SocialException Class
SocialException Members
Sitecore.Social.Infrastructure.Exceptions Namespace


SocialException Events

SocialException Events Sitecore Social Connected 2.0 API
The SocialException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SocialException Class
Sitecore.Social.Infrastructure.Exceptions Namespace


Sitecore.Social.Infrastructure.Extensions Namespace

Sitecore.Social.Infrastructure.Extensions Namespace Sitecore Social Connected 2.0 API
Provides a set of extension classes.
Classes
 | Class | Description
Public class | GuidExtensions | Provides a set of static methods to get Identifier for the Online Guid objects.
Public class | IdentifierExtensions | Provides a set of static methods to get values for the Identifier objects.
Public class | IDExtensions | Provides a set of static methods to get Identifier for the ID objects.
Public class | StringExtensions | Defines static methods that extend Online String.


GuidExtensions Class

GuidExtensions Class Sitecore Social Connected 2.0 API
Provides a set of static methods to get Identifier for the Online Guid objects.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure.Extensions GuidExtensions

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class GuidExtensions
public static class GuidExtensions
See Also
GuidExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


GuidExtensions Members

GuidExtensions Members Sitecore Social Connected 2.0 API

The GuidExtensions type exposes the following members.
Methods
Name | Description
GetIdentifier | Gets the identifier from GUID.
Back to Top
See Also
GuidExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


GuidExtensions Methods

GuidExtensions Methods Sitecore Social Connected 2.0 API
The GuidExtensions type exposes the following members.
Methods
Name | Description
GetIdentifier | Gets the identifier from GUID.
Back to Top
See Also
GuidExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


GuidExtensions.GetIdentifier Method

GuidExtensions GetIdentifier Method Sitecore Social Connected 2.0 API
Gets the identifier from GUID.

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Identifier GetIdentifier(
    this Guid value
)
public static Identifier GetIdentifier(
    this Guid value
)
Parameters
value
Type:   Online System Guid
The GUID.
Return Value
Type: Identifier
The GuidIdentifier.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online Guid. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var contentId = Guid.NewGuid().GetIdentifier();
var contentId = Guid.NewGuid().GetIdentifier();
See Also
GuidExtensions Class
GuidExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


IdentifierExtensions Class

IdentifierExtensions Class Sitecore Social Connected 2.0 API
Provides a set of static methods to get values for the Identifier objects.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure.Extensions IdentifierExtensions

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class IdentifierExtensions
public static class IdentifierExtensions
See Also
IdentifierExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


IdentifierExtensions Members

IdentifierExtensions Members Sitecore Social Connected 2.0 API

The IdentifierExtensions type exposes the following members.
Methods
Name | Description
GetGuid | Gets the GUID value.
GetID | Gets the ID from identifier.
Back to Top
See Also
IdentifierExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


IdentifierExtensions Methods

IdentifierExtensions Methods Sitecore Social Connected 2.0 API
The IdentifierExtensions type exposes the following members.
Methods
Name | Description
GetGuid | Gets the GUID value.
GetID | Gets the ID from identifier.
Back to Top
See Also
IdentifierExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


IdentifierExtensions.GetGuid Method

IdentifierExtensions GetGuid Method Sitecore Social Connected 2.0 API
Gets the GUID value.

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid GetGuid(
    this Identifier identifier
)
public static Guid GetGuid(
    this Identifier identifier
)
Parameters
identifier
Type: Sitecore.Social.Domain.Model Identifier
The identifier.
Return Value
Type:   Online Guid
The GUID value.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Identifier. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System InvalidCastException | The 'identifier' argument is not a GuidIdentifier object.
See Also
IdentifierExtensions Class
IdentifierExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


IdentifierExtensions.GetID Method

IdentifierExtensions GetID Method Sitecore Social Connected 2.0 API
Gets the ID from identifier.

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ID GetID(
    this Identifier id
)
public static ID GetID(
    this Identifier id
)
Parameters
id
Type: Sitecore.Social.Domain.Model Identifier
The id.
Return Value
Type: ID
The ID.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Identifier. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System InvalidCastException | The 'id' argument is not an IDIdentifier object.
Examples
View Colorized Copy to Clipboard Print
var messageItemID = messageId.GetID();
var messageItemID = messageId.GetID();
See Also
IdentifierExtensions Class
IdentifierExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace
Sitecore.Social.Infrastructure.Identifiers IDIdentifier


IDExtensions Class

IDExtensions Class Sitecore Social Connected 2.0 API
Provides a set of static methods to get Identifier for the ID objects.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure.Extensions IDExtensions

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class IDExtensions
public static class IDExtensions
See Also
IDExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


IDExtensions Members

IDExtensions Members Sitecore Social Connected 2.0 API

The IDExtensions type exposes the following members.
Methods
Name | Description
GetIdentifier | Gets the identifier from ID.
Back to Top
See Also
IDExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


IDExtensions Methods

IDExtensions Methods Sitecore Social Connected 2.0 API
The IDExtensions type exposes the following members.
Methods
Name | Description
GetIdentifier | Gets the identifier from ID.
Back to Top
See Also
IDExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


IDExtensions.GetIdentifier Method

IDExtensions GetIdentifier Method Sitecore Social Connected 2.0 API
Gets the identifier from ID.

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Identifier GetIdentifier(
    this ID id
)
public static Identifier GetIdentifier(
    this ID id
)
Parameters
id
Type: ID
The id.
Return Value
Type: Identifier
The Identifier.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ID. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
var messageId = messageItemID.GetIdentifier();
var messageId = messageItemID.GetIdentifier();
See Also
IDExtensions Class
IDExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace
Sitecore.Social.Infrastructure.Identifiers IDIdentifier


StringExtensions Class

StringExtensions Class Sitecore Social Connected 2.0 API
Defines static methods that extend Online String.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure.Extensions StringExtensions

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class StringExtensions
public static class StringExtensions
See Also
StringExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


StringExtensions Members

StringExtensions Members Sitecore Social Connected 2.0 API

The StringExtensions type exposes the following members.
Methods
Name | Description
Contains | Determines whether a string contains the specified string.
EscapeJavaScript | Escapes the java script.
Back to Top
See Also
StringExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


StringExtensions Methods

StringExtensions Methods Sitecore Social Connected 2.0 API
The StringExtensions type exposes the following members.
Methods
Name | Description
Contains | Determines whether a string contains the specified string.
EscapeJavaScript | Escapes the java script.
Back to Top
See Also
StringExtensions Class
Sitecore.Social.Infrastructure.Extensions Namespace


StringExtensions.Contains Method

StringExtensions Contains Method Sitecore Social Connected 2.0 API
Determines whether a string contains the specified string.

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Contains(
    this string source,
    string toCheck,
    StringComparison stringComparison
)
public static bool Contains(
    this string source,
    string toCheck,
    StringComparison stringComparison
)
Parameters
source
Type:   Online System String
The source string.
toCheck
Type:   Online System String
The string to check.
stringComparison
Type:   Online System StringComparison
The string comparison options.
Return Value
Type:   Online Boolean
true if the string contains the specified string; otherwise, false.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
StringExtensions Class
StringExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


StringExtensions.EscapeJavaScript Method

StringExtensions EscapeJavaScript Method Sitecore Social Connected 2.0 API
Escapes the java script.

Namespace: Sitecore.Social.Infrastructure.Extensions
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EscapeJavaScript(
    this string source
)
public static string EscapeJavaScript(
    this string source
)
Parameters
source
Type:   Online System String
The source.
Return Value
Type:   Online String
The escaped text.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
StringExtensions Class
StringExtensions Members
Sitecore.Social.Infrastructure.Extensions Namespace


Sitecore.Social.Infrastructure.Identifiers Namespace

Sitecore.Social.Infrastructure.Identifiers Namespace Sitecore Social Connected 2.0 API
Provides a set of identifier classes.
Classes
 | Class | Description
Public class | GuidIdentifier | Represents the identifier for the Online Guid object.
Public class | IDIdentifier | Represents the identifier for the ID object.


GuidIdentifier Class

GuidIdentifier Class Sitecore Social Connected 2.0 API
Represents the identifier for the Online Guid object.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Identifier
Sitecore.Social.Infrastructure.Identifiers GuidIdentifier

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GuidIdentifier : Identifier
[SerializableAttribute]
public class GuidIdentifier : Identifier
See Also
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier Members

GuidIdentifier Members Sitecore Social Connected 2.0 API

The GuidIdentifier type exposes the following members.
Constructors
 | Name | Description
Public method | GuidIdentifier | Initializes a new instance of the GuidIdentifier class with specific GUID.
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Overrides Identifier Equals(Identifier).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Inherited from Identifier.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the GuidIdentifier class whose value represents a not defined identifier.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Identifier IsEmpty.)
Public property | OriginalId | Gets the original id.
Public property | OriginalType | Gets the original type. (Overrides Identifier OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)
Back to Top
See Also
GuidIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier Constructor

GuidIdentifier Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the GuidIdentifier class with specific GUID.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GuidIdentifier(
    Guid id
)
public GuidIdentifier(
    Guid id
)
Parameters
id
Type:   Online System Guid
The id.
See Also
GuidIdentifier Class
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier Fields

GuidIdentifier Fields Sitecore Social Connected 2.0 API
The GuidIdentifier type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the GuidIdentifier class whose value represents a not defined identifier.
Back to Top
See Also
GuidIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier.Empty Field

GuidIdentifier Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the GuidIdentifier class whose value represents a not defined identifier.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly GuidIdentifier Empty
public static readonly GuidIdentifier Empty
Field Value
Type: GuidIdentifier
See Also
GuidIdentifier Class
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier Methods

GuidIdentifier Methods Sitecore Social Connected 2.0 API
The GuidIdentifier type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Overrides Identifier Equals(Identifier).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Inherited from Identifier.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
See Also
GuidIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier.Equals Method

GuidIdentifier Equals Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Overrides Identifier Equals(Identifier).)
Back to Top
See Also
GuidIdentifier Class
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier.Equals Method (Identifier)

GuidIdentifier Equals Method (Identifier) Sitecore Social Connected 2.0 API
Checks if the current identifier is equal to another one.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Identifier other
)
public override bool Equals(
    Identifier other
)
Parameters
other
Type: Sitecore.Social.Domain.Model Identifier
The other identifier.
Return Value
Type:   Online Boolean
true if the current identifier is equal to another one, otherwise false.

Implements
  Online IEquatable T  Equals(T)
See Also
GuidIdentifier Class
GuidIdentifier Members
Equals Overload
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier Properties

GuidIdentifier Properties Sitecore Social Connected 2.0 API
The GuidIdentifier type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Identifier IsEmpty.)
Public property | OriginalId | Gets the original id.
Public property | OriginalType | Gets the original type. (Overrides Identifier OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)
Back to Top
See Also
GuidIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier.IsEmpty Property

GuidIdentifier IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
GuidIdentifier Class
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier.OriginalId Property

GuidIdentifier OriginalId Property Sitecore Social Connected 2.0 API
Gets the original id.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OriginalId { get; private set; }
public Guid OriginalId { get; private set; }
Property Value
Type:   Online Guid

            The original id.

See Also
GuidIdentifier Class
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


GuidIdentifier.OriginalType Property

GuidIdentifier OriginalType Property Sitecore Social Connected 2.0 API
Gets the original type.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type OriginalType { get; }
public override Type OriginalType { get; }
Property Value
Type:   Online Type

            The original type.

See Also
GuidIdentifier Class
GuidIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier Class

IDIdentifier Class Sitecore Social Connected 2.0 API
Represents the identifier for the ID object.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model Identifier
Sitecore.Social.Infrastructure.Identifiers IDIdentifier

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class IDIdentifier : Identifier
[SerializableAttribute]
public class IDIdentifier : Identifier
See Also
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier Members

IDIdentifier Members Sitecore Social Connected 2.0 API

The IDIdentifier type exposes the following members.
Constructors
 | Name | Description
Public method | IDIdentifier | Initializes a new instance of the IDIdentifier class from the id.
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Overrides Identifier Equals(Identifier).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Inherited from Identifier.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the IDIdentifier class whose value represents a not defined identifier.
Back to Top
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Identifier IsEmpty.)
Public property | OriginalId | Gets the original id.
Public property | OriginalType | Gets the original type. (Overrides Identifier OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)
Back to Top
See Also
IDIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier Constructor

IDIdentifier Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the IDIdentifier class from the id.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDIdentifier(
    ID id
)
public IDIdentifier(
    ID id
)
Parameters
id
Type: ID
The id.
See Also
IDIdentifier Class
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier Fields

IDIdentifier Fields Sitecore Social Connected 2.0 API
The IDIdentifier type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the IDIdentifier class whose value represents a not defined identifier.
Back to Top
See Also
IDIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier.Empty Field

IDIdentifier Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the IDIdentifier class whose value represents a not defined identifier.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IDIdentifier Empty
public static readonly IDIdentifier Empty
Field Value
Type: IDIdentifier
See Also
IDIdentifier Class
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier Methods

IDIdentifier Methods Sitecore Social Connected 2.0 API
The IDIdentifier type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Overrides Identifier Equals(Identifier).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from Identifier.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Inherited from Identifier.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetGuid | Gets the GUID value. (Defined by IdentifierExtensions.)
Public Extension Method | GetID | Gets the ID from identifier. (Defined by IdentifierExtensions.)
Back to Top
See Also
IDIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier.Equals Method

IDIdentifier Equals Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to this instance. (Inherited from Identifier.)
Public method | Equals(Identifier) | Checks if the current identifier is equal to another one. (Overrides Identifier Equals(Identifier).)
Back to Top
See Also
IDIdentifier Class
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier.Equals Method (Identifier)

IDIdentifier Equals Method (Identifier) Sitecore Social Connected 2.0 API
Checks if the current identifier is equal to another one.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Identifier other
)
public override bool Equals(
    Identifier other
)
Parameters
other
Type: Sitecore.Social.Domain.Model Identifier
The other identifier.
Return Value
Type:   Online Boolean
true if the current identifier is equal to another one, otherwise false.

Implements
  Online IEquatable T  Equals(T)
See Also
IDIdentifier Class
IDIdentifier Members
Equals Overload
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier Properties

IDIdentifier Properties Sitecore Social Connected 2.0 API
The IDIdentifier type exposes the following members.
Properties
 | Name | Description
Public property | IsEmpty | Returns a Boolean value indicating if the specified instance is empty. (Overrides Identifier IsEmpty.)
Public property | OriginalId | Gets the original id.
Public property | OriginalType | Gets the original type. (Overrides Identifier OriginalType.)
Public property | StringValue | Gets the string value. (Inherited from Identifier.)
Back to Top
See Also
IDIdentifier Class
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier.IsEmpty Property

IDIdentifier IsEmpty Property Sitecore Social Connected 2.0 API
Returns a Boolean value indicating if the specified instance is empty.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
IDIdentifier Class
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier.OriginalId Property

IDIdentifier OriginalId Property Sitecore Social Connected 2.0 API
Gets the original id.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ID OriginalId { get; private set; }
public ID OriginalId { get; private set; }
Property Value
Type: ID

            The original id.

See Also
IDIdentifier Class
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


IDIdentifier.OriginalType Property

IDIdentifier OriginalType Property Sitecore Social Connected 2.0 API
Gets the original type.

Namespace: Sitecore.Social.Infrastructure.Identifiers
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type OriginalType { get; }
public override Type OriginalType { get; }
Property Value
Type:   Online Type

            The original type.

See Also
IDIdentifier Class
IDIdentifier Members
Sitecore.Social.Infrastructure.Identifiers Namespace


Sitecore.Social.Infrastructure.Utils Namespace

Sitecore.Social.Infrastructure.Utils Namespace Sitecore Social Connected 2.0 API
Provides classes that represent the infrastructure utilities.
Classes
 | Class | Description
Public class | GoogleUrlShortener | Defines the Google URL shortener class.
Public class | SearchUtil | Defines search utilities.
Interfaces
 | Interface | Description
Public interface | IUrlShortener | Defines the IUrlSortener interface class.


GoogleUrlShortener Class

GoogleUrlShortener Class Sitecore Social Connected 2.0 API
Defines the Google URL shortener class.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure.Utils GoogleUrlShortener

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleUrlShortener : IUrlShortener
public class GoogleUrlShortener : IUrlShortener
See Also
GoogleUrlShortener Members
Sitecore.Social.Infrastructure.Utils Namespace


GoogleUrlShortener Members

GoogleUrlShortener Members Sitecore Social Connected 2.0 API

The GoogleUrlShortener type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleUrlShortener | Initializes a new instance of the GoogleUrlShortener class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ShortenUrl(Uri) | Shortens the URL using the default API key.
Public method | ShortenUrl(Uri, String) | Shortens the URL using the specified API key.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GoogleUrlShortener Class
Sitecore.Social.Infrastructure.Utils Namespace


GoogleUrlShortener Constructor

GoogleUrlShortener Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the GoogleUrlShortener class

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleUrlShortener()
public GoogleUrlShortener()
See Also
GoogleUrlShortener Class
GoogleUrlShortener Members
Sitecore.Social.Infrastructure.Utils Namespace


GoogleUrlShortener Methods

GoogleUrlShortener Methods Sitecore Social Connected 2.0 API
The GoogleUrlShortener type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ShortenUrl(Uri) | Shortens the URL using the default API key.
Public method | ShortenUrl(Uri, String) | Shortens the URL using the specified API key.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
GoogleUrlShortener Class
Sitecore.Social.Infrastructure.Utils Namespace


GoogleUrlShortener.ShortenUrl Method

GoogleUrlShortener ShortenUrl Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ShortenUrl(Uri) | Shortens the URL using the default API key.
Public method | ShortenUrl(Uri, String) | Shortens the URL using the specified API key.
Back to Top
See Also
GoogleUrlShortener Class
GoogleUrlShortener Members
Sitecore.Social.Infrastructure.Utils Namespace


GoogleUrlShortener.ShortenUrl Method (Uri)

GoogleUrlShortener ShortenUrl Method (Uri) Sitecore Social Connected 2.0 API
Shortens the URL using the default API key.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri ShortenUrl(
    Uri url
)
public Uri ShortenUrl(
    Uri url
)
Parameters
url
Type:   Online System Uri
Long URL.
Return Value
Type:   Online Uri

            Shortened URL.

Implements
IUrlShortener ShortenUrl(Uri)
See Also
GoogleUrlShortener Class
GoogleUrlShortener Members
ShortenUrl Overload
Sitecore.Social.Infrastructure.Utils Namespace


GoogleUrlShortener.ShortenUrl Method (Uri, String)

GoogleUrlShortener ShortenUrl Method (Uri, String) Sitecore Social Connected 2.0 API
Shortens the URL using the specified API key.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri ShortenUrl(
    Uri url,
    string key
)
public Uri ShortenUrl(
    Uri url,
    string key
)
Parameters
url
Type:   Online System Uri
Original URL.
key
Type:   Online System String
API key.
Return Value
Type:   Online Uri

            Shortened URL.

Implements
IUrlShortener ShortenUrl(Uri, String)
See Also
GoogleUrlShortener Class
GoogleUrlShortener Members
ShortenUrl Overload
Sitecore.Social.Infrastructure.Utils Namespace


IUrlShortener Interface

IUrlShortener Interface Sitecore Social Connected 2.0 API
Defines the IUrlSortener interface class.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IUrlShortener
public interface IUrlShortener
See Also
IUrlShortener Members
Sitecore.Social.Infrastructure.Utils Namespace


IUrlShortener Members

IUrlShortener Members Sitecore Social Connected 2.0 API

Methods
 | Name | Description
Public method | ShortenUrl(Uri) | Shortens the URL using the default API key.
Public method | ShortenUrl(Uri, String) | Shortens the URL using the specified API key.
Back to Top
See Also
IUrlShortener Interface
Sitecore.Social.Infrastructure.Utils Namespace


IUrlShortener Methods

IUrlShortener Methods Sitecore Social Connected 2.0 API
Methods
 | Name | Description
Public method | ShortenUrl(Uri) | Shortens the URL using the default API key.
Public method | ShortenUrl(Uri, String) | Shortens the URL using the specified API key.
Back to Top
See Also
IUrlShortener Interface
Sitecore.Social.Infrastructure.Utils Namespace


IUrlShortener.ShortenUrl Method

IUrlShortener ShortenUrl Method Sitecore Social Connected 2.0 API
Overload List
 | Name | Description
Public method | ShortenUrl(Uri) | Shortens the URL using the default API key.
Public method | ShortenUrl(Uri, String) | Shortens the URL using the specified API key.
Back to Top
See Also
IUrlShortener Interface
IUrlShortener Members
Sitecore.Social.Infrastructure.Utils Namespace


IUrlShortener.ShortenUrl Method (Uri)

IUrlShortener ShortenUrl Method (Uri) Sitecore Social Connected 2.0 API
Shortens the URL using the default API key.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Uri ShortenUrl(
    Uri url
)
Uri ShortenUrl(
    Uri url
)
Parameters
url
Type:   Online System Uri
Long URL.
Return Value
Type:   Online Uri

            Shortened URL.

See Also
IUrlShortener Interface
IUrlShortener Members
ShortenUrl Overload
Sitecore.Social.Infrastructure.Utils Namespace


IUrlShortener.ShortenUrl Method (Uri, String)

IUrlShortener ShortenUrl Method (Uri, String) Sitecore Social Connected 2.0 API
Shortens the URL using the specified API key.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Uri ShortenUrl(
    Uri url,
    string key
)
Uri ShortenUrl(
    Uri url,
    string key
)
Parameters
url
Type:   Online System Uri
Long URL.
key
Type:   Online System String
API key.
Return Value
Type:   Online Uri

            Shortened URL.

See Also
IUrlShortener Interface
IUrlShortener Members
ShortenUrl Overload
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil Class

SearchUtil Class Sitecore Social Connected 2.0 API
Defines search utilities.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Infrastructure.Utils SearchUtil

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SearchUtil
public static class SearchUtil
See Also
SearchUtil Members
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil Members

SearchUtil Members Sitecore Social Connected 2.0 API

The SearchUtil type exposes the following members.
Methods
Name | Description
GetNormalizedEmptyContainer | Gets the normalized empty container.
NormalizeContainer(ItemUri, String) | Gets the normalized ItemUri string.
NormalizeContainer(String, String) | Gets the normalized container.
Back to Top
See Also
SearchUtil Class
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil Methods

SearchUtil Methods Sitecore Social Connected 2.0 API
The SearchUtil type exposes the following members.
Methods
Name | Description
GetNormalizedEmptyContainer | Gets the normalized empty container.
NormalizeContainer(ItemUri, String) | Gets the normalized ItemUri string.
NormalizeContainer(String, String) | Gets the normalized container.
Back to Top
See Also
SearchUtil Class
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil.GetNormalizedEmptyContainer Method

SearchUtil GetNormalizedEmptyContainer Method Sitecore Social Connected 2.0 API
Gets the normalized empty container.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetNormalizedEmptyContainer(
    string currentDatabaseName
)
public static string GetNormalizedEmptyContainer(
    string currentDatabaseName
)
Parameters
currentDatabaseName
Type:   Online System String
The name of the current database.
Return Value
Type:   Online String
The normalized container.
See Also
SearchUtil Class
SearchUtil Members
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil.NormalizeContainer Method

SearchUtil NormalizeContainer Method Sitecore Social Connected 2.0 API
Overload List
Name | Description
NormalizeContainer(ItemUri, String) | Gets the normalized ItemUri string.
NormalizeContainer(String, String) | Gets the normalized container.
Back to Top
See Also
SearchUtil Class
SearchUtil Members
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil.NormalizeContainer Method (, String)

SearchUtil NormalizeContainer Method (, String) Sitecore Social Connected 2.0 API
Gets the normalized ItemUri string.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string NormalizeContainer(
    ItemUri container,
    string currentDatabaseName
)
public static string NormalizeContainer(
    ItemUri container,
    string currentDatabaseName
)
Parameters
container
Type: ItemUri
The item URI.
currentDatabaseName
Type:   Online System String
The name of the current database.
Return Value
Type:   Online String

            The normalized container.

See Also
SearchUtil Class
SearchUtil Members
NormalizeContainer Overload
Sitecore.Social.Infrastructure.Utils Namespace


SearchUtil.NormalizeContainer Method (String, String)

SearchUtil NormalizeContainer Method (String, String) Sitecore Social Connected 2.0 API
Gets the normalized container.

Namespace: Sitecore.Social.Infrastructure.Utils
Assembly: Sitecore.Social.Infrastructure (in Sitecore.Social.Infrastructure.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string NormalizeContainer(
    string container,
    string currentDatabaseName
)
public static string NormalizeContainer(
    string container,
    string currentDatabaseName
)
Parameters
container
Type:   Online System String
The container.
currentDatabaseName
Type:   Online System String
The name of the current database.
Return Value
Type:   Online String

            The normalized container.

See Also
SearchUtil Class
SearchUtil Members
NormalizeContainer Overload
Sitecore.Social.Infrastructure.Utils Namespace


Sitecore.Social.SocialMarketer.Api.Model Namespace

Sitecore.Social.SocialMarketer.Api.Model Namespace Sitecore Social Connected 2.0 API
Provides the classes that extend domain model with the specific entities of Social Marketer network.
Classes
 | Class | Description
Public class | SocialMarketerMessageData | The social marketer message data.


SocialMarketerMessageData Class

SocialMarketerMessageData Class Sitecore Social Connected 2.0 API
The social marketer message data.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageData
Sitecore.Social.SocialMarketer.Api.Model SocialMarketerMessageData

Namespace: Sitecore.Social.SocialMarketer.Api.Model
Assembly: Sitecore.Social.SocialMarketer.Api (in Sitecore.Social.SocialMarketer.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SocialMarketerMessageData : MessageData
[SerializableAttribute]
public class SocialMarketerMessageData : MessageData
See Also
SocialMarketerMessageData Members
Sitecore.Social.SocialMarketer.Api.Model Namespace


SocialMarketerMessageData Members

SocialMarketerMessageData Members Sitecore Social Connected 2.0 API

The SocialMarketerMessageData type exposes the following members.
Constructors
 | Name | Description
Public method | SocialMarketerMessageData | Initializes a new instance of the SocialMarketerMessageData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | Comments | Gets or sets the comments.
Public property | CreatedDate | Gets or sets the Created date. (Inherited from MessageData.)
Public property | DisplayName | Gets or sets the display name. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | PostedDate | Gets or sets the Posted date. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)
Back to Top
See Also
SocialMarketerMessageData Class
Sitecore.Social.SocialMarketer.Api.Model Namespace


SocialMarketerMessageData Constructor

SocialMarketerMessageData Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SocialMarketerMessageData class

Namespace: Sitecore.Social.SocialMarketer.Api.Model
Assembly: Sitecore.Social.SocialMarketer.Api (in Sitecore.Social.SocialMarketer.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialMarketerMessageData()
public SocialMarketerMessageData()
See Also
SocialMarketerMessageData Class
SocialMarketerMessageData Members
Sitecore.Social.SocialMarketer.Api.Model Namespace


SocialMarketerMessageData Methods

SocialMarketerMessageData Methods Sitecore Social Connected 2.0 API
The SocialMarketerMessageData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SocialMarketerMessageData Class
Sitecore.Social.SocialMarketer.Api.Model Namespace


SocialMarketerMessageData Properties

SocialMarketerMessageData Properties Sitecore Social Connected 2.0 API
The SocialMarketerMessageData type exposes the following members.
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | Comments | Gets or sets the comments.
Public property | CreatedDate | Gets or sets the Created date. (Inherited from MessageData.)
Public property | DisplayName | Gets or sets the display name. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | PostedDate | Gets or sets the Posted date. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)
Back to Top
See Also
SocialMarketerMessageData Class
Sitecore.Social.SocialMarketer.Api.Model Namespace


SocialMarketerMessageData.Comments Property

SocialMarketerMessageData Comments Property Sitecore Social Connected 2.0 API
Gets or sets the comments.

Namespace: Sitecore.Social.SocialMarketer.Api.Model
Assembly: Sitecore.Social.SocialMarketer.Api (in Sitecore.Social.SocialMarketer.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Comments { get; set; }
public string Comments { get; set; }
Property Value
Type:   Online String
See Also
SocialMarketerMessageData Class
SocialMarketerMessageData Members
Sitecore.Social.SocialMarketer.Api.Model Namespace


Sitecore.Social.Twitter.Api.Model Namespace

Sitecore.Social.Twitter.Api.Model Namespace Sitecore Social Connected 2.0 API
Provides classes that extend domain's model with Twitter specific entities.
Classes
 | Class | Description
Public class | TweetsCounter | Represents the tweets counter
Public class | TwitterMessageData | Represents Twitter message data.


TweetsCounter Class

TweetsCounter Class Sitecore Social Connected 2.0 API
Represents the tweets counter
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model StatisticsCounter
Sitecore.Social.Domain.Model NumberCounter
Sitecore.Social.Twitter.Api.Model TweetsCounter

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TweetsCounter : NumberCounter
[SerializableAttribute]
public class TweetsCounter : NumberCounter
See Also
TweetsCounter Members
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Members

TweetsCounter Members Sitecore Social Connected 2.0 API

The TweetsCounter type exposes the following members.
Constructors
 | Name | Description
Public method | TweetsCounter | Initializes a new instance of the TweetsCounter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)
Back to Top
See Also
TweetsCounter Class
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Constructor

TweetsCounter Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the TweetsCounter class.

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TweetsCounter(
    string displayName,
    int number
)
public TweetsCounter(
    string displayName,
    int number
)
Parameters
displayName
Type:   Online System String
The display name.
number
Type:   Online System Int32
The number.
See Also
TweetsCounter Class
TweetsCounter Members
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Methods

TweetsCounter Methods Sitecore Social Connected 2.0 API
The TweetsCounter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
TweetsCounter Class
Sitecore.Social.Twitter.Api.Model Namespace


TweetsCounter Properties

TweetsCounter Properties Sitecore Social Connected 2.0 API
The TweetsCounter type exposes the following members.
Properties
 | Name | Description
Public property | DisplayName | Gets the statistics counter display name. (Inherited from StatisticsCounter.)
Public property | Name | Gets the statistics counter name. (Inherited from StatisticsCounter.)
Public property | Number | Gets the statistics numerical value. (Inherited from NumberCounter.)
Back to Top
See Also
TweetsCounter Class
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Class

TwitterMessageData Class Sitecore Social Connected 2.0 API
Represents Twitter message data.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Domain.Model MessageData
Sitecore.Social.Twitter.Api.Model TwitterMessageData

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TwitterMessageData : MessageData
[SerializableAttribute]
public class TwitterMessageData : MessageData
See Also
TwitterMessageData Members
Sitecore.Social.Twitter.Api.Model Namespace
Message MessageData


TwitterMessageData Members

TwitterMessageData Members Sitecore Social Connected 2.0 API

The TwitterMessageData type exposes the following members.
Constructors
 | Name | Description
Public method | TwitterMessageData | Initializes a new instance of the TwitterMessageData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | CreatedDate | Gets or sets the Created date. (Inherited from MessageData.)
Public property | DisplayName | Gets or sets the display name. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | PostedDate | Gets or sets the Posted date. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)
Back to Top
See Also
TwitterMessageData Class
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Constructor

TwitterMessageData Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the TwitterMessageData class

Namespace: Sitecore.Social.Twitter.Api.Model
Assembly: Sitecore.Social.Twitter.Api (in Sitecore.Social.Twitter.Api.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TwitterMessageData()
public TwitterMessageData()
See Also
TwitterMessageData Class
TwitterMessageData Members
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Methods

TwitterMessageData Methods Sitecore Social Connected 2.0 API
The TwitterMessageData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
TwitterMessageData Class
Sitecore.Social.Twitter.Api.Model Namespace


TwitterMessageData Properties

TwitterMessageData Properties Sitecore Social Connected 2.0 API
The TwitterMessageData type exposes the following members.
Properties
 | Name | Description
Public property | CampaignId | Gets or sets the campaign id. (Inherited from MessageData.)
Public property | CreatedDate | Gets or sets the Created date. (Inherited from MessageData.)
Public property | DisplayName | Gets or sets the display name. (Inherited from MessageData.)
Public property | Link | Gets or sets the link. (Inherited from MessageData.)
Public property | PostedDate | Gets or sets the Posted date. (Inherited from MessageData.)
Public property | Text | Gets or sets the text. (Inherited from MessageData.)
Back to Top
See Also
TwitterMessageData Class
Sitecore.Social.Twitter.Api.Model Namespace


Sitecore.Social.Twitter.Configuration Namespace

Sitecore.Social.Twitter.Configuration Namespace Sitecore Social Connected 2.0 API
Provides classes that allow read the Twitter specific configuration.
Classes
 | Class | Description
Public class | SettingsConfiguration | Twitter settings configuration.


SettingsConfiguration Class

SettingsConfiguration Class Sitecore Social Connected 2.0 API
Twitter settings configuration.
Inheritance Hierarchy
Online System Object
Sitecore.Social.Configuration.Model ConfigurationData
Sitecore.Social.Twitter.Configuration SettingsConfiguration

Namespace: Sitecore.Social.Twitter.Configuration
Assembly: Sitecore.Social.Twitter (in Sitecore.Social.Twitter.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
[SerializableAttribute]
public class SettingsConfiguration : ConfigurationData
See Also
SettingsConfiguration Members
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration Members

SettingsConfiguration Members Sitecore Social Connected 2.0 API

The SettingsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | SettingsConfiguration | Initializes a new instance of the SettingsConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.
Back to Top
Properties
 | Name | Description
Public property | DefaultTweetGoal | Gets or sets the default tweet goal.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration Constructor

SettingsConfiguration Constructor Sitecore Social Connected 2.0 API
Initializes a new instance of the SettingsConfiguration class

Namespace: Sitecore.Social.Twitter.Configuration
Assembly: Sitecore.Social.Twitter (in Sitecore.Social.Twitter.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SettingsConfiguration()
public SettingsConfiguration()
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration Fields

SettingsConfiguration Fields Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Fields
Name | Description
Empty | A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration.Empty Field

SettingsConfiguration Empty Field Sitecore Social Connected 2.0 API
A read-only instance of the SettingsConfiguration class whose value represents a not defined configuration settings.

Namespace: Sitecore.Social.Twitter.Configuration
Assembly: Sitecore.Social.Twitter (in Sitecore.Social.Twitter.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SettingsConfiguration Empty
public static readonly SettingsConfiguration Empty
Field Value
Type: SettingsConfiguration
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration Methods

SettingsConfiguration Methods Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration Properties

SettingsConfiguration Properties Sitecore Social Connected 2.0 API
The SettingsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | DefaultTweetGoal | Gets or sets the default tweet goal.
Public property | IsEmpty | Gets the value that indicates whether this instance is empty or not. (Overrides ConfigurationData IsEmpty.)
Back to Top
See Also
SettingsConfiguration Class
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration.DefaultTweetGoal Property

SettingsConfiguration DefaultTweetGoal Property Sitecore Social Connected 2.0 API
Gets or sets the default tweet goal.

Namespace: Sitecore.Social.Twitter.Configuration
Assembly: Sitecore.Social.Twitter (in Sitecore.Social.Twitter.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DefaultTweetGoal { get; set; }
public string DefaultTweetGoal { get; set; }
Property Value
Type:   Online String

            The default tweet goal.

See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Twitter.Configuration Namespace


SettingsConfiguration.IsEmpty Property

SettingsConfiguration IsEmpty Property Sitecore Social Connected 2.0 API
Gets the value that indicates whether this instance is empty or not.

Namespace: Sitecore.Social.Twitter.Configuration
Assembly: Sitecore.Social.Twitter (in Sitecore.Social.Twitter.dll) Version: 2.0.0.0 (2.0 rev. 131119)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsEmpty { get; }
public override bool IsEmpty { get; }
Property Value
Type:   Online Boolean
true if this instance is empty; otherwise, false.

Implements
IEmptyable IsEmpty
See Also
SettingsConfiguration Class
SettingsConfiguration Members
Sitecore.Social.Twitter.Configuration Namespace